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Knowledgeware Applications 
Interoperability

In this section, you will find information about interoperability between CATIA 

Knowledgeware Applications and other applications listed below:

ENOVIA LCA Interoperability
ENOVIAvpm Interoperability
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ENOVIA LCA Interoperability
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Working with Design Tables in ENOVIA LCA 
Using VPM Navigator

It is possible to save design tables in ENOVIA LCA and to apply design tables saved in ENOVIA LCA to existing 
parts using VPM Navigator. 

Note that:

●     To modify a design table saved in ENOVIA, the sheet must be synchronized with the design table saved in 
ENOVIA LCA. To do so, right-click the design table in CATIA and select the Synchronize (ENOVIA) 
command. The design table should also be checked out/locked in ENOVIA.

●     To share a design table, see Saving a Design Table in ENOVIA LCA Using the VPM Navigator
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Saving a Design Table in ENOVIA LCA Using the VPM 
Navigator

This task is designed to show the user how to save a design table and its external file in ENOVIA LCA by using the 
VPM Navigator and how to use the external file in another file (it is possible to share a .xls file with other design 
tables). This scenario is divided into the following steps:

●     In CATIA, the user creates the design table using a pre-existing file.

●     He saves the file in ENOVIA LCA.

●     He creates another part in CATIA, saves it and associates the design table external file stored in ENOVIA LCA.

To know more about the VPM Navigator, see the VPM Navigator User's Guide.

Prior to carrying out your scenario, enable the Enovia option in the Tools->Options->General->Document 
tab. 

Creating the design table

1.  Open the BallBearing.CATPart file. 

2.  Click the Design Table icon ( ) in the Knowledge tool bar. The Creation of a Design Table window 

displays.

3.  Click the Create a design table from a pre-existing file option and click OK. The File Selection dialog 

box opens.

4.  Select the BearingDesignTable.xls file and click Open. Click Yes when asked if you want to associate the 

columns of the table with the parameters.

5.  Click OK to apply the default configuration. DesignTable.1 displays below the Relations node.

Saving the files in ENOVIA LCA

6.  Save your files in ENOVIA LCA. To do so, proceed as follows:

❍     Choose the Start -> Infrastructure -> VPM Navigator menu item.
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❍     Click the Connect icon ( ) in the ENOVIA V5 toolbar. The Log On to dialog box displays:

❍     Click OK when done.

❍     Click the Save data in Enovia V5 icon ( ). The Save in Enovia V5 dialog box displays. 
Click OK to save the files. Close the file in CATIA.

The BearingDesignTable.xls file and the BallBearing.CATPart file are now both saved in ENOVIA LCA.

Applying the Design Table file saved in ENOVIA LCA to another part

7.  Open the New_BallBearing.CATPart file. Click the Save data in Enovia V5 icon ( ). The Save in 

Enovia V5 dialog box displays. Click OK to save the file.

8.  Click the Design Table icon ( ) to associate a design table to the part. 

7.  Click the Create a design table from a pre-existing file option and click OK. The 

File Selection window displays as well as the Browser (see picture opposite).

8.  Click Cancel in the File Selection window and click the Enovia button in the browser.

 

7.  The Search Conditions window displays.

8.  In the Creator field, enter the creator's name and click Search. The results display in the Search Result 

window.

9.  Select the BearingDesignTable.xls file and click Open.

10.  Click Yes when asked if you want to associate the columns of the table with the parameters.

1056Page Infrastructure Version 5 Release 13



11.  Click OK to apply the default configuration. DesignTable.1 displays below the Relations node.
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ENOVIAvpm Interoperability
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ENOVIAvpm / CATIA V5 Knowledgeware 
Integration

Note that for the Knowledgeware integration to work properly, VPM1.5 PTF13 is required.

The VPM integration of Knowledgeware information created at the product level is guaranteed for 
Knowledge Advisor, Product  Engineering Optimizer and for the infrastructure fonctionnalities (parameters, 
formulas, laws, Design Tables). 

The following Knowledgeware objects are supported:

●     Parameters sets 

●     Formulas, checks, rules, sets of equations 

●     Laws 

●     Design Tables (The link between design tables and their external files is not supported. The file should 
be located in a shared directory). 

●     Macros with arguments, Knowledge Advisor actions 

●     Reactions 

●     Equivalent Dimensions

●     Comments and URLs

●     Optimizations, Design of Experiments, Constraints Satisfactions. 

These objects, considered as connections, support the following pointings:

●     To Part parameters and objects 

●     To published parameters 

●     To Product users parameters 

●     To User properties of a product

●     To assembly constraints parameters 

●     To Knowledge objects at the Product level

Creating and Storing a Knowledgeware Relation
Useful Tips
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 Creating and Storing a Knowledgeware Relation

In the scenario described below, we assume that the user starts from scratch. The scenario is divided into the 
following steps:

●     Creating documents in VPM

●     Creating the Assembly in VPM

●     Applying constraints to the assembly in Catia

●     Creating a formula in Catia 

●     Loading the Assembly in Catia

To carry out this scenario, you will need the following files:

TowHook.CATProduct 
M39.CATPart 
Axis_Step3.CATPart 
Support.CATPart 
Liner_Step3.CATPart 

In Catia, from the Tools->Options menu, select Infrastructure->Product Structure and make sure that 
the Work with the cache system option is unchecked.

Creating Documents in VPM

1.  In VPM, select the Object->Document command to specify the type of file that you want to create.

2.  Select the File->Create & Save command. The Create&Save window displays.

❍     In the Part Number field, enter a string of characters. Note that this string will be visible in Catia 

when loading the part: M39 for example.

❍     In the Eng Change field, enter 1 (version number).

❍     In the Type field, enter Part.

❍     Click the Source field and select the M39.CATPart file.

❍     Enter 1 in the remaining fields.

❍     Click Ok when done. The document is now created in VPM.

3.  Double-click the Document to open the  PSN editor. 

4.  Right-click the sheet corresponding to the created document and select Open. The Part opens in 

CATIA.

5.  Repeat the 4 steps described above for the following parts:
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❍     Axis_Step3.CATPart

❍     Support.CATPart

❍     Liner_Step3.CATPart

Creating the Assembly

6.  In VPM, select the Object->Part command to specify the type of file that you want to create.

7.  Select the File->Create & Save command. The Create&Save window displays.

❍     In the Part Number field, enter TowHook.

❍     In the Eng Change field, enter 1 (version number).

❍     In the Type field, enter Product.

❍     Click OK when done and Yes to confirm.

8.  Specify that the TowHook is made up of M39.CATPart, Axis_Step3.CATPart, Support.CATPart, and 

Liner_Step3.CATPart. To do so, proceed as follows:

❍     Use the shift button to select the 4 documents listed above.

❍     Press the Ctrl+C keys.

❍     Click the TowHook file.

❍     Press the Ctrl+V keys. The assembly is created.

9.  Double-click TowHook in VPM. The editor displays.

10.  In the PSN editor, expand the documents and, holding the shift key, right-click the 4 documents and 

select the Open command.

11.  Select Add when asked if you want to replace or add the models in your current viewer session. The 

assembly displays in Catia.
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Applying constraints to the assembly in Catia

12.  Apply constraints to build the assembly. To do so, proceed as follows:

●     From the Start menu, select the Mechanical Design->Assembly Design workbench.

●     Apply a fix constraint to the Support.

●     Apply a coincidence constraint between Liner.1 and Support.1.

●     Apply an offset constraint (10 mm) between Liner.1 and Support.1.

●     Apply a coincidence constraint between Axis.1 and Liner.1.

●     Apply a coincidence constraint between Support.1 and Axis.1.

●     Apply a coincidence constraint between Bolt.1 and Axis.1.

●     Apply a contact constraint between Bolt.1 and Liner.1.

●     Do not hesitate to use the Manipulations parameters tool available in the Assembly workbench to 

move the assembly components before applying the constraints.
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The constraints are 
created (see picture 
opposite.)

Creating a formula

13.  Create a formula applied on the Offset constraint. To do so, proceed as follows:

●      

●     Click the f(x) icon. The Formula Editor displays.

●     In the specification tree, select the offset constraint and click the Add formula button.

●     In the editor, double-click Support\Plate_Thickness and add "+15mm". (See graphic below).

14.  Click OK twice. The formula is created.

15.  Save your .CATProduct file. Your file is saved in VPM.
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Loading the Assembly in Catia

16.  Go back to VPM and right-click M39.CATPart, Axis_Step3.CATPart, TowHook, 

and Liner_Step3.CATPart and select the Open command.

●     A message is fired by Knowledge indicating that the relation cannot be solved. 

●     The formula displays with an interrogation mark. 

●     The formula cannot be edited.

●     The formula can be deactivated.

●     Some parameters are seen as "unfound".

The constraints applied to the Support document do not display.

17.  Go back to PSN, right-click the Support document and select Add: The formula applies correctly and 

the constraints all display.
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Useful Tips

Replacing a document publishing parameters

In VPM 4, if you want to replace a document publishing parameters with another parameter, do it 
in CATIA: Before replacing the assembly, send it to CATIA as well as the document that will 
replace the existing one, perform the "replace" operation in CATIA and save it. 

Replace operations performed from VPM are supported with one restriction: In assemblies, you 
can only replace part instances directly located below the root product. 
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Workbench Description

Version 5 lets you create and manage parts, assemblies, drawings and CATIA Version 4 models in 
documents.

Version 5 uses a multiple document interface (MDI), meaning that you can manipulate several documents 
at the same time. You can even view the contents of the same document in several windows at the same 
time.

Opening a specific type of document activates the workbench and the associated workbench toolbar 
containing all the tools you need to edit the document, so the Version 5 application window looks a little 
different depending on what type of document you are editing. The same applies to the contents of the 
menu bar and the commands on pulldown menus.

This section contains the description of the icons and menus specific to the CATIA Object Manager 
workbenches. These commands are discussed in greater details elsewhere in the guide. 

The main application window looks like this (click the sensitive areas to see the related documentation):
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The section is organized as follows:

Menu Bar
Standard Toolbar

View Toolbar
Capture Toolbar

Graphic Properties Toolbar
3Dx Device Toolbar

Desk Toolbars
Symbols

Viewing and Hiding Toolbars
Viewing the Commands List

Keyboard Shortcuts
Knowledgeware Toolbar

Feature Dictionary Editor Toolbar
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Infrastructure Menu Bar

This section presents the main menu bar available when you run the application and before creating or 
opening a document.

 

Start SmarTeam File Edit View Insert Tools Window Help

 

Start
The Start menu is a navigation tool intended to help you toggle between different workshops. The 
contents of the Start menu vary according to the configurations and/or products installed. For more 
information about the Start menu, refer to "Accessing the Navigation Tools".

 

File
For... See...

New... Creating New Documents 

New from... Creating a New Document from an Existing One

Open... Opening Existing Documents 

Close Closing Documents

Save Saving Existing Documents

Save As Saving Documents For the First Time or Under 
Another Name
Saving Documents In Other Formats

Save All Saving All Documents

Save 
Management

Managing Document Save

Print... Customizing Print Settings Before Printing Your 
Documents

Printer Setup... Setting Up Your Printers on UNIX and Windows

Desk... Using the FileDesk Workbench

Send To Transferring Version 5 Data
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Edit
For... See...

Undo Undoing Actions

Redo/Repeat Redoing and Repeating Actions

Cut Cutting and Pasting Objects 

Copy Copying and Pasting Objects

Paste Cutting and Pasting Objects
Copying and Pasting Objects

Paste Special... Using the Paste Special... command

Delete Deleting Objects

Search... Selecting Using the Search... 
Command

Selection Sets... Storing Selections Using Selection Sets

Selection Sets 
Edition...

Editing Selection Sets

Find Owning 
Selection Sets...

Storing Selections Using Selection Sets

Links... Editing Document Links

Properties... Displaying and Editing Graphic 
Properties

Other Selection... Selecting Using the Other Selections... 
Command

 

View
For... See...

Toolbars Viewing and Hiding Toolbars

Commands List... Viewing the Commands List

Geometry Setting Document Window Layout 
Preferences
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Specifications Setting Document Window Layout 
Preferences

Compass About the 3D Compass

Reset Compass Manipulating Objects Using the Mouse 
and Compass

Tree Expansion Expanding and Collapsing the Spec 
Tree

Specifications 
Overview

Using the Overview on the Specification 
Tree

Geometry 
Overview

Using the Geometry Overview

Fit All In Fitting All Geometry in the Geometry 
Area

Zoom Area Zooming In On An Area

Zoom In Out Zooming In
Zooming Out

Pan Panning

Rotate Rotating

Modify->Look At Looking At Objects

Modify->Turn 
Head, Zoom In, 
Zoom Out, 
Normal View

Turning Your Head To View An Object
Zooming In
Zooming Out
Viewing Along a Normal to a Plane

Named Views... Using Standard and User-Defined 
Views

Render Style Using Rendering Styles

Navigation Mode Navigating

Lighting... Setting Lighting Effects

Depth Effect... Setting Depth Effects

Ground Viewing Objects against the Ground

Magnifier... Magnifying

Hide/Show Hiding and Showing Objects

Full Screen Using the Full Screen

 

Tools
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For... See...

Formula... Using Knowledgeware Capabilities

Image Capturing and Managing Images for the 
Album

Macro Recording, Running and Editing Macros

Utility... Using the Batch Monitor

Customize... Customizing Toolbars

Visualization 
Filters...

Using Visualization Filters

Options... Customizing Settings

Standards... Customizing Standards

Conferencing Conferencing

 

Window
For... See...

New Window Using Document Windows

Tile Horizontally Using Document Windows

Tile Vertically Using Document Windows

Cascade Using Document Windows

 

Help
For... See...

 CATIA V5 Help Getting Contextual Help

CATIA User 
Companion

Contents, Index 
and Search

Accessing the Online Help Library

What's This? Using the What's This? Command
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User Galaxy Accessing the Dassault Systèmes User 
Galaxy

About  CATIA V5 Displaying Copyright Information
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Standard Toolbar

 

See Creating New Documents

See Opening Existing Documents

See Saving Existing Documents

See Printing a Document Quickly without Customizing Print Settings

See Cutting and Pasting Objects

See Copying and Pasting Objects

See Cutting and Pasting Objects, and Copying and Pasting Objects

See Undoing Actions

See Undoing Actions

See Redoing and Repeating Actions

See Redoing and Repeating Actions

See Using the What's This? Command
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View Toolbar
The View toolbar appears in three different configurations.

This is the default View toolbar in Examine mode: 

 

 

Note: the visualization mode icons always show a black arrow within a white square to indicate a full 
pop-up. This means that clicking the icon displayed in the toolbar will pop-up the whole icon box to let 
you choose the appropriate rendering style (wireframe, shading. etc.). As it is a visualization mode 
command, it would be useless to let you run the command currently displayed without displaying the 
other available modes. 

This is the View toolbar in Walk mode:

 

This is the View toolbar in Fly mode:

 

 

See Navigating in Fly Mode

See Navigating in Fly Mode

See Navigating in Walk Mode

See Navigating in Examine Mode

See Fitting All Geometry in the Geometry Area

See Turning Your Head To View An Object 
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See Navigating in Fly Mode, Navigating in Walk Mode

See Navigating in Fly Mode, Navigating in Walk Mode

See Viewing Along a Normal to a Plane 

See Using Standard Views

See Using Standard Views

See Using Standard Views

See Using Standard Views

See Using Standard Views

See Using Standard Views

See Using Standard Views

See Panning 

See Rotating 

See Zooming In 

See Zooming Out 

See Shading (SHD) 

See Shading with All Edges

See Shading with Edges without Smooth Edges

See Shading with Edges and Hidden Edges

 See Shading with Material

See Customizing the View Mode

See Hiding Objects 

See Displaying Hidden Objects 
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Capture Toolbar
 

 

See Capturing Simple Images

See Capturing Selected Areas of Images

See Capturing Simple Images

See Capturing Selected Areas of Images

See Capturing Simple Images

See Capturing Simple Images
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Graphic Properties Toolbar
The Graphic Properties toolbar is hidden by default. it can be displayed using the View->Toolbars-
>Graphic Properties commands.

 

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar

See Using the Graphic Properties Toolbar
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3Dx Device Toolbar
The 3Dx Device toolbar is hidden by default. It can be displayed using the View->Toolbars->3DxDevice 
command.

 

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons

See Customizing Buttons
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Desk Toolbars
The Desk toolbar is hidden by default. To display it, select the View->Toolbars command then check 
"Desk (basic)":

See Using the FileDesk Workbench

See Using the FileDesk Workbench

See Using the FileDesk Workbench

See Using the FileDesk Workbench

See Using the FileDesk Workbench

The Desk File Management and Unload toolbars are available from the Desk window:

 

See Using the FileDesk Workbench

See Using the FileDesk Workbench

See Using the FileDesk Workbench

See Using the FileDesk Workbench
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Knowledgeware Toolbar

  

See Using Knowledgeware Capabilities

See Using Knowledgeware Capabilities

See the Knowledge Advisor User's Guide
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Feature Dictionary Editor Toolbar

 

See Creating a New Object Class and Creating a New Feature Dictionary

See Modifying the Object Naming Rules

See Opening a Reference Dictionary

See Creating a New Object Class

See Adding Properties to an Object Class

See Modifying the Object Naming Rules

See Generating a Report

 

1081Page Infrastructure Version 5 Release 13



Symbols Used in the Specification Tree
Depending on the operations you perform, you may encounter new symbols on your features in the 
specification tree. This table provides a list with a brief explanation about the use of these symbols.

 

Miscellaneous Symbols
Product Structure Symbols

Symbols reflecting an incident in the Geometry building
Referenced Geometry

Analysis Symbols
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Miscellaneous Symbols
 

 Miscellaneous

 

 PartBody

A part body. You have access to the part's features, 
the way it is organized (Pad, Pocket, Intersection, 
etc.).

xy plane

xy plane, yz plane or zx plane. You can click the 
desired reference plane either in the geometry area 
or in the specification tree.

Formula defined for Point.1. For more about 
formulas, please refer to Infrastructure User's Guide 
Version 5.

 BODY1
A model with geometrical representation.

 Sketch.1

Sketch. For more information about Sketcher 
Workbench, refer to : Entering the Sketcher 
Workbench in Sketcher User's Guide.

 AbsoluteAxis

Absolute Axis: contains information about Origin, 
HDirection and VDirection.

 Origin
Origin. 

 HDirection
HDirection or VDirection.
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 Geometry

Geometry (Point, Line,...): Wireframe and Surfaces 
features.

 Constraints
Constraints: Parallelism, Perpendicularity, etc.

 face

Publication : a CATPart or CATProduct element is 
published that is to say its geometrical data is 
exposed. For more information refer to Managing a 
Product Publication in Assembly User's Guide.

Assembly hole. For more about Assembly features, 
please refer to Assembly Design User's Guide 
Version 5. 

 Open_body.1

External references branch of the part : external 
geometry (a face, a point or a line) is 
copied/imported from driving parts to contextual 
parts that are being driven (Design in context). You 
can customize External References in Tools -> 
Options -> Mechanical Design -> Part Design, 
select the General tab and check the box Keep 
links with selected object.

  

 Product4

A product in NO SHOW. By clicking in the 
CATProduct's contextual menu or by using the 

Hide/Show icon , you can put the product in the 
SHOW or NO SHOW area, the product's geometry is 
hidden. As a consequence, the documents under it, 
for instance the CATPart is in the NO SHOW space as 
well. 
For more information about the SHOW/NO SHOW 
modes, see Displaying Hidden Objects in 
Infrastructure's User Guide.
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 Part5
A part in NO SHOW.

The Sketcher symbol is by default in NO SHOW. By 
this means the geometry lighter. But you can 
reactivate the Sketcher representation by clicking in 
the contextual menu or by using the Hide/Show icon 

. By double-clicking on this symbol you can 
return into the Sketcher workbench.
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Product Structure Symbols

Product Structure

 Product1

A product. For more information, refer to Insert a New 
Product in Product Structure User's Guide.

 Product2

A component or sub-product. For more information, refer to 
Insert a New Component in Product Structure User's Guide.

 Flexible_product

The purple little wheel to the left corner of the CATProduct 

icon and the light bar  identify a flexible sub-assembly. 
For more information, refer to Soft Sub-Assemblies in 
Product Structure User's Guide.

 Part.1

Instance of a part. This symbol  means that there is a 
geometrical representation of the part and that it is 
activated.

  

 
Part_with_DeactivatedRepresentation

The representation of this part is deactivated. This symbol 
means the geometric representation is deactivated. Before 
opening a document, you choose the activate or deactivate 
Shape representation in Tools->Options->Infrastructure, 
select the Product Structure tab and check the box entitled 
Do not activate default shapes on open.
For a particular instance in the document, you can deactivate 
or activate it by selecting the Representations -> 
Deactivate Node / Activate Node contextual commands.

 
Component_with_DeactivatedRepresentation

The representation of this component is deactivated.
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Contextual parts: 

For contextual parts, the reference keeps a link with the definition instance. For each parts, every instance 
keeps a link with its reference. But their first reference has only one link, with a single instance which is 
contextual. This unique link allows you to know the name of the document (CATProduct) on which the part 
's external geometry rests. Three types of contextual parts exists:

_  Definition Instance

This is a contextual part and more precisely a Definition 
Instance. The green gear and the blue chain signify the 
"original" instance of a part that is contextual (driven by 
another part, built with another part's data) in a CATProduct.

_  Instance of the Definition Instance

This contextual part is the Instance of the Definition Instance 
represented by the white gear and the green arrow. The 
geometry of this instance is connected with the Definition 
Instance (contextual link). You can edit this contextual part.

 

_  Other Instance of the Contextual 
Part

The brown gear and the red flash signify the second or 
subsequent instance of a part that is contextual. There is a 
distinction between the "original" and subsequent instances 
of contextual parts because the geometrical definition of 
contextual parts (Skillets) is dependant upon neighboring 
components (support) in the Assembly. The geometry of this 
contextual part depends upon another instance. This symbol 
can appear when you import this part into another 
CATProduct.

 Part1

Reference of a part. For more information, refer to Insert a 
New Part in Product Structure User's Guide.

  

 Deactivated_Component

A deactivated component. The shape representation is 
deactivated; its geometry is not visible. This functionality can 
occur simultaneously on several documents containing this 
component, especially when this component is the instance 
of a reference. This operation is equivalent to the Delete 
operation because the reference of the component no longer 
exists within the Bill Of Material.

 Deactivated_Product
A deactivated product.

 Unloaded_Product

The geometry  of the component disappears. The product is 
downloaded, its references are missing but the user is able to 
find them back.

1087Page Infrastructure Version 5 Release 13



Symbols reflecting an incident in the Geometry building
Miscellaneous Incidents

Incidents on Constraints

Miscellaneous Incidents

Part to be updated

 Product5

No visualization of the product or the part. The product's reference cannot be found. The geometry of the component 
disappears.

 PartBody
A broken link. The access to this product is impossible because the link with the root document has been lost.

A broken shaft.

The pocket's representation is deactivated.

Isolated plane (can no longer be edited)

Incidents on Constraints

 Offset.1
A broken constraint. The access to this product and the information about its constraints cannot be retrieved.

 Parallelism.1
A deactivated constraint (a parallelism constraint).
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 Perpendicularity.1
A constraint to be updated (a perpendicularity constraint).
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Referenced Geometry

 Referenced Geometry
Geometry copied from a document different from 
the CATPart document in which it is pasted.

Initial geometry has undertaken modifications in the 
original CATPart document: solid to be 
synchronized.
Initial geometry has been deleted in the original 
CATPart document or the original CATPart document 
has not been found
Pointed document found but not loaded (use the 
Load contextual command or the Edit -> Links 
command)
External link deactivated so that geometry cannot 
be synchronized during the update of the part (even 
if the option "Synchronize all external references for 
update" is on).
Geometry pasted (using the As Result with Link 
option) within the same CATPart document from 
which it is has been copied
Point referenced in the CATPart document is a 
published element.

Sketch referenced in the CATPart document is a 
published element. The published point has 
undertaken modifications so that a synchronization 
is required.
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Analysis Symbols
Depending on the operations you perform, you may encounter new symbols on your features in the 
specification tree. This table provides a list with a brief explanation about the use of these symbols. 

Analysis Manager
Links Manager

Nodes and Elements
Properties

Property Connections
Virtual Parts
Restraints

Loads
Mass

Adaptivity Process
Sensors 

Analysis Connection Manager 

 

 Analysis Manager 

All the objects making up an analysis document. 

 

  
Links Manager All the links managed from the CATAnalysis document to 

other documents: a part, result data or computation 
data.

  
Finite Element Model: Models with representations used for performing 

computer-aided engineering analysis (CAEA) of 
products. They are complementary to computer-aided 
design (CAD) models, which are mainly geometric 
representations of products. 

  
Adaptivity Process Any specification required for managing the process that 

will let you perform adaptativity computation (re-
meshing). 
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 Links Manager 

All the links managed between the CATAnalysis document and other documents: a part, result 
data or computation data. 

  
Results Path to an external storage file directory (result data). 

  
Computations Path to an external storage file directory (computation 

data).

  
Link Any link to a part or a product (assembly). 

 

  Finite Element Model

Models with representations used for performing computer-aided engineering analysis (CAEA) of 
products. They are complementary to computer-aided design (CAD) models, which are mainly 
geometric representations of products.  

  Static Case A procedure for the computation of the system response 
to applied static loads under given restraints.  

  Frequency Case
A procedure for the computation of the system vibration 
frequencies and normal modes for a given non-structural 
mass distribution under given restraints.

  Buckling Case

A procedure for the computation of the system buckling 
critical loads and buckling modes for a given Static 
Analysis Case. 

 

  Nodes and Elements 

Nodes and elements that can be created are either Smart Surface Mesh (FMS) or OCTREE (GPS) 
type. 

  
OCTREE Tetrahedron Mesh Automatic mesh specifications generating tetrahedron 

mesh elements and using OCTREE methods. 

 

  Properties 

Any specification applied to physical properties (geometry): material and thickness (surface), 
connections, virtual connections and virtual parts. 
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  Material Property3D A link to the material (either 2D or 3D) assigned to the 

part: name, support and thickness. 

 

 Property Connections 

Property Connections: assembly connections used to specify the boundary interaction between 
bodies in an assembled system. 

  
Fastened Connections Link between two bodies which are fastened together at 

their common boundary, and will behave as if they were 
a single body.

  
Slider Connections Link between two bodies which are constrained to move 

together in the local normal direction at their common 
boundary, and will behave as if they were allowed to 
slide relative to each other in the local tangential plane.

  
Contact Connections Link between two part bodies which are prevented from 

inter-penetrating at their common boundary, and will 
behave as if they were allowed to move arbitrarily 
relative to each other as long as they do not come into 
contact within a user-specified normal clearance.

  
Pressure Fitting Connections Link between two bodies which are assembled in a 

Pressure Fitting configuration, more precisely when 
there are interferences or overlaps between both parts.

  
Bolt Tightening Connections Connection that prevents bodies from penetrating each 

other at a common interface.

  
Virtual Rigid Bolt Tightening 
Connections

Connections used to specify the boundary interaction 
between bodies in an assembled system. This connection 
takes into account pre-tension in a bolt-tightened 
assembly in which the bolt is not included.

  
Virtual Spring Bolt Tightening 
Connections

Connections are used to specify the boundary interaction 
between bodies in an assembled system. This connection 
takes into account pre-tension in a bolt-tightened 
assembly in which the bolt is not included.

  
Rigid Connections Connection that fastens bodies together at a common 

rigid interface.

  
Smooth Connections Connection that fastens bodies together at a common 

soft interface.

  
Spot Welding Connections Connection that fastens bodies together at a common 

soft interface. 

 

 Virtual Parts

Structures created without a geometric support. They represent bodies for which no geometry 
model is available, but which play a role in the structural analysis of single part or assembly 
systems. Virtual Parts are used to transmit action at a distance. 

  
Rigid Virtual Parts Generates a stiff transmission rigid virtual part.

  
Smooth Virtual Parts Generates a soft transmission rigid virtual part.
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Contact Virtual Parts Generates a contact transmission rigid virtual part.

  
Rigid Spring Virtual Parts Generates a stiff transmission elastic spring virtual part.

  
Spring Smooth Virtual Parts Generates a soft transmission elastic spring virtual part. 

 

  Restraints

Generates restraining joins, either on a geometry selection or on a virtual part or still various types of 
degree of freedom restraints.

Restraint Any combination of degrees of freedom on a geometry 
selection.

Isostatic Statically determinate supports generated on a part.

Clamp Fixes all degrees of freedom on a geometry selection.
Surface Slider Generates surface constraint joins, which allow points of 

a surface to slide along a coinciding rigid surface (fixes 
the translation degree of freedom for a surface in the 
direction of the local normal).

Slider Generates prismatic joins (sliders), which allow a rigid 
body to translate along a given axis (fixes all degrees of 
freedom of a point, except for one translation).

Sliding Pivot Generates cylindrical joins (actuators) which allow a rigid 
body to translate about  and rotate around a given axis 
(fixes all degrees of freedom of a point, except for one 
translation and one rotation).

Ball Join Generates spherical joins (balls), which allow a rigid 
body to rotate about a given point (fixes all translation 
degrees of freedom of a point).

Pivot Generates conical joins (hinges), which allow a rigid 
body to rotate around a given axis (fixes all degrees of 
freedom of a point, except for one rotation).

  Loads

Generates distributed force systems equivalent to given static resultants, force densities of given 
intensity or acceleration fields.
Pressure Generates pressure loads over a surface.

Distributed Force Generates a distributed force system equivalent to a 
pure force at a point (given force resultant and zero 
moment resultant).

Moment Generates a distributed force system equivalent to a 
pure couple (given moment resultant and zero force 
resultant).

Bearing Load Simulate contact loads applied to cylindrical parts.

Acceleration Generates a uniform acceleration field over a part.    

Rotation Force Generates a linearly varying acceleration field over a 
part.
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Line Force Density Generates a line force field of given uniform intensity on 
a part edge.  

Surface Force Density Generates a surface traction field of given uniform 
intensity on a part face.  

Body Force Generates a volume body force field of given uniform 
intensity on a part.

Enforced Displacements Assigns non-zero displacement values to restrained 
geometric selections.

  Mass

Non-structural mass densities of given intensity.
Distributed Mass Equipment Non-structural lumped mass distribution equivalent to a 

total mass concentrated at a given point.
Line Mass Densities Scalar line mass field of given uniform intensity on a 

curve geometry. 
Surface Mass Densities Scalar surface mass field of given uniform intensity on a 

surface geometry.

  Adaptivity Process

Adaptivity Convergence Creating global adaptive mesh refinement specifications 
and computing adaptive solutions.

Adaptivities Selectively refining the mesh in such a way as to obtain 
a desired results accuracy in a specified region.

Adaptivity Boxes Local specifications relative to the maximum error in the 
approximate computed solution relative to the exact 
solution.

 Sensors

Sensors A synthesis of analysis results which 
provide measures that can be re-used in 
Knowledgeware in order to set rules, 
checks and formulas. 

Sensor sets Different types of object sets can be 
generated:  

●     Static case: misesmax (Maximum von Mises), 
dispmax (Maximum Displacement), reaction 
(Reaction on geometry associated to restrain and 
connection specifications) and globalerror 

●     Frequency case: Frequency (Represents the 
frequency value) and Frequencies (Represents the 
list of the frequency values)

●     Buckling case: Buckling Factor 
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  Analysis Connection Manager 

 
Analysis Connections All the connections that you choose not to create using 

the Assembly Design workbench. 

 
Face Face Analysis Connections Connections used for connecting either faces that are 

parallel to each others or concentric cylinders, on an 
assembly model. 

Distant Analysis Connections Connections used for connecting any part from an 
assembly with or without point type geometrical 
elements, on an assembly model.  

Spot Welding Analysis Connections Connections used for projecting welding points onto two 
parallel faces, on an assembly model. 
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Viewing and Hiding Toolbars

Method 1 

1.  Select View->Toolbars.

The list of current toolbars is displayed. Currently visible 
toolbars are indicated by a tick symbol to the left of the toolbar 
name. 

 

 

2.  In the list, click the toolbar you want to view or hide.

Note that: 

●     you can detach toolbars from the application window border by dragging the double 
line to the left of the toolbar: you can drag the toolbar anywhere around the screen, 
then dock the toolbar in the same or in another location by dragging it onto the the 
application window border

●     you can drag a tool icon from a workbench toolbar, and drop it onto a selected 
object: this is a quicker way to run a command.

You can also drag and drop an object onto an object: for example, copy a fillet on a part.
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1.  Right-click any icon in any toolbar.

The list of current toolbars is displayed. Currently visible 
toolbars are indicated by a tick symbol to the left of the 
toolbar name.

2.  Select the Customize... command to display the Customize dialog box.

3.  Click the Toolbars tab, then toggle the Hide or Show button to hide or show the toolbar.

Method 2 
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Viewing the Commands List

This task illustrates how to access a list of all available commands.

1.  Select View -> Commands List...

The Command List... dialog box is displayed: 

2.  Select a command in the list.

Help about the command is displayed in the dialog 
box: 
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3.  With the command still selected, click OK.

The selected command is accessed if the appropriate workbench is already activated. 

To access a command rapidly, double-click the name of the command in the list. 

If you know the first letter of the command, select any command in the list, then type 
the first letter to go to the commands starting with the letter you typed.
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Keyboard Shortcuts 
 

Use this keyboard key (or 
combination)... To...

Escape Exit the current dialog box (when there is one)

F1 Get contextual online help

Shift + F1 Get help on toolbar icons

Shift + F2 Toggle the specification tree overview on and off

F3 Toggle specification tree display on and off

Alt + F8 Run macros

Shift + F3 Activate the graph is the model is active and inversely

Home Display the top of the graph

End Display the bottom of the graph

Page Up Relocate the graph one page up

Page Down Relocate the graph one page down

Ctrl + Page Up Zoom In the graph

Ctrl + Page Down Zoom Out the graph

Up arrow Relocate the graph 1/10th (one tenth) of a page to the top

Down arrow Relocate the graph 1/10th (one tenth) of a page to the bottom

Left arrow Relocate the graph 1/10th (one tenth) of a page to the left

Right arrow Relocate the graph 1/10th (one tenth) of a page to the right

Ctrl + Tab Swap active document windows

  

  

Alt + Enter Run the Properties... command

Ctrl + C Run the Copy command

Ctrl + F Run the Search... command

Ctrl + G Run the Selection Sets... command

Ctrl + N Run the New... command

Ctrl + O Run the Open... command

Ctrl + P Run the Print... command

Ctrl + S Run the Save... command

Ctrl + V Run the Paste command

Ctrl + X Run the Cut command

Ctrl + Y Run the Redo command

Ctrl + Z Run the Undo command
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Another useful shortcut

Clicking an icon lets you run the command associated with that icon only once. However, double-clicking an icon lets you use the 
associated command as many times as you want without having to click on the icon several times. 
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Customizing
Customizing Toolbars

Customizing Standards
Customizing Settings
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Customizing Toolbars and Workbenches
Customizing a Toolbar by Dragging and Dropping

Managing User-Defined Toolbars
Creating User-Defined Workbenches
Customizing Command Properties

Customizing Options
Customizing Buttons 
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Customizing a Toolbar by Dragging and Dropping

This task shows how to customize a toolbar by dragging and dropping a command onto the toolbar to add 
the command, and dragging a command away from a toolbar to delete the command.

1.  Right-click any icon in any toolbar to display the list of toolbars.

For example, the following toolbar list appears when no documents are open: 

 

2.  Select the Customize... command to display the Customize dialog box.

The dialog box contains the following tabs:

●     Start Menu: customizes the Start menu and workbench access icons (as described in 
"Accessing the Navigation Tools")

●     User Workbenches: lets you create your own workbenches

●     Toolbars: lists the currently visible toolbars (default)

●     Commands: lists the commands you can drag and drop onto a toolbar

●     Options: contains general customization options.
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With the Toolbars tab open, double-clicking any icon highlights, in the toolbars list, the toolbar 
the icon belongs to. Double-clicking any toolbar also highlights the toolbar name, allowing you 
to identify it. 

3.  Click the Commands tab to list the commands available.

The Categories list allows you to filter the listed commands by category: the category is the 
name of the menu in the menu bar.

For example, selecting the Edit category in the Categories list displays in the commands list all 
the commands likely to appear on the Edit menu.
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The category All Commands lists all commands available. You can also select the Select 
command.

If you created macros, the macro names are also listed. You can then add macros to a toolbar. 

4.  Select a command from the command list.

In this example, the Capture... command has been selected. Note that the icon for the 
command is displayed at the bottom of the dialog box, along with a short help message 
explaining the role of the icon. 
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5.  Drag the command from the command list to the toolbar to which you want to add the command.

6.  Drop the command onto the desired toolbar.

In our example, the icon for the Image 
Capture... command has been added to the 
standard toolbar:  

 Note that this does not apply to icon boxes which cannot be customized.

7.  To delete a command from a toolbar using the drag-and-drop mechanism, drag the command and 

drop it back inside the list of commands in the Customize dialog box.

You can also drag and drop commands which do not have icons: in this case, the command 
name appears in the toolbar. 
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Your customization is stored automatically in the FrameConfig.CATSettings file: you recover it if 
you exit and restart. For more information about settings, refer to "About Settings" .

Working with ENOVIA LCA: Optimal CATIA PLM Usability

The Safe Save mode prevents the user from creating or editing data in CATIA that cannot be 
correctly saved in ENOVIA V5.
Working in this mode means that certain commands are unavailable (i.e. grayed) as you enter the 
workbench.

However, the list of commands displayed using the Customize... command does not gray these 
unavailable commands. As a consequence, if you drag and drop one of these commands onto a toolbar 
then use it, bear in mind that the created data will not be saved in ENOVIA V5.

For detailed information on the interoperability between CATIA and ENOVIA, refer to the Version 5 
ENOVIA-CATIA Interoperability User's Guide.

1109Page Infrastructure Version 5 Release 13



Managing User-Defined Toolbars

This tasks shows how to create, rename, delete, restore, hide and show user-defined toolbars.

1.  Right-click any icon in any toolbar to display the list of toolbars and associated 

commands.

For example, the following toolbar list appears when no documents are open: 

 
2.  Select the Customize... command to display the Customize dialog box, and click the Toolbars tab if it is not 

already activated.
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 The Toolbars tab lists the currently available toolbars, and provides the commands for:

●     creating new toolbars

●     renaming toolbars

●     deleting toolbars

●     restoring the original content of selected toolbars

●     restoring the original content of all toolbars

●     restore the toolbars to their original position in the current workbench

●     add commands to the selected toolbar

●     remove commands from the selected toolbar.

 
3.  To create a new toolbar, click the New... button.

The New Toolbar dialog box appears with a default toolbar name (NewToolBar001), and an empty toolbar 
appears: 
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4.  Enter the name of the new toolbar, then click OK.

The new toolbar is added to the bottom of the list, and an empty toolbar is added to the right of the main 
application window.

In our example, the toolbar "MyToolbar" has been added to the list: 

 

 
5.  Click the Command tab and drag and drop commands onto the new toolbar.

In our example, the toolbar "MyToolbar" contains three icons: 
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6.  To rename a user-defined toolbar, click the Toolbar tab again, select a toolbar, click the Rename... button 

and enter the new name, then click OK.

 
7.  To delete a user-defined toolbar, click the Toolbar tab again, select a toolbar, click the Delete... button, 

then click OK.

 
8.  To restore the original contents of a toolbar, click the Toolbar tab again, select a toolbar, click the 

Restore... button, then click OK.

The Restore All... button restores the original contents of all toolbars. 

 
9.  To hide or display a user-defined toolbar, click the Toolbar tab again, select a toolbar, and click the Hide or 

Show button to toggle toolbar display on or off, then click OK.
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Working with ENOVIA LCA: Optimal CATIA PLM Usability

The Safe Save mode prevents the user from creating or editing data in CATIA that cannot be correctly 
saved in ENOVIA V5.
Working in this mode means that certain commands are unavailable (i.e. grayed) as you enter the workbench.

However, the list of commands displayed using the Customize... command does not gray these unavailable 
commands. As a consequence, if you drag and drop one of these commands onto a toolbar then use it, bear in mind 
that the created data will not be saved in ENOVIA V5.
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Creating User-Defined Workbenches

This task explains how to create and customize workbenches.

1.  Right-click any icon in any 

toolbar to display the list of 

toolbars.

For example, the following 
toolbar list appears when no 
documents are open:  

2.  Select the Customize... command to display the Customize dialog box.

 

 

 
3.  You can select a workbench then click the Ctrl, Shift, Alt or Other... buttons to include them in the shortcut 

displayed in the Accelerator field.

 

The Other... button lets you see the list of available keys. Just select a key then click the Add button, or 
double-click a key. 

Whichever method you use, the corresponding choice is displayed in the Accelerator field, for example like this: 
Ctrl+. 
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The shortcut you define will appear besides the workbench name in the Start menu. 

4.  Click the User Workbenches tab.

Note that the New... option will be available only if there is an active workbench: if no document is open, the 
New... option will be grayed out. 

 

5.  Click the New... option to 

display the New User 

Workbench dialog box:

6.  Enter the name for your workbench, then click the OK button.

In our example, let's assume the name of the user workbench is "My Workbench". Clicking the OK button adds 
the workbench name to the list... 
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... deactivates the current workbench, and activates "My Workbench", represented by the icon top right: 

 

7.  Click the Toolbars tab, then click the New... option to start adding toolbars to "My Workbench".

The New Toolbar dialog box and an empty toolbar are displayed: 
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In the New Toolbar dialog box: 

●     the Workbenches list contains a list of all workbenches related to the current working context: in our 
example, a CATPart document was open when we created "My Workbench", so the list contains all 
workbenches that could possibly be activated in a CATPart document

●     the Toolbars list contains the toolbars belonging to the selected workbench.

8.  Name the new toolbar to be included in your workbench.

9.  Select a workbench from the Workbench list.

The toolbars belonging to the selected workbench are displayed in the Toolbars list. 

10.  Select a toolbar.

The contents of the toolbar are added to your empty toolbar, for example: 
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11.  Click OK, and close the 

Customize dialog box.

You can then drag your new 
toolbar and dock it to the 
right of the application 
window so that your 
workshop now looks like 
this: 

Note: your user-defined workbench will remain active after it is created, until you activate another workbench. 

Your new workbench is added to: 

●     the top of the Start menu (and to the Favorites list in the Start Menu tab)

●     the "Welcome to CATIA V5" dialog box, which appears when you start a session, or when you click the icon 
representing the current workbench

●     the list of workbench icons accessed by right-clicking the current workbench icon.
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You can also insert your favorites workbenches in the Workbenches toolbar. 

This toolbar is activated when you select Workbenches from the toolbar list:

 

 
The Workbenches toolbar displays the workbenches selected as favorites in the Start Menu tab of the 
Customize dialog box.

 
In the example below, we selected the Product Structure, Real Time Rendering and Catalog Editor workbenches 
as favorites. Thus, the Workbenches toolbar will look like this: 

 

 
Just click one of the icons to start the corresponding workbench.

Note: when removing a dynamic (i.e. non-static and shareable) license during a session, the corresponding 
favorite workbench disappears from the list of favorites. From now on, when the removed license is acquired 
once again, the workbench automatically reappears in the list of favorites. You do not need to add it manually 
anymore.
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Customizing Command Properties

This task explains how to customize command properties by assigning keyboard shortcuts or icons to the 
commands.

 Note that this does not apply to icon boxes which cannot be customized. 

1.  Right-click any icon in 

any toolbar to display the 

list of toolbars and 

associated commands.

For example, the 
following toolbar list 
appears when no 
documents are open: 

2.  Select the Customize... command to display the Customize dialog box.

The dialog box contains three tabs: 

●     Start Menu: customizes the Start menu and workbench access icons (as described in 
"Accessing the Navigation Tools")

●     User Workbenches: lets you create your own workbenches

●     Toolbars: lists the currently visible toolbars (default)

●     Commands: lists the commands you can drag and drop onto a toolbar

●     Options: contains general customization options.
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 3.  Click the Commands tab to list the commands available.
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4.  Select a category (menu name), then double-click a command, or select it and click the Show 

Properties... button.

The Command Properties frame is added to the bottom of the dialog box: 
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5.  Enter a new name for the command, if needed, in the title field.

6.  Click the Ctrl, Shift or Other buttons to include them in the shortcut displayed in the Accelerator 

field.

If the command you are customizing is not represented in a toolbar, a menu bar, etc., the 
Accelerator field is grayed to prevent you from defining a new accelerator or from using an 
already existing accelerator. 
In that case, simply drag and drop the command onto any toolbar to activate the Accelerator 
field.

The Meta button is now named "Other". 
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7.  If you want to use 

another key, click the 

Other... button to see 

the list of available keys.

 

8.  Select a key then click the Add button, or double-click a key.

Whichever method you use, the corresponding choice is displayed in the Accelerator field, for 
example like this: Ctrl+. 

 The User Alias field lets you assign an alias to the selected command. After clicking the Close 
button, you just have to type c:alias_name in the PowerInput field to run the command.
For example: 

enter cap in the User Alias field

then

enter c:cap in the PowerInput field

press ENTER.

The Capture command starts. 

9.  Click the button to the right of the Icon option (bottom right).
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This displays the Icon 
Browser which lets you 
access all the graphic 
icons installed with the 
Version 5 software, 
then browse to select 
the appropriate icon. 

 
10.  Click an icon and click the Close button (if you used the Icon Browser).

The icon is now displayed for the command in the Commands tab, and the Show Properties... 
button changes to Hide Properties...: 
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11.  Click the Reset... button to access the reset options.

You can:

●     restore the original settings of the present command

●     or restore the original settings of all commands in the present category.

 
12.  Click the VR Button Customize button to access the Button Customize window which lets you 

assign any command or macro to a device button.

For detailed information, refer to Customizing Buttons in this guide.

13.  Click the Close button.
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Customizing Options

This task explains how to customize general options.

1.  Right-click any icon in any toolbar to display the list of toolbars and 

associated commands.

For example, the following toolbar list appears when no documents are 
open: 

 

2.  Select the Customize... command to display the Customize dialog box.

3.  Click the Options tab:
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4.  Check the Large Icons option if you want large icons displayed.

The default icon size is large. Uncheck this checkbox if you want the icons to be normal size. 

5.  Check the Tooltips option to switch tooltips on or off.

Tooltips are short help messages displayed when you point to icons, as explained in "Displaying 
Tooltips and Help Messages". 

 

6.  Check the Lock position of toolbars option to lock the position of all toolbars so that they cannot 

be moved.

Note that you do not need to restart the session to take the lock into account. 

When logged as administrator, a green lock button is displayed to the left:

 

 

Clicking this green lock (which then turns ) lets you lock the position of toolbars for all 
users. As a consequence, the Lock position of toolbars option will be disabled when running a 
session as non-administrator.

7.  The User Interface Language option lets you define a Version 5 user interface language 

independently from any other localized languages that may be used in other applications.

Once you have selected the desired language, you have to restart your Version 5 session to take 

the new language into account.

Note: the common use is to leave the field to "Environment language (default)". This default 
option corresponds to the language you define in the Regional Settings tab (on Windows) or in 
the LANG variable (on UNIX). 

 When logged as administrator, you have the ability to lock this option to prevent users from 
modifying the user interface language:
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Click the green lock displayed to the left of "User Interface Language": the lock will turn  
and the option will be disabled when running a session as non-administrator.
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Customizing Buttons

This task explains how to customize buttons which allows you to assign (i.e. map) any given command or macro a 
device button. 
This functionality is available for any application-supported hardware providing the necessary buttons, e.g. Space 
Mouse and the Spaceball range of 3D input devices, joysticks, Intersense wand...

1.  Select the Opens the Button Customize dialog  icon from the 3DxDevice toolbar to open the Button 

Customize dialog box. 

The 3DxDevice toolbar can be accessed by selecting View->Toolbars->3DxDevice.

 Just a few words about the 3Dx Device toolbar which looks like this:
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This toolbar contains native integrated commands which let you modify the mode of the 3Dconnexion® 
device you are currently using. For detailed information, you can browse the following Internet site:

http://www.3dconnexion.com

Clicking:

 toggles the translation mode on/off

 toggles the rotation mode on/off

 toggles the dominant mode on/off

 increases the sensitivity of the device

 decreases the sensitivity of the device

 resets the sensitivity of the device to its original state

 toggles the fast zoom mode on/off. Note that when the fast zoom mode is on, all other manipulation 
commands are disabled. 

 
Note that when entering the Sketcher workbench, the rotation mode is automatically switched to "off".

You can also access the Button Customize dialog box using one of the methods below:

●     select the Tools->Customize command, choose the Commands tab then click the VR Customize 
button

●     select the View->Commands List command then select the VR Button Customize command

●     type  c:VR Button Customize or  c:3Dx Button Customize in the power input field then press 
ENTER

●     press button "1" of your Space Mouse or Spaceball (if you are using original settings).

 

2.  Use the input device name area on top of the dialog box to select the desired device from the pulldown list 

in order to modify button mappings.

In our example, the device is a Space Mouse Plus.

 
Let's have a look at the various information displayed in this dialog box. Click a text to access the 
corresponding information:
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●     the navigation buttons will not be grayed out to let you skip backward  and forward 
through the pages if the device you chose has more than 12 buttons

●     the button title displays the device button title. For instance, with a SpaceBall 4000FLX
the tenth button from the top is shown as "Button A"

●     the button drag-and-drop area to the right displays the title of the command or macro which
is currently assigned to the corresponding device button. For instance, Button 2 has been assigned 
3Dx Rotation On/Off

●     the command icon displays the mapped command icon (if available) as it is shown on a toolbar

●     the help area in bottom part of the dialog box displays a help text for the corresponding mapped 
command
when a device button is pressed (a red arrow identifies in the dialog box the button you press)

3.  Map the desired device button to a particular command or macro using one of the four methods detailed 

below:

 

Dragging and dropping from a toolbar
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1.  Make sure that the toolbar containing the command to be mapped is visible.

2.  Press and hold down the left-mouse button on top of the command icon.

3.  Drag the icon to the top of the button drag-and-drop area:

 

4.  Release the left-mouse button.

The command is assigned to the device button:
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Dragging and dropping from the Customize dialog box

1.  In the Button Customize dialog box, click the Customize... button or select the Tools-

>Customize... command to open the Customize dialog box.

2.  Select the Commands tab:
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3.  In the Categories list, select a category to map a command, or select the "Macros" category to 

map a macro.

4.  Select the command or macro to be mapped from the list of commands.

5.  Press and hold down the left-mouse button on top of the command or macro entry.

6.  Drag the icon to the top of the button drag-and-drop area.

7.  Release the left-mouse button.

The command is assigned to the device button.

 

Note that you can now assign the 3Dx Swap view/tree command to one of the buttons of your 
Space Mouse or Spaceball in order to swap the focus between the specification tree and the 
geometry.

 

Dragging and dropping from another button

You can copy a command or macro already assigned to a device button. To do so:
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1.  Press and hold down the left-mouse button on top of the button drag-and-drop area of the button 

mapping to be copied.

2.  Drag the button mapping to the other button drag-and-drop area the command or macro is to be 

assigned to.

3.  Release the left-mouse button.

The command or macro is now assigned to two different device buttons.

  

Using the contextual menu

As an alternative to the above-detailed drag-and-drop methods, it is also possible to use the contextual 
menu to access the complete list of available commands.

1.  Right-click the desired button drag-and-drop area to display the contextual menus:

2.  Select Get Command.... The Command list dialog box listing the commands available is 

displayed.
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3.  In the Commands list dialog box, select the command to be mapped.

4.  Click OK to validate.

The button drag-and-drop area now shows the title of the mapped command.

If you wish to remove a button mapping, simply right-click the desired button drag-and-drop area then 
select the Delete contextual command. This will empty the button drag-and-drop area to indicate that no 
macro or command is currently assigned to this device button.

The contextual menu also lets you restore the selected button to its original settings by selecting the 
Default contextual menu. In case the selected button has no original settings but only a mapped 
command or macro, the button drag-and-drop area will be emptied (mapped commands or macros are 
not considered as original settings).

4.  Repeat step 3. as many times as needed to map your device buttons.

5.  Press the desired device button to activate the command you assigned to it.

Note: the Restore... button lets you open the Restore Mappings dialog box:
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You can select two options:

●     the current device to restore original button mappings for the device you are currently using

●     all devices to restore button mappings for all devices to their original commands.

In both cases, if the button mappings have no original settings but only mapped commands or macros, 
the button drag-and-drop areas will be emptied since mapped commands or macros are not considered 
as original settings.
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Customizing Standards
About Standards

Customizing Standards for Layers and Filters 
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About Standards
 

This section aims at giving a general overview of standards. For detailed information on standards 
which are specific to a workbench, you will be asked to refer to the corresponding documentation. 

The second part of this section shows a basic example of how standards impact the documents you 
create. 

Introduction

Standards are defined by your administrator in XML (Extensible Markup Language) files and let you 
set default values for element properties. 
Standards can be customized afterwards according to your needs but bear in mind that unless you 
are logged as administrator, you will not able to modify standards.  

There are two types of standards:
 

●     default standards provided by Dassault Systèmes. These standards can be customized using the 
interactive standard editor.
For detailed information on each type of standards, you will have to refer to the corresponding 
documentation. These default standards are for: 

❍     General parameters including
■     default graphic attributes (for Solids, OpenBodies, Points, Lines, Planes and Surfaces) in 

CATStdMechanicalDesign.xml

■     attributes for layers and filters in
■     CATStdLayerAndFilter.xml and CATStdTypeLayerAndFilter.xml for CATPart documents

■     CATDftStdLayerAndFilter.xml and CATDftStdTypeLayerAndFilter.xml for .CATDrawing 
documents

Refer to Customizing Standards for Layers and Filters in this guide.

■     attributes for line thickness in CATStdLineThickness.xml.

❍     Drafting parameters: as far as .CATDrawing documents are concerned, the use and 
administration of their specific standards is detailed in the Version 5 Interactive Drafting 
User's Guide - Administration Tasks

❍     Generative parameters: for detailed information on generative view styles, refer to the 
Version 5 Generative Drafting User's Guide - Administration Tasks.

As far as default standards are concerned, their file name cannot be modified.
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●     user standards which are created and managed by the administrator.

In both cases, the administrator controls the access to the standard files and can, for instance, 
prevent users to edit one or more of these files.

Standard files are identified by two runtime environment variables which are: 

Environment variable Description

  
CATDefaultCollectionStandard Indicates the name and path of the sub-directory (or sub-

directories) containing the default standards provided by 
Dassault Systèmes. This variable is set by default to 
installation_folder\resources\standard during the 
installation procedure

CATCollectionStandard Indicates the name and path of the sub-directory (or sub-
directories) containing the standards customized by the 
administrator. This means that you should save your 
customized standards in these sub-directories

For detailed information on environment variables, refer to What is An Environment? in the Version 5 
Installation and Administration Guide.
For detailed information on how to set variables, refer to Customizing Your Environment on Window 
or Customizing Your Environment on UNIX (depending on your operating system).

 

Impact of standards - Example

This scenario will show you how to access the pre-defined values for information only using the 
interactive standard editor and then, how these standards impact the new documents you will create.

Bear in mind that if you want to be able to modify standards, you must be logged as administrator. 
An example of customization is given in Customizing Standards for Layers and Filters.
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Our example deals with default graphic attributes and thus, this scenario assumes you set up the 
corresponding CATStdMechanicalDesign file. To do so:

1.  Access the following folder to copy the CATStdMechanicalDesign file:

C:\Program Files\Dassault Systemes\B13\intel_a\startup\templates

2.  Paste the CATStdMechanicalDesign file in the following folder: 

C:\Program Files\Dassault Systemes\B13\intel_a\resources\standard

1.  Select the Tools->Standards... command to access the interactive standard editor: 
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Bear in mind that you cannot modify the data, you access the editor for information only.

2.  Select the Category you wish to display: either General or Drafting-specific. Once a category 

is selected, the corresponding .xml file names are displayed in the File list. For instance, 

CATStdLayersAndFilters.xml lets you define default properties for the current layer and filter. 

3.  From the file list, select the CATStdMechanicalDesign.xml file to display the default 

visualization properties defined by your administrator.

4.  Click the plus sign next to CATStdMechanicalDesign node then repeat this step for each node 

to display the complete xml tree structure. As you can see it in the dialog box below, 

standards can be defined for Solids, OpenBodies, Points, Lines, Planes and Surfaces:
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5.  Select the desired item in the tree to expand the node then select the desired element to 

display the corresponding values on the right.

In our example, we display standards applied to the point default color but you can display 

standards for all 3D elements such as line type, thickness, etc.
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The interactive standard editor shows that the default color for points is green which 
means that in any new document you will create, points will be created with a green 
color. 

6.  Click OK to close the interactive editor. 
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7.  Suppose you create a new part document by clicking the New icon  or by selecting the 

File->New... command. 

Standards impact new CATPart documents only. They do not apply to other documents 

you may have previously created.

For detailed information on document creation, refer to Creating New Documents in this 

guide.

8.  From the Start menu, select Shape Design then access the Generative Shape  Design 

workbench.

9.  Create as many points as you wish by clicking the Point icon then entering the desired 

coordinates:
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The color of the created points matches the color displayed in the interactive editor.
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Customizing Standards for Layers and Filters
 

As explained in About Standards, default standards for layers and filters are provided by Dassault Systèmes and 
referenced by the CATDefaultCollectionStandard environment variable which is set to 
installation_folder\resources\standard by default.

Two sets of .xml files are provided: 

●     CATStdLayerAndFilter.xml and CATStdTypeLayerAndFilter.xml for part documents

●     CATDftStdLayerAndFilter.xml and CATDftStdTypeLayerAndFilter.xml for .CATDrawing documents. 

The default values set in these samples can easily be customized to address your needs, provided that you are logged 
as administrator.

This scenario aims at explaining how to modify the standard parameters for layers and filters either by using the 
interactive editor, or by editing the .xml standard file.
We will take CATStdLayersAndFilters.xml as an example but the method is identical for editing the other XML files 
available in the General category.

Prior to modifying standards, you need to set the CATCollectionStandard environment variable to identify the location 
where your customized standards will be saved. 
For detailed information on how to set environment variables, refer to Customizing Your Environment on Windows (or 
on UNIX depending on your operating system).

Using the interactive editor 

1.  Select the Tools->Standards... command to access the interactive standard editor: 
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2.  Check that the General category is selected then from the file list, select the CATStdLayersAndFilters.xml file.

 
3.  Click the plus sign next to CATStdLayersAndFilters node then repeat this step for each node to display the 

complete xml tree structure with the values defined by your administrator. 

As you can see it in the picture below, standard properties have been defined for the following instances: 

●     current layer and filter

●     2 layers named "General" and "Basic geometry". 

Refer to Assigning Objects to Layers for detailed information on how to use layers

●     3 filters named "None", "All' and "Current". 

Refer to Using Visualization Filters for detailed information on layer filters.

More precisely, our example shows that the layer Basic geometry has been assigned number "1" without any 

comment:

1150Page Infrastructure Version 5 Release 13



Now let's suppose you want to add a new layer. To do so: 

4.  Select the Layers node from the tree structure then click the Add instance button to the right.

This creates a new instance  in the tree structure which is named "NoNameDefined" by default.

5.  Select the created instance, i.e. "NoNameDefined" then assign a number (the value must be comprised between 

0 and 999) to the layer, a name of your own choosing as well as a comment (if necessary) in the corresponding 

fields as shown below:
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6.  To create a new filter, select the Filter List node then click the Add instance button.

7.  Select the created instance (NoNameDefined) then enter a name and a value:
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You can modify any field value anytime simply by selecting the desired instance then entering the new value 
in the corresponding field.

8.  In case you are not satisfied with an instance, select the node under which you want to remove an instance then 

click the Remove instance button (in our example, we choose the Layers node).

This opens the following dialog box which displays the list of available instances for the selected node:
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Just select the instance to be deleted then click OK to validate.

9.  When finished, you can:

●     click OK to save the modifications in the CATStdLayersAndFilters.xml file. A pop-up message will inform 

you that the modified standard file has been saved in the directory specified when setting the 

CATCollectionStandard variable

●     click Save As New to save the modifications in a new .xml file. Clicking this button opens the Save As 

dialog box which places you in the directory you specified when setting the CATCollectionStandard 

variable and lets you give a name to the file. This new file will then be accessible from the File pulldown 

list.

 

Editing the .xml file

Standard files are stored in a format called XML (Extensible Markup Language) used to exchange data very easily. 
XML files can be customized in a simple way, for instance to add new layers and filters, provided that you respect some 
syntax rules detailed hereafter.

Be careful not to edit the CATStdTypeLayerAndFilter.xml file since it contains the layer and filter type definition used 
in the CATStdLayerAndFilter.xml file: 

 

1.  Open the CATStdLayerAndFilter.xml file in your XML editor. This file is made up of the following parts:

 
●     XML starting tags indicating the format as well as the name and type of the file:

Note: you cannot change the name of standard files included in the General category. For these files, the Save As
New button can only be used to generate a new file under another directory but still with the same name.
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●     data related to the "Current" layer and filter, i.e. the layer to which objects are assigned and the 
visualization filter set as current. We recommend that you leave these data unchanged to avoid any 
trouble or misunderstanding.
In our example, the value "-1" corresponds to the layer "None" which means that there is no current 
layer:

 

●     the list of layers declared in this standard file. This list is surrounded by <std:node name="Layers"> at 
the beginning and </std:node> at the end.
Two layers have been defined in our example, each layer definition containing a Number and a Name (a 
Comment may be added, if necessary):

 

●     the list of layer filters. This list is surrounded by <std:node name="LayersFilters"> at the beginning and 
</std:node> at the end.
Three filters have been defined in our example, each filter definition containing a Name and a Value:
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●     the file ends with the tag </std:node>.

2.  To declare a new layer, you just have to add a sequence <std:typeval name="CATLayer"> ... </std:typeval> to 

the node "Layers". For instance:

<std:typeval name="CATLayer">

    <std:intval name="Number">50</std:intval>

    <std:strval name="Name">My new layer name</std:strval>

</std:typeval>

 

Note that the layer number must be comprised between 0 and 999. 

 

3.  To declare a new filter, add a sequence <std:typeval name="CATLayersFilter"> ... </std:typeval> to the node 

"LayersFilters". 

For instance:

<std:typeval name="CATLayersFilters">

    <std:strval name="Name">Only Layer One</std:strval>

    <std:strval name="Value">Layer=1</std:strval>

</std:typeval>
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As you can see it in the above example, a filter must be created using a layer number. However, neither filter 
value nor filter definition needs the layer to be declared. 

For instance, you can enter:

<std:typeval name="CATLayersFilters">

    <std:strval name="Name">My Filter</std:strval>

    <std:strval name="Value">Layer=0 + Layer=50 + Layer=100</std:strval>

</std:typeval>

even if Layer 100 does not exist.

You can even use more complex expressions such as "Layer=0 + (Layer>50 & Layer<100)" but the simpler, 
the better.

4.  When finished, save the modified .xml file. 

The new standards for layers and filters will be applied to any documents you will create from now on.
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Customizing Settings

About Settings
General

Infrastructure
Mechanical Design

Shape
Analysis & Simulation

AEC Plant
NC Manufacturing

Digital Mockup
Equipments and Systems

Knowledgeware
Digital Process for Manufacturing

Ergonomics Design & Analysis
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About Settings

Types of Data Created by Version 5

Version 5 creates two types of data: 
●     application data contained in the documents you create

●     and setting files which are non-editable

There are two types of settings:

●     temporary settings

●     permanent settings.

What Do Settings Files Contain?

Temporary settings contain settings of a temporary nature (album screen captures, roll file information,...) 

CATTemp contains two folders or directories:

●     Album: contains screen captures created using the Tools->Image->Capture... command

●     CNext01.roll: roll file.

Temporary settings are created in a location referenced by the CATTemp variable.

Permanent setting files store customization you perform mainly using the various tabs provided by the Tools->Options... command. For example, 
application window customization, background colors, part and print settings, etc.

Permanent setting files are identified by the suffix: *.CATSettings, and are created in a location referenced by the CATUserSettingPath variable.
Deleting either types of files deletes your customization.

 

How Do You Specify Settings?

You specify settings using the Tools->Options... command which displays the Options dialog box:
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The left-hand column contains a list of categories used for organizing the different groups of settings. There are general settings for all configurations 
and products, and settings for each type of configuration installed. The category names are the same as those listed on the Start menu.  

To access the settings for a specific configuration, click the "+" to display the subcategories. Clicking on the subcategory displays the settings tabs for 
that subcategory.
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Where Are Settings Files Located on Windows?

The location of settings files on Windows platforms is inspired by the general data and settings management requirements operating on the Windows 2000 
platform, which provides an underlying infrastructure allowing you to separate user data, user settings and computer settings. 

The mechanism used is the CSIDL value mechanism. This implementation allows:

●     your permanent settings (CATSettings) to roam as part of your user profile (CSIDL_APPDATA)

●     your temporary settings (CATTemp, etc.) to be still stored in the user profile, but prevents them from roaming (CSIDL_LOCAL_APPDATA).

The following table will help you determine where your settings are now located:

Windows 2000/XP

VARIABLE LOCATION

CATUserSettingPath C:\Documents and Settings\user\Application Data\DassaultSystemes\CATSettings

CATTemp C:\Documents and Settings\user\Local Settings\Application Data\DassaultSystemes\CATTemp

CATCache Obsolete

CATReport C:\Documents and Settings\user\Local Settings\Application Data\DassaultSystemes\CATReport

CATErrorLog C:\Documents and Settings\user\Local Settings\Application 
Data\DassaultSystemes\CATTemp\error.log

CATMetasearchPath C:\Documents and Settings\user\Local Settings\Application Data\DassaultSystemes\CATTemp

CATW3PublishPath C:\Documents and Settings\user\Local Settings\Application Data\DassaultSystemes\CATTemp

1161Page Infrastructure Version 5 Release 13



CSIDL Values in Environment Variable Paths

The values: 

 C:\Documents and Settings\user\Application Data

are the defaults on these Windows platforms for the CSIDL_APPDATA values.

The values:

 C:\Documents and Settings\user\Local Settings\Application Data

are the defaults on these Windows platforms for the CSIDL_LOCAL_APPDATA values.

Location of Settings Files on UNIX

Permanent settings are stored in the CATSettings directory in your home directory; temporary settings are stored in the CATTemp directory, also in your 
home directory.

Administrator Settings

If you start a session in administrator mode using a specific environment, you can lock settings so that other users running a session with the same 
environment inherit those settings and cannot change them. For full details how to do so, refer to Locking Settings.

Default Settings and Recommended Settings
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 Default settings are provided by applications. However, we recommend the following settings to enhance performance: 
●     General category, Performance tab: 

❍     deactivate occlusion culling

❍     level of details (static) = 1 to 1.2

❍     level of details (while moving)  = 10 to 11

●     General category, Visualization tab:
❍     deactivate the graduated color background

❍     deactivate preselect highlighting

❍     deactivate the manipulation bounding box

●     Product category, Cache Management tab:
❍     work with cache management

❍     cache size = 600MB

Selecting View->Render Style->Shading to work with shading without edges will also enhance performance.

 

Accessing Settings Without Running a Session
You do not need to start a session to be able to access your settings.

On Windows

1. Change to the default folder in which you installed the product. 

On Windows, the default folder is:

C:\Program Files\Dassault Systemes\B13\intel_a\code\bin
2. Enter the command: 

CATOptionsMgt
You can also access the Options dialog box using the Start->Programs->CATIA Tools menu, and running the Settings Management V5R13 
command.
The Options dialog box is displayed.
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This function is useful for administrators because it allows you to set up user settings without having to start an interactive session first. 

Specify your settings as usual.

On UNIX

1. Log on as root or end user.
2. Enter the command: 

/usr/DassaultSystemes/B13/OS_a/code/command/catstart -run CATOptionsMgt
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General
General

Help
Licensing
Document

Macros
Performances

Printers
Server Manager

Statistics
Display

Compatibility
Parameters and Measure

Devices and Virtual Reality 
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General  

This task explains how to customize general-purpose settings.

1.  Select the Tools->Options... command.

 
2.  Select the General category (in the tree to the left), then the General tab:
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User Interface Style
●     CATIA - P1: sets the P1 user interface style, and is available for both CATIA - P1 and 

CATIA - P2 users 

●     CATIA - P2: sets the P2 user interface style, and is available for CATIA - P2 users only

●     CATIA - P3: sets the P3 immersive user interface style and features, and is available 
for P3 products/configurations only.

Data Save

The option Automatic backup every ... minutes allows you to specify a save frequency 
other than the default frequency (30 minutes). This option is activated by default.

The purpose of this option is to automatically save your data to allow you to recover it 
after a crash. When a crash occurs, and you restart your session, the Warm Start dialog 
box asks the following question:

Do you want to recover previous session data?

If you choose "Yes", your documents will be recovered in the state in which they were last 
saved by the automatic save option. Any data created after the last automatic save will 
not be restored.

If you choose "No", a new document will be created when opening the session.

No automatic backup: documents are not saved automatically.

You may encounter, when working on a document, a dialog box containing the following 
message:

Command interrupted

When this occurs, we recommend that you click OK to continue (a check is launched on 
your data in the background). Then, you should immediately save your document(s) and 
exit then restart your session.

We also recommend the same method if a dialog box appears containing the message:
"This handler is null"
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 Incremental backup

Autosave Feature Constraints

Until now, warm start meant simply automatically saving all documents every xx minutes. 
Autosave operations on large amounts of data can take a long time, even lasting several 
minutes, and all interactions since the last autosave are lost. The autosave feature can 
also be deactivated by users who prefer to save their documents frequently and manually 
to avoid losing data.

Incremental Warm Start Principles

All open documents are stored in a temporary directory, and all modifications to the 
document are logged in a log file. These operations involve a minimum inconvenience for 
the end user when opening documents (direct copy without loading), and the logging of 
document modifications at each interaction is not perceptible.

Regarding the restore behavior:

●     after a crash, all documents are opened from the temporary directory

●     all modifications stored in the log are replayed

●     all necessary editors are opened

●     restoring data could take a long time:
❍     all modifications made by users (including test/try, mistakes, etc.) are replayed

❍     time is needed to replay necessary updates.

A slight risk is involved: the modification log needs to be complete, otherwise there is a 
risk of restoring corrupted data.

The incremental warm start mechanism is available for the CATPart, CATProduct and 
CATDrawing document workbenches.

Note: movements of components using compass are not retrieved when 
translation/rotation is the last operation before a crash. 

Example

1.  Start a Version 5 session, select the Tools->Options... command, click the 

General tab, and check the Incremental backup option, then click OK to save, and 

restart Version 5.

2.  Continue making modifications to the current document until a crash occurs.

3.  Kill your Version 5 session.
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4.  Restart Version 5.

5.  After restarting, you are prompted as follows:

Previous session abnormally ends,

do you want to recover data?

Click OK to recover data.

A progress bar is displayed while the data is being restored, and a confirmation 

window is displayed after the data has been restored:

Data successfully restored, please save all to activate incremental warmstart again

6.  Check visually that your data was correctly restored.

7.  You must save all data to reactivate the incremental warm start feature.

If you do not do so, the incremental warmstart feature will be deactivated.

8.  Continue working.

Partial Activation

As specified above, certain workbenches do not support the incremental warm start 
feature. When you switch to a workbench which does not support it, a message will inform 
you that the workbench does not support this feature, and warn you that it is deactivated.

The same also applies to certain commands: when you start the command, you will be 
warned that the incremental warm start feature is deactivated.

To reactivate the warm start feature, go into a workbench supporting the incremental 
warm start feature, and save all documents. If you close all documents, the warm start 
feature will be activated for the next opened document supporting the incremental warm 
start. You can close or save one V5 document, but if there is always only one dirty 
document in the session, the warm start will not be reactivated.

Generally speaking, if in doubt, save all documents to be sure the warm start is 
reactivated. It enables you also to empty the modification logging files which can be large 
after a long time.

 

Disconnection 

The option Automatic disconnection after ... minutes lets you activate automatic 
disconnection of your Version 5 session after a user-defined duration (in minutes) without 
program use. 
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Referenced Documents

By default, the Load referenced documents option is checked. This means that when a 
father document is loaded, the child documents it points to are also loaded. However, if 
you uncheck this option, only the father document is actually loaded when you open it. 
This may be useful for reasons of performance and efficiency. A typical case of this would 
be a CATProduct or CATDrawing document, i.e. the father document pointing to CATPart 
or model documents i.e. the child documents.

Once a father document has been loaded you cannot load or unload its child documents as 
changing the option cannot apply retroactively. You must close the father document, 
check or uncheck the Load referenced documents option then reopen the father 
document.

If you open a father document containing unloaded child documents you can load one or 
more of these documents using the File->Desk command (see Using the FileDesk 
Workbench).

Note that when loading objects pasted "As Result With Link" or external references, the 
pointed documents containing the referenced geometry are not loaded and this, even if 
the Load referenced documents option is checked. These pointed documents will be 

identified by the symbol  in the specification tree to indicate that they have been 
found but not loaded.

 
Conferencing 

If you installed a license for a DMU Navigator product, you will be able to run conferencing 
sessions: a conference host initiates a conferences and invites other users to join the 
conference as guests. 

The actions replicated during a conference are the following:

●     workbench transition

●     object selection

●     viewpoint modification (zoom, rotation)

●     3D annotations (creation, modification and deletion)

●     2D annotations (linked to cameras) creation, modification and deletion.

Conferencing is available on the Windows and UNIX platforms, and is based on two 
underlying prerequisites:

●     NetMeeting (provided with Windows)

●     the Communications Backbone (provided with the Version 5 infrastructure), required 
for conferencing on UNIX.
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For more information, refer to the DMU Navigator User's Guide.

Drag & Drop 

Enables dragging and dropping in the viewers (for copying, pasting or cutting purpose 
only).  

For more information, refer to Dragging and Dropping Icons onto Objects and Dragging 
and Dropping Objects onto Objects in this guide.

Note: this drag and drop option does not apply to toolbar customization.

3.  Click OK to confirm.
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Help  

This task explains how to customize contextual help-purpose settings.

1.  Select the Tools->Options... command.

2.  Select the General category (in the tree to the left), then the Help tab:

 

 
Technical documentation

The Location field displays the current location of the online documentation. By default, 
the online documentation is located in: 

C:\Program Files\Dassault Systemes\B13doc 

Enter the path where the documentation is installed or click the Path selection  icon 

to navigate to the desired location then click the  icon to add the selected directory or 
file to the path (displayed to the right).

Once a path has been added to the list, you can select it then click the following icons to:
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●      move it up in the list

●      move it down in the list

●      remove it from the list.

Please note the following information: 

●     if you install the documentation on the network, you can map a drive and enter the 
appropriate path in this field. UNC (Universal Naming Convention) syntax is also 
supported. Refer to Doc Installation Path for more details.

●     if the online documentation is installed on a http server, the installation path must be 
surrounded by quotes, for instance "http://myserver/B13doc".

Note also that the Path Selection dialog box lets you select several different paths to 
interactively concatenate them. On Windows, you can perform the concatenation 
manually. In that case, the separator to be used is ; and not : . 
Furthermore, when you select several paths using the Path Selection dialog box, the 
concatenated paths are represented between " ", for example, like this:

"J:\V5R13DOC\Doc";"F:\V5R13DOC\Doc"  

If you indicate a wrong path, an error message is displayed to inform you that the 
previous path will be kept.

The Language pulldown list lets you select your documentation language: "Environment 
language (default)" or any language you selected when installing the software. For 
detailed information on installing Version 5, refer to Unloading Your Product Code on 
Windows (or on UNIX). 
The default environment language corresponds to the language you define in the Regional 
Settings tab (on Windows) or in the LANG variable (on UNIX). 

To access a documentation in the same language as the software, you need to install the 
online documentation in the appropriate language. Refer to Installing the Online 
Documentation After Installing the Software on Windows (or on UNIX).
However, note that the documentation language you choose is independent from the 
language of your session or of your operating system. For instance, you may run a 
session in Japanese and access an English documentation, provided that you installed it 
on your computer.
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 User Companion

The Location field displays the path to the User Companion (provided that the Computer-
Based Training module and the Companion have been previously installed). You can enter 

another path directly in this field or click the Path selection  icon to navigate to the 

desired location then click the  icon to add the selected directory or file to the path 
(displayed to the right).

Contextual Priority

This area enables you to specify which documentation ("Technical Documentation" or 
"User Companion") will be accessed in priority when pressing the F1 key to get contextual 
help.
By default, the User Companion takes priority.

3.  Click OK to confirm.
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Licensing 
Refer to Reserving Static Licenses Using the License Manager for detailed information about how to 
reserve configuration and product licenses using the License Manager.
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Document 
This task explains how to manage document environments as well as linked document localization.  

For detailed information about the administration of document environments based on the DLName mechanism, refer to Administrating 
Data Using the DLName Mechanism.

1.  Select the Tools->Options... command.

2.  In the General category, click the Document tab:

 

File Options

 

You can activate at anytime the "Upper case for document names" option which converts file names to upper case when saving 
documents.
This conversion will be taken into account when using the following commands:
 

●     File->New...

●     File->Save As...

●     File->Save Management...

●     File->Send To->Mail/Directory.

 

The File Options group box also lets you organize DLNames in a logical way. Refer to Activating Logical FileTree for DLNames 
further in this scenario for detailed information.
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Document Environments

 

The Document Environment is a way of accessing your documents. When you access the Document tab, the following document 
environments are displayed:

●     Folder: default document environment in which the dialog access any folder containing the documents

●     DLName: document environment which lets you restrict the access to specific folders referenced by logical names 
("DLNames"). Each folder is assigned a logical name.
Any modification of a path impacts the DLName once, thus avoiding to search for and modify manually any occurrence of this 
path. 
The administrator may also define the folders in which users are allowed to work

●     SmarTeam: lets you access SmarTeam projects stored in SmarTeam - CATIA Integration

●     SmarTeam Query: lets you access SmarTeam projects stored in SmarTeam - CATIA Integration using queries

●     SmarTeam2: lets you access documents stored in SmarTeam - CATIA Xtended Integration

●     Enovia: lets you access documents stored in ENOVIA V5

●     Catalog: lets you access documents stored in catalogs

●     Loaded document: lets you access documents loaded in the current session.

 A document environment may be assigned one of the following states:
 

●     Current: sets the selected environment as the current document environment and defines the dialog box (i.e. File->Open, 
File->Save, Edit->Links, etc.) that will be displayed when accessing your documents

●     Allowed: indicates that the environment may be set as "Current" or "Not allowed"

●     Not allowed: indicates that the environment may not be set as "Current". You have to assign it the "Allowed" state before 
selecting it as your "Current" environment. 

Note that the Catalog and Loaded document environments cannot be set as "Current".

If your administrator has locked the document environments, the Allowed and Not allowed buttons are grayed and thus 
cannot be selected by the user. Only the Current and Configure... buttons are active. 

Setting the DLName environment as Current

3.  In the Document Environments column, select "DLName". 

4.  Select successively the Allowed and Current buttons. 

DLName is now defined as your current document environment as indicated by the "Current" value in the State column.

Defining DLNames

Now that you have set the DLName environment as your current environment, you have to create the DLNames you will use.  

5.  Click the Configure... button to open the Configure dialog box which lets you add or remove DLNames:
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Note: the UNIX Folder column is displayed on Windows only when running Version 5 in administrator mode. On UNIX, only the 
Windows folder is displayed.
When running Version 5 in user mode, only the column corresponding to your operating system will be displayed (for instance, 
"Windows Folder" when working on Windows).

The Lock column is displayed in both administrator and user modes:

●      means "locked" (in user and administrator mode)

●      means "locked at administrator level" (in administrator mode)

●      means "no lock" (in administrator mode). In user mode, there is no lock symbol.

6.  Click the  button or right-click then select the New command to create a new DLName.

A default name and a default folder are assigned to the new DLName as shown below (you can create as many DLNames as 
necessary):
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7.  If you are authorized by your administrator (i.e. when no lock appears opposite the DLName), you can modify the values displayed. 

To do so, click the desired value to be able to edit it then type the new data.

In administrator mode, you can modify the DLName and the associated paths as you wish.

In user mode, you can create a root DLName. However, do not forget that some rules apply if you want to modify names and 

folders:

●     when changing the folder of a sub-DLName, the new folder must correspond to a folder of the father DLName

●     the name of the last folder (on UNIX and Windows) must be the one of the DLName.

Therefore, be extra careful when renaming a DLName since this modification will impact the name of the folder and of the sub-

folder(s), if any!

Any modification of a root DLName path is controlled by the administrator which may prevent you from doing so.

As far as sub-DLNames are concerned, you cannot modify the path of a sub-DLName because this path contains the name of the 

sub-DLName and depends on the location of the parent DLName.

 

To modify the Windows folder of a DLName, just select the folder to be modified in the Windows column then choose the 

Browse contextual command: this opens a dialog box that lets you navigate to the new folder. After clicking OK, this new folder 

will then replace the former folder in the Windows column.

Note that you can include variables in DLNames using the syntax $ {VARIABLE}.

For instance:

C:\users\${MODEL}\publish    where  ${MODEL}      is a user-defined variable. 
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8.  If you are running in administration mode, you can lock or unlock each DLName individually simply by clicking the green symbol 

opposite the DLName.

Locking a DLName changes its state from  to  (and inversely when you unlock the DLName).  

As an administrator, you can also click the general lock to prevent end users from defining and modifying DLNames. Therefore, 

the following commands will not be available: New, Browse, Delete, Import and Export.

 

9.  When finished adding DLNames to your list, you can then click the  button or use the Export contextual command to save your 

list of DLNames as a .txt file in the appropriate location using the Export DLNames dialog box. 

You can make as many lists as you like and, for further use, import the list whenever you want to. To do so, click the  button 
or use the Import contextual command then select the list to be imported in the Import DLNames dialog box.

 10.  If you want to remove a DLName from the list, select it then click the  button or use the Delete contextual command.

 Once DLNames have been created, they are displayed in the "Look in" pulldown list:

 

 
You can then use this list to display sub-DLNames, if any. In our example, selecting DLNAME 1 in the list shows that it contains a 
sub-folder "DLNAME4":

 

 

Note that you can also display sub-DLNames either by double-clicking the father DLName in the DLName column or by selecting 
the father DLName (still in the DLName column) then the Down contextual command.

To re-access the upper level, click the  button.

12.  Click Dismiss to close the Configure dialog box then OK to exit the Document tab. 

Once you have defined your DLNames, you are allowed to put them in a search order. For more information, refer to Localizing 
Linked Documents further in this task.

Defining DLNames also impacts the commands in which they are integrated. Refer to the DLName Integration section for 
detailed information.
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Activating the Logical FileTree for DLNames

This task aims at explaining how to organize your DLNames in a "logical tree" so that they are easier to access and how this will impact all 
commands providing access to DLNames through file or folder selection.

Prior to organizing DLNames, you must define them. Refer to Defining DLNames for detailed information.

 

Once your .txt list of DLNames has been created, some additional modifications are necessary to create the required structure with respect 
of rules that will be detailed hereafter:

●     each DLName has a unique name inside the whole logical structure

●     each DLName has one logical DLName "father", which can be an already defined DLName or the abstract "Root DLName"

●     there is no relation between the logical structure and the physical one. When working in administrator mode, you can place the 
DLName wherever you want and give it the name of your choice. 
However, in user mode, bear in mind that when you decide to define a DLName as a sub-DLName of another existing DLName:

❍     the name of its physical sub-folder will be the one of the sub-DLName

❍     the location of its physical folder will be a sub-folder of the parent DLName's physical folder.

1.  Open your .txt list to define your structure using the following format:

 
●     one line per DLName

●     each line has four fields separated each with a semi-colon as shown: Logical Name;Windows Folder;UNIX Folder; Father 
Logical Name. The first three fields correspond to the first three fields displayed when configuring DLNames

●     each field ends with a semi-colon

●     a blank space between the last two semi-colons means that the Father Logical Name will be "Root DLName".

 Let's have a look at the following example...

DLName1;E:\users\ajt\;/tmp; ;
DLName2;E:\users\ajt\DLName2;/tmp/DLName2;DLName1;
DLName3;E:\temp;/tmp; ;

... and more precisely at the meaning of each line:

DLName1;E:\users\ajt\;/tmp; ;

●     the logical name is named "DLName1"

●     the logical name is located in "E:\users\ajt" on Windows

●     the logical name is located in "/tmp" on UNIX

●     the logical father name is "Root DLName".

DLName2;E:\users\ajt\DLName2;/tmp/DLName2;DLName1;

●     the logical name is named "DLName2"

●     DLName2 is a sub-directory of DLName 1. This sub-directory is named "DLName2" after the DLName it corresponds 
to. As a consequence, the logical name is located in "E:\users\ajt\DLName2" on Windows

●     DLName2 is a sub-directory of DLName 1 and thus, the logical name is located in "/tmp/DLName2" on UNIX

●     the logical father name is "DLName1".

DLName3;E:\temp;/tmp; ;

●     the logical name is named "DLName3"

●     the logical name is located in "E:\temp" on Windows

●     the logical name is located in "/tmp" on UNIX

●     the logical father name is "Root DLName".

 
2.  Save your .txt file.

 
3.  Access the Document tab in Tools->Options...->General then click the Configure... button.
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2.  Save your .txt file.

 
3.  Access the Document tab in Tools->Options...->General then click the Configure... button.

 

 

4.  Click the  button to import the logical structure you have created in step 1.

 
5.  Navigate to the .txt file to be imported then click Open. The logical structure is imported:
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6.  Click OK to validate.

 
7.  Check the "Activate Logical FileTree for DLNames" option.

 

8.  Click the Open icon  or select the File->Open... command. You will see that the Open document dialog box reflects the 

hierarchical organization and differs slightly from the Open document dialog box displayed when the logical filetree is not activated.

Example 1 - logical filetree is activated:

 

 Example 2 - logical filetree is not activated:
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 The Open document dialog box opens simultaneously with the Browse window. For more information on this window, refer to 
Opening Existing Documents Using the Browse Window.

 
9.  To access the sub-directory "DLName2", just double-click it from the list. You can, of course, display the preview of the desired 

element by selecting it:

 

 
When you are in a sub-directory as this is the case in our example, you can click the icon  to move up in the hierarchy. In 
our case, we can use it to access the father directory "DLName1".

 
10.  Clicking the black arrow next to "Look in" displays a pulldown list containing the hierarchical structure from which you can click the 

directory you want to access:
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 Would you need to display more information on the files displayed, click the Details icon. This display mode gives you 
information on the size, the type and the last modification date and time:

 

 If you want to revert to the List mode, click the List icon.

 
11.  Click OK to open the selected document.

 

 

DLName Integration

This task aims at giving you one example of the DLName integration with the File->Open command.

1.  Click the Open icon  or select the File->Open... command. Instead of the usual File Selection dialog box, the following dialog 

box opens:
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The Open document dialog box opens simultaneously with the Browse window. For more information on this window, refer to 
Opening Existing Documents Using the Browse Window.

In case no DLName has been previously defined, a warning dialog box opens when running the command.

Clicking the black arrow next to "DLName1" displays a pulldown list containing the DLNames you defined in the previous steps:
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Should you need to display more information on the files displayed, click the Details icon. This display mode gives you 
information on the size, the type and the last modification date and time:

 

 
If you want to revert to the List mode, click the List icon.

Note: this Open document dialog box is very similar to the File Selection displayed when opening existing documents since you 
can, for instance, select the document type. For more information, refer to Opening Existing Documents in this guide.

2.  Select the desired File name and type from the list

 3.  If you want to filter the list of DLNames to be displayed, click the Look in: button to open the Logical Name Selection dialog box:

 

 

This dialog box lists existing DLNames in alphabetical order. To filter the list, just enter the desired string in the Searched String 
field then press ENTER to validate. 
For instance, entering "1" displays only DLNames containing the string "1" as shown below:
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You can reset the filtered list to its original state by clicking the Reset button.
When finished, just click OK to close the window and go back to the Open document dialog box.

4.  Click OK to open the selected document

DLNames are also integrated in the following commands: 

●     File->Save (included Save As..., Save All and Save Management...)

●     File->Desk

●     File->New from...

●     File->Send To

●     Edit->Links...

●     Search order ("Other folders" option)

●     Browse another catalog (refer to the Version 5 Component Catalog Editor User's Guide - Browsing a Catalog using the 
Catalog Browser for detailed information)

●     Save in catalog (refer to the Version 5 Generative Shape Design User's Guide - Saving PowerCopies into a Catalog for 
detailed information)

For more information on these commands, refer to the corresponding task in this guide by clicking one of the above hyperlinks.

 

Localizing Linked Documents

The "Linked Document Localization" replaces the "Search Order" command. 

This task shows you how to define a personal strategy for link resolution.

The primary aim of the Linked Documents Localization... function is to resolve document links and to manage in an easy way the strategy 
that will be used to locate your linked documents. Its purpose is different from that of the Edit -> Links command (see Editing Document 
Links).

A default strategy will always take an already loaded document with the same identification to resolve document links. In a 
file-based environment, a document is identified by its name and an internal identifier. 

1.  Select the Tools->Options... command then in the General category, click the Document tab.

 The following dialog box appears:
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The Document Location column contains the various strategies you can choose to localize your linked documents.
The Active column indicates whether a strategy has been activated ("Yes" value) or deactivated (blank value).

If your administrator has locked the Linked Document Localization, all buttons except Configure... are grayed.

2.  Choose a strategy from the proposed list:
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●     Folder of the link: provides the absolute path which was saved in the link, i.e. the path used when you saved your document

●     Folder of the pointing document: provides the current folder of your document

●     Relative folder: provides a sub-folder with the same starting path

●     Other folders: provides a user-defined list of folders (former "Search Order")

●     PDM Reconciliator Locator: enables to reroute document links by providing the path to documents moved from one PDM to 
another (for instance, from ENOVIA VPM to ENOVIA V5)

●     Entreprise Process-libraries: provides the path to folder containing process libraries (.act files)

●     Catalog & Startup Documents: provides the absolute path to catalogs and documents saved in the startup installation folder 
(for instance c:\Dassault Systemes\B12\$OS\startup\...). When migrating from one release level to another, any link to 
a catalog or document located in the installation folder will be automatically updated to match the new startup path

●     SmarTeam Database (appropriate license is required) for documents stored in SmarTeam

●     ENOVIA LCA (appropriate license is required) for documents stored in ENOVIA LCA

●     ENOVIA VPM database (appropriate license is required) for documents stored in ENOVIA VPM.

The following example illustrates more precisely the behavior of the four first strategies:

First of all, we created a product named Product1.CATProduct 
in the folder /u/users/DS/. 
This product is linked to Part1.CATPart, which is stored in the 
folder /u/users/DS/Sub/.

Then, we moved Product1 to another folder, i.e. E:\tmp\DS\. 
As this product is linked to Part1.CATPart, you need to select a 
link resolution strategy. Depending on the strategy you select, 
the behavior will be:

●     Folder of the link:
try to locate Part1 in /u/users/DS/Sub

●     Folder of the pointing document:
try to locate Part1 in E:\tmp\DS

●     Relative folder:
try to locate Part1 in E:\tmp\DS\Sub

●     Other folders:
try to locate Part1 in user-defined folders.

 

 

3.  Once the strategy is selected, click one of the buttons displayed in the right part of the dialog box. These buttons are grayed out 

depending on the strategy you selected:

●     "Activate" lets you activate a strategy that has been deactivated

●     "Deactivate" enables you to deactivate a strategy

●     "Up" and "Down" let you customize the strategy order

●     "Configure" is available for the Other folders strategy only.

Note: whichever action you choose for the strategy, you must restart your Version 5 session to take this modification into 
account. A warning message will be displayed after clicking one of the above buttons.
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Here is a comparison between the former Search Order command and "Linked Document Localization": 

           Tools->Search Order Tools->Options->Document->Linked 
Document Localization 

 

= "Folder of the link" first

= "Other folders" first

= Deactivate "Other folders"

= Only "Other folders" is activated

Note: "Relative folder" is used for catalog component links.

 
When you click the "Configure..." button, a dialog box appears with a user interface depending on your current document 
environment. In our example, we are working in a Folder environment. 
For more information on managing document environments, refer to the Document Environments part in this task.

 

 

                            Folder environment

4.  Select a directory in the "Look in" list then click the Add button.  

In case at least one document is already opened in your current session, a warning window will be displayed to ask you to close 
then reopen the document(s) to take into account your modifications.
Thus, it is recommended to close any opened documents before modifying the Other folders strategy.
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Note: you can also click the Add Tree button to add the folder tree underneath the specified directory. However, bear in mind 
that the more elements, the longer the duration.
This button is available for the Folder environment only. When working in a DLName environment, you can copy a DLName but 
not its folders.

This puts the directory into the Search order list as shown below:

 

The  icon lets you access your various directories and the  icon lets you move up in the directory hierarchy.

You do not need to enter the whole path in the "Look in" field. Just enter the main directory and press Enter. Any subdirectories 
are then displayed in the list. Select the appropriate subdirectory and click the Add button.

Note that you can use the multiselection to add your folders to the search order:
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The Search order list is intended to contain the directories in which your linked documents are saved. You may wish to use 
different search order lists for particular uses and for different circumstances.

5.  Continue adding your most frequently used directories to the list. When you have finished click the Export... button and save the list 

as a .txt file in the appropriate location in the Export Search Order dialog box:

6.  You can make as many lists as you like. When you want to use one of these lists just click the Import... button. The Import Search 

order dialog box appears.
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Right-clicking on any of the .txt files allows you to edit these files. If you then click the Open button the contents of the .txt file 
you chose is placed in the list and replaces the elements previously contained, if any.

The Import Add... button lets you import and add a search order contained in a text file to the current Search order list.

7.  The search order lists can easily be updated. To change the priority of a directory i.e. move it up or down in the list, select it then 

click the corresponding button: Up or Down.

Note that the multi-selection is also allowed.

8.  To remove a directory, simply select it and click the Remove button.

The Remove, Up and Down buttons are activated only when at least one item in the list is selected.
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Macros

This task explains how to use the Macros tab for accessing the macro development environment for automation purposes.

1.  Select the Tools->Options... command.

 
2.  Select the General category (in the tree to the left), then the Macros tab:

 

 Default Editors

 The default editors list is as follows: 

●     CATScript: internal V5 editor

●     VBScript: internal V5 editor

●     VBA: Visual Basic Editor.

If you are using CATScript or VBScript, click the Change editor... button and select the editor you want to use. You cannot change 
the editor if you are using VBA.

After choosing an external editor, you can restore the default editor by selecting the language and clicking the Default editor button.

 External References
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 External references are only used when your macro script is used to control external applications. You have identify and select the 
corresponding typelibs.

 By default, the external references list is empty. Clicking the All references... button displays the Current references dialog box 
containing a list of all the Version 5 typelibs because they are installed automatically. 

To add external typelibs, click the Add reference... button and navigate to select the typelibs. If you click the All references... button 
again, you will see the external references at the bottom of the list in the Current references dialog box.

 To remove external references, select them from the list and click the Remove reference button.

3.  Click OK to confirm.
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Performances 

This task explains how to customize settings for undoing commands.

1.  Select the Tools->Options... command.

2.  In the General category, select the Performances tab:

3.  In the Stack size field, indicate the number of commands (from 0 to 99) which can be undone 

for each document.

Whatever the value, it is always possible to undo internal transitions (also called "local 
actions") inside the current command ("global action").

4.  Click OK to validate.
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Printers 

This task explains how to customize settings for printers directories.

1.  Select the Tools->Options... command.

2.  In the General category, select the Printers tab:

 Please note that you can use variables other than ${CATReferenceSettingPath} or 
${CATUserSettingPath} ; user-defined variables are supported.

To edit a user-defined variable, click the  button then enter the new value in the 
Printer Directory dialog box that opens:
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 When finished, click OK to validate.

Printer Directory List

This area provides a list of directories that will be used to store the configuration files of 
your 3DPLM printers. You can add your own directories and also lock or unlock the access 
to the desired directories when logged as administrator.

3.  When logged as administrator, you can select the desired directory from the list then use the 

Protect Printers contextual command to lock the access to this directory (the green lock 

 under the Protection column turns red). 

Inversely, once a directory has been locked, you can make it accessible using the Free 

Printers contextual command (the red lock  turns green).

Note: you can also use the above-mentioned commands when logged as a standard user 

but it is recommended to be an administrator.

 "Locking" a printer directory means that when accessing the Printer Properties dialog box 
to configure a printer, the parameters defined by your administrator will be displayed but 
you will not be able to modify them.
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4.  To add a directory to the list, click the  button then browse your filetree.

If no directory has been added, ${CATUserSettingPath} and ${CATReferenceSettingPath} 
are automatically added to the list. These two variables reference in the Version 5 
environment the directories where setting files are stored:

●     CATReferenceSettingPath: points to the directory (or directories) where administrator 
settings are stored

●     CATUserSettingPath: points to the directory where user settings are stored.

Note that any directory you add should have a father directory named "Printers". This 
father directory must be located at the end of the path, for instance "e:\users\Printers".  
If no such directory exists, the application automatically adds it to the path.

 

5.  To remove a directory from the list, select it then click the  button.

When a printer directory has been locked by your administrator, you can still add printers 
from this directory but you cannot modify them.

 

Printer Creation Directory

6.  The Printer Creation Directory field lets you navigate to the directory where the configuration 

files for your new 3DPLM printers will be stored by clicking the  button.

By default, 3DPLM Printer configuration files are stored in the permanent setting files 
which are created in a location referenced by the CATUserSettingPath variable. This 
location is:

●     $HOME/CATSettings/Printers/PLOTxxxx.xml  (on Windows)

●     $HOME\CATSettings\Printers\PLOTxxxx.xml  (on UNIX).

where "$HOME" represents the CATUserSettingPath variable.

If no directory has been specified, the field displays ${CATUserSettingPath} to indicate 
that the default location will be used.

Once a directory has been specified in the Printer Creation Directory field, any new 3DPLM 
printer you add afterwards (refer to Adding a Printer for detailed information) will be 
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added to this directory.

Note: any printer creation directory you specify should have a father directory named 
"Printers". If no such directory exists, the application automatically adds it to the path.

When working in administrator mode, new printers are created in ${CATUserSettingPath} 
by default but you can change it to ${CATReferenceSettingPath} if needed. In that case, 
once printers have been created, do not forget to change ${CATReferenceSettingPath} 
back to ${CATUserSettingPath} to provide a user environment to end users.

 

Driver Configuration Path

 This area is relevant when working in a CAA environment only since it lets you customize 
the path to external drivers that may have been defined with CAA Version 5 APIs.

7.  Enter the path to the configuration file where your driver settings are stored or click the 

 button to navigate to the desired location.

This file is identified by the suffix *.cfg.

By default, the external driver configuration file is stored in:

●     $HOME/CATSettings/Printers/Drivers.cfg  (on Windows)

●     $HOME\CATSettings\Printers\Drivers.cfg  (on UNIX).

where "$HOME" represents the CATUserSettingPath variable.

If no path is specified, the field displays ${CATUserSettingPath}\Printers\Drivers.cfg to 
indicate that the default location will be used.

Printer Group Definition

 In this area you can define, modify and delete groups of printers. These groups will then 
enable you to filter the printers that will be displayed in the Print dialog box and therefore, 
select the desired printer more easily.

Note that the printer groups you define in this tab are saved in the Printers.CATSettings 
file (stored in the CATSettings directory).
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8.  Click the New button to open the Printer Group dialog box:

 

 
The left column displays the printers that have already been set up.

 
The group name is displayed in the Name field and can be modified if needed. The group 

number is incremented for each new group you create.
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9.  In the left column, select the printers to be added to the new group then click the  

button to add them to the right column of the dialog box.

 Once a printer has been added to a group, you can remove it by selecting it in the right 

column then clicking the  button: in that case, the removed printer will reappear in 
the left column.

Note: you use the multi-selection to select your printers in the left and right columns.

 
10.  Click OK to close the Printer Group dialog box.

 
The Printer Group Definition area now looks like this:

 

 
11.  You can then carry out the following actions on the created groups:

●     modification: select a group then click the Modify button. This opens the Printer group 

dialog box detailed above and you can then add or remove printers

●     removal: select a group then click the Remove button to remove it from the group 

list.

 Once printer groups have been defined, you use them to filter the printers displayed in 
the Print dialog box using a specific combo box.

 
12.  When finished, click OK to validate your settings.

1203Page Infrastructure Version 5 Release 13



Server Manager
 

Creating a Limit of One Session per User

The following setting enables you to limit each user to one session. In the case that the user already has a session opened, that 
session will be aborted.

 

1.  In the General category, click the Server Manager tab.

2.  Check the Limit to one session per user checkbox.

3.  Click  the OK button to validate.
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Statistics 
This task explains how to obtain workbench and command use statistics, to log the time spent in workbenches, specific commands and server and session statistics.

1.  Select the Tools->Options... command.

2.  Select the General category, then the Statistics tab:
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 General settings 

The General settings control for all log files:

●     B: size of buffer file in Kbytes; the log file is  only written to disk once the log file size exceeds the buffer size you set

●     File's maximum size: sets the maximum log file size; each time this size is exceeded, the file is written to the location you specify by navigating using the file 
selection box in the Maximum number of copies and location option, which also controls the number of copies written to the disk: this helps to optimize disk 
space. Once the maximum number of copies is reached, the oldest log file is deleted.

 You can log statistics for the following types of activities: 
●     time spent in workbenches

●     time spent using specific commands in those workbenches

●     server statistics

●     session statistics.

 There are two log display modes: 
●     File: the log is written to the file whose default name is Workbench.log or Command when you exit the session, in the location pointed to by the CATErrorLog 

variable. Consequently, the files are written by default to:

CSIDL_LOCAL_APPDATA\DassaultSystemes\CATTemp\Statistics\Workbench.log
CSIDL_LOCAL_APPDATA\DassaultSystemes\CATTemp\Statistics\Command.log

●     Console: the log is written to a window.

There are two log update modes: 
●     Add: the log is written to the existing log

●     Session: the existing log is overwritten by the log of the current session.

The log can be formatted or non-formatted.

Logging Workbench Activity
Example of formatted traces for a workbench log:
...

them=WORKBENCH:time=Wed May 22 10.29.02 2002:elps=0.000000:rtim=0.000000:cpus=0.000000:Session=Start:User=SES:Host=JANEDSY
WORKBENCH: Wed May 22 10.38.57 2002:0.000000:0.000000:0.000000:Start:SES:JANEDSY
them=WORKBENCH:time=Wed May 22 10.39.32 2002:elps=5888.000000:rtim=861.000000:cpus=370.000000:Workbench=CATDrwDrwWkb:NLS=Drafting
them=WORKBENCH:time=Wed May 22 10.39.38 2002:elps=3213621.000000:rtim=901.000000:cpus=170.000000:Workbench=CATPstProductWkb:NLS=
Product Structure
them=WORKBENCH:time=Wed May 22 11.33.12 2002:elps=4567.000000:rtim=270.000000:cpus=130.000000:Workbench=CATCuiCATALOGWks:NLS=Catalog Editor
them=WORKBENCH:time=Wed May 22 11.33.16 2002:elps=3866.000000:rtim=100.000000:cpus=60.000000:Workbench=CATMaterialWorkshopWks:NLS=
Material Library
them=WORKBENCH:time=Wed May 22 11.33.20 2002:elps=3585.000000:rtim=100.000000:cpus=90.000000:Workbench=CATAifAssemblyWkb:NLS=Assembly Design
them=WORKBENCH:time=Wed May 22 11.33.24 2002:elps=50.000000:rtim=50.000000:cpus=40.000000:Workbench=CATMaterialWorkshopWks:NLS=Material 
Library
them=WORKBENCH:time=Wed May 22 11.33.24 2002:elps=40.000000:rtim=40.000000:cpus=30.000000:Workbench=CATCuiCATALOGWks:NLS=Catalog Editor
them=WORKBENCH:time=Wed May 22 11.33.24 2002:elps=1833.000000:rtim=120.000000:cpus=110.000000:Workbench=CATAifAssemblyWkb:NLS=Assembly 
Design
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Example of non-formatted traces:

WORKBENCH:Wed May 22 11.36.17 2002:48690.000000:341.000000:300.000000:Workbench=CATAifAssemblyWkb:NLS=Assembly Design
WORKBENCH:Wed May 22 11.37.06 2002:2173.000000:481.000000:290.000000:CATPstProductWkb:Product Structure
WORKBENCH:Wed May 22 11.37.08 2002:11517.000000:1832.000000:1451.000000:CATPcfPartWkb:Part Design
WORKBENCH:Wed May 22 11.37.21 2002:4877.000000:471.000000:430.000000:CATDrwDrwWkb:Drafting
WORKBENCH:Wed May 22 11.37.26 2002:4747.000000:491.000000:120.000000:CATHybridPartWorkbenchWkb:Hybrid Part Workbench
WORKBENCH:Wed May 22 11.37.31 2002:50.000000:50.000000:30.000000:CATDrwDrwWkb:Drafting
WORKBENCH:Wed May 22 11.37.31 2002:1292.000000:70.000000:60.000000:CATHybridPartWorkbenchWkb:Hybrid Part Workbench
Note that:

●     Workbench = internal workbench name

●     NLS = NLS name of the workbench (the name which appears in the Start menu).

When you change an option, exit the session and restart to take your settings into account.
 

Logging Command Activity
 Here is the log syntax:

Them=COMMAND:time=Date and time:elps=elapsed time:cpus=cpu time:Workbench=Internal current workbench name:NLS=Workbench 
title:Command=Internal command name:NLS=Command title

Elps: elapsed time spent in the command.

rtim: "response time", which is the ellapsed time minus user wait time.

Cpus: cpu time spent is the command.

This trace will be logged when you exit the command. The workbench name is the current workbench when you exit the command.

Note that certain auxiliary commands (for example, the Search command) are not logged.
 Example of formatted traces for a command log

them=COMMAND:time=Wed May 22 10.05.14 2002:elps=0.000000:rtim=0.000000:cpus=0.000000:Session=Start:User=SES:Host=JANEDSY
them=COMMAND:time=Wed May 22 10.05.17 
2002:elps=8993.000000:rtim=7491.000000:cpus=630.000000:Command=FileNew:NLS=New...:CurrentWorkbench=CATPstProductWkb:NLS_CurrentWorkbench=
Product Structure:Origin_Header=Global:mode=ForegroundCmd
them=COMMAND:time=Wed May 22 10.05.14 
2002:elps=11998.000000:rtim=20.000000:cpus=20.000000:Command=Select:NLS=Select:CurrentWorkbench=CATPstProductWkb:NLS_CurrentWorkbench=Product 
Structure:Origin_Header=Global:mode=ForegroundCmd
them=COMMAND:time=Wed May 22 10.05.26 
2002:elps=779110.000000:rtim=80.000000:cpus=60.000000:Command=Select:NLS=Select:CurrentWorkbench=CATPcfPartWkb:NLS_CurrentWorkbench=Part 
Design:Origin_Header=undef:mode=ForegroundCmd
them=COMMAND:time=Wed May 22 10.20.23 
2002:elps=79014.000000:rtim=16935.000000:cpus=480.000000:Command=OpenSettings:NLS=Options...:CurrentWorkbench=CATAifAssemblyWkb:
NLS_CurrentWorkbench=
Assembly Design:Origin_Header=undef:mode=ForegroundCmd
them=COMMAND:time=Wed May 22 10.21.42 
2002:elps=2143.000000:rtim=20.000000:cpus=20.000000:Command=Select:NLS=Select:CurrentWorkbench=CATAifAssemblyWkb:NLS_CurrentWorkbench=Assembly 
Design:Origin_Header=undef:mode=ForegroundCmd
them=COMMAND:time=Wed May 22 10.19.45 
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2002:elps=119642.000000:rtim=80.000000:cpus=20.000000:Command=AnalyserCmd:NLS=AnalyserCmd:Origin_Header=Global:mode=BackgroundCmd
them=COMMAND:time=Wed May 22 10.21.44 
2002:elps=50.000000:rtim=50.000000:cpus=50.000000:Command=FileExit:NLS=Exit:CurrentWorkbench=CATAifAssemblyWkb:NLS_CurrentWorkbench=Assembly 
Design:Origin_Header=undef:mode=ForegroundCmd

 Example of non-formatted traces for a workbench log

COMMAND:Wed May 22 10.29.14 
2002:7051.000000:171.000000:160.000000:Command=OpenSettings:NLS=Options...:CurrentWorkbench=CATAifAssemblyWkb:NLS_CurrentWorkbench=
Assembly Design:Origin_Header=Global:mode=ForegroundCmd
COMMAND:Wed May 22 10.29.21 2002:2673.000000:30.000000:30.000000:Select:Select:CATAifAssemblyWkb:Assembly Design:Global:ForegroundCmd
COMMAND:Wed May 22 10.29.24 2002:1392.000000:31.000000:30.000000:PasteSpecial:Paste Special...:CATAifAssemblyWkb:Assembly Design:Global:
ForegroundCmd
COMMAND:Wed May 22 10.29.25 2002:2003.000000:21.000000:10.000000:Select:Select:CATAifAssemblyWkb:Assembly Design:Global:ForegroundCmd
COMMAND:Wed May 22 10.29.00 2002:27429.000000:70.000000:10.000000:Command=AnalyserCmd:NLS=AnalyserCmd:Origin_Header=Global:mode=
BackgroundCmd
COMMAND:Wed May 22 10.29.27 2002:50.000000:50.000000:40.000000:FileExit:Exit:CATAifAssemblyWkb:Assembly Design:Global:ForegroundCmd

 

Logging Session Statistics
 The Session Statistics is a new statistics theme which records information about application sessions (duration, start date, exit status). This information is collected via 

a statistics theme so as to take advantage of the statistics infrastructure (for example, the automatic copy and relocation of statistics files exceeding a determined 
size).

This information is limited to one event per session.

As such, it will help keep track of users' session durations and ending status, providing a supplementary tool to measure MTBF. 
 More advanced statistics can be obtained by clicking the "+" option:

 When activated, the Session Statistics generates one output line by session on the console or in a file. The default file is:

CATTemp/Statistics/Stats_SESSION_user_HOST

Example of output:

them=SESSION:time=Mon Apr 14 09.12.06 2003:elps=131690.000000:
rtim=1112.000000:cpus=110.000000:MainName=CATIA:ExitStatus=normal_end 

No output is generated for the session during which the session statistics are activated. You have to exit then restart your Version 5 session, and from then on you will 
obtain session statistics output for all further sessions.

This new functionality is mainly useful for Version 5 administrators. Session Statistics list all the sessions, their duration, and exit conditions for any or all users, easily 
providing them with a comprehensive view of the average duration of user sessions and allows a global view of the usage of Version 5 by any user or group of users. 
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It also provides an idea of the percentage of sessions where no failure occurred.

Session statistics add a global view in addition to the more detailed views already provided by the existing COMMAND and WORKBENCH statistics.
 

Notes about output logs

Event dates in the output file are not organized in chronological order. A statistics event is always logged when it is terminated. The start date and duration are 
specified. Events are generated in event termination chronological order. Because the statistics software allows interlaced or embedded events, events do not 
necessarily end in the order in which they began.

The two start and end slots indicate the same time. A statistics event is always logged when it is terminated. The start time and duration are specified. The 
corresponding session event is generated at the end of the session: it started at the beginning of the session and lasts the duration of the session. Due to the possibility 
of having several successive session statistics in the same session, it is necessary to physically log the start of a session. This is the session start event (whose duration 
is null). The two events are generated at the same time in the code. To determine the end time, information is provided for the start date and duration.
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Setting Specification Tree Appearance Options 

This task explains how to set specification tree display options.

1.  Select the Tools->Options... command. 

The Options dialog box appears with the General category selected in the left-hand column.

 2.  In the Display sub-category, select the Tree Appearance tab to display the document layout options.

 

 

Tree Type

In the Tree Type section of the dialog box, you will notice that the option Classical Windows Style is 
selected by default. This is the conventional way of displaying the specification tree.
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●     Classical Windows Style

This option might, for example, be useful when working on solids and assemblies.

 

 
●     Structure
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●     Constructive Historic

If the whole of the tree is not displayed, you may have to enlarge the window. 

Alternatively, you can reduce the length of tree item names. To do this, go back to the Tools-
>Options... dialog box and select the Fixed Size option in the Tree Item Size section. The 
default number of characters is 8. You can of course specify the number you wish.

 

 
●     Relational

To do this, go back to the Tools->Options... dialog box and select the Relational option in 
the Tree Type section. The tree will then look something like this:
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This option might, for example, be useful when working on solids and surfaces. 

 
Tree Orientation

Note that the tree orientation can be modified only when displaying the specification tree in 
"Constructive Historic" or "Relational" mode.

●     Vertical
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As you can see, this option shows all possible relations between the different items that go to make up 
the part. 

 
●     Horizontal

To do this, go back to the Tools->Options... dialog box and select the Horizontal option in the Tree 
Orientation section:
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This option could, for example, be used for surface creation. 

You can also change the background colors using the Visualization tab via the Tools->Options... 
function.

If the specification tree prevents you from seeing the geometry, you can move the tree by first clicking 
the reference axis (the geometry is displayed in low highlighting mode), then dragging the tree to a new 
location using the middle mouse button.

 
Tree Item Size

This option enables you to specify the number of characters used for the names of the items displayed 
in the specification tree. 
The default option is "Text-dependent", which means that each item name will be displayed as a whole.
If you check the "Fixed" option, the field displayed to the right is activated to let you enter the fixed 
number of characters that should be displayed for item names. 

 
Tree Show/No Show 

When this option is checked, if you select an item in the tree, then select the Hide/Show  icon, the 
item is grayed out in the tree.

If this option is unchecked, you will not be able to gray out an item in the tree. Clicking the Hide/Show 

 icon will have no effect.

When the size of the tree exceeds the window size, a scrollbar appears: you can then move the tree and 
navigate using the scrollbar. 

 3.  Click OK to confirm.
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Setting Specification Tree Manipulation Options

This task explains how to set specification tree manipulation options.

1.  Select the Tools->Options... command. 

The Options dialog box appears with the General category selected in the left-hand column. 

 
2.  In the Display sub-category, select the Tree Manipulation tab to display the document layout 

options.

 

 
Scroll

●     Automatic scroll activation during drag and drop
When checked along with the "Activate the Visualization of Show/No Show" option, this 
option lets you scroll the tree automatically when dragging and dropping icons or objects 
onto it. 
The tree is scrolled until you remove the mouse from the scroll area.

For more information on dragging and dropping, refer to Dragging and Dropping Icons 
and Objects in this guide.
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 ●     Display geometry during tree scrolling
When checked, this option enables you to see the geometry while you are scrolling the 
specification tree using the scroll bar displayed to the left. 

Note that this option has no impact when scrolling the specification tree using the 
mouse scroll button or when dragging and dropping icons with the "Automatic 
scroll activation during Drag and Drop" option activated: in both cases the 
geometry is displayed.

 
Automatic Expand

When checked, this option activates the automatic expansion of the specification tree up to 
the second level as shown below:

 Example 1

When clicking the + sign next to 
the first "DragObjectOntoObject" 
item with the automatic expand 
not activated:

 Example 2

When clicking the + sign next to 
the first "DragObjectOntoObject" 
item with the automatic expand 
activated:

 When the automatic expand is activated, a message informs you that the automatic expand 
of the specification tree will be taken into account the next time you open a document.
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 Zoom on Tree

When this option is checked, if you click any branch in the tree, the geometry is dimmed and 
only the tree is active, enabling you to manipulate it on its own (zoom it up and down, etc.). 
This option is activated by default.
When deactivated, the only way to manipulate the graph is to click the reference axis in the 
bottom right corner of the document.

 3.  Click OK to confirm.
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Navigation 

This task explains how to customize display navigation settings.

1.  Select the Tools->Options... command.

 2.  In the General category, select the Display sub-category then the Navigation tab:
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The Navigation tab lets you customize:

 

Selection
 

●     Preselect in geometry view: activates preselection highlighting. As you point to objects, different parts of the objects are highlighted in the 
geometry area, and the object name is highlighted in the specification tree.
However, note that deactivating this option impacts all commands using prehighlight, especially the Other Selection... command that does not 
work anymore when it is based on prehighlight.

 

●     Preselection navigator after ... second(s): sets the amount of time, in seconds, which elapses before the preselection navigator appears after 
pointing at an object. Refer to "Selecting Using the Preselection Navigator" for more information about how to use the preselection navigator. For 
more information about navigating in fly mode, refer to "Navigating in Fly Mode".

 
●     Highlight faces and edges: controls the way faces and edges are prehighlighted and highlighted.

How elements are prehighlighted and highlighted: 

●     is determined by whether you are in Design mode (editing an element in the context of an assembly) or in Visualization mode

●     and varies according to the current visualization mode: shading with edges. shading, wireframe (NHR), dynamic hidden line removal 
(HRD). Note that some minor differences in the way elements are highlighted are noticeable using the HRD mode.

The default prehighlight and highlight colors are different, and can be customized using the Visualization tab. By default, faces and edges are 
highlighted. Depending on the element type, elements may or may not be displayed using the Z-buffer.

The following examples use the shading mode.

When you are editing an object, a selected face is highlighted like this:
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 ... and a selected edge is highlighted like this:
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 If you select the Pad or the PartBody in the specification tree, the whole object is highlighted like this:
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 If you are in Visualization mode in an assembly, the whole object is highlighted.

 

●     Display manipulation bounding box: when clicking on an object, displays a box around the 
selected object if it uses manipulators:
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Objects using manipulators can be manipulated by the 3D compass . For more information about manipulating objects using the 3D compass, 
refer to "Manipulating Objects Using the Mouse and Compass".

 
●     Limit display of manipulators to ... element(s): sets a limit on the number of elements selected in multi-selection mode (using the selection 

trap) on which manipulators can be displayed. In case you select more elements than the limit (for example, by using the CTRL key to extend the 
selection), no element can be manipulated.

This option is activated when working in a 2D context (objects with handles such as texts and arrows, for instance) or 3D context. 
 

The following scenario uses the Drafting application as an example:

1. Enter a value in the Limit display of manipulators field, "10" for instance then click OK to validate.

    Note that setting a high number (greater than "50") will have an impact on the content of the 
    contextual menu displayed when right-clicking a selected element.

2. In the geometry area, select six elements either using the selection trap or the CTRL key.

As you can see it below, manipulators are displayed on the selected elements to let you modify them:

If you set the limit to "5" instead of  "10", no manipulator will be displayed since the number of selected elements (i.e. six) exceeds the limit:
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●     Display immersive list for the preselection navigator: this option is activated by default to display the list of all the elements you can preselect 

when using the preselection navigator. 
If you do not want to display the immersive list, uncheck the option.

●     Display auxiliary viewer for preselection navigator: checking this option activates an auxiliary viewer displaying the preselected object when 
using the preselection navigator. This viewer enables you to perform viewing operations with the mouse such as zoom, rotate or pan. 

 
●     Prehighlight faces for preselection navigator: this option lets you activate the highlight of the face(s) you preselect using the preselection 

navigator.

 

Navigation
 

●     Gravitational effects during navigation: fixes the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that 
the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane.
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●     Follow ground at altitude (in mm): first check "Gravitational effects during navigation" to be able to activate this option. When flying and 
walking, this gravitational effect makes you automatically fall if you do not reach the specified altitute (in millimeters). This allows you to follow the 
ground relief, such as stairs.
An altitude set to "0" means that the eye level will be set at ground level, whereas an altitude higher than "0" will set the eye level above ground 
level.

Note that the "Follow ground" mode is automatically deactivated when it is not relevant, i.e. when no ground is detected.

 
●     Animation during viewpoint navigation: set this option if you want viewpoint changes in certain contexts to be animated. To see an example of 

the effect of this option, check the option, then select a plane and click the Sketcher  icon. The selected plane is slowly rotated until parallel to 
the screen just like during an animation. If you do not check this option, the selected plane is set parallel to the screen immediately (without the 
animation effect).

Note: the visualization time of the product impacts the number of animation steps. The longer the duration, the less steps. In case the 
visualization takes too much time, there is no viewpoint animation at all.

 

●     Disable the rotation sphere display: hides the rotation sphere usually displayed when rotating an object. The result is as follows:

 

           
     Rotation sphere activated (default mode)                               Rotation sphere deactivated
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Fly/Walk
 

●     Collision detection enabled

Checking this option activates the following two options:

 

 

●     Point/scene collision: when flying and walking, detects if you collide with an object, so that you bounce off the object instead of going 
through it. This is the default option.

●     Sphere/scene collision: this options works the same way as the "Point/scene collision" option but this time, the user is modelized as a 
sphere whose radius can be defined by entering a value (in millimeters) in the field to the right. When flying and walking, the option 
detects if the sphere collides with an object, so that you bounce off the object. As no object can break through the sphere, this provides a 
more "immersive" experience.

Note that this detection collision mode works with complex geometry since it is based on visualization triangles.
Note also that, when used in combination with the "Follow ground" option, this option can provide video game Quake-like 
navigation effects.

However, bear in mind that there is a price to pay in performance when using large models.

 
●     Mouse Sensitivity: sets the mouse sensitivity when flying and walking: if you set a low value, pointing the cursor produces only slow, minor 

changes in direction; if you set a high value, pointing the cursor produces rapid, significant changes in direction.

 

●     Start Speed: when you begin to fly, this option lets you choose between two options:
❍     Automatic: you will begin to fly at the default speed, i.e. the speed at which you will first approach the object will depend on the initial distance 

from the object and will be calculated automatically

❍     Custom: you can define by yourself the speed at which you will first approach the object using the slider.
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●     Mouse Speed: sets the time interval (from 0 to 100 milliseconds) during which mouse movements will not be taken into account for prehighlight 

purposes: the higher the speed, the fewer elements are prehighlighted.

3.  Click OK to confirm, or Reset... and OK again to reset default settings.
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Performance 

This task explains how to customize display performance settings.

1.  Select the Tools->Options... command.

2.  In the General category, click the Display category then the Performances tab:
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Occlusion Culling 

Click "Occlusion culling enabled" to activate occlusion culling.

Occlusion culling avoids redisplay of hidden elements, particularly useful when viewing highly 
compartmented scenes such as plants and buildings but it does not improve display 
performance.

Let's have a look at the picture below to see what happens when occlusion culling is 
activated:

 

3D Accuracy and 2D Accuracy

The accuracy setting controls the tessellation of surfaces."Tessellation" means that the 
surfaces of your geometry are built using triangles. A triangulation is computed to describe 
the neighborhood relation of all points. 

Note that 2D accuracy settings are the same as for 3D.

You have two choices (the preview area to the right shows you the effect of each setting): 

●     Fixed: sets a fixed sag value (from 0.01 to 10) for calculating tessellation on all objects, 
which does not vary with object size.

The sag value defines the chordal deviation for curves and surfaces.
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The "curve chordal deviation" represents the maximum distance between a 
polyline ("chord") whose end points lie on a curve and a point on this curve:

 

 

The "surface chordal deviation" represents the maximum distance between the 
tessellation triangles and the surface.

●     a low value means that a very fine mesh is used to render surfaces because 
the distance between the geometry and the triangles in the tessellation is very 
low.
However, the drawback is that geometry will be redrawn more slowly when 
using the viewing tools.

 

Example with default fixed sag value ( = 0.20)

 

●     a high value increases the distance between the geometry and the triangles 
and thus, decreases the number of triangles that will be computed on the 
object. This means that a very coarse mesh is used, but the advantage is that 
geometry will be redrawn more quickly.
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Example with default fixed sag value set to 8.5

●     Proportional to element size

Tessellation is calculated according to object size: the larger the object, the coarser the 
tessellation. For the same sag value, the tessellation on small objects will always be finer 
than on large objects.

The sag value used to calculate the tessellation of each object is calculated is as follows:

sag = coeff. x radius of sphere/100

where:

●     "coeff." is the value you set using the slider (between 0.1 and 1)

●     "radius of sphere" is the radius of a sphere encompassing the object entirely (this value is 
obviously higher on larger objects).

The following examples show the difference between a fixed and a proportional sag value 
applied to two spheres with different radiuses:
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           Radius = 100 mm                                   Radius = 10 mm  
          Fixed sag value = 0.20                           Fixed sag value = 0.20

 

    
           Radius = 100 mm                                    Radius = 10 mm  
     Proportional sag value = 0.20                    Proportional sag value = 0.20

Start by setting a high fixed value in order to decrease the number of tessellation triangles 
and thus, pay a lower price in performance.

Warning: when working with V4 models, be careful not to set a too high sag value for 3D 
accuracy, otherwise you will not be able to visualize them.

 
●     Curve accuracy ratio
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 This option lets you control the curve accuracy using the slider displayed to the right (you 
can choose a value between 0.1 and 1). 
The curve accuracy is a ratio of the 3D accuracy you define using the above-detailed 3D 
Accuracy option. 

The curve accuracy is calculated as follows:

sag = 3D accuracy x ratio

As a consequence, the tessellation on curves will be finer than the tessellation on surfaces.

For instance, setting the 3D sag value to 0.20 and the curve accuracy ratio to 0.10 means 
that:

●     faces will be tessellated with a 0.20 sag

●     curves will be tessellated with a 0.02 sag (0.20 x 0.10).

 

Example 1
Fixed 3D accuracy = 10
Curve accuracy ratio = 1

 

 

Example 2
Fixed 3D accuracy = 10
Curve accuracy ratio = 0.10
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Level of Details

You do not always need to view a high level of detail in your geometry all the time. You can 
use the Static and While Moving settings to add or remove display quality:

●     Static: even if you do not want to move geometry, it is often useful to remove details 
you do not need to see. Set a low value if you want to see all the details, or a high value 
to remove details

●     While Moving: you will be able to move large parts more quickly if you set While Moving 
to a high value. When you release the mouse after moving the part, the normal level of 
detail will be redisplayed.

In both cases, the higher the value, the lower the level of detail. Normally, you set Static to a 
low value, and While Moving to a high value. The added value is increased display 
performance. 

Note that if you are using the Level of Details option with Product Structure or DMU Navigator 
functions, you must activate the cache for your LOD settings to be taken into account.

 
Pixel Culling 

This option is similar to Level of Details, but in that case, it lets you define the size in pixels 
of objects to be hidden/displayed in your geometry using the Static and While Moving 
settings.

●     Static: even if you do not want to move geometry, it is often useful to remove details 
you do not need to see. To do so, set a high value to remove these details. On the 
contrary, setting a low value displays the details. For instance, setting "2" means that 
objects whose size on screen is lower than 2 pixels will be static

●     While Moving: setting a high value will enable you to move large parts more quickly. 
When you release the mouse after moving the part, the Static size will be redisplayed.
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Transparency Quality 
 

●     Low (Screen Door): similar to viewing an object through a mesh or a screen. Use this 
setting when you need to look at objects through another transparent object. This mode 
is also recommended for increased display performance. 
When checked, the transparency is not impacted whatever value you set (between 1 and 
255).

●     High (Alpha Blending): similar to looking through clear glass. Use this setting when 
you need to view several transparent objects located at different depths of a scene. For 
example, looking through a car windscreen at other opaque objects inside the car. Note, 
however, that this mode is computation-intensive and consequently has an adverse affect 
on display performance.
When checked, the transparency is impacted according to the value you set.

Note that you also need to set the transparency coefficient on selected objects using the 
Edit->Properties command or Properties command on the contextual menu, by 
dragging the Transparency slider on the Graphic tab. Refer to Displaying and Editing 
Graphic Properties for more information.  

Frames per second

Check the Enabled button if you want to control the minimum number of frames per second 
(frame rate) during animations (zooming, moving, flying,... etc.) when using a regular 
mouse. The frame rate varies from 1 to 30. Setting a low frame rate keeps a maximum 
number of details visible, but animations are less smooth and fluid; setting a high frame rate 
limits visible details, but provides smoother, more fluid animations.

This option is particularly useful, for example, in Fly mode: when flying within large objects, 
you may not need to see all the details, but you want to navigate through the object in as 
smooth a manner as possible.
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Frames per second for 3Dx Devices

Check the Enabled button if you want to control the minimum number of frames per second 
(frame rate) during animations when using a 3Dx device such as a Space Mouse. This option 
works the same way as the above-detailed "Frames per second", the only difference is that it 
is specific to 3Dx devices.

 
Miscellaneous

 Show Hidden Edges (whenever possible): note that the display of hidden edges is now 
activated in the Custom View Modes dialog box.
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 Enable isoparametrics generation 

This option enables you to generate (in this context, it means to "display") the topological 
elements defined as being isoparametrics. 
By default, the option is not checked for performance reasons.

To use this option, just follow the steps below:

1.  Check the "Enable isoparametrics generation" option: you are then asked to restart 
your Version 5 session

2.  Restart your Version 5 session
3.  Re-access the Performances tab then, if desired, specify the number of isoparametrics 

to be generated for u and v axes using the field displayed to the right. You can 
generate up to 10 isoparametrics.

4.  Select the View->Render Style->Customize View command then check the 
"Isoparametrics" option which is now activated. 

The isopamametrics are displayed:

 

                   

                 Example 1                                                             Example 2
 "Enable isoparametrics generation" and                     "Enable isoparametrics generation" and
     "Isoparametrics" options are off.                                "Isoparametrics" options are on.
                                                                        2 isoparametrics are displayed for u and v
                                                                      axes since we entered the value "2" in step 3.

 

 Enable two side lighting for faces and surfaces only 

This option helps you viewing the two sides (i.e. front side and back side) of a face or surface 
by lighting them. 
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              Example with option on                                             Example with option off

 Enable back face culling for faces and surfaces only 

Check this option to avoid redisplay of back sides of faces or surfaces.  

Note that when this option is checked along with the "Enable two side lighting for faces and 
surfaces only" option, only front faces will be lightened.

 Enable OpenGL local viewer lighting 

When checked, this option provides a better lighting quality. However, bear in mind that 
there is a price to pay in performance.  
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 Save lineic elements in cache 

This option lets you save lineic elements (such as wireframe elements, for instance) when 
saving files of type cgr.

 Enable OpenGL Shader

This option lets you apply OpenGL materials when working with the Real Time Rendering 2 
product. These advanced materials are used to create textures such as paint, wood or 
marble. 
For detailed information, refer to the section entitled "Advanced Materials" in the Version 5 - 
Real Time Rendering User's Guide.

To be able to use this advanced material, you need to download the OpenGL Shader™ 
development kit. To do so:

●     if you are working on IRIX, browse the following site: 

http://www.sgi.com/software/shader/downloads.html

then download the corresponding kit.

●     if you are working on Windows, browse the following site:

http://www.sgi.com/industries/manufacturing/partners/catia/

then follow the instructions.

The option will be displayed when re-accessing the Performances tab: 
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 Halo when displaying the geometry with hidden lines removed 

This option lets you display a halo around intersecting edges to create a perspective effect.

Prior to using it, you need to switch to Hidden Line Removal mode otherwise, you will not be 
able to use this option. To do so, select the View->Render Style->Customize View then 
activate the "Dynamic hidden line removal" option before clicking OK to validate.

The following picture shows an example of halo:

 

 

 

Picking 

This area enables you to pick elements, i.e. select elements when pointing them. In "normal" 
picking mode, you need to move your mouse to select an element whereas in accurate 
picking mode, the slightest move (one pixel, for instance) is enough to select. 

The "Window size for picking" field lets you specify the size (in pixels) of the window you will 
use for picking elements in normal mode. You can set a value comprised between 1 and 100, 
the default value being 4 pixels.
The smaller the value, the more precise the picking.

The "Enable accurate picking option" helps you select more precisely elements that are very 
close to each other when displaying the geometry. 
It is recommended to work with a magnified view of your document by selecting the View-
>Magnifier... command as shown below:
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For more information, refer to Magnifying in this guide. 

When "Enable accurate picking option" is checked, the "Window size for accurate picking" 
option is activated to let you define the size of the window (in pixels) used for accurate 
picking.
The maximum value you can enter corresponds to the maximum value defined for the 
"normal" picking, i.e. the value entered in "Window size for picking". 

Note that if you this option enables you to use normal picking as well.

Checking this option may have a negative impact on the performances when using big 
models.

When working on UNIX workstations, you can use the "Double click latency" slider to manage 
the maximum duration (in milliseconds) between two mouse clicks so that they could be 
considered as a double-click. 
The default value is 500 ms but you can increase it up to 2 seconds.

3.  Click OK to confirm.
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Customizing Visualization Settings 

This task explains how to customize display visualization settings.

1.  Select the Tools->Options... command.

 2.  In the General category, select the Display sub-category then the Visualization tab:

 

The Visualization tab lets you customize:
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●     Graduated color background

 
Note that this option is also available for P1 users.

This option 
activates a 
graduated 
color 
background in 
all open 
documents, 
and in the 
Preview and 
workbench list 
areas of the 
Visualization 
tab itself. 

For example, 
this document 
uses a 
graduated 
color 
background. 
The color 
becomes 
gradually 
lighter 
towards the 
bottom of the 
document:

...but this 
document 
uses a normal 
color 
background:
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●     Background: sets background color in all open document windows. 
Note that the default graduated background color can be reset simply by selecting it 
from the pulldown list.

 

●     Selected elements, Preselected elements, Low-intensity elements and 
Preselected element linetype: set colors of selected elements, preselected 
elements, low-intensity elements, and the linetype used to display preselected 
elements. 

Note: low-intensity elements are elements such as parts, products, drawings, etc. 
which can be neither filtered, nor removed. The default color for low-intensity 
elements is "dark green" (as indicated in the picture of the Visualization tab above).

Refer to "Preselecting and Selecting Using the Pointer" for a discussion of 
preselection and selection techniques.
 

 

●     Update needed: sets the color of objects to be updated; refer to the Part Design 
documentation for more information about updating objects. 

 

●     Handles: sets manipulator handle colors. Graphic manipulators are displayed on 
certain objects (planar patches, holes, ...) for the purpose of moving the objects 
more easily. Refer to "Moving Objects Using the 3D Compass" for more information 
about how the compass is used on examples of where manipulators are used.

 
●     Selected edges: set colors of selected edges.

 

●     Surface boundaries: check this option to set the color and thickness of surface 
boundaries. 

 

●     Smooth Edges: note that the visualization of smooth edges is now defined in the 
Custom View Modes dialog box.

 

●     Display all elements using Z-buffer depth: activates the Z-buffer so that all 
elements hide each other. When activated, all elements including lines and planes 
(usually displayed in front of other elements) are displayed at their true depth in the 
3D scene. When deactivated, lines and planes are always displayed in front of other 
elements.
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●     Anti-aliasing: activates anti-aliasing on all edges and lines.

Anti-aliasing 
makes jagged 
lines and 
edges appear 
smoother:

... and when 
switched off, 
edges and 
lines look 
jagged:
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●     Stereo enable: enables or disables stereoscopic visualization of graphical data with 
a perception of realistic, three-dimensional images: 

❍     On: enables stereoscopic vision

❍     Off: disables stereoscopic vision.

For more information, refer to "Stereoscopic Viewing".

 
 

●     Display current scale in parallel mode: when set to "On", this option activates 
the display of the scaling factor (at the bottom right of the geometry area) when 
displaying objects in a parallel view (using the View->Render Style->Parallel 
command). 

The option helps you to know the real size of an object using the following formula:

real size = size on screen / scaling factor

Note that the scale display is automatically refreshed when zooming.

To illustrate this, let's suppose a pad with the following dimensions:

 

 Now, follow the steps below:

1.  Display this pad in a parallel view then set the viewpoint so that you 
see one face of the pad.

2.  Set the "Display current scale in parallel mode" option to "On".
3.  Zoom until the scale factor is equal to 2.00. The result should look like 

this:
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 According to the above-mentioned formula, you know that the pad real 
dimensions are:

Length = 50 mm (100 mm / 2)
Width  = 20 mm (40 mm / 2)
Height = 10 mm (20 mm / 2)

3.  Click OK to confirm, or Reset... and OK again to reset default settings.
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Thickness & Font 
  

This task explains how to set thickness properties.

1.  Select the Tools->Options... command.

2.  In the General catagory, click the Display sub-category then the Thickness tab:
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3.  In the Index column of the Thickness area, select a thickness type from the 55 values 

contained in the list.

4.  If necessary, modify the Size in pixels or in millimeters by selecting the value to be 

modified then clicking it once.

The Size in pixels reflects the result displayed on screen and the Size in mm corresponds to 

the printed version.

You cannot assign a size greater than 16 pixels.

 

5.  The "Use system TrueType fonts in CATIA" option enable you to use TrueType fonts 

provided by Windows and thus, add them to the font chooser. 

This default list of fonts can be customized. To do so, refer to Customizing Fonts for 
Displaying Geometry Area Texts in this guide.

6.  Click OK to confirm.
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Customizing Settings for Layer Filters
 

This task explains how to customize settings for layer filters.

1.  Select the Tools->Options... command.

 2.  In the General category, select the Display sub-category then the Layer Filter tab:

 

3.  Select the type of filter to be applied in the Filter and Document Display area which lets you 

choose between two options:

●     Current filter on all documents means that the current filter will be applied to all 
documents opened in your Version 5 session

●     Current filter of the document means that each document will use its own current 
filter (if there is one).
Note that there is a price to pay in performance when using this filter mode.

 4.  Click OK to validate and apply the selected filter. 
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Linetype  

This task explains how to set linetype properties. This functionality is relevant for Drafting products 
only.

1.  Select the Tools->Options... command.

2.  In the General catagory, click the Display sub-category then the Linetype tab:

 

 

The available linetypes are displayed in a list, the eight first types being grayed as they 
correspond to the default linetypes (displayed in the Graphic Properties toolbar) and cannot 
be modified.
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 3.  Double-click the linetype to be modified. The Linetype Editor opens:

 

You can either define a mono-dimensional linetype or a bi-dimensional linetype.

4.  To define a mono-dimensional linetype, click the Define a new mono-dimensional linetype 

button. The Mono-dimensional linetype editor dialog box opens:
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This dialog box lets you define the linetype for visualization and print purposes. 

5.  In the Visualization definition field, click the desired squares to define the linetype pattern: a 

white square corresponds to a drawing, a black square to a blank. You can select up to 16 

squares.

The Preview will be updated accordingly as shown below:
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 6.  Use the Factor field to stretch the pattern by increasing the value as shown below:

 

7.  In the Print definition field, enter the length in millimeters for each pattern segment (do not 

forget to leave a blank space after each character you type). 

A positive value indicates a drawing and a negative value indicates a move without 
drawing.

The capture below illustrates the print definition of the pattern defined in step 5:

 

8.  Click OK to validate and close the dialog box. 

The new linetype replaces the selected line in the Linetype editor list. If you do not wish to 
go on defining linetypes, just click OK once again to close this dialog box and the new 
linetype will be displayed instead of the selected line at the end of the Linetype list.
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9.  To define a bi-dimensional linetype, double-click a line from the Bi-dimensional linetype list in 

the Linetype editor. The Bi-dimensional linetype editor window opens:

10.  Move the cursor then click to create a segment and repeat theses steps as necessary to define 

the desired pattern. 

You can create segment breaks by double-clicking a point then moving the cursor to draw a 

new segment:
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11.  Use the following icons to: 

●      delete the whole pattern

●      delete the last segment

●      reframe the bi-dimensional line editor.

12.  Click OK to validate and close the dialog box. 

The linetype is displayed instead of the selected line at the end of the Linetype editor.

13.  Click OK once again to close the Linetype editor and display the new linetype instead of the 

selected line at the end of the Linetype list.
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Compatibility
V4 Data Reading

Saving As V4 Data
V4/V5 DRAW
V4/V5 SPACE
V4/V5 SPEC

Migration Batch
DELMIA/Deneb

DXF/DWG
Electrical Migration

ENOVIA LCA
External Formats

IGES 3D
IGES 2D

SmartBOM
STEP
VRML
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V4 Data Reading

This task shows you how to customize Compatibility settings.

1.  Select the Tools -> Options... command.

The Options dialog box appears with the category tree in the left-hand column.

2.  In the General category of the Options Tree, select Compatibility and click the V4 Data Reading tab. The 
following dialog box appears:

 

In CATIA Version 4, certain information was specified by means of the parameter settings in the declaration files. 
These declaration parameters are no longer supported in Version 5 and there is no way to transfer them 
automatically to Version 5. Such information must be provided by means of the Options dialog box shown above, 
before attempting to read Version 4 data.

The Options dialog box lets you:

 
●     display faces and surfaces visible in shading mode in CATIA Version 4.

●     open CATIA Version 4 models referencing an external PROJECT file.

●     specify the Initial Model File Path: to translate V5 CATPart documents into V4 Models using V4 standards 
defined in the V4 Initial Model.

●     specify the writing code page identifying unlabeled data.

●     declare the code page to be stored in the CATIA data to be written when saving Version 5 CATPart 
documents as CATIA Version 4 models.

●     declare the Model Dimension when saving V5 CATPart documents as V4 Models.

●     declare the Model Unit when saving V5 CATPart documents as V4 Models.

●     declare the location of a character equivalence table.

●     choose options for Migration Batch: Conversion Mode and Format.
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Reading V4 Data
●     Display only elements with Sensitive Attribute:

In CATIA V4, the "Display only elements with Sensitive Attribute" mode enables you to decide whether to display the faces and 
surfaces sensitive to the shading mode in CATIA Version 4.

To display only the faces and surfaces that were sensitive to the shading mode in Version 4, you must therefore activate this option. 
In CATIA Version 5, by default, this box is deactivated.

●     Display 3D elements labels

This option is checked by default. It means that when you download a model in CATIA V5, the visualization of the 
V4 elements' Id or 3D text is recalculated. For instance, the Id *FAC can appear near the 3D Face in the 3D 
space.

If you do not check this option, the 3D text associated to the V4 elements will not be built. They will not appear in 
the 3D space in CATIA V5.

 
●     Open in Light Mode: Open a V4 Model without DRAW Data

If you activate this setting, you can disable the reading of DRAW data.

The integration of V4 models in V5 applications generally uses only the 3D Master representation of the model. On 
the other hand, the management of V4 DRAW data brings several critical issues:

- Stability issue: PRJ has to be referenced correctly, else CATIA may crash
-  Performance issue: data conversion (CATAIX/CATUNIT) of DRAW data is very expensive.
- Memory consumption.

Skipping DRAW data when opening the model will not bring any restriction when working in Assembly or DMU 
workbenches for instance. On the contrary, it will be a major stability / performance / memory cost upgrade.

The DRAW data is suppressed before any operation (internal or external) can be performed on the model. 
However the DRAFT tab page is still available, but swapping to this tab page will generate a warning message 
indicating that the model has been opened in light mode:

You only get SPACE elements in the *MASTER tab; the *DRAFT tab is empty:
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 This setting can also be effective with CATProducts and Sessions containing V4 models.
Note:

- the warning is displayed only once per tab page.
- some functionalities open directly the models in 2D mode (for example: ENOVIA DMU / Send to V5 2D Viewer). 
The warning should be sent in that case too. 

If a user wants to reread a model and browse V4 geometry, it is necessary to uncheck the setting ant to reopen the model.
If this setting is activated, the V4-V5 Migration Batch will not be able to migrate V4 Drawing data. Therefore, if you want to 
convert V4 drawing elements in CATIA V5, it is necessary to uncheck this option. For more information about the Migration 
Batch, please refer to the CATIA - V4Integration User's Guide.

 If the model has an external PRJ File which is not specified in the Tools-Options, a second message appears (even if the PRJ 
File Path is not necessary when you choose the Light Mode). However, this warning is useful when the user decides to go 
back to the normal mode (not the Light Mode), at the same time he can also specify the PRJ File Path in the Tools-Options.

 

This mode is also available in PDM Application when sending a model from PDM Application into CATIA V5.

●     Specifying the code page identifying unlabeled data

In V4, the declaration parameter catsite.DEFAULT_DS_CODE_PAGE declares the language to identify the data 
read if this data is not labeled (i.e. if it is just labeled EBCDIC or ASCII, and not labeled with a standard code page 
such as ISO8859-x, IBM-392, EUC-KR, EUC-CN, and so forth).

In Version 4, information such as the language used to identify unlabeled readable data was specified by means 
of the parameter settings in the declaration files. These declaration parameters are no longer supported in Version 
5 and there is no way to transfer them automatically to Version 5. Such information must be provided by means 
of the dialog boxes described below, before attempting to read Version 4 data.

For Version 4 data that is not labeled with a standard code page (for example, ASCII-DS-xxx or EBCDIC-DS-xxx) 
other than US English, you must specify the appropriate language from the list provided. 

To do this, click on the DS_DEFAULT_CODE_PAGE list in the V4 Declarations part of the dialog box and select the 
appropriate language. 
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●     PROJECT File Path: Opening CATIA Version 4 models referencing an external PROJECT File

In V4, certain model data must be contained in a PROJECT file which can either be internal to the model or 
external. If it is external, the only way to access such data is to provide Version 5 with precise information about 
the PROJECT file's whereabouts.

Enter, in the PROJECT File Path field, the location of the PROJECT file referenced by the V4 model you wish to 
display. Make sure you complete this field before displaying a Version 4 model. 

Bear in mind the following: 
●     If you do not specify the PROJECT file path before opening the model, a warning message will appear.

●     There are no restrictions as regards the PROJECT file's code page. However, you must make sure that the code pages of 
the model and the PROJECT file are compatible.

The following reference tables in the PROJECT files can now be accessed in Version 5: 

●     attribute and class tables

●     annotations/dimensions.

On UNIX and NT, you can reference an external PROJECT File using the http protocol, the address to be specified should 
be like this:

http://serverName/path/PRJDirName

Make sure beforehand that an http server has been installed on the machine where the V4 data resides. For more 
information, you can refer to About Data Sharing between Windows and UNIX, in CATIA - Infrastructure User's Guide.

On UNIX only, you can also reference PRJ files with a UNIX path: 

/u/path/PRJDirName 

On NT only, if you have access to PRJ files installed on the NT disk, you can reference it with an NT path: 

E:\path\PRJDirName

In that case, you need to bring these Project files referenced by the model into an NT directory and rename these files 
according to the conversion table. In the PROJECT File path, you refer to the directory containing the Project Files. 
For more information about character conversion, refer to the Conversion Table in the Model Naming chapter in CATIA - 
V4Integration User's Guide.

Thus, in the PROJECT File path you refer to the directory containing the Project Files. For more information about the 
methodology of coping your Project File on NT, refer to Having Access to PRJ File on NT in CATIA - V4Integration User's 
Guide.
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●     DLNAME 

In the V4/V5 Infrastructure settings, the only way to locate a PROJECT File physically is to fill in the PROJECT File 
Path. The DLNAME setting does not allow this functionality. This setting only allows to compare the Model DLNAME 
(when the Model references a DLNAME instead of a PRJ File Path) with the specified one within the setting.

When the user has only specified the PRJ File Path (User_PRJ) and not the DLNAME, whereas the model 
references only a DLNAME (User_dlname), the following Warning message appears:

 

 Whatever the value of the DLNAME field is, the PROJECT File Path is taken into account (reference to locate the 
PROJECT File). This is the reason why the DLNAME option is automatically deleted when the PROJECT File Path is 
not specified and when you click OK to close the panel.

Conversion V4/V5
●     Characters Equivalence Table Path:

The Characters Equivalence Table is taken into account when using the following functionalities:

 

1.  File / Open a Session or a .asm document (documents are read with V5 compliant names).

For more information about this functionality, read Opening a CATIA V4 Session in CATIA V5, in CATIA - 

V4Integration User's Guide.

 

2.  V4 to V5 Migration Batch (documents are migrated with V5 compliant names).

The Characters Equivalence Table allows to convert characters contained in CATIA V4 documents. It is 
mainly used to generate V5 compliant names from V4 names by replacing special characters (", *, /, 
etc...) by standard characters.

A default table exists (table path empty) but the user can choose a different table by specifying its NT 
or UNIX path in the option box:
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The table file is a .txt document. By default, the conversion table will be applied to special characters: 

ASCII Code of the 
Original Character 

Character  
to be Replaced New Character String

       0x22         "        _Inch
       0x2a         *        x
       0xB1               _
       0x2f         /        _
       0x3a         :        _
       0x3c         <        _
       0x3e         >        _
       0x3f         ?        _
       0x5c         \        _
       0x7c         |        _

For instance, the double-quotes (0x22 in ASCII code) will be replaced by "_Inch".

If you want to display it on Windows, the address to be specified should look something like this: 
home/path/table.txt.

CATIA V4 documents, containing the special characters space and slash, are saved with a 
name which does not have the space or slash character. The space is automatically 
converted in (0xB1) and the slash is automatically converted in (0XB4).

In CATIA V4, if a pointed document is renamed or moved, the multi-model link is broken.

If a document name contains a space, it is a result of a manual renaming procedure, so 
the pointed document is considered to be not the same as the one corresponding to the 
link name.

When V4 documents dependencies are scanned for renaming, V4 links (if exist) are 
analyzed, and the CATV4ToV5CompatibilityName try to find the pointed documents. If 
their name must be changed, they are added to the list of documents to rename. But, if 
the name of the pointed document does not match the saved pointed document (with ± 
and ') the dependency is not taken into account. And the pointed documents are 
considered as not found.

In the multi-model links, the conversion table is applied on:

●     the document name (in the link) for the slash

●     the saved name for the space.

If the conversion table is not defined, the default character for space and slash for the 
CATV4ToV5CompatibilityName is underscore.

If the conversion table is defined, it is used to convert the V4 documents.

Here is an example with a pointed document or a model name:

●     Link name with space and slash
❍     Sample  ZZZ/ZZZ.model

●     Pointed document on disk:
❍     Sample ±ZZZ 'ZZZ.model
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●     With no conversion table:

❍     new name: Sample_ZZZ_ZZZ.model    (± and ' become _ )

●     With Conversion table: (if ± converted into A and  / converted into B)

❍     new name: SampleAZZZBZZZ.model

For more information about this functionality, read Migration in Batch Mode, in CATIA - V4 Integration User's Guide.

  
Click OK to confirm.
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Saving as V4 Data

This task shows you how to customize Compatibility settings, and more particularly for the V5 to V4 Migration 
(Save As Model).

1.  Select the Tools->Options... command. 

The Options dialog box appears with the category tree in the left-hand column.

2.  In the General category of the Options Tree, select Compatibility and click the Saving as 4 Data tab. 
The following dialog box appears:

Saving as V4 Data

●     Declaring the writing code page when saving Version 5 CATPart documents as CATIA Version 4 
models

For a full scenario illustrating this functionality see "Saving Version 5 CATPart Documents As CATIA 
Version 4 Models" in the CATIA - V4 Integration User's Guide.

In Version 4, the declaration parameter catsite.WRITING_CODE_PAGE declares the code page to be 
stored in the Version 5 data to be written. The writing code page ISO-8859-1 is the default value so 
normally, unless another code page was already specified, you can go ahead with the save. 

However, if you want to use a writing code page other than ISO-8859-1, open the 
WRITING_CODE_PAGE list in the V4 Declarations part of the dialog box (indicated by the arrow above), 
select the appropriate code page and click OK. 
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●     Declaring the Model Dimension when saving Version 5 CATPart documents as CATIA Version 4 
models 

It is possible to customize Model Dimension for V4 models generated in V5.  

V4 tolerances will be computed according to V4 recommended values from this Model Dimension.  In V4, 
model tolerances can be modified through Standards -> Model Function. The Model Dimension 
Parameter, which can be modified in CATIA V4, has an impact upon the precision of geometrical 
calculation. The value by default is 10000mm and it corresponds to the V4 value. 

Before saving a V5 Part as a Model, you can change the Model Dimension parameter to fit your V4 
standards. The whole set of tolerances will be computed from this Model Dimension according to the V4 
recommended values. 

 

Be aware that modifying this value without consideration can affect dangerously the V4 geometry. The modification 
of the Model Dimension parameters should only be used to respect the V4 standards. 

The management of the resolution is different in V5 and in V4 :  

In V5 the main concept for tolerances is the Resolution which defines the minimum length of a valid object. It is 
fixed to 10-3mm. The management of confusions ("Do two objects have the same geometry?") is a direct 
consequence of the resolution: if the distance between to geometric points is less than the resolution, the two 
points are considered to be geometrically at the same location. 

In V4, tolerances are driven by the Model dimension. The most appropriate value to fit V5 resolution is 10000mm. 
Note that this is also the V4 default value.

●     Declaring the Model Unit when saving Version 5 CATPart documents as CATIA Version 4 models: 

You can apply a scale factor between the imported file and what you want to get from the original 
Model. You can choose a V4 Unit in this list: 
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●     Writing the Initial Model File Path 

With this option, you have the possibility to translate V5 CATPart documents into V4 Models using V4 
standards defined in the V4 Initial Model.

You may use an Initial Model; this means that you define a reference model which includes default 
values. To customize the environment (initialization values to modal parameters and management 
parameters), you need to create an Initial Model. Such a Model is often used to ensure that everyone in 
a company works with the same predefined standard values.

The Save As Model operation is able to take into account a V5 setting: a V4 Initial Model file path.  
Before saving a V5 CATPart as a V4 model, you can specify an initial Model file path in this setting Tools-
>Options...->General->Compatibility->V4/V5 Infrastructure. 

 
The "Initial Model file path" setting can replace the following settings:

●     The "WRITING_CODE_PAGE" setting

●     The "Model Dimension" setting

●     The "Model Unit" setting.

And the "Initial Model file path" setting defines other V4 standards:

●     The layer filters

●     The colors

●     Standards for SPACE elements: GENERAL and HLR standards can be taken into account. SPEC 
ELEMENTS standards cannot be defined.

●     Standards for DRAW elements

This information will be extracted from the Initial Model and added to the V5-generated model.
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Initial Models referenced in CATIA V5 should not contain: 

●     any geometry, SPACE or DRAW

●     any applicative data

●     Internalized Project File

Therefore, Initial Models used in CATIA V4 will not always be reusable directly in V5, and it will be generally easier 
to recreate a dedicated Initial Model for CATIA V5.

If the Initial Model contains elements that are not supported, the Save As Model operation will be aborted.

 
●     Associativity Mode

 

 

You can create a model in associative mode during the Batch migration or interactively. Applying a Save As Model 
operation on a Volume or a Surface means that the model keeps in memory the path of the Part and you can 
resynchronize the model after modifying the Part. You can choose either the Associative Mode or the Non-
Associative Mode.

Previously, associativity could be maintained only on the PartBody (on volumic components). A message was 
displayed whenever the migration could not take place for non-volumic elements.

Now, you can launch the associative mode whatever the CATIA components' nature is (volumic or not). Therefore, 
a standard Save as Model can be applied on non-volumic or non-surfacic elements.

Synchronization of the model:

At each stage of synchronization, the non-associative elements created during the previous migration are added in 
the "bin" layer. And the non-associative elements of the current CATPart's geometry are entirely re-created. In this 
way, the user, if he wants, can delete all the old non-associative geometry by selecting  the "bin" layer in CATIA 
V4.

Number of the layer for non-associative data:

The number of layer can be specified by the user thanks to the Tools->Option->Compatibility Settings. Note 
that in V4 model, a number of layer can have a value between 0 and 254. If this setting is not informed, a default 
layer number is used: layer number 254. If you enter 255 for instance, a warning is displayed. The layer is visible 
in the model. The user can put it in the No Show space or delete it if he wants.
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Identifiers of the non-associative elements:

During the stage of synchronization, non-associative elements issued from the previous migration are moved into 
the "bin" layer and their identifiers are modified in order to know which migration number they come from. Each 
identifier is modified in that way: RxxxIDENT, where xxx is the migration number.

For instance, the identifier LINE.1 becomes R001LINE.1 at the first synchronization of the model. If we make two 
synchronizations, the model contains LINE.1 and the following identifiers R001LINE.1 and R002LINE.1.
 

 
●     Create an error feature in CATPart if saving is incomplete

When some V5 elements cannot be migrated into CATIA V4, a warning message can be displayed and an error 
feature appears in the CATPart's Specification Tree.

Never: if the user does not want to see this message and the error feature, he can click this option.

After user agreement: if he chooses this option, a panel appears, asking if he wants to see the corresponding 
error feature in the Specification Tree.
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If the user click Yes, an error feature indicates the V5 component that could not be migrated: "Invalid BRep 
Geometry.1 (This face is too small)". In the Geometry, the face is highlighted in red and the user can modify it.

Always: no panel is displayed and the error feature automatically appears in the CATPart's tree.

Click OK to confirm.

 
●     V4 Model File Name
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 Before migrating a CATPart into a .model, you can specify in the Saving as V4 Data settings that the resulting 
.model must have Capital Letters.

1.  Check the option: File Name in Capital Letters.
2.  Open a CATPart in CATIA V5.

 

 3.  Save the CATPart as a .model.
4.  Open the .model in CATIA V5. In the File Selection panel and in then in CATIA V5, the model's name is in 

Capital Letters:
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V4 / V5 DRAW 
You can customize given options when using interoperability from version 4 to version 5.

1.  Select the Tools -> Options... command. 

2.  Click Compatibility in the list of objects to the left of the Options dialog box. 

3.  Select the V4/V5 DRAW tab. 

●     Geometry import

When importing geometry, you can decide that you do or do not create centers and end points.

●     Dimension conversion mode

When converting dimensions, the resulting dimensions can or cannot be edited (modified).
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●     Explode mode

When importing a ditto (or component), this ditto is automatically exploded. As result each element in 
that ditto can be modified separately.

By default, you can convert the V4 Symbolo into Ditto in CATIA V5, but when this setting is activated 
you can keep the former mode, Explode symbolo mode.

 
●     Blink element

When this setting is activated, you obtain a red element in CATIA V5 corresponding to the V4 Blink 
element. If you do not activate this option, the migrated Blink element is displayed in highlight.

 

 
●     Generative View style

This setting specifies the generative view style that should be used when migrating AUXVIEW2 views 
from V4 to V5. Select an XML file from the list. The generative view style parameters defined in this 
file will be used for the migration. 
If this setting is unavailable, you need to uncheck the Prevent generative view style creation setting 
from Tools -> Options -> Mechanical Design -> Drafting -> Administration tab.
For more information on generative view styles, refer to the Generative Drafting User's Guide.

5.  Click OK to confirm the operation.
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V4 / V5 SPACE 

You can customize given options when using interoperability from CATIA version 4 to CATIA version 5. You can choose different 
parameters for pasted Surfaces/Curves Continuity and Segmentation. In order to optimize Continuity, this panel offers you 
3 settings allowing you to control the deformation of V4 Geometry in CATIA V5.

In this page, there are two sections: explanations about the concepts followed by three examples for practice.

 
Concepts: Controlling the Deformation of V4 Geometry in CATIA V5.

Gap Healing
Curvature Improvement (Maximum Deformation)
Surface and Curve Sub-elements (Segmentation)
Migrating DETAILS SPACES used by Dittos

Examples: 

How to use Gap Healing
How to use Curvature Improvement
How to keep Segmentation

 
Other Settings:

In this panel, you can also customize the migration of isolated Geometry from Details / Dittos by using a variable and the 
migration of Mock-Up Solids as PartBody:

Interactive Migration of unused Geometry from Details
Isolated Geometry or unused Geometry is Geometry not in use for Geometry or family building. For more information, 
please refer to: Optimizing V4 Migration: Deactivation of the V4 Parents' Filter in CATIA - V4 Integration.

 
Isolated Mock-Up Solids Migration

Mock-Up Solids can be converted (as Result) into CATIA V5 as CGR or as PartBody.

CATIA V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from CATIA V4 to 
V5, this geometry (Curves, Surfaces) is first optimized and then broken down into a set of contiguous geometries (Faces, 
Edges), each of them being C2-continuous. 

This panel allows you to optimize and control the quality of the geometry and to obtain C2 Continuity (deformation is 
possible).

Open the .model of your choice.

1.  Select the Tools -> Options... command. 

2.  Click Compatibility in the list of objects to the left of the Options dialog box. 

3.  Select the V4/V5 SPACE tab. 
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You can customize V4->V5 SPACE settings:

Concepts:

Gap Healing 
Gap Healing has an impact on External Control Points and not on Inner Control Points. External Control Points are 
modified according to the following options. In this category you have the choice between two options:
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●     Model relative value (corresponding to the Identical Curves Value defined by the model)

External Control Points are modified according to the model's value or tolerance.

●     User defined value (External Control Point Maximum Deformation)

Here is a schema to explain the position of the External Control Points, before activating this option:

 

and the displacement of the External Control Points after activating this option:

 

When this option is activated, it allows you to fill in the gaps between two arcs/patches, and therefore to 
optimize the geometry. Both patches are joined because the External Control Points have merged. There is 
however a deformation tolerance and this process can give the Surfaces a C0 Continuity. The examples 
in How to use Gap Healing will help you to understand the results. 

Curvature Improvement (Maximum Deformation) 
For a Surface/Curve, the number of generated V5 Faces/Edges varies according to another parameter: the 
maximum value allowed for Control Point deformation. 

Curvature Improvement has an impact on Inner Control Points. Inner Control Points are modified (displaced) 
according to the value defined by the following options. If you select the Inner Control Point Maximum 
Deformation option, the Curvature Improvement value can be modified.
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●     Use the default value (corresponding to the Projection Point tolerance defined by the model)

If you choose this option, the value which is taken into account is the maximum value between  the V5 
resolution value (10-3) and the Projection Point tolerance value (10-3 for instance, in V4) for a model 
dimension of 10 000m.

For a model dimension of 10m, the standard value of the Curvature Improvement is 0.001mm 
(corresponding to the V4 model's value). In CATIA V4, the geometric standards are listed in the following 
dialog box:

In order to understand the Curvature Improvement results, please refer to the paragraph entitled How to 
use Curvature Improvement.

●     Inner Control Point Maximum Deformation (User Value)

If the Inner Control Point Maximum Deformation value is equal to 0, the geometry is broken and an edge 
is created for each patch limit.

To decrease the number of cells/patches in the geometry, you need to select this option (default value) 
and to increase the tolerance/curvature improvement. The unit is the millimeter (V4 model unit in 
general).
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Surface and Curve Sub-elements (Segmentation) 

When V4 Surfaces/Curves are migrated into CATIA V5, some Faces/Edges are created in V5. In order to keep a C2 
continuity with the geometric objects, Surface and Curve sub-elements may be deformed and cut into several pieces 
(where they are not C2).

●     Keep Segmentation

By default, the Keep Segmentation option is not selected, the simplification of the geometry is active. If 
you want to reduce the geometry data size, select this option. If you want to keep the same number of 
sub-elements, deselect this check-box.

For instance, two arcs and two surfaces with a C2 Continuity can be transformed into a single patch or arc 
in order to simplify the geometry. But if you keep the patch segmentation, these arcs and surfaces are not 
simplified.

You can find an example in the section entitled How to Keep Segmentation.

  

 Migrating DETAILS SPACES used by Dittos

If you want to make a special migration for Dittos, you can add select one of the following settings:
●     Usual optimized mode: corresponds to the normal and advised mode (with no setting). You can select this option if you 

want to see the geometry (curves, lines, surfaces) non-used by the Solid and contained in the Detail's area. 
This is what we call "Isolated Wireframe Geometry".

 

 
●     Like V4 explode mode: before it was activated by a setting "set V4V5ForceDetailToExplode=1" on NT and 

"export V4V5ForceDetailToExplode=1" on UNIX. If you want everything to be migrated without CARWL, like 
the explode of a V4 model, you can select this option.

 

 Both isolated wireframe migration mode: before it was activated by a setting "set V4ToV5DetailGeomRequired=1" on 
NT and "export set V4ToV5DetailGeomRequired=1" on UNIX.
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 Note:
●     be careful, use these functionalities only when it is really necessary. Do not use it systematically, otherwise there could be 

memory crashes. 

●     Use one or the other setting, but not both at the same time. 

●     If you choose one of these settings, be careful because it will be also activated in the interactive mode and in the Batch 
mode (CATV4ToV5Migration). For information, the batch offers another way to migrate workspaces. 

 Examples:

How to use Gap Healing 
Open SURFACE_NON_C0_WITH_CURVE.model.

In all these examples, the option Keep Segmentation is not activated.
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Example 1: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and you obtain:

 

3.  Update the CATPart:

1283Page Infrastructure Version 5 Release 13



 

External Control Points are modified according to the model's value or tolerance.

Example 2: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and press the Update button.
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The number of cells is reduced because there is an optimization of the geometry.

Example 3: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and press the Update button.
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The patches are joined because the External Control Points have merged.

How to use Curvature Improvement

Open SURFACE_CURVATURE.model

Enter the  parameters in the Curvature Improvement (Maximum Deformation) area, according to the maximum value allowed 
for deformation. In all these examples, the option Keep Segmentation is not activated. 

If the Curvature Improvement value is positive or equal to 0, the value appearing in the V4/V5 SPACE panel is recommended 
as Maximum Deformation.

These examples reveal the influence of Curvature Improvement variations.

Example1: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and press the Update button.
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Example2: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and press the Update button.
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Example3: 

1.  Select the following settings:

2.  Copy / Paste the .model document into a CATPart and press the Update button.
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The higher the Curvature Improvement value is, the fewer Faces there are. Tolerance is more important when 
Curvature Improvement is high, which means that a slight variation is allowed between the original document and 
the new one.

How to Keep Segmentation

Open SURFACE_C2_WITH_3_PATCHES.model and copy / paste it into a V5 CATPart and update the V5 CATPart. 
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Here are two examples illustrating the behavior of this setting:
 

1.  When the Keep Segmentation option is not activated and the Curvature Improvement (Maximum Deformation) is 
0.1mm, go into the FreeStyle Shaper workbench and copy/paste *SUR5 into a new Part. Select Surface.1 (*SUR5)  and 

click the Geometric Information icon . The Geometric Analysis dialog box appears:
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Geometry Analysis delivers the following information:

Number of components U: 1
Number of components V: 1 -> only one component because you do not have selected the Keep Segmentation 
option. The default value of this option is taken into account and the Surface has been simplified.

Without selecting the Keep Segmentation option, the nodes are removed and geometry is simplified within the 
tolerance. 

2.  When the Keep Segmentation option is activated and the Curvature Improvement (Maximum Deformation) is 0.1mm, 

go into the FreeStyle Shaper workbench and copy/paste *SUR5 into a new Part. Select Surface.1 (*SUR5) and click the 

Geometric Information icon . The Geometric Analysis dialog box appears:
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Number of components U: 1
Number of components V: 3 -> 3 components because you have selected the Keep Segmentation option and it 
forces the numbers and boundaries of the arcs and patches to be kept. 

 

 

 Copy/Paste Details and Dittos: Migration of unused 
Geometry from Details

This functionality allows you to get round the constricted migration of isolated Geometry from Details. The result is the same 
for the Geometry as if you had exploded all the Dittos in CATIA V4 and then migrated the *MASTER, but in our example below 
everything is made in CATIA V5. The Copy / Paste As Result With Link (CPARWL) is not used for the Geometry. And the 
process is unchanged for the Solids.

On Windows and UNIX, before opening CATIA V5, you need to launch this option by entering the command (to make it visible 
in Tools->Options):

●     set V4ToV5DetailGeomRequired
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If you want to make a special migration for Dittos, you can add one of the following setting in the CNEXT launching shell:

●     set V4ToV5DetailGeomRequired =1: if you want to see the geometry (curves, lines, surfaces) non-used 
by the Solid and contained in the Detail's area. This is what we call "Isolated Wireframe Geometry".

●     set V4V5ForceDetailToExplode =1: if you want everything to be migrated without CARWL, like the explode 
of a V4 model.

Note:

●     be careful, use these functionalities only when it is really necessary. Do not use it systematically, otherwise there could be 
memory crashes.

●     Use one or the other setting, but not both at the same time.

●     If you add a setting in the CNEXT launching shell, be careful because it will be also activated in the interactive mode and in 
the Batch mode (CATV4ToV5Migration). For information, the batch offers another way to migrate workspaces.

1.  Select the Tools -> Options... command.
2.  Click Compatibility in the list of objects to the left of the Options dialog box.
3.  Select the V4/V5 SPACE tab.

 

 You can customize the following setting:

4.  Check the option: "Migration of unused geometry from Details required".
5.  Open V4ToV5DetailGeomRequired_ODT.model in CATIA V5:
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 6.  Copy/Paste (As Spec or As Result) *MASTER into a V5 CATPart. And you obtain: V4ToV5DetailGeomRequired.CATPart.
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 Thanks to this option, all the Geometry of the Dittos is migrated, it is gathered under the corresponding OpenBody: for 
instance, the isolated Geometry of DIT12 is under OpenBody from DITTO *DIT12 in CATIA V5.

If you do not use the option, the isolated Geometry of the Dittos is not migrated within a single Part but under the Detail.

When you have finished, do not forget to uncheck this option.

 

 

 Isolated Mock-Up Solids Migration
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 Isolated Mock-Up Solids (SolidM) means that they do not have any history, any specifications.

For their migration into CATIA V5, you can choose between:

●     the SolidM conversion "as CGR" meaning that you will only get the meshing view (visualization mode)

●     or the SolidM conversion "as PartBody" meaning that you will be able to see the Geometry of the Solid, to edit it and you 
obtain an exact Solid.

Launching the "As PartBody" migration mode:

1.  On NT, enter the following command: set CATMigrSolidMUV4AsPart=1

On UNIX, enter the following command: export CATMigrSolidMUV4AsPart=1
2.  Or activate the setting "as PartBody" in the option entitled "Isolated Solids Mock-Up Migration - Feature Result" in 

Tools -> Options -> General -> Compatibility -> V4/V5 Space (by default, the "as CGR" option is checked):

 

 If you select the "as PartBody" option or use the variable, you will also have the following message after the copy/paste of the 
SolidM into a CATPart:

 

 
If you do not the use the variable nor the setting, the SolidM will be migrated as CGR.

For more information about the Conversion of SolidM, please refer to the scenario entitled Conversion of SolidM entities as 
Result (migrated as a PartBody) in CATIA - V4 Integration User's Guide.
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V4 / V5 SPEC 
You can customize given options when using interoperability from version 4 to version 5.

Open the .model of your choice.

1.  Select the Tools -> Options... command.

2.  Click Compatibility in the list of objects to the left of the Options dialog box.

3.  Select the V4/V5 SPEC tab.

Use of Step-by-step Update and Reroute: 
●     Step-by-step Update: If you select this option, you do not need to update your document after the copy/paste 

of a .model into a CATPart or a CATProduct. The update operation is automatic and you no longer need to 

press the update button: .

●     Automatic Reroute: it is a means to use the geometry in order to recover the Edges and Faces. This 
functionality is applicable only with updated EXACT or SMART Solids.

In interactive mode, this option is deselected by default.

In batch mode, this check-box is selected by default.

What is the reroute mechanism? 

When a contextual primitive (a Fillet, a Chamfrain, a Support or a Feature Draft) is unsolved in V5, the Modeler (in 
Part Design) is able to visualize the former geometric shape and the Fillet's Specifications.

  

 Draft feature migration mode:

The V4 propagation edges for draft is done with SQUARE mode:

In order to get the best V5 results (close to CATIA V4) from copying / pasting As Spec a model containing Drafts 
into CATIA V5, it is advisable to choose the Square mode (formerly it was activated with: set DraftEquerre=1 on 
Windows or export DraftEquerre=1 on UNIX). Indeed, this is the mode used in CATIA V4.

Open DRAFT_4_FACES.model.
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1.  Select the Square option and click OK, all the migrated Drafts (during the copy / paste As Spec from 

CATIA V4 to CATIA V5) will be migrated in this mode.

 

 
2.  Select *MASTER and copy / paste it in a CATPart.

3.  In the CATPart, DRAFT_4FACES_SQUARE.CATPart, double-click Draft.1 in order to see the Draft Definition 

panel.

 

 In the Draft Definition panel, you can see the property "Square" in the Draft Form field.
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4.  If the paste of a Draft or the update of the resulting Draft goes wrong, select the Cone mode (formerly it 

was activated with: set DraftCone=1 on Windows or export DraftCone=1 on UNIX). It will allow you to 

paste the Draft:

 

 
5.  Select *MASTER and copy / paste it in a new CATPart.

6.  In the CATPart, DRAFT_4FACES_CONICAL.CATPart, double-click Draft.1 in order to see the Draft Definition 

panel. This time, the Draft Form is "Cone".
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However, after you have copied / pasted the Draft in Cone mode and before leaving your CATIA V5 session, you 
should not forget to re-select the Square mode so that the Cone mode is not chosen  by default in further 
sessions.
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Migration Batch 

This task shows you how to customize Migration Batch settings.

1.  Select the Tools -> Options... command.

The Options dialog box appears with the category tree in the left-hand column.

2.  In the General category of the Options Tree, select Compatibility and click the Migration Batch tab. 

Or when the Migration Batch panel is open:

1.  Select the Options button. The Batch Options dialog box appears with five tabs.
2.  Click the Migration Batch tab.

Migration Batch

The following options are only useful in the Migration Batch context, not with interactive CATIA V5.
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●     Format: Selecting the format of Migration in Batch Mode (AS SPEC or AS RESULT)

By default, the format of this migration is AS SPEC, but the user can select the AS RESULT option.

With the AS SPEC format, you can get the model's specifications in a first place and the geometry in a second place (after 
updating the document). Then you can modify the elements you have converted into CATIA V5.

The AS RESULT format allows you to migrate the V4 elements that cannot be converted AS SPEC. And this operation is 
more efficient in terms of performance.

●     V4 Part Definition

A CATPart by Geometric Set: if you check this option, the "V4 Part" definition is the Geometric Set. Therefore, the subsets 
will be migrated into a V5 CATPart document.

A CATPart by Solid: The "V4 Part" definition can also be a Solid. The Solids will be migrated into CATParts and the non-
solid elements (for instance: Wireframe) into a CATPart as well.

 
●     Conversion Mode:

Selecting the Migration of SPACE / DRAW data in Batch Mode:

According to its content, a model is migrated into several documents : a CATPart and / or a CATProduct and / or a 
CATDrawing. It is possible to separate the treatment of SPACE data and DRAW data. In the Batch window, there is an 
Options button giving you access to this Tools-Options panel and you can choose between Space And Draw, Space, and 
Draw.

When a model contains DRAW data, they are migrated as a unique document : a CATDrawing.

Some entities undergo a few changes during the V4 to V5 conversion:

●     V4 DRAFT -> V5 Sheet

●     V4 Detail -> V5 Detail Sheet

●     V4 Views -> V5 Views

In the Batch Mode, all Draw and Detail workspaces are migrated in CATIA V5. On the contrary, if you Copy / Paste a Draft 
or a View interactively, only referenced Details are migrated.

Batch Migration of SPACE data:

There are 2 Part definitions; the migration of each Set respects the definition determined by the "V4 Part definition" a 
few lines above.

Every Workspace containing several Dittos or Set instances is converted as a CATProduct. Under this CATProduct, there 
are as many components as Dittos (Part or Product instances) and Sets.

The impacts of the V4 to V5 conversion on the entities:

●     V4 Set -> V5 Part

●     V4 Detail -> V5 Part or Product

●     V4 Model -> V5 Part or Product and/or CATDrawing

●     V4 Ditto -> V5 Product component
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Display Report Attribute:

This functionality allows the visualization of 3D elements attributes in the Migration Report. For each element, the list of 
its attributes is displayed with the following data:

●     The name of the attributes

●     The value of the attributes

The CATV4ToV5Migration interface is unchanged.

The Report panel displays attributes information.

 There are some limitations:
●     Display of geometrical elements' attributes (2D and 3D elements) only. You can find the information about the 3D elements in 

the interactive report and about the 2d elements in the .rpt file.

●     Display of only the attributes which have a value. For example, empty words that is to say words with no number are not 
displayed.

 

 
●     Drawing Parameters

 Initial Drawing Path: Select a .CATDrawing document which will serve as a template. The standard used by this document 
will be used during the migration. If you leave this field blank, the standard used by default during the migration will be 
the last one you used when creating a drawing.

 Projection of Space for transparent views: Specify what kind of projection mode you want to use for transparent views during 
the migration: the NHR V4 mode, the HLR V4 mode or the same projection mode as the V4 model.
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●     Mapping Files Location for Saving (to retrieve Multi Model Links)

This functionality allows you to find pointed entities in V4 MML Solids and to retrieve associativity in CATIA V5. You can store them 
in the following directories:

- Batch Target Directory

- Model Directory: a mapping table per model is available; it is stored at the same place where the associated model is.

- Source Directory: you can specify the directory path of your choice.

 

●     Mapping Files Location for Retrieving

When you migrate the pointing model, you need to know where the mapping table is, in order to retrieve the V5 entities.

The mapping table has the same name as the model; this is why it is important not to change the name of the mapping table. It is 
also not recommended to rename V5 documents otherwise you will not be able to find them in the next migrations, and therefore to 
recreate the V5 associativity.

 If you cannot find the mapping table, a Migration As Result will take place: first, the pointed models are migrated and then the 
pointing models (asynchronous migration).

If you cannot find the pointed element, the link between the models cannot be reproduced.

Click Add repository to find the mapping table location. With the arrows (Up and Down), you can move in the list and with the 

rubber button , you can erase a file location.

  

 Migration Interface:
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●     Interface Name:

This option allows you to customize Applications' migration from CATIA V4 to CATIA V5. You can specify a particular behavior for 
this migration. You can choose how your applicative data will be migrated by writing source code (the name of the interface) in this 
empty field.

 

Click OK to confirm.
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Setting the DELMIA/Deneb 
Compatibility Tab

The following procedure describes how to set the DELMIA/Deneb Compatibility tab. Setting this tab enables your V5 system to 
use D5 data created with DELMIA (formerly Deneb Robotics) software.
 

1.  Select Tools->Options. 

By default, the General option is highlighted.

2.  If the gray ball next to General (in the left bar) has a plus (+) sign next to it, and does not show its three sub-options, 

click on the ball to expand the tree.  

The compatibility option appears, as shown in the figure below.
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3.  Select the "DELMIA/Deneb Compatibility" tab.

4.  Enter the full path name of the project library in the PATH block.

5.  Click the Register button to register this path in the root library list.

Several project libraries can be entered in the root library list. If more than one library is currently in the list, select the one which you 
would like to be the current project and click the Set Current button. This will place the selected library at the top of the root library 
list.

6.  Press the OK button. 

Whenever work is saved or imported, the system looks in the current project directory. The last project selected by the Set Current 
button remains the current project until it is changed again.
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DXF/DWG Settings

This task shows you how to customize DXF/DWG settings

1.  Select the Tools->Options... command.

2.  Select the General category, then the Compatibility category, then click the DXF tab.

 

 

Import 
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Unit of the File

 
 By default, the option is set to Automatic and the unit of import is determined automatically (either millimeter or inch) for the best possible resulting drawing. However, in some 

cases the resulting drawing is not satisfactory and requires another unit. Select this unit in the list. Then restart the import.

If you have selected Scale Factor, enter the value of the scale factor between the imported file and what you want to get from the original Drawing in the fields on the right. 
 

Paper Spaces and Model Space

 

The Interactive Drafting workbench provides a simple method to manipulate a sheet. A sheet contains: 

●     a main view: a view which supports the geometry directly created in the sheet 

●     a background view: a view dedicated to frames and title blocks 

●     interactive or generated views.

An AutoCAD file is usually made of:

●     a model space that contains the geometry,

●     a paper space (or several in AutoCAD 2000). 
AutoCAD recommends that the paper space contains the title box and one or several viewports 
(A viewport is a window to the model space). However other configurations are possible.

Check this option to put the Paper Spaces in the Background view. The viewports will be created in the working view.

Check this option to keep the entire Model Space in its own sheet.
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Create end points

It is not easy to modify and stretch geometry of imported elements the way you can do it in a V5 native elements. A solution is to create end points when needed, but to the 
detriment of performances. Create end points offers you three options to fit your needs:

●     Never: it is the default option. It ensures the best performances.

●     For few entities: creates end points only for hatch boundaries and mixed polylines. This is an intermediate choice between performances and edition capabilities.

●     Always: creates end points for arcs, ellipses, lines, mlines, leaders and not standard polylines and splines. Use this option only when edition capabilities are required.

●     

Information on the option selected is given in the report file:
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Convert dimensions as

Check the required option:

●     Dimensions: 

This option preserves the semantic of AutoCAD dimensions in V5 as best as possible. 

●     In most cases, the whole semantic of the dimension is kept. 
This means the position, the layout and the text are preserved. 
The position, color, thickness, text caption (symbol, value, tolerance, font, color) can be edited. 

●     In some cases, text with redundant information 
(e.g. tolerance present both in the dimension field and in the dimension text) or dual dimension, 
or other unrecognized information will be dealt as a text with an associative link with the dimension.
This dimension has a "fake value" that is blanked.
To display the true dimension value, delete the associated text and enter the data in the properties of the dimension.

Limitation for the Dimensions option: 
●     Angular dimensions, problems may occur while positioning texts,

●     Following attributes are not yet supported : 

●     suppression of one of the dimension lines (for half dimensioning),

●     offset extension or suppression of extension lines,

●     arrowhead choice (the V5 default arrowhead is used),

●     automatic suppression of arrowheads if space is not sufficient.

●     Geometry: 

Check this option to keep the graphical aspect. Geometry is exploded into multiple lines, arcs, texts. (this mode increase performance when loading a model).

●     Details: dimensions are turned into details. 
This is an halfway notion between the previous two, in which the geometry is preserved and the dimension is easy to handle (it can be all selected at once).

See also the FAQ
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Mappings

Several mapping options are available from the Tools->Options->General->Compatibility->DXF. 

The lists of attributes are not the same in V5 and AutoCAD. Mapping options are used to come as close as possible to the AutoCAD attributes, or to switch them to V5 attributes. 

Line Type Mapping

A default mapping is available for imported lines, but you can customize the mapping of imported line types. 

Push the Line Type  Define button. The Import Line Type Mapping dialog box is displayed. 
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●     A default mapping is proposed for each DXF/DWG line type.

●     Use the Sort button of the DXF/DWG column to list the DXF/DWG line type names in alphabetical order,

●     Use the Sort button of the CATIA V5 column to list the V5 line type by number. 

●     To modify the mapping for a given DXF/DWG line type, select the name of this line type in its text field and select a new V5 line type from the corresponding combo box. 

●     To add a new DXF/DWG line type, push the New button. A line is added at the bottom of the list. The name proposed for the new line type is New_x. A default mapping is 
proposed for this new line type. Proceed as above to modify this mapping.

●     To change the name of an existing line type, or of a newly created line type, select the text of the line type and enter the new name.

●     To remove a line type from the list, select the name of the line type, erase it in the text field and click outside the text field.

●     For better performances, do not hesitate to remove useless types from the mapping list. 

Text Font Mapping:

By default, a mapping is done automatically between the AutoCAD font and V5. 

Push the Text Font button to customize this mapping to:

●     map any DXF font with a V5 font,

●     associate a X scale factor to reframe a font with a different geometry (characters too wide or too narrow) 
to achieve the best possible alignment ,

●     define a default font to be used when there is no mapping for a DXF font,

●     define a default KANJI font, other than SSS4, to be used when the BigFont DXF font is not mapped.

The Import Text Font Mapping dialog box is displayed:
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Under the DXF/DWG button, you find the DXF font to define, 
Under the CATIA V5 button, you find combo boxes listing the V5 fonts available, and the scale factors.

You can:

●     edit each column: enter the name of the DXF/DWG font, choose a V5 font from the combo box, and enter a scale factor, 

●     add a new mapping: push the New button, and repeat the step above,

●     delete a mapping: erase the name of the DXF/DWG font in its field,

●     sort the fonts: push the DXF/DWG or the CATIA V5 button,

●     define two default fonts with their scale factor at the bottom of the column.

If you reset the DXF tab, the list of fonts is re-initialized with the most often mapped fonts.
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Color/Thickness Mapping: 
●     By default (button not checked)  

●     When importing an Autocad2000 DXF or DWG file (this format is automatically recognized) 
the "weight"property of each entity is mapped to the nearest available V5 line weight. 
The current V5 line weights are visible and customizable through the menu Tools->Options->General->Display->Thickness. 

●     Previous versions (up to AutoCAD 14)did not offer weight attributes for the geometry. 
Therefore, all the geometry is created with the default weight attribute. 

●     If you

1.  Push the Color to thickness Define button. The Import Color/Thickness Mapping dialog box is displayed. 

 

In the mapping dialog box, you can select DXF colors by their number (the combo of colors is automatically updated) or by selecting it in the combo of colors (the 
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editor of color numbers is automatically updated) and finally select the corresponding V5  thickness. 

A default thickness is requested for not defined colors. 

You can also: 

●     add mappings with the New button or

●     delete mapping by erasing the color number in its field and clicking outside the text field and

●     sort the table by colors or by thickness with the DXF/DWF or CATIA V5 push buttons.

 

Export
 

Exported Sheets

1.  Check the required option to export either all sheets or only the current sheet of a multi-sheet drawing.

●     The option "Only current" exports the data to a file with the name entered in the Save as dialog box. 

●     The option "All" exports the data to several files. 

The name of each file is made of the name entered in the Save as dialog box and the name of the sheet (Drawing1_sheet_1.dxf, Drawing_sheet_2.dxf, ...). 

Version

1.  Select the required export file format from the combo box.

 

Version 5 supports DXF/DWG formats version 12, 13, 14 and Autocad2000.
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Export mode 

This option offers the choice between three export modes:

●     Graphic:
This was the only available mode up to Release 9. It is the default mode.
It is quick and reliable. It is useful if you want to export a CATDrawing to AutoCAD and print it without modifying it. 

●     Structured:
This mode is introduced in Release 10. The exported file can be modified. For example, in the case of a dimension exported in Structured mode, all the graphic entities 
representing the dimension are exported to an Insert/Block. 
The more complex Drafting elements are exported the same way whereas the basic geometric elements (lines, arcs, etc)  are exported as isolated elements.  

●     Semantic:
This mode is introduced in Release 11 and is similar to the Structured mode, with the advantage that linear, angular and circular dimensions are exported as true dimensions 
(with a default dimension style). "Default dimension style" entails that most graphic attributes (such as color, display format of the dimension value, type of arrow, space...) 
of the dimensions are lost. 

 

For more information, see the What About the Elements You Export? chapter. 
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Customizing Compatibility Options 

Before you start your first working session, you can customize the way you work to suit your 
habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you 
end your session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Choose the General category in the left-hand box.

3.  Click the Compatibility options.

The Electrical tab displays.

This tab lets you define the migration option.

4.  Change this option according to your needs.

5.  Click OK when done.
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Electrical Migration Options 
Click here to see the parent page.

Migration Options  

Bundle segments

If this option is checked, it means that each V4 BNS is migrated to a V5 bundle segment. Each V5 bundle 

segment is stored in a CATPart document. They are instantiated in the geometrical bundle, a CATProduct 

document.

 It is the default value.

Multi-branchable bundle segments

If this option is checked, it means that all the BNSs of a V4 GBN are migrated to one multi-branchable 

bundle segment in a V5 geometrical bundle. All the V5 bundle segments are stored in a single CATPart 

document, the multi-branchable bundle segment CATPart.

In case there are several V4 GBNs to be migrated, as many V5 geometrical bundles (CATProduct 

documents) are created, with one multi-branchable bundle segment (CATPart document) containing all 

the bundle segments.

Migration Options Disabled
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The electrical migration options can be disabled if the Interface Name parameter is not filled up with the 
CATIE3DMigration value in the Migration Batch tab.
Refer to Migration Interface.
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ENOVIA LCA

This task shows you how to customize Compatibility settings.

1.  Select the Tools->Options... command.

The Options dialog box appears with the category tree in the left-hand column.

2.  In the General category of the Options Tree, select Compatibility and click the ENOVIA LCA tab.

 This option is useful in a CATIA/VPM interoperability context.

In CATIA V5, you can select the DMU Mode (Digital Mock-Up) in order to transfer a lighter version of VPM data 
into CATIA V5. If this check-box is selected, only the visible data will be sent to CATIA V5; the transfer is more 
rapid because the constraints are not downloaded during the interoperability process.
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Customizing External Formats Import 
This task explains how to customize the import settings.

You imported a CAD Part  through the Insert ->Existing Component command.

1.  Select the Tools->Options... command. The Options dialog box appears.

2.  Expand the General category in the left-hand tree and select the Compatibility category.

3.  Click the External Formats tab.

If you have the SolidWorks, SolidEdge or Acis Plug-In license, the following settings will be available:

4.  Modify the settings as desired.
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●     Visu Format Unit :

This setting allows you to specify the number of millimeters per unit of the model. For instance, if you have a file in inch, 
you need to enter 25.4 in this field.

This option is taken into account when you have the following formats: SLP, STL, OBJ, BYU, IFF and _PS.

Note: For a file of type _PS, the Visu Format Unit must be set to 10. 

 
●     Preferred Conversion Technology

❍     Indirect : use of CAD license (available for DELMIA product line only).

❍     Direct : no use of CAD license. 
Support of ProE20 only.
Support of UG data up to V18.   
For Solidworks, SolidEdge, Parasolid, ACIS, DXF 3D, Inventor and VDA-FS : use the direct mode on Windows. (Note: These 
formats are supported on Windows only.) 

 
●     Link Mode

❍     Visu : tesselated data

❍     Exact Geo : recovery of CAD's exact geometry to generate V5 geometry (NCGM). After selecting this option, this message 
appears: "Please, restart session to take modifications into account".

❍     CATPart : link with a V5 CATPart. Do not modify this CATPart in CATIA V5.

 
●     Others 

❍     Save Coorsys in cgr : store part coordinate systems in .cgr file. It is only supported in the indirect mode. This parameter 
determines whether coordinate systems present in imported ProE, UG or IDEAS parts will be imported into the resulting CGR 
files.

 
●     Associative Mode

❍     Output Path : you can customize the Output File for generated data. It specifies the location where CGR, NCGM and 
CATParts will be generated.

If you have the IDEAS, ProEngineer or Unigraphics Plug-In licenses, additional options will appear in the External Formats tab. 

With the IDEAS Plug-In license, you obtain:

●     IDEAS (indirect mode only)
❍     Tesselation Parameter: parameter of IDEAS chordal deviation. The Tesselation parameter holds the value tessellating the 

surfaces contained by the I-DEAS parts.

❍     Project Name: This parameter is only used when converting data through the MS8 and MS9 based converter.This 
parameter must hold the name of the project under which the model file is being converted, and is registered, in the I-DEAS 
Data Management system.

❍     Library Name: pkg import (IDEAS package file) is the name of the library to transfer.

❍     Part or Assembly Name: you can select any kind of data you want to read from the pkg file Part or Assembly and specify 
its name.

❍     Part Number: this setting is optional, you can specify the part number you want to transfer.

❍     Revision Number: this setting is optional, you can specify the revision number you want to transfer.

With the ProEngineer Plug-In license:

1323Page Infrastructure Version 5 Release 13



●     ProEngineer
❍     Quilts Read: enables to activate the transfer of quilts surfaces inside CGR. This setting does not apply to NCGM or CATPart 

conversions.

❍     Simplified Representation: only part simplified representation is supported. To set the name of the part simplified 
representation to use before the Assembly conversion, check this box and enter the name.

❍     Instance Name: When you want to import a specific instance of a generic assembly/part, check this button and specify the 
name of the instance of your choice.

NOTE: For Simplified Representation and Instance Name, only upper case names are supported with the direct converter.

And with the Unigraphics Plug-In license:

●     Unigraphics (indirect mode only)
❍     Layers: string indicating the layers that need to be transferred during conversion. The syntax is:

*  : all layers are transferred by default
5, 8, 27  : only layers 5, 8, 27 are transferred.
8-32  : all layers from 8 up to 32 (including 8 and 32) are transferred.
2, 5, 8-32  : layers 2, 5 and all layers from 8 up to 32 (including 8 and 32) are transferred.

❍     Convert active layers only: if this option is activated, it enables to transfer only active layers or to transfer all types of 
layers (active and inactive). It can be used together with the previous Layers setting, in that case only layers that are 
compliant with those two settings will be transferred.

❍     Convert open surfaces: when this option is activated, it enables to transfer UG Open Surfaces during the conversion.

❍     Drawing Name: this setting is used in Batch mode only, while creating a CATDrawing. In this box you can specify the name 
of the drawing you want to transfer.

5.  Click OK to confirm your operation.
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Customizing IGES 3D Settings

 

This task shows you how to customize IGES settings.

1.  Select the Tools->Options... command.

2.  Select the General category, then the Compatibility category, then click the IGES tab.
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Refer to the Version 5 Data Exchange Interfaces User's Guide - Customizing IGES 3D Settings. 
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Customizing IGES 2D Settings
As you import  an IGES 2D file, you may customize the units and the dimensions format

1.  Select Tools -> Options -> ... .

2.  Click General-> Compatibility  in the list of objects to the left of the Options dialog box. 

3.  Click the IGES 2D  tab. 

Import
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Unit of the file 

 By default, the option is set to Automatic and the unit of import is determined automatically (either millimeter or inch) for the best possible resulting drawing. However, in some cases the 
resulting drawing is not satisfactory and requires another unit. Select this unit in the list. Then restart the import.

 

 

Destination view

Check the view in which you want to import the file.

Create end points

It is not easy to modify and stretch geometry of imported elements the way you can do it in a V5 native elements. A solution is to create end points when needed, but to the detriment of 
performances. Create end points offers you three options to fit your needs:

●     Never: it is the default option. It ensures the best performances.

●     For few entities: creates end points only for hatch boundaries and mixed polylines. This is an intermediate choice between performances and edition capabilities.

●     Always: creates end points for arcs, ellipses, lines, mlines, leaders and not standard polylines and splines. Use this option only when edition capabilities are required.
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Information on the option selected is given in the report file:

Convert dimensions as

  

If you check:

●     Dimensions: linear, angular and circular dimensions will be preserved, others (ordinate types) will be transformed into details.
This option keeps the semantic of the dimension. This means the position, the layout and the text are preserved. The position, color, thickness can be edited. The text of the dimension is a 
text that has an associative link with the dimension.
This dimension has a "fake value" that is blanked.
To display the true dimension value, delete the associated text and enter the data in the properties of the dimension.
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Limitation for the Dimensions option: 
●     Linear dimensions: rotated dimensions, i.e. linear dimensions with a fixed angle other than horizontal or vertical are turned into details,

●     Radial dimensions: problems may occur while positioning arrows,  

●     Angular dimensions, problems may occur while positioning texts,

●     Following attributes are not yet supported : 

●     suppression of one of the dimension lines (for half dimensioning),

●     offset extension or suppression of extension lines,

●     arrowhead choice (the V5 default arrowhead is used).

●     Geometry: geometry is exploded into multiple lines, arcs, texts. 
Check this option to keep the graphical aspect (this mode increase performance when loading a model).

●     Details: dimensions are turned into details. This is an halfway notion between the previous two, in which the geometry is preserved and the dimension is easy to handle (it can be all 
selected at once).

Export
 
Exported Sheets

1.  Check the required option to export either all sheets or only the current sheet of a multi-sheet drawing.

●     The option "Only current" exports the data to a file with the name entered in the Save as dialog box. 

●     The option "All" exports the data to several files. 

The name of each file is made of the name entered in the Save as dialog box and the name of the sheet (Drawing1_sheet_1.ig2, Drawing_sheet_2.ig2, ...). 

Export mode 

This option offers now the choice between three export modes:

●     Graphic:
This was the only available mode up to Release 11. It is the default mode.
It is quick and reliable. It is useful if you want to export a CATDrawing and print it without modifying it. 

●     Structured:
This mode is introduced in Release 11. The exported file can be modified. For example, in the case of a dimension exported in Structured mode, all the graphic entities representing the dimension 
are exported to an Insert/Block. The more complex Drafting elements are exported the same way whereas the basic geometric elements (lines, arcs, etc)  are exported as isolated elements.  

●     Semantic:
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This mode is introduced in Release 11 and is similar to the Structured mode, with the advantage that linear dimensions are exported as true dimensions (with a default dimension style). "Default 
dimension style" entails that most graphic attributes (such as color, display format of the dimension value, type of arrow, space...) of the dimensions are lost. 

 

For more information, see the What About the Elements You Export? chapter. 
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Export SmartBOM from CATIA Version 5 
This task shows you how to export SmartBOM from CATIA Version 5. In Supply Chain environment 
or in Project management, the Bill of Material (BOM) is one of the most precious information shared 
between actors. Export of BOM Briefcase enables to share such data by means of nomad application 
(SmartBOM Editor from SmarTeam corporate). No specific installation is required to view and edit 
BOM.

Install SmartBOM Product from the SmarTeam Corporate.

1.  In order to set the environment data, select the Tools -> Options... command. The option 

dialog box appears with the category tree in the left-hand column.

2.  In the General category of the options tree, select Compatibility and click the SmartBOM 

tab. The following dialog box appears.

3.  Insert the User Name and e-mail address of you choice.
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For the Export operation,

4.  Check the Embed associated documents box to attach CATIA documents (geometry and 

specifications) in Briefcase.

5.  Check the Export Active Briefcase box, if you want to export BOM as a nomad application 

(.exe). This will enable you to browse the "Install Path". Install path is a temporary directory 

where the nomad application is built before being sent.

 

For the Import operation,

6.  Browse the temporary directory where imported package will be read.

7.  Open a CATProduct document.

 

 
8.  Save it as stbom file (or .exe file): select stbom or .exe as file format in the File/Save As 

dialog box.
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This will generate the SmartBOM Briefcase (for instance: Landing_Gear_NewAssy.stbom) 
or SmartBOM Active Briefcase with your data (.exe file). You can then send this data by e-
mail or publish it on your Web site.

 

9.  Edit the stbom file in SmartBOM Editor: double-click the stbom file (or .exe file) to edit the 
BOM by using SmartBOM Product:

 

 

10.  Save your changes by using SmartBOM Editor (File->Save as).

11.  To import a new SmartBOM Briefcase in CATIA V5, select File->Open in CATIA V5 and 

choose the stbom format: the new BOM is imported with the attached CATIA documents. 
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STEP Settings
This task shows you how to customize STEP settings

 

 

1.  Select the Tools->Options... command.

2.  Select the General category, then the Compatibility category, then click the STEP tab.
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General

Detailed Report

By default, the report file contains a Detailed Conversion chapter. Uncheck the Detailed Report option to remove this chapter from the report file. 

 

 
Geometric Validation Properties

This functionality is available in STEP AP214 only.

1.  Check the Geometric Validation Properties option (By default, they are not processed ). 

2.  The Tolerances button becomes available. It opens a dialog box where you can define the tolerances for the GVP checking.

●     The first tolerance is the percentage of variation of volume or area allowed. Default value: 1%. 

●     The second tolerance is the maximum error for the center of gravity, expressed in mm. Default value: 1mm. 

●     You can retrieve the default values with the Default Values button.

For import:

●     Geometric validation properties are computed for each solid, shell, product or instance, and this information is written in the report file.
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●     For each solid, shell, product or instance, the report file gives the computed geometric validation properties: 

●     Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance),

●     Area: area of the entity (wetted area for solids) (applies to solid, shell or product),

●     Volume: volume of the entity (for solids only) (applies to solid or product).

●     If the imported STEP file contains geometric validation properties, these properties are read. This information is written in the report file.

●     For each read geometric validation properties, the report file gives the status of comparison between read and computed properties, with the following 
information:  

●     Centroid deviation error (distance measure) (applies to solid, shell, product or instance),

●     Surface area difference value and error ratio (applies to solid, shell or product),

●     Volume difference value and error ratio (applies to solid or product).

●     A global status for the conversion is given, together with the maximum deviations found. 

Example of report file: 
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●     The status of comparison for a given solid, shell, product or instance is ok if: 

●     ratios (Volume difference and Surface area difference) are lower than 1%.

●     and the centroid deviation is lower than 1 mm.

●     If all status are ok, the global status is ok too.

●     The maximum deviation found for each comparison (centroid, area and volume) is given in the report file with the corresponding entities (the maximum 
deviations found do not necessarily apply to a single object).

●     This functionality involves a slight performance loss, due to the properties computation cost.

 For export:

●     The exported STEP file includes geometric validation properties for each solid, shell, product or instance, according to STEP AP214 and the CAX-IF 
recommended practices.

●     For each solid, shell, product or instance, the report file gives the computed geometric validation properties: 

●     Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance),

●     Area: area of the entity (wetted area for solids) (applies to solid, shell or product),

●     Volume: volume of the entity (for solids only) (applies to solid or product).

●     The unit used for geometric validation properties is the STEP length user unit. See Unit option. 

●     If the option Assemblies/Structure only is checked, the Geometric Validation Properties are not available.

●     This functionality involves a slight performance loss, due to the properties computation cost.

Import

Insert Existing Component Mode

This option appears only if both the V5 - STEP AP203 Interface and the V5 - STEP AP214 Interface and the MULTICAx STEP Plug-in exist on the machine.

If you check MultiCAD, you activate the MultiCAD mode.
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Continuity Optimization of Curves and Surfaces

This setting allows a better user control over the number of curves and surfaces that are created during the process of importing STEP data into V5:

 

 
V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from a STEP file, this geometry (curves, surfaces) is 
broken down into a set of contiguous geometries, each of them being C2-continuous. This is what happens when the No Optimization option is chosen. 

However, this can produce an increase of the size of the resulting data, because more curves/surfaces are created. In order to limit this drawback, two 
other modes are optionally offered. 

In those modes, the STEP interface tries to limit the splitting of curves and surfaces by modifying their shape slightly, so that they become C2-continuous 
while remaining very close to their original shape. 

In order to guarantee that the deformation is not excessive, a maximum deviation parameter is used. When in Automatic  Optimization mode, this 
maximum deviation is read into the STEP file itself, in the STEP parameter that documents the precision of points in the file. In this mode, the value read 
from the STEP file is then corrected so that it remains comprised between 10E-2 and 10E-3. This guarantees an optimization that remains compatible with 
the precision for the data that was set by the emitting system. 

Last, if this strategy is not enough, you can choose the Advanced Optimization mode, in which an arbitrary deviation value can be entered. 

 By default, the Automatic Optimization  is proposed:
●     No approximation, thus this option does not create a significant deformation and keeps the internal BSpline structure (equations and knots). 

●     A continuity optimization is performed within the deformation tolerance used for optimizing BSplines, comprised between 0.001mm and 0.01mm 
(depending on the tolerance value defined within the imported STEP file) on:

●     BSpline surfaces,

●     BSpline boundary curves (3D and P-curves when available),

●     BSpline independent 3D curves,

●     The parameters box cannot be activated 

This option soften the effect C2 cutting of faces and boundaries (which is mandatory in V5) without any significant geometric deformation 

If you check No optimization: 

●     No optimization is performed on BSplines (neither curves nor surfaces). 

●     Elements are cut at  discontinuity points to suit the modeler (exact mathematic continuity). This may result in a dramatic number of faces and boundary 
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curves, data of poor quality and poor performances in further use in V5.

If you check Advanced Optimization:

●     No approximation. The internal BSpline structure (equations and knots) is kept, 

●     A continuity optimization is performed on: 

●     BSpline surfaces,

●     BSpline boundary curves (3D and P-curves when available),

●     BSpline independent 3D curves,

●     but the deformation tolerance is set by the user (see Parameters). 

With this option, you can enter a larger tolerance value which may enhance the optimization impact (resulting in less C2 cutting on faces). 

Push the Parameters button to access advanced optimization options and tolerances. 
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User-defined Tolerance

●     Deformation: maximum deformation (in millimeter) allowed in the optimization of curves and surfaces. Ranges between 0.005 and 0.1 mm.

●     Push the Default Values button to revert to the default value.

User-defined Advanced Option

●     Curves and Surfaces Approximation: 

●     BSpline surfaces and curves continuity is optimized,

●     In addition, Bspline curves and surfaces approximation is performed,

●     It is possible to enter a user value for Deformation,

●     This option may change the internal structure of BSplines (equations and knots),

●     This option usually results in a significant decrease in the number of faces cuttings. 

 

 

Export
 

Application Protocol (AP)

1.  Check the required export mode:  

●     AP203 iso

●     AP214 iso

The data contained in a CATPart or CATProduct document will be saved in STEP AP203 or AP214 formats. For more information about STEP AP203 

and STEP AP214, refer to Exporting CATPart or CATProduct Data to a STEP AP203 / AP214 File.  
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Units

1.  Check the required export mode:

●     mm (millimeter)

●     Inch

to export a CATPart or a CATProduct in STEP format and in Inch or millimeter independently of the V5 Session unit.

 

Show/NoShow

A CATProduct to export may contain:

●     visible entities placed in the Show space,

●     hidden entities placed in the NoShow space.

By default, i.e. when the option is not checked, only Show entities are exported.

Check the Export all entities option to export all entities belonging to both the "Show" and the "NoShow" spaces. Note that the "NoShow" entities are 
exported as if they were "Show" entities. This means that reading back a STEP file generated with the Export all entities option will put all the "NoShow" 
entities in the "Show" space.

 

 
Header of STEP file
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1.  Push the Define... push button. The Define header of STEP file dialog box is displayed:

2.  Fill in the form as required. You can revert to the Default Values by pushing the Default Value push button.

 
The header of the exported file looks like this:
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Assemblies

 

 

 
1.  Check the required option to select the export mode. 

●     Structure and Geometry in one file: one STEP file only containing the structure and geometry of the components. This is the option by default.

●     Structure only: a STEP file containing structure and entities PRODUCT_DEFINITION_WITH_ASSOCIATED_DOCUMENT which have a link with 
CATPart files.

●     STEP external references:  

●     one STEP file containing the structure

●     and a STEP file for each component 
The STEP file names, for each component, have the same name as the components.
the structure and the component STEP files are generated in one shot, in the same location.

●     CATIA external references: one STEP file containing the assembly structure with external links to CATPart, CATShape, model V4, .cgr, .wrl 
files, according to AP 214 external references mechanism.

The External References functionality is available only with AP214.  

A STEP file cannot refer to a STEP assembly file. 

This summary table shows you all the possible combinations within the first two frames, Export : Application Protocol and Export : Assemblies. 

Frame Export AP 
---------

Frame Export Assemblies 

203 (1) 214 (2)

Structure and Geometry in one file 
(3) YES YES

STEP External References (4) NO (inactive button) YES

CATIA External References (4) NO (inactive button) YES

Structure only (5) YES YES
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(1) = reference of the Application Protocol Config Control Design (AP203)
(2) = reference of the Application Protocol Core Data for Automotive Machanical Design Processes (AP214)
(3) = Export of the Structure and Geometry of a CATProduct into one file only
(4) = Export of the Structure and Geometry of a CATProduct into different files
(5) = Export of the Structure only of a CAProduct
If you have no STEP license,you can export a CATProduct in Structure Only mode. You can choose either AP203 or AP214, but the following buttons remain 
inactive:  

●     Structure and Geometry in one file 

●     External References

Dynamic Licensing:

If you release the STEP license and you access the STEP options panel, the export assemblies options may change. 

In this case, when you recover the STEP license, you have to go back to the STEP options panel to restore the good values.
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VRML

This task explains how to customize the VRML settings when saving a document in VRML format.

1.  Select the Tools->Options... command.

 
2.  In the left-hand tree, select the General category then the Compatibility sub-category.

 
3.  Click the VRML tab:

 
4.  Modify the settings as needed:

 

Import
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●     Unit 

From the pulldown list, select the desired unit for the VRML file to be imported: Meter, Millimeter or 
Centimeter. 

●     Options 

The Crease angle field impacts the generation of default normals. The following picture illustrates 
this:

 

 If the angle you defined in the Crease angle field is lower than the angle between the two 
geometric normals (shown in blue) of the adjacent edges, then a default and unique normal 
will be calculated so that the faces look smoother across the edges.
If the defined angle is greater than the angle between the two normals, two normals will be 
calculated and the faces will look less smooth across the edges.

 

Export
 

●     Version 

You are now able to choose between the VRML 1.0 and the VRML 97 format. To do so, simply check 
the corresponding radio button.

Note: when saving sections in VRML 97 format, make sure that the Save edges export option is 
checked.

 
●     Options 

This option is relevant for VRML 97 format only and lets you save normals and/or edges contained in 
your model when converting it into VRML format.
Bear in mind that saving edges increases the file size significantly.

You can also activate the Save textures option to save your textures:

●     in an external file of type .jpg 

●     directly in the VRML file. However, note that this will increase the file size considerably. 
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●     use the "Background color of generated VRML file" pulldown list to select the background color to 
be used when visualizing the generated VRML file in a standard VRML viewer (such as Cosmo 
Player, for instance).
The default color is "black" but you can select the desired color from the list or choose the More 
Colors... option to access the color palette. This palette lets you define more colors or create your 
own colors.
Note that when reopening your VRML document in Version 5, this background color will not be 
taken into account.

 
5.  Click OK to validate your settings.
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Parameters and Measure
Knowledge
Language

Measure Tools
Parameter Tolerance
Report Generation

Symbols
Units 
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Knowledge

This task explains how to specify the options when working with Knowledgeware relations, 
parameters and design tables. Refer to Using Knowledgeware Capabilities for more 
information.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Select the Tools->Options... command. The Options dialog box displays. 
2.  Select General->Parameters and Measure and click the Knowledge tab. This is what 

you can see onscreen:  

 
Parameter Tree View Field

 

●     Check Tools->Options...->General->Parameters and Measure->Knowledge-
>Parameter Tree View->With value to display the parameter values in the 
specification tree.

●     Check the Tools->Options...->General->Parameters and Measure-
>Knowledge->Parameter Tree View->With formula to display the formulas 
constraining  the parameter  in the specification tree. 
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Parameter names Field

 

> 
●     Check the Tools->Options...->General->Parameters and Measure-

>Knowledge->Parameter Names->Surrounded by the symbol' option if you 
work with non-Latin characters. If this option is unchecked,  parameter names 
should have to be renamed in Latin characters when used in formulas.

 Relations update in part context

Before V5R12, Knowledge relations (formulas, rules, checks, design tables, and sets of 
equations) used to execute as soon as one of their inputs were modified.
The user can now choose, when creating the relation, if it will be synchronous (i.e. the 
evaluation will be launched as soon as one of its parameters is modified) or 
asynchronous (i.e. the evaluation will be launched when the Part is updated). Each 
relation can therefore be synchronous or asynchronous. 

The 2 following options enable the user to create synchronous or asynchronous 
relations.

Creation of 
synchronous 
relations

Enables the user to create synchronous relations, that is to say 
relations that will be immediately updated if one of their 
parameters is modified. Relations based on parameters are the 
only one that can be synchronous.

Creation of 
relations evaluated 
during the global 
update

Enables the user to associate the evaluation of asynchronous 
relations with the global update. The relations can be 
asynchronous for 2 reasons:

●     The user wants the relations to be asynchronous

●     The relation contains measures. 

●     Relations based on parameters: These relations can be synchronous or 
asynchronous.

●     Relations based on geometry: These relations can only be asynchronous.

●     Relations based on parameters and on geometry: For the part of the relations 
containing parameters, the user decides if he wants the update to be synchronous 
or not. For the other part of the relations, the update occurs when the global update 
is launched. 

To get more information about the update in a Part context, see Controlling Relations 
Update.

 
Design Tables Field
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Automatic 
Synchronization at 
Load

When loading a model containing user design tables, if the design 
table files have been modified and the external file data is 
contained in the model, the design table will be synchronized 
automatically if this radio button is checked. 

Interactive 
Synchronization at 
Load

When loading a model containing user design tables whose 
external source file was deleted, this option enables the user to 
select a new source file or to save the data contained in the design 
tables in a new file.

Manual 
Synchronization

When loading a model containing user design tables, if the design 
table files have been modified and the external file data is 
contained in the model, the design table will be synchronized if 
this radio button is checked. To synchronize both files, right-click 
the design table in the specification tree and select the 
DesignTable object->Synchronize command or the Edit-
>Links command.

Default Mode: Copy 
Data Into Model

If checked, the data contained in the external source file will be 
copied into the model.

Default Mode: Do 
Not Copy Data Into 
Model

If checked, the data contained in the external source file will not 
be copied into the model.

3.  Click OK when done.  
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Language

This task explains how to specify the options you may need to check when working with Knowledge browsers.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Select the Tools->Options... command. The Options dialog box is displayed. 

2.  Select General->Parameters and Measure and click the Language tab. This is what you can see onscreen:  

 

Language Field

This field is to be used when using measures in relations or user functions. Measures are specific 
functions to be used in formulas and rules.
The Knowledge Advisor User's Guide provides you with tasks explaining how to use measures. For 
how to create and use user functions, see the CATIA Application Architecture documentation.

●     Check Tools->Options...->General->Parameters and Measure->Knowledge->
Load extended language libraries and select the packages you want to
load under Packages to load if you want to load a limited number of packages. 

This option is particularly useful for the administrator to limit the number of packages used by 
the user. 
It is also very useful to improve performances since only the required libraries are loaded.

●     Check Tools->Options...->General->Parameters and Measure->Knowledge
->Load extended language libraries and select  All packages to load 
all the packages displayed under Packages to load. 

 

Reference Directory For Types field 
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If you want to reuse the generated type in another Catia session in the PKT workbench, proceed 
as follows: 

●     save the CATGScript file in the Directory indicated in the Reference Directory for Types field (see 
Tools->Options->Parameters and Measure-> Language tab) 

●     check the Load extended language libraries check box and select the package containing the 
type you created.

  

3.  Click OK when done.  
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Measure Tools

 

This task explains how to customize measure settings.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click General -> Parameters and Measure in the left-hand box. 

3. Click the Measure Tools tab.

 

The Measure Tools tab lets you customize the graphic properties and automatic update of 
measures.

Update 

●     Automatic update in part: when checked, measures made on parts are automatically updated 
if you edit the part. 
Note:  This option requires that the automatic update of parts option is also checked (Tools -> 
Options, Mechanical Design -> Part Design -> General tab).

 
●     Automatic update in product: when checked, measures made on products are automatically 

updated if you modify geometry or move geometry in a product structure context.
Note: If you edit a part, the measure is updated when you activate the product.

 
Only associative measures can be updated. 
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Graphic properties 

The graphic properties available for editing are:

●     Display ~ for approximate measurement: sets the default display of the tilde (~) in dialog 
boxes and the geometry area to visually identify approximate measures.

●     Color, line width and text color: sets fill color, measure line width and text color.

●     Box: when checked, creates a box of the color specified around measures.

Important: You cannot edit the text color or measure style (i.e. choice between fill color 
or box).

 
Graphic properties set in the Options dialog box are automatically applied to documents containing 
measures made before Version 5 Release 8, Service Pack 1 when you open the document. You are 
therefore advised to customize your graphic properties before you open the document.

 Save as cgr
●     Save density in cgr: when checked, stores the density, if any, of a part in the CGR when the 

part is saved as a CGR file.
This lets you measure part density in visualization mode using the Measure Inertia command.

4. Click OK in the dialog box when done
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Parameter Tolerance
The Parameter Tolerance tab allows you to specify the default tolerance of Angle and Length type 
parameters. 

Angle and Length type parameters can be assigned a tolerance. To do this, edit the parameter, right-click 
the value field then select the 'Add Tolerance...' command from the contextual menu. The default values 
which are displayed in the tolerance dialog box are those you have specified in the Parameter Tolerance 
tab.

Using the tolerances specified in the figure 
opposite: 

●     If you create a Length type parameter then 
assign a tolerance to it, the default values 
displayed in the tolerance edition box will 
be 1 mm and 0 mm.

●     If you create an Angle type parameter then 
assign a tolerance to it, the default values 
displayed in the tolerance edition box will 
be 1 deg and 0 deg.

●     If you uncheck the 'Default Tolerance' box, 
all value fields are grayed out and you 
can't specify any default values.
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Report Generation

 

This task explains how to customize the reports generated by the Global Check Analysis tool in the 
Knowledge Advisor and Knowledge Expert workbenches.

You can choose to display a xml or a html report.

Displaying a HTML report

To generate a html report when performing the check analysis, go to Tools->Options->General-
>Parameters and Measure and select the Report customization tab. Select Html in the Select 
Report Visualization area. 

In this case, only the Check Advisor, the Check expert and the Passed objects options are 
available in the Report content area. You can specify the output directory containing the generated 
HTML report in the Select output directory field.

 
Select Html if you use a Netscape browser. 

Displaying a XML report

To display a XML report when performing the check analysis, go to Tools->Options->General-
>Parameters and Measure and select the Report customization tab. Select Xml in the Select 
Report Visualization area. . The following window opens:
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The Report Customization tab is made up of 4 different fields: The Select Input XSL, the Report 
Content, the Select output directory, and the HTML options fields.

Select Input XSL field

This field enables the user to select the XSL style sheet that will be applied to the generated XML 
report. The StyleSheet.xsl file is the default XSL file, but you can use your own template.

Report content field

Failed Checks If checked, the generated report will contain information about 
the failed checks only.

All Checks If checked, the generated report will contain information about 
all the  checks contained in the document.

Check advisor
If checked, the generated report will contain information about 
all the  Knowledge Advisor checks contained in the document.
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Parameter 
information If checked, the generated report will contain information about 

the parameters of the Advisor checks.

Check expert If checked, the generated report will contain information about 
all the  Knowledge Expert checks contained in the document.

Passed 
objects

If checked, the generated report will contain information about 
the objects that passed the Expert checks as well as information 
about the parameters of these objects (diameter, depth, 
pitch,...).

 

Objects 
information

If checked, the generated report will contain information about 
all the objects contained in the Expert checks as well as 
information about the parameters of these objects (diameter, 
depth, pitch,...).

Select output directory field

This field enables the user to select the output directory containing the generated XML report.

HTML options field

This option is available for Windows only. It enables the user to define if the report will be opened 
in a CATIA session (in this case, the check box should be checked) or if it will be opened in an 
Internet Explorer session (in this case, the check box should remain unchecked.)

 

Note that it is highly recommended not to use this report as a basis for macros or for 
other applications. It is only provided for information purposes.
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Customizing Constraint Appearance

 

This task shows you how to customize the display and style of the constraints defined in your 
document.

 

1. Select the Tools->Options command. 

The Options dialog box is displayed. 

2. Click  General category, then the Parameters category, then click the tab Symbols. 

This tab lets you customize:

●     Constraint Style

●     Dimension Style

●     Display at Creation

Note that a Preview glyph displays your preferences as you are specifying them.
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Constraint Style

3. To set the colors where 
appropriate, click the arrow of 
the constraint type combo box. 

A list appears containing the 
current color and the colors 
available by default. 

You can define a personal color 
too. See CATIA for more 
information. 

4. Choose any of these colors.

 

5. To choose between the constraints you wish to see or not in the geometry area, click the Filter 
button. 

The Constraint Filter dialog box contains filter options available for all the constraints that can be 
defined for the geometry.
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The Filter frame contains three options: 
●     Show all: shows all the constraints

●     Hide all: hides all the constraints

●     Conditional Filter: once activated, it makes the options of the Status Filter frame available. You 
can then decide whether you wish to display the constraint status or not, or display unverified 
or verified constraints. It also makes the Filter by Type options available. You can then decide 
the constraint types you wish to display by checking the appropriate options.

 The Filter by Type option now lets you filter out driving or driven constraints.

The Product frame contains the Show on active product option. If activated, this option displays the 
constraints defined on the active product. This option is specific to Assembly Design workbench.

6. Uncheck the constraints you do not wish to display and click OK to confirm.
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Dimension Style

7. Set the Scale option to Large. This defines the size of the symbols for tangency and parallelism 
constraints. You can set:

●     Small

●     Medium

●     Large

 

 8. Check Displays iconified constraint elements. This option increases the number of graphic 
symbols you can see in the geometry area. For example, you can see symmetry axes.

 9. Check Highlight pointed elements to make sure the application highlights the constrained 
elements when their constraints are pointed to. 

 10. Enter a value to define the gap between construction lines and geometric elements. For 
example, enter 4mm.

 The default gap is 2mm. The glyph previews the new gap.

 

 11. Enter a value to define the overrun between construction lines and geometric elements. For 
example, enter 9mm.
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 The glyph previews the new 
overrun.

 Display at Creation

 

 12. The Display mode option lets you choose between four options:

 - 'Value': only the constraint (or 
parameter) value is displayed.

 - 'Name': only the constraint (or 
parameter) name is displayed.
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 -  'Name + Value': the constraint 
(or parameter) name and value 
are both displayed.

 - 'Name + Value (formula)': the 
constraint (or parameter) name 
and value are displayed as well 
as the possible formula defined 
for this constraint.

 Whatever mode you choose, it applies to all constraints you are creating. However, you can edit 
each constraint individually by using the contextual commands available (xxxobject -> Value 
Display or Name Display or Name/Value Display).

13. Click OK to confirm the operation and quit the Options dialog box.
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Customizing Units

This task explains how to customize units.

 

 

 

 

1.  Select the Tools->Options... command.  
2.  In the General category, click the Parameters sub-category, then the Unit tab. You can define or redefine: 

❍     the default unit

❍     and the display of values for magnitude type parameters.

In the upper part of the dialog box, the default unit along with its symbol is displayed for each magnitude:

 3.  In the lower part of the dialog box, the 'Dimension Display' check boxes allow you to define:
❍     whether you want to display trailing zeros

❍     the upper and lower limits for using an exponential notation

❍     how many decimal places to display.

 
4.  If you want to redefine a default unit:

1.  Select the line with the magnitude whose unit is to be redefined. The list of available units for this magnitude is displayed right 
below the magnitude list (the magnitude name is grayed out). For example, if you want to redefine the Length unit, the list of 
available units is:
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2.  select the unit you want to define as new default unit in the selection list (in the example above, the Inch has been selected). 
The magnitude definition is updated in the magnitude list right above.

5.  If you want to display trailing zeros, check the 'Display Trailing Zeros' box.
Example: a 10 mm value will be converted in 10.000 mm if the number of decimal places is set to 3.

6.  If you want to redefine the decimal places, check the appropriate options.
Example: a 10.571 mm will be converted to 10.57 mm if the number of decimal places is set to 2.

7.  If you want to define the exponential notation limits, enter the value under and below which you want to display a magnitude type 
parameter in an exponential form.   
Example1: 105700 mm will be displayed as 1.06e+005mm if the upper limit for an exponential notation is set to 5.
Example2: 0.000057 mm will be displayed as 5.70e-005mm if the lower limit for an exponential notation is set to 4.

8.  Click OK to confirm your choice.

 

The new settings will apply immediately both to documents already loaded and to those subsequently loaded.The default values for length, 
mass and time are millimeters, kilos and seconds.
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Devices and Virtual Reality
Devices

Tablet Support 
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Devices 

 

This task explains how to set up peripheral devices. 

The peripheral devices concerned are primarily:

●     the joystick

●     the spaceball/space mouse.

The joystick is supported on all product brands and on all supported Windows platforms.

The spaceball and space mouse are supported on all P2 products on all supported platforms.

After installing Version 5, you must connect your peripheral devices and install the appropriate drivers.

1.  Select the Tools->Options... command.

 
2.  In the General category, select the Devices and Virtual Reality sub-category. 

 
3.  Click the Devices tab:
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The Devices tab lets you customize: 

Virtual Reality Configuration

The Virtual Reality Configuration area lets you activate the configuration to be used to run 
your tracking devices when starting a Version 5 session.
Prior to activating a configuration, you need to generate the corresponding configuration file 
in the Immersive System Assistant workbench.
Each configuration is saved in a .xml file and contains all the necessary MPK display 
configuration, including those related to the supported drivers and brokers which are now 
threaded.
To set a configuration as active, click the Manage button to open the following dialog box:
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 The list contains all the configuration files you have previously generated.

Select the desired configuration in the list and click Activate then OK to validate: the 
selected configuration now appears in the Active Configuration field. You need to restart your 
Version 5 session to take the new active configuration into account.

You can also:

●     remove a configuration from the list by selecting it then clicking the Delete button

●     add a configuration to the list by clicking the Add button. This opens the Select VR 
Configuration dialog box that lets you browse your file tree to select the configuration file 
to be added to the list. Once a file is selected, click the Open button to add it to the list.

 Virtual Reality Options

Check the "Move compass with 3D devices" option to be able to move the compass using 3D 
devices, i.e. a Space Mouse ou a SpaceBall for instance when put into the 3D scene.

 Global

You can customize the 3D picking device (laser beam) representation to obtain a better 
precision in picking and a better visualization in dark environments, all you need to do is:

Select the VRCursorLook check box.
the 3D picking device representation becomes a white and thin line (see images below)
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     Standard representation New representation

Maximum frequency for event sending

Maximum frequency (number of events per second) at which events are sent by peripheral 
devices. This value aims at limiting the frequency of emitted events for some devices. 
Polhemus, for instance, is not impacted by this value.
We recommend that you use the default value, unless the peripheral device you are using has 
special requirements. 

A process filters the mass of events generated when using I/O devices and relays only the 
useful events to Version 5.

The c:VR Monitor command toggles on a diagnostic window (named VRMonitor) displaying 
any drivers declared to the broker as well as any events those drivers are able to send. 
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 Automatically Started Daemons 

This part of the tab lists the peripheral devices for which native support is provided by Version 
5. Just activate the threaded drivers you need: 

●     Space Daemon: spaceball/space mouse. It is an automatic, i.e. threaded, driver which 
means that it can be managed by an automatic broker. This driver manages the 
orientation as well as button information

●     Function Keys

●     SW_Joystick: joystick.

Check the corresponding option to ensure that the peripheral device will be activated and 
recognized the next time you start a session. This setting requires the use of a peripheral 
broker. If you are using the peripheral devices for which native support is provided by Version 
5 (joystick, spaceball/space mouse): the peripheral broker process is started automatically 
when you start a session. Otherwise, you must run it manually.

4.  Click OK to confirm, or Reset... and OK again to reset default settings.

5.  Exit your session, then restart for your new settings to take effect.

 

1376Page Infrastructure Version 5 Release 13



Tablet Support 
 

This task explains how to set up pad options in order to perform viewing operations using the Tablet Pen on a Tablet PC. 
Note that you can use the pad to visualize both 2D and 3D objects.

 This functionality is available on Windows only.

1.  Select the Tools->Options... command.

 
2.  In the General category, select the Devices and Virtual Reality sub-category. 

 
3.  Click the Tablet Support tab:

 

The "Activate Transformation Pad" option lets you activate/deactivate the pad display in the geometry area. When 
working with a Tablet PC, this option is already checked.

By default, the pad is displayed to the right as shown below:
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4.  In the Pad Position area, activate the corresponding radio button to position the pad:

●     to the top

●     to the bottom

●     to the left

●     to the right.

By default, the pad is located to the right part of the screen.

 
5.  Set the pad size using the slider. You can choose a value comprised between 1 and 15.

6.  Use the Pad Transparency slider to define how transparent the pad will be: the higher the value, the more transparent 

the pad.

 

 No transparency Transparency = 60%

 

choose among the following actions:

●     Open option panel

This action opens the Tablet Support dialog box directly in the geometry area. You can then modify your pad 

options without having to re-access the Tablet Support tab:
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7.  The "Action on double-click" pulldown list lets you select the action to be triggerred when double-clicking. You can 

choose among the following actions:

●     Open option panel

This action opens the Tablet Support dialog box directly in the geometry area. You can then modify your pad 

options without having to re-access the Tablet Support tab:

 
●     Reframe

Zooms in or out to fit all the geometry into the available space

●     Center location
Centers the geometry at a specific location

●     No action
Means that no action will be performed on double-clicking. This may be useful, for instance, to avoid involuntary 
actions when manipulating the Tablet Pen.

 For more information on the various viewing operations you can perform with the Tablet Pen, refer to Activating 
Viewing Tools.

 
8.  When finished, click OK to validate your settings.
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Infrastructure
Product Structure
Material Library
Catalog Editor
VPM Navigator
Photo Studio

Real Time Rendering 2
Part Infrastructure

3D Annotations Infrastructure
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Customizing
Cache management

CATIA / ENOVIA VPM Interoperability
Nodes Customization

Product Structure
Product Visualization
Tree Customization
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Customizing Cache Settings 

Working with a Cache System 

Two different modes are available when a component (V4 model, V5 CATPart, V5 CATProduct, etc.) is inserted into a 
DMU Navigator CATProduct document:

●     Design mode: in this mode, the exact geometry is available and the document is inserted as is

●     Visualization mode: in this mode, a representation of the geometry only is available and the corresponding cgr 
file, if it exists, is inserted from the cache system.

Using a cache system considerably reduces the time required to load your data. The cache system is organized into 
two parts:

●     Local cache: a read/write directory located locally on your machine and used to store cgr files. The first time a 
component is inserted, it is tesselated. This means that the corresponding cgr file is computed and saved in the 
local cache as well as displayed in the document window. The next time this component is required, the cgr file 
which already exists (and not the original document) is automatically loaded from the local cache. The user is 
normally responsible for the local cache.

●     Released cache: a read-only cache that can be located anywhere on your network.
Several directories can be defined for the released cache. If a cgr file cannot be found in the local cache, the 
software browses the released cache directories in their listed order to see if the cgr file is located in one of them. 
If the cgr file is still not found, the component is tesselated and the resulting cgr file is saved in the local cache. 
The site administrator is normally responsible for the released cache. 

A timestamp enables the verification that no modifications have been made to a document since the generation of the 
corresponding cgr file found in either of the above caches:

●     Timestamp: the date and hour at which the origin document was last modified. If you activate the Check 
timestamp button, then before a cgr file is loaded into a viewer, its timestamp will be checked to verify that no 
modifications have been made to the document since the generation of the cgr file. If you don't activate the  
Check timestamp button, then a cgr file of a document will be loaded without any verification of its time-wise 
coherence with the document. 

The process used for loading data using the caches is as follows:
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●     The user requests the loading of a document into a viewer.

●     The System searches for a corresponding tesselated file (cgr file) in the user's local  cache. 

●     If found, then the timestamp is checked. 

●     If the timestamp of the cgr file is more recent than that of the document, then the cgr file is loaded 
into the viewer.

●     If not, then the document is tesselated, the resulting cgr file is  added to the user's local cache and the 
cgr file is loaded into the viewer.

●     If not found, then the System searches for the corresponding tesselated file (cgr file) in the released 
cache. 

●     If found, then the timestamp is checked. 

●     If the timestamp of the cgr file is more recent than that of the document, then the cgr file is loaded 
into the viewer.

●     If not, then the document is tesselated, the resulting cgr file overwrites the existing cgr file in the user's 
local cache and the cgr file is loaded into the viewer.

●     If not found, then the document is tesselated and the resulting cgr file is  added to the user's local 
cache and the cgr file is loaded into the viewer.
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Reading Components from a Database: The cache system works in exactly the same way when components inserted 
into a CATProduct document come from a database. An additional check is run: if the cgr file is not found in the local 
or released caches, the DMU Navigator requests that, if the cgr file exists in the database, it be downloaded.

The cache system is managed via the Cache Management tab in the Options dialog box. All cache options can be 
locked.

This task explains how to customize data cache settings.

A DMU Navigator document must be opened.

It is imperative that any directory designated for use as a cache directory be reserved for this usage only, i.e. you 
should not manually save any other files in this directory. (When necessary, the Check Maximum Size option purges 
the least-recently-accessed files in order to maintain the cache smaller than the designated Maximum size. As a 
result, any files that you manually save to this directory could eventually be purged.)
 
When you are working in Cache mode, a .model or .CATPart is converted to a .cgr format. You can convert the .cgr to 
a .model or .CATPart format using the Design Mode command. See the task Design Mode in the Product Structure 
user guide.

1.  Select the Tools -> Options... command.

The Options dialog box appears. 

2.  Click Infrastructure -> Product Structure in the left-hand box.
3.  Click the Cache Management tab.
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Cache Activation

4.  To activate the cache, check the Work with the cache system checkbox. (By default, the cache is not 
activated.) 

Cache Location

New features have been added to the Cache Management that render the configuration of the local and released 
caches easier. The new features are:

●     Local cache - a history of the last five defined paths 

●     Released cache - a configuration panel that enables you to:

●     select directories from a list of "accessible" directories that have been 
pre-defined by the administrator 

●     reorder directories list

●     remove entries from the directories list

Note that it is possible to use environment variables to define a local cache or a released cache:
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●     the variable should be defined (using the set command on Windows NT or the export command on UNIX) in the 
script file used to launch the executable file of the interactive application 

●     the variable must be correctly valuated to an existing directory

●     the entry in the local cache or released cache text-entry field should be of the form ${variable_name} 

5.  To define a local cache directory, enter the name of the directory in the Path to the local cache text-entry 
field or click the  Path to the local cache selection button and select an entry from the proposed history list.

6.  To define a released cache directory, enter the name of the directory in the Path to the local cache text-
entry field or  invoke the released cache configuration panel by  clicking the  Path to the released cache 
Configure button. 
The Configuration panel appears.

 

7.  To add one of the Accessible Directories to the list of Current Directories, select the entry in the Accessible 

Directories list and click the Right-arrow icon   .
The entry is added to the Current Directories list.

Note: The list of directories in the Accessible Directories list is defined by the administrator as follows:

●     define a .txt file of which each line contains the path to a directory that will 
appear in the list of accessible directories

●     set and export an environment variable AVAILABLE_CACHE_DIR_PATH 
that points to the above .txt file

●     the administrator can, of course, manage the access rights to the above-defined directories so as to 
restrict their access to groups of users or specific users

8.  To move one of the entries in the Current Directories list to a higher place in the list (remember that released 
cache directories are searched in the order in which you see them displayed), select the entry in the Current 
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Directories list and click the Up-arrow icon  .
The entry is moved up in the list. 

 

9.  To delete an entry from the Current Directories list, select the entry in the Current Directories list and click the 
Delete button.

 

 10.  (Optional) Enter the paths identifying the cache locations:

The Browse icon  enables you to locate the file you want. The user can enter the path to his own 
local cache location, and if permitted by the site administrator, one or more paths to released cache 
locations. 

The default directory is the user's home directory under UNIX and the USERPROFILE directory under 
Windows. 

 Cache Size

11.  (Optional) Set the maximum size for the local cache (in write mode).

When the maximum size is exceeded,  the automatic deletion of .cgr files (on a first-in / first-out basis) is 
triggered. The default maximum size is 500 MB.

1387Page Infrastructure Version 5 Release 13



 
12.  (Optional) Set the Check maximum size option:

When creating new cgr files in the cache, the check maximum size option serves to purge the oldest cgr 
files if necessary in order to respect the defined maximum cache size. 

If the option is activated, the check and eventual purge will be performed.
If the option is not activated, the check will not be performed.

Timestamp

13.  (Optional) Set the Check timestamp option:

The timestamp option serves to check whether or not the tessellated cgr file is up-to-date. 

If clicked, the system checks the original document's date against that of the corresponding cgr file, and if 
older, tessellates the document again overwriting the out-of-date version. If dates are the same, no 
tessellation is done and the cgr file in the data cache is loaded.
Turning this option off means that no check is run and cgr files in the cache are systematically loaded.

 Until now, the cache timestamp has been based on local time. This can lead to unwanted re-tessellations if you are 
sharing data between sites located in different time zones.

It is now possible to base your cache on GMT time.

The following are the rules for implementing your cache based on GMT time:

●     a batch job will permit you to migrate old caches to GMT time-based caches

●     once a cache is migrated to or designated as GMT time-based, you can never go back to a local time-based cache

●     ALL caches (local cache and released caches) must be of the same format 

To migrate an old cache, use the following command:

CATSysMvCache -o UTC -inputdir input_directory -log file.txt [-outputdir output_directory] 

If outputdir is not set, the cache specified in inputdir and the documents it contains are converted to GMT format. 

Once a cache has been migrated to GMT time-based, it is no longer compatible with previous releases of ENOVIA DMU 
or CATIA (i.e. a migrated cache cannot be used in V5R11 or below).

 

14.  Check the GMT timestamp format checkbox to designate all caches specified in Cache Location as GMT 
time-based.

Note: When the GMT timestamp format option is activated:

●     all new caches will be based on GMT time
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●     all specified caches must have been updated using the provided batch job 

If any of the caches specified do not conform to the rule that all caches must be of the same format, an 
error message will appear.

 Cache Content

When working in visualization mode, the insert component of a CATProduct will generate in the cache a cgr containing 
Levels of Detail (Lods). This option is activated by default.

15.  To deactivate the Generate cgr with level of detail option, click the corresponding checkbox.

 16.  When you've finished defining the different options, click OK to confirm. 
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Customizing CATIA/ENOVIAVPM Interoperability 
Settings

This task shows you how to customize ENOVIAVPM settings.

1.  Select the Tools->Options... command. When it appears, select the Infrastructure-
>Product Structure category in the tree on the left.

2.  Click on the ENOVIAvpm tab. The following dialog box appears:

As you can see, the Options dialog box is divided into four parts: 

CDM Interoperability Administration
PSN Display Options
Customize Session Building
V4 CDM Cache Management

CDMA Interoperability Administration 

There are three pushbuttons in this part: 

●     Selecting the Database Administration button lets you define the parameters for connection to the 
CDMA databases you wish to use (see "Connecting an ORACLE or DB2 Database to Your CATIA Version 5 
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Environment" in the ENOVIAVPM User's Guide).

●     Checking the Database Server Dictionary box lets you define a CDMA dictionary associated with a 
server.

●     Checking the ENOVIAvpm/Product Structure Mapping box lets you map CDMA and assembly 

attributes (see "Mapping CDMA and Assembly Attributes" in the ENOVIAVPM User's Guide).

PSN Display Options 

There is one checkbox in this part: 

●     Checking the Automatic Highlight in PSN box sets the automatic highlight for the identification of 
models in a PSN graph from a Version 5 session and vice-versa. This means that whenever you select one or 
more models in a PSN graph they are automatically highlighted in the Version 5 session. When selected in a 
Version 5 session, they are automatically highlighted in the corresponding PSN graph.

 
If you do decide to use this option you should be aware that performance will be adversely affected.

Customize Session Building 

There are two checkboxes in this part: 

●     Checking the Load all EnoviaVPM properties box means that when a session is built all the 
properties visualized in VPM that have not been mapped will be loaded as user properties.

 If you do decide to use this option you should be aware that performance will be adversely affected.

●     Checking the Disable Applicative Object management box speeds up performance.

 If you do decide to use this option you should be aware that V5 applicative objects such as publications, 
constraints, etc. will neither be saved nor stored in the database.

V4 CDM Cache Management 

There is one checkbox in this part: 

●     Checking the Work with the V4 CDM cache system box enables you to use the cache system 
and provide the location of the V4 local cache in the field CDM Cache path.

You can also specify the access method in the field Access method.
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Nodes Customization 

This task shows you how to give a particular name, reference or description to a product or a 
component.

1.  Select the Tools->Options->Infrastructure->Product Structure command and click the 

Nodes Customization tab. Check the option Customized Display and the settings become 

active.

 
2.  Check Customized Display. Then, you can select different options: Part number (#PN#), 

Revision (#RE#), Definition, Nomenclature, Source, Instance Name, Description. You can 

directly replace the diagram (PN, RE,...) between the two #  by the term of your choice and 

it will appear in the Product Structure. By the same way, you can add a comma and a blank 

space between these parameter.
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If you are using CATIA "with cache system", many informations that you can usually display on each 
node are not available for the CATPart nodes when opening a CATProduct.

In this case, the unavailable information is replaced by the character string '[?]'. There is one exception : the "Part 
Number" (#PN#) which is replaced by '[NNNN]' where NNNN is the name of the file containing the CATPart (without 
the directory name).

Those unavailable informations are made available when you use the "Properties" command on a CATPart. At this 
moment, the '[?]' strings are replaced by the real values for this particular node in the specification tree.

3.  These attributes are also accessible in the component's contextual menu: Edit->Properties. 

For instance, open the following example ManagingComponents01.CATProduct and select the 

Edit->Properties contextual command of CRIC_AXIS.CATPart.

For more information about Component Properties, please refer to Modifying Component Properties 
in CATIA - Product Structure User's Guide.

4.  Click the Define other properties button to add new attributes to CRIC-AXIS.CATPart and 

click the New Parameter of type button. The following dialog box appears:

 You can add the "Price" parameter in the Edit name and value field:
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 And you can notice the modifications in the Properties dialog box:
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5.  Click OK.

 
6.  Select the Tools->Options->Infrastructure->Product Structure command and the 

Nodes Customization tab. Check the option Customized Display and choose the following 

settings:
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 To specify the Price parameter, you need to use these characters: #@xxx@#.

 
7.  Click OK. And you obtain in the following result in the Specification Tree:
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Customizing Product Structure Settings 

This task explains how to customize Product Structure settings.

1.  Select the Tools->Options... command.

2.  Select the Infrastructure category, then the Product Structure sub-category, then the Product Structure 

tab:

Defining the Default Part Number of the Component to be Imported 

Check Manual input if you wish to assign the name you wish to the component you insert into the assembly.

Selecting the Low Light Mode of the component that does not belong to the active level 

If you check the Low Light Mode option and select (double-click) a component in a CATProduct, it becomes UI Active 
(highlighted) in the Geometry Space:
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The second example shows that the operation is also possible with Models. 

This is a visualization mode : the selected element remains highlighted and the other geometric components are in low 
light (gray-colored). If you double-click on another element, it immediately becomes highlighted and the other ones 
are grayed.

Describing the model file in the Bill Of Material 
Select the Model In BOM option in order to have access the Models' information (path name for instance) in the 
document's BOM.

 1. Open a CATIA document containing one or several models.

2. Select the Analyze -> Bill Of Material Menu and click the Listing Report tab.

3. Click on the Refresh button in order to access to the components' properties (path name for example):

1399Page Infrastructure Version 5 Release 13



These Models have been inserted into a CATProduct and you can now visualize the Models' path name. You can find 
the original directories in which the models were stored. When there is a broken link, you can read the following 
expression : "Unretrieved document".

Reframe Mode after insert existing component 

Check the Reframe Mode options you need:

In the following examples, CRIC_FRAME.1 has been inserted into Product6 and a different Reframe Mode has been 
selected beforehand. The original CATProduct looks like this:
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●     Global Reframe: this is the default value, Global Reframe zooms on the whole geometry and it allows you to see all 
the components. After the insertion of CRIC_FRAME.1 into Product6, the visualization of the geometry is re-
adjusted in CATIA window so that all the components can be seen.

●     No Reframe: if you insert an element in the product, you may not see the totality of this element in the CATIA 
window. The visualization on  the already existing component, CRIC_AXIS.1, does not change. There is no Reframe 
on the last inserted element.
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●     Reframe on last inserted component: This zoom-in capability improves the visualization of the last inserted 
component. Therefore, in some cases, you cannot visualize the other CATIA objects because there is an automatic 
Reframe on the last inserted component.

Customizing the Specification Tree 
●     Products to display the products in the Specification Tree.

When the option is activated: When the option is deactivated:
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To display the Constraints, Parameters and Relations, you need go to the Tree Customization tab. 

To modify the setting Automatic expand, you need to select the Tools->Options->General->Display category and 
the Tree tab:

3.  Click OK to confirm.
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Customizing Product Visualization Settings 

This task explains how to customize Product Visualization settings.

1.  Select the Tools->Options... command.

 
2.  Select the Infrastructure category, then the Product Structure sub-category, then the Product 

Visualization tab:

 

 Representation

In the "Representation" area, if you click the "Do not activate shapes on open" selection box, the graphical 
representations of all the components will not be computed when opening a CATProduct. So the only thing that will be 
displayed is the specification tree.
This option may be used to speed up the opening of large CATPRoducts when you don't need to see all the 
components.
Once the CATProduct is opened, you can display the component you need to see by using the Representation -> 
Activate Node option in the contextual menu of these components.

 
 Visualization Mode Type
 

●     Visualization Mode with local cache: option by default, when the Cache is activated (check the Work with the 
cache system checkbox). In this case you create all the cgr files in a local cache in mono process.

 

 
 

●     Multi Process Visualization Mode with local cache: when the Cache is activated. You can choose the creation of 
Cache files in multi process (DMU context). If you decide to check "Multi Process Visualization Mode with local 
cache" rather than "Visualization Mode with local cache", the following message appears:
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●     Visualization Mode without local cache: the cgr files within local Cache cannot be visualized; they are not created 
in the local cache.

 
●     None: when this option is activated, you are not in Visualization Mode but in Design Mode.

 

 
 

3.  Click OK to confirm.
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Tree Customization 

This task explains how to customize Product Structure settings.

1.  Select the Tools->Options... command.

 
2.  Select the Infrastructure category, then the Product Structure sub-category, then the 

Tree Customization tab:

 

 In the Specification Tree Order category, there is a list of CATIA attributes corresponding to the 
nodes in the Specification Tree. This list allows you to order nodes in the Specification Tree and to 
activate or deactivate their visualization.

 

 This is an order by default. You can modify this order by selecting a Specification Tree Node Name 
and clicking the Up or Down button. You can reorder the whole structure, for instance:
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3.  Click OK and the option panel is closed. The result in the Specification Tree corresponds to the 

order you had customized in the setting, for instance:

 

 The column entitled Activated allows you to activate or deactivate one or several nodes in the 
Specification Tree. For instance, you can choose to deactivate the Constraints node:

 

 And you obtain:
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Products and Publication Nodes cannot be deactivated.

 If you add a new node (for instance, a Material: Concrete) in the Specification Tree, you can activate 
the corresponding nodes:

 

 You can deactivate this component by the same way:
 

 Or reorder the components within the Specification Tree:
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 And you obtain:
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Customizing For Real Time Rendering 1 

 

This section describes how to customize different settings. All tasks described here deal with permanent 
setting customization. These tasks are:

Setting Priority Between Part and Product
Material Library
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Setting Priority Between a Part and a Product 

 

This tasks explains how to set material visualization priority between the material applied to a Part and 
another material applied to a Product.

Open the PriorityProduct1.CATProduct document. 

The document contains a Part, a Part instance and a Product onto which three different materials have 
been applied. By default, the material mapped onto the Product is displayed, having precedence over 
any other element into the document.
Therefore, in our example, the Alpine Fir material is visible:

 

 

1.  Right-click the Alpine Fir material in the specification tree and using the Properties menu item, 

display the Properties dialog box.
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2.  Select the Inheritance tab.

 

 

The three available inheritance modes are the following ones:

●     Propagates material towards children: the material propagates towards
lower levels in the hierarchy (default mode). 

The corresponding material icon in the specification tree is .

●     No propagation of material towards children: the material does not propagate.

The corresponding material icon in the specification tree is .

●     Force material and do not accept material from father: the material is
forced, i.e. it is visible even if an upper level material propagates.

The corresponding material icon in the specification tree is .

 
3.  Check the "No propagation of material towards children" option. 

The element visualization is instantly modified, and you can now visualize the material mapped 

onto the Part instance.

The geometry now looks like this: 
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4.  Click OK.

If you had selected the "Force material and do not accept material from father" option, the 
geometry would have looked like this:
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To be able to visualize the material mapped onto the lowest element in the specification tree 
(the Part here) you only need to force the material on this element.
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Material Library 

This tasks explains how to define material general settings using the  Tools -> Options... menu 
item.

1.  Select the Tools -> Options... command. 

 
2.  Click the Infrastructure category then select the Material Library subcategory to display 

the Material tab:

 

 
3.  Activate the "Warning when adding new properties to a material".
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 Once the warning option has been activated, whenever you wish to 
add properties to a material (by double-clicking on it and choosing the 
Analysis or Drafting tab for examples) a warning message is issued: 

 

This to let you know that the material have been modified when you 
accessed the analysis or drafting properties.

 

4.  Check the "Link mode is the default mode for applying materials" option to map the selected 

material as a linked object and thus, have it automatically updated to reflect any changes to 

the original material in the library. 

Note: the link mode is activated whichever method you use to apply 
the material: click Apply Material or use drag & drop capabilities. For 
more information, refer to "Applying Materials" in the Version 5 - Real 
Time Rendering User`s Guide.

 

5.  The "Force mode is the default inheritance mode" option lets you activate the force 

inheritance mode, i.e. force a material when applying it onto parts, products, bodies or 

surfaces in order to make it visible even if a father material propagates.  

For more information on inheritance modes, refer to Setting Priority 
between Part and Product in the Version 5 - Real Time Rendering 
User`s Guide.

 

6.  Use the "Desynchronize visualization when modifying material attributes" option to modify the 

material properties independently from the visualization and thus, to avoid visualization 

refresh which can take a long time when working on big models.
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7.  The "Applying a material opens the catalog in read/write mode" option enables you, for any 

applied material, to open and modify the corresponding material library. 

 
8.  When checked, the "Creation of a material parameter when creating a Product or a part" 

option automatically creates a material parameter for any part or product you create (either 

using the File->New... or the Insert->New Part/New Product command), even if no material is 

mapped onto it.

Activating this option also means that the "Material=None" parameter will appear in the 

specification tree. 

 
9.  Use the "Modifying a material parameter creates a link towards catalog" option to create 

(when checked) or not a linked material when modifying a mapped material using 

Knowledgeware capabilities.

Do not forget to check the "Parameters" option in Tools->Options->Infrastructure->Part 

Infrastructure->Display to visualize the Material parameter. 

In the two examples below, the Material parameter was selected in 
the specification tree then modified via the Edit Parameter dialog box 
(using the Material object->Definition... contextual command):

 

Example 1

 Option "On"
Material applied as a linked material

Example 2

Option "Off"
Material applied as a non-linked 

material
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10.  The Default Material Catalog Path area lets you browse your file tree using the  icon to 

select the material catalog to be used by default when applying materials. 

This material catalog will supersede the one defined in the 
CATStartupPath environment variable and thus, will be retrieved when 
selecting "Default Material Catalog" from the Library dialog box.

  

 

11.  The Environment Image area enables you to use your own environment instead of the default 

one provided. 

Simply enter the path to the user-defined environment or use the  icon to open the File 

Selection dialog box which lets you browse your folders to the desired location. 

Or

Click the Environment image generator  icon to open the 
Environment Map Generator dialog box (this icon only appears when 
working with a Real Time Rendering 2 license):
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 In the upper part of the dialog box, just click each environment wall 
(i.e. "Up", "Back", etc.) then navigate to the desired image using the 
File Selection dialog box. 
The resulting environment will be displayed on the environment map 
as shown below:
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The Image Size pulldown list lets you choose a Small, Medium or 
Large size for your environment image.  

Once the image is generated, enter its name and path in the "Save 

as" field or click the  icon to open the File Selection dialog box 
which lets you browse your folders to the desired location.

Click OK to validate and go back to the Material tab.

12.  Click OK.
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Customizing Catalogs

This tasks explains how to define Catalog Editor settings using the  Tools -> Options... menu item.

These settings are relevant for catalogs with design tables only.

1.  Select the Tools -> Options... command. 

 
2.  Click the Infrastructure category then select the Catalog Editor subcategory to display the 

Catalogs tab:

 

 

3.  In the Folder field, enter the path to the folder in which you will store your resolved parts along 

with their configurations. 

This avoids recalculating the part resolution whenever you wish to use a part in a 
configuration.

You can also click the icon to the right to open the Folder Chooser dialog box which lets you 
browse your folders to the desired location.
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4.  Use the "Create new reference for each instantiation" option to create a component reference 

from each instantiated reference part (just like the New from... command). In other words, 

each component instantiation will result in the generation of a .CATPart document saved in the 

Storage Folder you specified.

 
5.  The "Allow family component dynamic resolution during instantiation" option lets you 

dynamically resolve components when instantiating them.

6.  The "Instantiate only resolved family components" option lets you instantiate only resolved and 

stored components. Otherwise, an error message appears to warn you that the component 

cannot be resolved.

 
7.  In the Performance area, checking the "Minimize referenced document access" option improves 

performance since if the preview of a catalog component is not stored in the catalog, this 

preview will not be displayed (either in the Catalog Browser or in the Preview tab).

Checking this option also means that pointed catalogs will not be loaded and that the links to 

these catalogs will not be checked. As a consequence, you will not be aware of broken links, if 

any.

However, note that you can still display the preview of a pointed element by double-clicking it 

in the list.

8.  Click OK to validate.
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Customizing For Photo Studio
This section describes the different types of setting customization you can perform. All tasks described 
here deal with permanent setting customization. 

These tasks are:

    

Display
General
Output
Satellites
Stickers
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Display

This task explains how to customize Rendering display settings.

1.  Select the Tools->Options... command then in the Infrastructure category, click the Photo 

Studio sub-category.  

The Display tab appears:

 

 Setting Display for Active Lights

This area lets you control the display of active lights, whether they be standard or surfacic 
light sources:

●     check the "Wireframe display" option to display the representation of the light source in 
wireframe mode. This is the default mode:
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   Spot light source:
   wireframe display

 
●     check the "Shaded display" option to display the representation of the light source in 

shading mode as shown below:

 

   Spot light source:
    shaded display

 You can use the manipulators to interactively position the light source as you would do for 
the default wireframe representation.
This display helps you visualize more easily which part of the object will be illuminated as 
shown below:
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 Note that the color of the shaded representation corresponds to the color defined for the light 
source (via the Lighting tab in the Properties dialog box). In the above example, the light 
intensity has been assigned a green color.

Setting Display for Inactive Lights

This area lets you control the display of inactive lights:

●     check the "No display for inactive lights" option to turn off inactive light display

●     check the "Full display for inactive lights" option to turn on inactive light display.

Setting Environment Display 

This area lets you to set the type of environment display:

●     check the "No display for inactive environments" option to turn off inactive environment 
display

●     check the "Simplified display for inactive environments" option to display inactive 
environments in a simplified way

●     check the "Full display for inactive environments" option to turn on inactive environment 
display.

 Note that dynamic reflections are no longer supported.
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2.  Click OK to validate your settings.
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General

This task explains how to customize general settings for light sources.

1.  Select the Tools->Options... command then in the Infrastructure category, click the 

Photo Studio sub-category.  

2.  Click the General tab:

 

 New Light Position

This area lets you define how the new light sources you will create will be positioned. 
You can choose between three modes:

●     Default mode
The light source will be positioned in the upper part of the geometry area, oriented 
down and centered:

1428Page Infrastructure Version 5 Release 13



 

Spot light source - "Default" mode

●     As Viewpoint
The light source will be positioned according to the user's viewpoint:

 Spot light source - "As viewpoint" mode
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●     Gravitational

The light source will be positioned along the X, Y or Z axis of the model. The axis to 
be used is defined by checking the corresponding radio button next to 
"Gravitational":

 

 Spot light source - "Gravitational" mode along Y axis

 
3.  Click OK to validate your settings.
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Output 

This task explains how to customize Rendering output settings.

1.  Select the Tools->Options... command then in the Infrastructure category, click the 

Photo Studio subcategory.

2.  Click the Output tab:

 

3.  In the Image Size area, specify whether the image size is defined "From active viewpoint" or 

"Fixed". If you selected the "Fixed" option, you must then enter the image width and height in 

pixels.

4.  In the Output area, indicate the output type, i.e. On screen or On disk. If you select the "On 

disk" option, you must then specify the new path and name of the image either by entering 

them directly in the field or by clicking the  icon to browse your folders to the desired 

location.
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5.  In the Save area, check the "Increment name if file already exists". In case the file name you 

specify already exists, this option adds the suffix "_ number" to the name. The number will be 

automatically incremented as necessary, e.g.  "CatiaRender_1.tif", "CatiaRender_2.tif", and 

so on.

 6.  Click OK to validate your settings.
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Satellites
  

The satellites tab lets you define the name of the remote computers ("satellites") used in network 
to compute a rendered image.
Distributed rendering enables to decrease rendering time since several processors are used to 
generate the image.

This tab is available only when using Photo Studio Optimizer.

 For detailed information on how to use this tab, refer to "Using Distributed Rendering" in the 
Version 5 Photo Studio Optimizer User's Guide.
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Stickers 
  

This task explains how to customize the sticker default image.

1.  Select the Tools->Options... command then in the Infrastructure category, click the Photo 

Studio subcategory.

 
2.  Click the Sticker tab:

 

 
3.  The Default Image area lets you replace the default sticker image with your own image. 

Simply enter the path to the user-defined image or use the  icon to open the File Selection 

dialog box which lets you browse your folders to the desired location.

 
4.  Click OK to validate.
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Customizing For Real Time Rendering 2 

This section describes how to customize different settings. All tasks described here deal with permanent 
setting customization. These tasks are:

Display
General
Stickers
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Display

This task explains how to customize the rendering display.

1.  Select the Tools->Options... command then in the Infrastructure category, click the Real 

Time Rendering sub-category.  

The Display tab appears:
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 Setting Display for Active Lights

This area lets you control the display of active lights:

●     check the "Wireframe display" option to display light sources in wireframe mode in the 
geometry area. This is the default mode:

 

    Spot light source:
   wireframe display

 
●     check the "Shaded display" option to display spot and punctual light sources in shading 

mode in the geometry area:

 

   Spot light source:
    shaded display 

 You can use the manipulators to interactively position the light source as you would do for 
the default wireframe representation.
This display helps you visualize more easily which part of the object will be illuminated as 
shown below:
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 Note that the color of the shaded representation corresponds to the color defined for the light 
source (via the Lighting tab in the Properties dialog box). In the above example, the light 
intensity has been assigned a green color.

Setting Display for Inactive Lights

This area lets you control the display of inactive lights:

●     check the "No display for inactive lights" option to turn off inactive light display

●     check the "Full display for inactive lights" option to turn on inactive light display.

Setting Environment Display 

This area lets you to set the type of environment display:

●     check the "No display for inactive environments" option to turn off inactive environment 
display

●     check the "Simplified display for inactive environments" option to display inactive 
environments in a simplified way

●     check the "Full display for inactive environments" option to turn on inactive environment 
display.
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Setting Environment Reflections

This area lets you define reflection parameters:

●     check the "Enable" option to enable active environment reflections on reflective objects.

However, bear in mind that this option does NOT deactivate the active environment 
reflections. Whenever you wish to restore the default reflections, you can either 
deactivate the environment by right-clicking it in the specification tree then 
unchecking the "Environment Active" option, or simply delete it.

Checking this option activates the fields displayed below:

●     specify the reflection Quality: Low, Medium or High

●     check the "Enable reflections when viewpoint is changed" option to update 
environment reflections on reflecting objects when the viewpoint is modified beyond a 
predefined threshold. Otherwise, the reflection update only occurs when you are working 
with a new or modified environment (i.e. new wall textures or colors)

●     you can use the "Quality while moving" option to indicate the texture size used when 
the viewpoint is moved

●     the "Update threshold" field lets you specify the texture update threshold in degrees 
when the viewpoint is rotated

●     the "Computation passes" field lets you indicate the number of texture passes.

 
 

2.  Click OK to validate your settings.
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General

This task explains how to customize general settings for light sources.

1.  Select the Tools->Options... command then in the Infrastructure category, click the 

Real Time Rendering sub-category.  

 2.  Click the General tab:

 

New Light Position

This area lets you define how the new light sources you will create will be positioned. 
You can choose between three modes:

●     Default mode
The light source will be positioned in the upper part of the geometry area, oriented 
down and centered:
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Spot light source - "Default" mode

●     As Viewpoint
The light source will be positioned according to the user's viewpoint:

 

Spot light source - "As viewpoint" mode
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●     Gravitational

The light source will be positioned along the X, Y or Z axis of the model. The axis to 
be used is defined by checking the corresponding radio button next to 
"Gravitational":

 

Spot light source - "Gravitational" mode along Y axis

 
3.  Click OK to validate and close the dialog box.
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Stickers

This task explains how to customize the sticker default image.

1.  Select the Tools->Options... command then in the Infrastructure category, click the Real 

Time Rendering subcategory.

 2.  Click the Sticker tab:

 

 
3.  The Default Image area lets you replace the default sticker image with your own image. 

Simply enter the path to the user-defined image or use the  icon to open the File 

Selection dialog box which lets you browse your folders to the desired location.

 
4.  Click OK to validate.

 

 

1443Page Infrastructure Version 5 Release 13



Customizing

Tree and Geometry View
General Settings

Constraint Appearance
CATPart Document

Tolerancing
Display

Manipulators
Annotation

View/Annotation Plane

 

 

 

1444Page Infrastructure Version 5 Release 13



Customizing the Tree and Geometry Views
This page deals with the these categories of options:

●     Display in Specification Tree

●     Display in Geometry Area

●     Checking Operation When Renaming

Display in Specification Tree

 

There are six types of elements you can display or not in the Specification tree. If you want them to be 
displayed, just check them.

 

External References

Copies with links of geometry from other documents.

 By default, this option is checked.

 

Constraints

Dimensional and geometrical constraints created in the CATPart document.

 By default, this option is unchecked.

 

Parameters 

Parameters created using the Knowledge Advisor capability. If you wish to know what parameters and 
relations are, refer to the CATIA Knowledge Advisor Users Guide Version 5.

 By default, this option is unchecked.

 

Relations

Relations (formulas) created using the Knowledge Advisor capability. If you wish to know what relations 
are, refer to the CATIA Knowledge Advisor Users Guide Version 5.

 By default, this option is unchecked.
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Bodies under operations 

Operations attaching bodies in different ways (Add, Assemble, Remove, Intersect, Union Trim). This 
option is available only with Part Design application. For more, refer to "Associating Bodies" in the 
CATIA Part Design Users Guide Version 5.

 By default, this option is checked.

 

Sketches 

If the Sketches option is checked, the sketches are displayed in the specification tree during creation. 
If unchecked, sketches are present in the tree but you need to use the expand capability.

 By default, this option is checked.

 

Display in Geometry Area

There are five options available for customizing the geometry display. 

 

Only the current operated solid 

This option is used when editing features belonging to attached bodies only. It lets you display only 
the features of the current body and greatly improves the application performances whenever you edit 
these features. Please note that this option is available in Part Design application as well as for 
geometrical and ordered geometrical sets. 

Note: Instead of accessing this option via Tools -> Options, you can click this icon  available in 
the Tools toolbar.

 By default, this option is unchecked.

 

Only Current Body 

This option displays the geometry of the current part body or open body only.

 By default, this option is unchecked.

 

Future geometry
This option displays the geometry located after the current feature only.

 By default, this option is unchecked.
 

Parameters of features and constraints
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This option permanently displays parameters attached to Part Design features and Sketcher 
constraints.

 By default, this option is unchecked.  

Axis system display size (in mm)

This option lets you define the size of axis systems in mm.

 By default, this option is unchecked.

 

Checking Operation When Renaming

 

Three options let you define rules for renaming geometric elements (using the Properties command).

 

No name check 

Use this option if you wish to allow all types of rename operations whatever the locations of the 
elements in the specification tree.

 By default, this option is checked.

 

Under the same tree node

Check this option to prevent two elements belonging to a common node from having the same name. If 
you are giving an identical name, a warning message is issued informing you that the element you are 
renaming will be suffixed as 'Renamed'. The check operation in case-insensitive.

 By default, this option is unchecked.
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In the main object
 

Check this option to prevent two elements belonging to the same main node from having the same 
name. The check operation in case-insensitive.

 By default, this option is unchecked.
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Customizing General Settings  
This page deals with these categories of options:

●     External References

●     Update

●     Delete Operation

●     Replace

●     Select

External References

 

Keep link with selected object 

Checking this option lets you maintain the links between external references, copied elements for 
example, and their origins when you are editing these elements. This option is used as you are editing 
parts included in assemblies. For more about designing parts in assembly context, refer to the CATIA 
Assembly Design Users Guide Version 5. If later you need to cut the link between external references and 
their origin, you just need to use the Isolate command.

 By default, this option is unchecked.

Create external references as shown elements
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Checking this option lets you define the visualization mode for external references or imported elements 
only.

 By default, this option is unchecked.

Confirm when creating a link with selected object

Checking this option enables you to be informed that when you are pasting a part.

 By default, this option is unchecked.

Use root context in assembly

Check this option to ensure that the root of the assembly is the context used. Uncheck this option if you 
prefer to use the minimal context. For more about changing contexts, please refer to the task describing 
the Define Contextual Links command in the Product Structure User's Guide.

 By default, this option is checked.

Only use published elements for external selection keeping link

Check this option  if you want to make only published elements valid for selection.

 By default, this option is unchecked.

Publish a face, edge, vertex or extremity

Check this option if you wish to be able to directly select faces, edges, vertices, axes extremities when 
using the Publication command.

 By default, this option is checked.

Update
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Automatic/Manual

Check Automatic if you want parts to be updated automatically. Conversely, check Manual if you wish to 
control your update operations. 

 By default, the Automatic option is checked.

Stop Update on first error

Check this option to stop the update process as soon as the application finds an error when building the 
geometry. 

 By default, this option is checked.

Synchronize all external references for update

Check this option to make sure that the application updates elements copied from other parts. 
Synchronizing assumes that all modifications to the other parts affect external references included in your 
part. If this option is deactivated, the application will update your part only. 

 By default, this option is checked.

Activate local visualization 

Check this option to visualize features as they are being rebuilt during the update process.

 By default, this option is unchecked.

Delete Operation

Display the Delete dialog box 
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Check this option if you wish to access filters for deletion (see "Deleting Features" in the Part Design Users 
Guide Version 5).

 By default, this option is checked.

Delete exclusive parents

Check this option  if you wish to delete the parents of the features you are deleting. The parents will be 
deleted only if they are exclusive, which means that if they are shared by other features, they will not be 
deleted. When this setting is active, the option is checked in the Delete dialog box, but by default, the 
option is not checked. 

Even if the option is checked in the Delete dialog box, you can uncheck it if you wish to. If the Display 
the Delete dialog box (see above) setting is not checked, this setting has no effect. For more 
information, refer to Deleting Features in the Part Design Users Guide Version 5.

 By default, this option is unchecked.

Replace

 

Do replace only for elements situated after the In Work Object

Checking this option makes the Replace... operation possible only for features located below the feature 
in Work Object and in the same branch.

 By default, this option is unchecked.

Select

 

Enable selection of not drawn geometry
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This option applies to the elements you select when you are creating features that will be located in an 
ordered geometrical set. If unchecked, selecting elements whose geometry is not visible any more, is not 
possible.

Here, for instance, selecting Fill.1 is not possible for defining Split.2 because Fill.1 geometry was absorbed 
by Split.1. A black sign indicates that this selection is not possible. Additionally, the application displays a 
tooltip explaining why it is not possible.

 By default, this option is unchecked.

Enable selection of posterior geometry

This option applies to the elements you select when you are creating features that will be located in an 
ordered geometrical set. If unchecked, the selection of elements located after the element being created is 
not possible.

Here, for instance, selecting Offset.1 is not possible for defining Split.2, as shown by the black sign. 
Additionally, the application displays a tooltip explaining why this selection is not possible.
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 By default, this option is unchecked.
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Customizing a CATPart document 

This page deals with two options dealing with the creation of a part.

New Part 

Create an Axis System when creating a new part

Check this option if you wish to create a three-axis system which origin point is defined by the intersection 
of the three default planes that is plane xy, plane yz, and plane zx. When the CATPart is open, the axis 
system is displayed both in the geometry and in the specification tree. For more information about the 
Axis System capability, refer to CATIA - Part Design User's Guide. 

 By default, this option is unchecked.

Note: data contained in the CGR format are saved within the CATPart format when you are saving your 
part in order to improve performance when working in Assembly Design workbench. 

Create a Geometrical Set when creating a new part
Check this option if you wish to create a geometrical set as soon as you create a new part. For more 
information about the Axis System capability, refer to Generative Shape Design User's Guide.

 By default, this option is unchecked.
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Customizing for 3D Annotations Infrastructure 
This section describes the various settings you can customize for 3D Annotations Infrastructure via the 
Tools -> Options command. 

These settings will then be used when creating annotations via the Annotations toolbar available in some 
workbenches such as Part Design or Weld Design, for example.

 

Tolerancing
Display
Manipulators
Annotation
View/Annotation Plane 
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Tolerancing  

This task will show you how to customize 3D Annotations Infrastructure tolerancing settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Infrastructure category.

3.  Click the 3D Annotations Infrastructure subcategory.

4.  Click the Tolerancing tab.

The Tolerancing tab appears, displaying two categories of options:

Tolerancing Standard  

 Default standard at creation

Defines the default standard at creation. 

Provides five conventional standards:

●     ASME: American Society for Mechanical Engineers

●     ASME 3D: American Society for Mechanical Engineers

●     ANSI: American National Standards Institute

●     ISO: International Organization for Standardization

●     JIS: Japanese Industrial Standard

Leader associativity to the geometry  
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 Free

 Specifies that leader annotations are freely positioned relative to their 
geometrical elements.

 Perpendicular

 Specifies that leader annotations are positioned perpendicular to their geometrical 
elements.
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Display  

This task will show you how to customize 3D Annotations Infrastructure display settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Infrastructure category.

3.  Click the 3D Annotations Infrastructure subcategory.

4.  Click the Display tab.

The Display tab appears, displaying two categories of options:

Grid  

Display

Defines whether the grid is displayed.

Snap to point

Defines whether annotations are snapped to the grid's point. 

Allow Distortions

Defines whether grid spacing and graduations are the same horizontally and 
vertically. 

H Primary spacing

Defines the grid's horizontal spacing. 
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H Graduations

Defines the grid's horizontal graduations.

V Primary spacing

Defines the grid's vertical spacing (available only if Allow Distortions is checked).

V Graduations

Defines the grid's vertical graduations (available only if Allow Distortions is 
checked).

 

Annotations in Specification Tree  

 Under Geometric Feature nodes

 Defines that 3D annotations should be displayed under the geometric feature 
nodes in the specification tree. This lets you view 3D annotations under the Part 
Design or GSD feature nodes to which they are applied.

 Under View/Annotation Plane nodes

 Defines that 3D annotations should be displayed under the view/annotation plane 
nodes in the specification tree. This lets you view 3D annotations under the view 
node to which they are linked.

 Under Annotations Set node

 Defines that 3D annotations should be displayed under the annotation set node in 
the specification tree. 
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Manipulators  

This task will show you how to customize 3D Annotations Infrastructure manipulators settings.

1.  Select  Tools -> Options... 

The Options dialog box appears.

2.  Click the Infrastructure category.

3.  Click the 3D Annotations Infrastructure subcategory.

4.  Click the Manipulators tab.

The Manipulators tab appears, displaying one option:

Manipulators  

 Reference size

 Defines the annotation manipulator's size.

 Zoomable

 Defines whether the annotation manipulator is zoomable or not.
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Annotation   

This task will show you how to customize 3D Annotations Infrastructure annotation settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Infrastructure category.

3.  Click the 3D Annotations Infrastructure subcategory.

4.  Click the Annotation tab.

The Annotation tab appears, displaying one category of options:

Annotation Creation  

 Annotation following the mouse (Ctrl toggles)

 Defines whether the annotation is positioned according to the cursor, following it 
dynamically during the creation process or not.
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View/Annotation Plane 

This task will show you how to customize 3D Annotations Infrastructure view/annotation plane 
settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Infrastructure category.

3.  Click the 3D Annotations Infrastructure subcategory.

4.  Click the View/Annotation Plane tab.

The View/Annotation Plane tab appears, displaying two categories of options:

View/Annotation Plane Associativity   

 Create views associative to geometry

 Creates views associative to the geometry, so that views and their annotations 
are automatically updated when the geometry is modified. 

View/Annotation Plane Display  

 Current view axis display
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 Defines whether the active annotation plane axis system is displayed. 

 Zoomable

 Defines whether the annotation plane axis is zoomable.

 Visualization of the profile in the current view

 Defines whether the view/annotation plane profile on the part/product is 
displayed or not. 
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DELMIA Infrastructure
Refer to the 3D Simulation for Manufacturing User's Guide
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Mechanical Design
Assembly Design

Sketcher
Mold Tooling Design

Structure Design
Drafting

Aerospace Sheetmetal Design
Sheetmetal Design

Functional Tolerancing and Annotation
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Customizing for Assembly Design
This section describes the different types of setting customization you can perform in Assembly Design 
using the Tools -> Options command. 

All tasks described here deal with permanent setting customization.

General
Constraints
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General  

This task will show you how to customize Assembly Design constraints settings..

1.  Select  Tools -> Options..., the Options dialog box appears.

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the Assembly Design subcategory.

4.  Click the General tab

The General tab appears, displaying five categories of options:

 

Update  
 

 Update affects Assembly constraints, Assembly features, Weld features, contextual 
design.

●     Automatic

❍     This option update your assembly automatically after each interaction.

●     Manual

❍     This option lets you decide when you need to update your assembly. It is the 
default mode.

 

Update propagation  
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 Update propagation affects Assembly constraints, Assembly features, Weld features.

●     Active level

❍     This option update child components of the active components only.

●     All the levels

❍     This option update all components under the active components.

Compute exact update status at open  
 

This option is only take into account when you work with the Work with the cache 
system option checked, and when you are opening an assembly document or inserting 
an assembly component.

 
●     Automatic

❍     This option load the minimal data needed in assembly components to determine 
the update status of the assembly: updated or not.

●     Manual

❍     This option displays the Unknown Status Update icon when the minimal data 
needed are not loaded to determine the update status of the assembly.

 

Access to geometry  
 

This option is only take into account when you work with the Work with the cache 
system option checked.

 
●     Automatic switch to Design mode

❍     This option ensures that the application will automatically launch the Design 
mode when using the following commands: constraints creation, reuse 
pattern and define multi-instantiation.
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Move components involved in a Fix Together  
 

 
●     Always

❍     This option ensures to move all the components involved in a Fix Together 
without warning.

●     Never

❍     This option ensures to move only the selected component involved in a Fix 
Together without warning.

●     Ask each time

❍     This option ensures to display of a warning message that appears when moving 
components.

 The message will appear whenever you will apply the following commands to components 
fixed together:

 
●     compass

●     Snap  

●     Translation or Rotation 

●     Manipulate
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Constraints  

This task will show you how to customize Assembly Design constraints settings..

1.  Select  Tools -> Options..., the Options dialog box appears.

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the Assembly Design subcategory.

4.  Click the Constraints tab

The Constraints tab appears, displaying three categories of options:

 

Paste components  
 

 
●     Without the assembly constraints

❍     You can paste one or several components without the assembly constraints 
applying to them. 

●     With the assembly constraints only after a Copy

❍     You can paste one or several components with the assembly constraints applying 
to them, only after the Copy command.

●     With the assembly constraints only after a Cut

❍     You can paste one or several components with the assembly constraints applying 
to them, only after the Cut command.

●     Always with the assembly constraints
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❍     You can paste one or several components always with the assembly constraints 
applying to them.

 

Constraints creation  
 

 
●     Use any geometry

❍     You can select any geometrical element. 

●     Use published geometry of child components only

❍     You can select any published element belonging to child components.
For more information about publication, refer to Managing a Product 
Publication in the Assembly Design documentation.

●     Use published geometry of any level

❍     You can select any published element

 

Quick Constraint  
 

 
●     The Quick Constraint command is based on a ordered list of constraints to be 

created by the application. The setting available here lets you reorder the list of 
constraints having priority when applying the Quick Constraint command to the 
selected geometrical elements. What you need to do is select the constraint type you 
wish to reorder and click the arrows to the right of the selection to reorder the 
selected constraint.

●     Additionally, you can create verified constraints if the option Creation verified 
constraints first is checked.
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Customizing for Sketcher  
The Sketcher settings will help you sketch your profile with given options. For example, the grid will make it 
easier to sketch a profile requiring parallel lines. 

 

1. Select the Tools -> Options command to display the Options dialog box. The Options dialog box 
appears.

2. Expand the Mechanical Design option, then click Sketcher. The Sketcher tab appears, containing the 
following set of options:

●     Grid

●     Sketch Plane 

●     Geometry 

●     Constraint

●     Colors 

 
Grid 

 

 Display

 Check this option to display the grid in your session. 

 By default, this option is unchecked.
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H; V; Primary spacing; Graduations

To define your grid, enter the values of your choice in the H and V fields. The Primary spacing option lets 
you define the spacing between the major lines of the grid. The Graduations field lets you set the number of 
graduations between the major lines of the grid, which actually consists in defining a secondary grid. 

Note that in the Sketcher workbench you need to set 2D curves in NO Show mode to be able to visualize the 
part edges in the 3D area. 

 Snap to point

 

Check the Snap to point option if your sketch needs to begin or end on the points of the grid. 

 By default, this option is checked.

 Allow Distortions

Check this option to apply different graduations and spacing between H and V.

 By default, this option is unchecked.
 

Sketch Plane 
 

 Shade sketch plane 

 Check this option to view the sketch plane in the Sketcher workbench. Note that you also need to display the 
grid in order to be able to see the shaded plane. 

The sketch plane will be shaded in the Sketcher workbench:

 By default, this option is unchecked.
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Position sketch plane parallel to screen 

Check this option to ensure that the sketch plane will be positioned properly each time you enter the Sketcher 
workbench. 

 By default, this option is checked.

 Visualization of the cursor coordinates 

Check this option to have the cursor coordinates displayed, near the cursor, within the geometry.

 By default, this option is checked.

Geometry 

 

 Create circle and ellipse centers

 
You can decide whether or not you want to create centers when sketching circles or ellipses. By default, this 
option is activated. Just uncheck it if you do not need to create centers when sketching.

 By default, this option is checked.

 Allow direct manipulation

 
Select this option to be able to move geometry using the mouse. When moving geometry, you can move 
either the minimum number of elements, the maximum number of elements, or still the minimum number by 
modifying the shape of elements, if needed. Click the Solving mode... button to configure manipulation. 

 By default, this option is checked.

 Solving mode...
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The dialog box that appears offers the following options as regards the solving mode:

Solving mode for moving elements

Standard mode 
You move as many elements as possible and also respect existing constraints.

 By default, this option is checked.

 

 

 

Minimum move
You move as few elements as possible and also respect existing constraints.
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Relaxation
You move elements by re-distributing them over the sketch, globally speaking. This method solves element 
moving by minimizing energy cost. 

Drag elements end points included

Furthermore, you can choose to drag elements along with their end points by checking this box.

 

Constraint 

 

 Creates the geometrical constraints

Lets you specify whether or not you want to created the geometrical constraints detected by the SmartPick 
tool. 

 By default, this option is checked.

 Creates the dimensional constraints

 Lets you specify whether or not you want to created the dimensional constraints detected by the SmartPick 
tool.

If both these detection options are unchecked, the Create detected constraints option will be inactive by 
default in the Tools toolbar. You will be able to activate it at any time.

 By default, this option is checked.

 SmartPick... (switch button) 
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 As you create more and more elements, SmartPick detects multiple directions and positions, and more and 
more relationships with existing elements. This may lead to confusion due to the rapid highlighting of several 
different detection possibilities as you point the cursor at different elements in rapid succession. 
Consequently, you can decide to filter out undesired detections by clicking the SmartPick... button.

 

 In the SmartPick dialog box that appears, the following options are available.
●     Support lines and circles

●     Alignment

●     Parallelism

●     Perpendicularity 

●     Tangency

●     Horizontal and vertical

 By default, all of these options are checked.

Uncheck the elements you do not wish to detect while sketching. 

Disabling SmartPick completely (i.e. unchecking all options in the SmartPick dialog box) is particularly useful 
when your screen is full of elements: in this case, it may be a good idea to disable SmartPick to concentrate 
only on the geometry.

 
Colors 
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 Two types of colors may be applied to sketched elements. These two types of colors correspond to colors 
illustrating:

●     Graphical properties
Colors that can be modified. These colors can therefore be modified using the Tools->Options dialog 
box.

OR

●     Constraint diagnosis
Colors that represent constraint diagnoses are colors that are imposed to elements whatever the graphical 
properties previously assigned to these elements and in accordance with given diagnoses. As a result, as 
soon as the diagnosis is solved, the element is assigned the color as defined in the Tools->Options 
dialog box.

 Default color of the elements

 From the list, choose the color that you want to use as the default for sketched elements.

 Visualization of diagnosis

 Select this option if you want over-constrained, inconsistent, not-changed or iso-constrained elements to be 
identified using specific colors. Then, click the Colors... button to configure these colors.

 

 In the dialog box that appears, you can configure colors for the following types of elements:

Over-constrained elements
The dimensioning scheme is over-constrained: too many dimensions were applied to the geometry.

Inconsistent elements
At least one dimension value needs to be changed. This is also the case when elements are under-constrained 
and the system proposes defaults that do not lead to a solution.

Not-changed elements
Some geometrical elements are over-defined or not-consistent. As a result, geometry that depend(s) on the 
problematic area will not be recalculated.

Iso-constrained elements
All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved from its geometrical 
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support.

 By default, this option is checked.

 Other color of the elements

 Click the Colors... button to configure the colors of other elements.

 

In the dialog box that appears, you can configure colors for the following types of elements:

Protected elements
Non-modifiable elements.

Construction elements
A construction element is an element that is internal to, and only visualized by, the sketch. This element is 
used as positioning reference. It is not used for creating solid primitives.

SmartPick 
Colors used for SmartPick assistant elements and symbols.

3. Once you have chosen all of your options, click OK to confirm your choices and to exit the Options dialog 
box.
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Customizing for Mold Tooling Design
 

General
Component
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Customizing for Mold Tooling Design
 

This task shows you how to customize the options of components of the Mold Tooling Design application.

1. Select the Tools, Options menu, then Mechanical Design, Mold  Tooling Design in the specification tree. 

 

2.Catalog storage Directory in the General tab is the directory where the root catalogs are stored. This field may not be empty. A 
default directory is proposed. You can add other root catalog storage directories according to your needs. Separate each path by a 
";". 

3.Then, select the Component options. 
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4.The option 'Not cut in section views' is used to determine whether the component will be visualized in crosshatch display when a 
cut is being performed in its drafting. 

By default, all types of screws (cap screws, countersunk screws, locking screws,...) and dowel pins are not cut; therefore the option is 
selected by default for these components

5.Selection filter allows the user to activate or not know-how rules when creating components. When activated, associated filters are 
applied in the Catalog Browser during component creation.

By default, the rules are automatically applied to all components:
For a: 

●     bushing: the value of the inner diameter of the bushing (InD) must correspond to the value of the leader pin 's tip diameter (D) 
if there is one.
The following filter is therefore activated: InD=D

●     core pin: the overall length of the core pin (L) must be greater than or equal to H, the height between the bottom of 
EjectorPlateA and the top of the uncut CorePlate. 
The following filter is therefore activated: L>=H
Also, the height of the core pin's guide hole is set by the Offset_Parting parameter.

●     ejector: the overall length of the ejector (L) must be greater than or equal to H, the height between the bottom of EjectorPlateA 
and the top of the uncut CorePlate
The following filter is therefore activated: L>=H
Also, the height of the ejector's guide hole is set by the Offset_Parting parameter.

●     ejector pin: the overall length of the ejector pin (L) must be greater than or equal to H, the height from the bottom of 
EjectorPlateA to the top of the uncut CorePlate.
The following filter is therefore activated: L>=H
Also, the height of the ejector pin's guide hole is set by the Offset_Parting parameter.
There is a check on the height value of the hole containing the ejector pin's shouldered part to determine whether it is consistent 
with the course of the ejection plates; an error message is displayed when there is a risk of collision.

●     ejector sleeve: the overall length of the ejector sleeve (L) must be greater than or equal to H, the height from the bottom of 
EjectorPlateA to the top of the uncut CorePlate
The following filter is therefore activated: L>=H
Also, the height of the ejector sleeve's guide hole is set by the Offset_Parting parameter.
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●     flat ejector: the overall length of the flat ejector (L) must be greater than or equal toH, the height between the bottom of 
EjectorPlateA and the top of  the uncut CorePlate.
The following filter is therefore activated: L>=H
Also, the height of the flat ejector's guide hole is set by the Offset_Parting parameter.
There is a check on the height value of the hole containing the flat ejector's shouldered part to determine whether it is consistent 
with the course of the ejection plates; an error message is displayed when there is a risk of collision

●     leader pin: in the case of a standard mold base, use of the DLP diameter parameter (a mold base parameter which is displayed 
in the specification tree) is recommended by the supplier.
The following filter is therefore activated: D=DLP;

●     locating ring: in the case of a standard mold base, use of the DLR diameter (a mold base parameter which is displayed in the 
specification tree) is recommended by the supplier.
The following filter is therefore activated: ShD=DLR

●     sleeve: the inner diameter of the sleeve (InD) must correspond to the diameter of the leader pin (D) if there is one. The following 
filter is therefore activated: InD>=D
The length of the sleeve (L) must be greater than the height of the riser bars (H). The following filter is therefore activated: L>H.
One or two filters can be activated, depending on the current situation.

●     stop pin: in the case of a standard mold base, use of the DSP diameter (a mold base parameter which is displayed in the 
specification tree) is recommended by the supplier. 
The following filter is therefore activated: ShD=DSP

●     support pillar: the length of a support pillar (L) must equal the height of the riser bars, i.e. the distance between SettingPlate 
and CoreSupportPlate or CorePlate.
The following filter is therefore activated: L=H

 
6.Several Instances per Reference is active by default for all components (except for core pins, ejectors, ejector pins, flat ejectors, 

ejector sleeves , spring, sliders, and inserts). This is an option that allows you to create several instances of one reference 
component. If you deactivate this option, only one instance will be created per reference component.

 7.Default plate: use this option to define a default plate for a given component. By default it is set to None. 

Select the component, then select a plate from the Plate name list at the bottom.
8.Plate Position: use this option to define a default positioning on a plate for a given component. 

By default, this option is set to Bottom. Click the label to change it to Top.

First select the plate on which the component is to be positioned. The Top and Bottom option becomes available. Check the proper 
one.

The next time you will create a component of this type, it will be positioned on the chosen plate, on the selected face, without 
selecting it.
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Customizing for Drafting
These sections explain how to customize settings for Drafting.

 

Customizing for Interactive Drafting

Customizing for Generative Drafting
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General Settings 

This task shows you how to set general settings to be used in the Interactive Drafting workbench.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the General tab. It contains several categories of options:

●     Ruler

●     Grid

●     Rotation

●     Colors

●     Tree

●     View Axis

 

 
Ruler  

 

 

Show ruler

Check this option to display the ruler in your sheet. It means you visualize the cursor 
coordinates as you are drawing. 

Grid  
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Display

Check this option to display the grid in your session. You will note that this capability is 
also available via the Drafting Options toolbar.

Snap to point

You need to check this option if the geometry needs to begin or end on the points of the 
grid.

Allow Distortions

Check this option to apply different graduations and spacing between H and V.

H; V; Primary spacing; Graduations

To define your grid, enter the values of your choice in the H and V  fields. The Primary 
spacing option lets you define the spacing between the major lines of the grid. The 
Graduations field lets you set the number of graduations between the major lines of 
the grid, which actually consists in defining a secondary grid.

Rotation  

 

 

Rotation Snap Angle 

Specify the angle that should be used when rotating text elements (text, frame, or 
leader) using snapping. In other words, this option defines the snapping value used 
when rotating an element using the Select or Rotate commands.

Automatic Snapping 

This option automatically uses snapping when rotating an element.

 
Colors  

You can customize a number of options for modifying the drawing background color. You can do 
this at any time.
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Sheet background

Choose the color that will be used for the sheet background.

Detail background

Choose the color that will be used for the background of 2D components.

Graduated color

If you want the sheet background and/or the detail (i.e. 2D component) background to 
be graduated, check the associated box.

For example, if you customize the color type as shown below:

 

You will get this result:
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Tree 

You can choose whether or not parameters and relations should be displayed in the specification 
tree.

 

 

Display parameters

Check this option to display in the specification tree the formula parameters used in the 
drawing.

Display relations

Check this option to display in the specification tree the relation parameters used in the 
drawing.

View axis 

 

Display in the current view

Check this box if you want the view axis to be displayed when you activate a view. 

Zoomable

Check this box if you want to be able to zoom view axes (as you can do with 
geometry).

Reference size 

Enter the size that you want to use as a reference to display view axes size.

4. Choose the options you want and then click OK to validate your settings.
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View and Sheet Layout Settings 

You can customize given options when creating views or when adding sheets.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the Layout tab. It contains the following sets of options:

●     View Creation

●     New Sheet 

●     Background View

●     Section / Projection Callout

 
View creation 

 

View name

Check this box if you want the view name to be created automatically when creating 
views.

Scaling factor

Check this box if you want the scaling factor to be created automatically when creating 
views.

View frame

Check this box if you want the view frame to be created automatically when creating 
views.

Propagation of broken and breakout specifications
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Check this box if you want broken and breakout specifications to be reproduced.

Auxiliary and section views orientation according to profile

You can decide if auxiliary and section views will be oriented according to the profile. In 
this case, the X axis will be parallel to the profile. 

View axis system based on 3D axis system

Check this box if you want the axis system of the generated view to be based on the 
axis system of the 3D part. This enables you to create views with the same orientation 
if, when creating two views in the same projection plane by selecting two different 
faces, the axis systems which are specific to these faces are different.

For example, take the following part:

 

 With the View axis system based on 3D axis system option not checked, the view 
orientation will be different depending on the element selected in the 3D when creating 
the view:

 

 View orientation when a face 
of the rectangular pad is 
selected

View orientation 
when a face of the 
elliptic pad is selected

View orientation when the 
absolute XY plane is selected
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With the View axis system based on 3D axis system option checked, the view 
orientation will always be the same, no matter what element is selected in the 3D when 
creating the view:

 View orientation when either a face of the 
rectangular pad, a face of the elliptic pad, 
or the absolute XY plane is selected

 

New sheet 
 

 Copy background view

Check this box if you want a background view to be copied into newly created sheets.

Source sheet

Specify whether you want the source sheet for the background view to be the first 
sheet of the current drawing, or a sheet from another drawing by selecting the 
appropriate option.

Background view 
 

  

 Directory for frame and title block

You can specify the path to the directory containing the frame and title block macros.

Section/Projection Callout 
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Size not dependent on view scale

Check this option if you do not want the size of projection and section callout elements 
to be dependent on the view scale. This option will apply to newly created callouts, i.e. 
selecting this option will not have any impact on existing callouts.

Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. 
versions up to V5 R10).

4. Choose the options you want and then click OK to validate your settings.
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View Generation Settings 

 

You can customize given options for controlling geometry and dress-up behavior when generating 
views, as well as view generation. 

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the View tab. It contains several categories of options:

●     Geometry generation / Dress-up

●     View generation

Geometry generation / Dress-up 

 

 

This category of options lets you specify what kind of geometry and dress-up elements you want to 
generate when generating views.

Generate axis

Check this option to generate axis lines.

Generate threads

Check this option to generate threads.

Generate center lines
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Check this option to generate center lines.

Generate hidden lines

Check this option to generate hidden lines.

Generate fillets

Check this option to generate fillets. Additionally, click the Configure button to configure 
fillets generation. You can choose to generate either of the following types of fillets:

 
Boundaries
Thin lines, representing the mathematical limits of the fillets. 

Boundaries will not be projected if they correspond to two faces 
which are continuous in curvature. They will be projected only 
if they correspond to a smooth edge which is situated between 
two faces whose curvature radii vary. 

This mode will be used automatically to represent a connection 
between two faces which are not joined by a fillet, no matter 
what option you select.

 

Symbolic 
Original edges, projected in a direction that is normal to each 
corresponding surface.

 

Approximated Original Edges
Original edges, at the intersection of the two surfaces joined by 
the fillet.

 

Projected Original Edges 
Original edges, projected on fillet surfaces in the direction of 
the view projection. 
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This projection mode is equivalent to the CATIA V4 fillet 
projection mode.

Dimensions on Symbolic, Approximated Original Edges and Projected Original Edges are not 
associative.

  

 

Inherit 3D colors

Check this option if you want the colors of a part to be automatically generated onto the 
views.

In the case of white parts, the views generated with this option selected will be white, and 
will therefore not be properly displayed.

 
 Project 3D Wireframe

Check this option to visualize both the wireframe and the geometry on generated views. 
Additionally, click the Configure button to configure the 3D wireframe projection 
mode. You can choose whether projected 3D wireframe can be hidden (in some cases, 
depending on the projection angle, part or all of 3D wireframe will possibly be hidden) or 
is always visible (3D wireframe will be visible in all cases, independently of the projection 
angle).

 

Project 3D Points

Check this option to project points from 3D (no construction element). Additionally, click 
the Configure button to select the type of points visualized in the projected drawing. In 
the 3D Point Projection dialog box, you can choose between keeping the symbols that are 
used in the 3D or using a new symbol.
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Apply 3D specification

Check this option to specify that, in an assembly, given parts will or will not be sectioned 
into section views or breakout views (Generative Drafting workbench). For this, you select 
one view, then the Edit -> Properties command from the menu bar from the Assembly 
Design workbench (Mechanical tab, Drafting properties options) and either activate or 
de-activate the Not cut in section views option.

 
View Linetype

Click the Configure button to configure linetypes for specific types of views: section view, 
detail view, broken view, breakout view, skin section view (in the case of wireframes and 
surfaces). In the Linetype and Thickness dialog box, select the line type and the thickness 
you want for each type of view, from the associated fields. Click Close when you are 
done.
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If you choose the zigzag linetype (linetype #8), note that this 
linetype is just a graphical dress-up of the view. This means 
that if one line is relimited on the breakout line, then it will be 
relimited on the theoretical line as shown here, and not on the 
visualized zigzag line.

 View generation 
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View generation mode

From this list, select how you want to generate views. 

Exact view

Generates exact views from the Design mode, i.e. views for which the geometry is 
available. The exact generation mode will be the best option in most cases:

●     This is the fastest generation mode. 

●     All types of views can be generated using this option.

●     All functionalities (dress-up, dimensions, annotations, etc.) are available.

However, there are a few cases in which choosing the exact generation mode will not be 
appropriate:

●     In the case of sophisticated products or assemblies involving large amounts of data, 
generating exact views may consume too much memory.

●     Polyhedral elements (such as dittos, surfaces, etc.) from V4 .model documents are not 
supported. 

CGR 

Generates views using the CGR format (CATIA Graphical Representation). CGR 
corresponds to a data format containing a graphical representation of the geometry only, 
which is available with the Visualization mode (as opposed to the exact geometry, which 
is available with the Design mode). With CGR, only the external appearance of the 
component is used and displayed; the geometry is not available. The corresponding .cgr 
file, if it exists, is inserted from the cache system. 

CGR views are not as high in quality as exact views, but they consume much less memory 
during the generation. This may be useful when dealing with sophisticated products or 
assemblies involving large amounts of data. However, this generation mode is rather 
slow. 

For more information about the advantages and restrictions associated with the CGR 
generation mode, see Advantages and restrictions common to CGR and Approximate 
modes below.
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 Approximate 

You can now generate views in Approximate mode. Although Approximate views are not 
as high in precision and quality as exact views, this generation mode dramatically reduces 
memory consumption. Performances may also be improved, depending on how you fine-
tune precision. Therefore, the Approximate mode is particularly well-adapted to 
sophisticated products or assemblies involving large amounts of data. 

The Approximate mode offers about the same advantages and restrictions than the CGR 
generation mode (see above). However, there are some differences: 

●     Approximate consumes even less memory than CGR. 

●     Approximate is faster than CGR, but performances largely depend on fine-tuning. 

●     Approximate provides more approximate results than CGR, but these results largely 
depend on how you fine-tune precision. 

You can fine-tune the generation options according to your needs. Click the Configure 
button. In the dialog box, move the cursor to set the precision (i.e. the level of detail - 
LOD) with respect to the performances (i.e. generation time - Time). The level of detail 
corresponds to the precision with which the application determines which edges are 
hidden and which are not. As a result, decreasing this precision may lead to smaller 
geometry being visible whenever it should not be, and vice-versa.
The higher the precision, the lower the performances. In any case, memory consumption 
will not be impacted. Click Close when you are done. 

For more information about the advantages and restrictions associated with the 
Approximate generation mode, see Advantages and restrictions common to CGR and 
Approximate modes just below. 

Advantages and restrictions common to CGR and Approximate 

Using CGR or Approximate to generate views offers the following advantages: 

●     Optimize memory consumption when generating and handling projection views for 
large products or assemblies. 

●     Generate views from third-party data (such as MultiCAD), as well as from polyhedral 
elements (such as dittos, surfaces, etc.) in V4 .model documents. 

However, the CGR or Approximate generation mode involves a number of restrictions: 

●     You cannot generate section views, section cuts, detail views, detail view profile, 
breakout views, unfolded views and views from 3D. 

●     You cannot project 3D elements such as wireframe, points, etc. on CGR or 
Approximate views. 

●     CGR or Approximate views cannot contain dress-up elements (axis, center lines, 
threads). 

●     Auxiliary view profiles, annotations, dimensions, etc. are not associative on CGR or 
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Approximate views.  

●     CGR or Approximate views being only a graphical representation of the geometry, only 
line segments are generated in such views. As dimensions are not associative, the 
only elements that can be dimensioned are these line segments. 
As a result, it is impossible to create certain types of radius or diameter dimensions in 
such views; to put it simply, you cannot create radius and diameter dimensions on 
elements other than these line segments. 

As a consequence of these restrictions, selecting either the CGR or the Approximate 
option disables a number of other options on the View and on the Generation tab. 

 Raster

Generates views as images. This enables you to quickly generate overall views for large 
products or assemblies, regardless of drawing quality. Such views are associative to the 
3D geometry and can be updated when the part or product changes. 

Raster views offer a number of restrictions: 

●     You cannot generate the following types of views using this option: view from 3D, 
section views, section cuts, detail views, breakout views, unfolded views. 

●     Raster views cannot contain dress-up elements (axis, center lines, threads).

●     Creating dimensions is impossible. 

●     Generally speaking, all commands requiring the selection of geometry are not 
available. 

●     Raster views cannot be edited (you can work around this by isolating the view: double-
clicking the image will then launch an image editor). 

As a consequence of these restrictions, selecting this option disables a number of other 
options on the View and on the Generation tab. 

To optimize disk space and memory consumption, it is recommended that you do not 
select the Inherit 3D colors option when generating views as images.
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 Click the Configure button to configure the raster mode options. 

From the Mode list, select the mode that you want to use: Dynamic Hidden Line Removal, 
Shading, Shading with edges. These modes are equivalent to the 3D rendering styles. For 
more information, refer to Using Rendering Styles in the Infrastructure User's Guide. 

Now, set the level of detail (i.e. the definition, in dpi) that will respectively be used to 
visualize and to print the drawing. You can choose between three pre-defined modes (Low 
quality, Normal quality and High quality) and a custom mode (Customize). If you choose 
to customize the definition yourself, set the dpi for visualization and for print in the 
appropriate fields. 

Click Close when you are done. 

 

The level of detail applies to the scale of the view. In some cases (when the view would 
print with a considerable height or width), there may be too many pixels to generate the 
view. In this case, the view will be displayed as a red cross-mark. If this happens, try to 
reduce the scale of the view and/or the level of detail. 

If you want the colors of a part to be used when generating Raster views using the 
Shading or Shading with edges mode, remember to select the Inherit 3D Colors option. 
Otherwise, the view will be generated using shades of grey. 

To further improve performance when generating Raster or CGR views, we recommend you work in 
Visualization mode: to do this, in the Options dialog box, go to Infrastructure -> Product 
Structure -> Cache Management tab and select Work with the cache system. (For more 
information, see Customizing Cache Settings in the Infrastructure User's Guide and Visualization 
mode in the Product Structure User's Guide.)  
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 Exact preview for view generation

Make sure this option is selected if you want an exact preview when generating views. As 
a result, the part or product will be loaded in Design mode when previewing the view to 
generate, even if you are working in Visualization mode. Deselect this option to get a 
quick preview of the 3D document when generating views. In this case, a part or product 
open in Visualization mode will not be loaded in Design mode for the preview, which 
optimizes memory consumption.

 
 Only generate parts larger than

To specify that you only want to generate parts which are larger than a certain size, select 
this option and indicate the appropriate size by providing a value in millimeters in the 
appropriate field.

 
 Enable occlusion culling

Select this option if you want to save memory when generating exact views from an 
assembly which is loaded in Visualization mode (i.e.  when the Work with the cache 
system option is active). This will load only the parts which will be seen in the resulting 
view (instead of loading all of them, which is the case by default), which optimizes 
memory consumption and CPU usage.
To ensure the efficiency of this option, make sure that the Exact preview for view 
generation option is not selected.
In the case of an assembly which is loaded in Design mode, or in the case of a part, the 
Enable occlusion culling option will help increase performance by reducing CPU usage.

Keep the following restrictions in mind when selecting the Enable occlusion culling 
option:

●     The Project 3D points option will be disabled.

●     The only option available for Project 3D wireframe is Can be hidden. 

●     If you choose to project 3D wireframe, you will need to make sure that your wireframe 
elements have been taken into account when the CGR data was created: this is the 
case if you activated the Save lineic elements in cache option from Tools -> 
Options -> General -> Display -> Performances before the creation of CGR data 
(i.e. before you launched the part or product in Visualization mode). If not, you need 
to activate the Save lineic elements in cache option and then re-create the CGR 
data. To do this: 

1.  Close all open parts and products and exit the application. 
2.  Delete your CGR data from the cache. (The cache location is specified in Tools -> 

Options -> Infrastructure -> Product Structure -> Cache Management tab, 
Path to the local cache field.)

3.  Re-open the product in Visualization mode. 
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4. Choose the options you want and then click OK to validate your settings.

 

These options are also available in the Properties dialog box for each view: from the contextual 
menu, click Properties, click the View tab and then select the desired options.
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Generation 
You can customize given options for controlling dimension and balloon generation in generative 
views. 

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Generation tab. It contains several categories of options:

●     Dimension generation

●     Balloon generation

Dimension generation 
 

Generated dimensions are positioned according to the most representative views. In other words, a 
dimension will appear on a view so that it does not need to be created on another view. 

The dimensions are generated on the views on the condition the settings were previously switched 
to the dimension generation option.

Generate dimensions when updating the sheet 

Check this option to generate dimensions automatically each time you update the sheet.

Filters before generation

Check this option to display the Dimension Generation Filters dialog box before 
generation. This enables you to specify what type of dimensions you want to generate. 
Also, in assembly or product views, this lets you indicate what parts you want to generate 
dimensions for. 

Automatic positioning after generation
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Check this option if you want the dimensions to be automatically positioned after 
generation. 

Allow automatic transfer between views

Check this option if you want dimensions to be automatically transferred to the most 
appropriate view when regenerating dimensions.

Analysis after generation

Check this option to display the Generated Dimension Analysis dialog box after 
generation. 

Generate dimensions from parts included in assembly views

Check this option to extract 3D part constraints (on top of assembly constraints) when 
generating product dimensions.

This option is particularly useful if you want to generate dimensions for all parts included 
in assembly or product views, without displaying the Dimension Generation Filters dialog 
box before dimension generation. Note that if you display the Dimension Generation 
Filters dialog box before generating dimensions, you will need to indicate what parts you 
want to generate dimensions for (whether this option is selected or not).

Delay between generations for step-by-step mode

Specify the delay between each dimension generation when generating dimensions step 
by step. 

 

Balloon generation 
 

 Creation of a balloon for each instance of a product

If you select this option, a balloon will be generated for each instance of a component: 
therefore, if a component is used two times within a product, then the balloon will be 
generated twice. 

If you leave this box unselected, a single balloon will be generated for all instances of the 
same component, when a component is used several times within a part or product.

4. Choose the options you want and then click OK to validate your settings.
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Geometry Creation 

You can customize given options when creating 2D geometry, either or not using autodetection 
(or SmartPick), or still adding constraints to this geometry.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the Geometry tab. It contains several categories of options:

●     Geometry

●     Constraints creation

●     Constraints Display

●     Colors

Geometry 

 

 

Create circle and ellipse centers

You can decide whether or not you want to create centers when creating circles or 
ellipses. By default, this option is activated. Just uncheck it if you do not need to create 
circle and ellipse centers.

Allow direct manipulation

Select this option to be able to move geometry using the mouse. When moving 
geometry, you can move either the minimum number of elements, the maximum 
number of elements, or still the minimum number by modifying the shape of elements, 
if needed. Click the Solving mode... button to configure manipulation. 
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The dialog box that appears offers the following options as regards the solving mode:

Solving mode for moving elements

Standard mode 
You move as many elements as possible and also respect existing constraints.

Minimum move
You move as few elements as possible and also respect existing constraints.

Relaxation
You move elements by re-distributing them over the sketch, globally speaking. This 
method solves element moving by minimizing energy cost. 

Drag elements end points included

Furthermore, you can choose to drag elements along with their end points by checking 
this box.

 Show H and V fields in the Tools Palette

You can show the H and V fields in the Tools Palette when creating 2D geometry or 
when offsetting elements. Leaving the option unchecked enables you to directly enter 
the value corresponding to the type of element you are creating: for example, the 
length when creating a line, the radius when creating a circle or the offset value when 
offsetting elements. 

When a command (such as the Point creation command) does not have any parameters 
other than H and V, then these two fields will remain in the Tools Palette, whether you 
select this option or not.
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Create end points when duplicating generated geometry

When duplicating geometry that was generated from the 3D, you can choose to create 
end points for these geometrical elements. 

 
Constraints creation 

 

 

Create detected and feature-based constraints 

Select this option if you want to create the geometrical or dimensional constraints 
detected by the SmartPick tool. If all of the detection options are unchecked, the 
Create detected and feature-based constraints option is not available.

If this detection option is unchecked, the Create detected constraints option will be 
inactive by default in the Tools toolbar. You will be able to activate it at any time.

SmartPick... (switch button)

As you create more and more elements, SmartPick detects multiple directions and 
positions, and more and more relationships with existing elements. This may lead to 
confusion due to the rapid highlighting of several different detection possibilities as you 
point the cursor at different elements in rapid succession. Consequently, you can decide 
to filter out undesired detections by clicking the SmartPick... button.
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The SmartPick dialog box provides these options:

●     Support lines and circles

●     Alignment

●     Parallelism, perpendicularity and tangency

●     Horizontality and verticality

Uncheck the elements you do not wish to detect when sketching. 

Disabling SmartPick completely (i.e. unchecking all options in the SmartPick dialog box) 
is particularly useful when your screen is full of elements: in this case, it may be a good 
idea to disable SmartPick to concentrate only on the geometry.

Constraints Display 

 

Display constraints

Check this option to visualize the logical constraints specific to the elements. Note that 
if the Display constraints option is unchecked, the other options in this category are 
not available.

Reference size

Specify the size that will be used as a reference to display constraints symbols. 
Changing this reference size will modify the size of all constraints representations.

Constraints color

Choose the color that will be used to display constraints.

Constraints types... (switch button)

Click this button to define which types of constraints you will visualize as you create the 
geometry.
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The Constraints types dialog box provides these options:

●     Horizontal

●     Vertical

●     Parallelism

●     Perpendicularity

●     Concentricity

●     Coincidence

●     Tangency

●     Symmetry

Uncheck the types of constraints you do not want to visualize as you create the 
geometry.

 
Colors 

 

1511Page Infrastructure Version 5 Release 13



 

Two types of colors may be applied to sketched elements. These two types of colors correspond to 
colors illustrating:

●     Graphical properties
Colors that can be modified. These colors can therefore be modified using the Tools-
>Options dialog box.

OR

●     Constraint diagnosis
Colors that represent constraint diagnoses are colors that are imposed to elements whatever 
the graphical properties previously assigned to these elements and in accordance with given 
diagnoses. As a result, as soon as the diagnosis is solved, the element is assigned the color as 
defined in the Tools->Options dialog box.

Visualization of diagnosis

Select this option if you want over-constrained, inconsistent, not-changed or iso-
constrained elements to be identified using specific colors. Then, click the Colors... 
button to configure these colors.

 

 

In the dialog box that appears, you can configure colors for the following types of 
elements:

Over-constrained elements
The dimensioning scheme is over-constrained: too many dimensions were applied to 
the geometry.

Inconsistent elements
At least one dimension value needs to be changed. This is also the case when elements 
are under-constrained and the system proposes defaults that do not lead to a solution.

Not-changed elements
Some geometrical elements are over-defined or not-consistent. As a result, geometry 
that depend(s) on the problematic area will not be recalculated.
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Iso-constrained elements
All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved 
from its geometrical support.

Other color of the elements 

Click the Colors... button to configure the colors of other elements.

 

In the dialog box that appears, you can configure colors for the following types of 
elements:

Isolated elements
Use-edge (projection, intersection, etc.) that does not depend on the 3D anymore.

Protected elements
Non-modifiable elements.

Construction elements
A construction element is an element that is internal to, and only visualized by, the 
sketch. This element is used as positioning reference. It is not used for creating solid 
primitives.

SmartPick 
Colors used for SmartPick assistant elements and symbols.

When opening a drawing, colors are not recomputed. Colors will not be displayed until you create 
another element or move the geometry. 

 

4. Choose the options you want and then click OK to validate your settings.
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Dimension Creation 

You can customize given options when creating or re-positioning dimensions.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the Dimension tab. It contains several categories of options:

●     Dimension Creation

●     Move

●     Line-Up

●     Analysis Display Mode

Dimension Creation 

 

Dimension following the mouse (ctrl toggles) 

You can decide that the dimension line is positioned according to the cursor, following it 
dynamically during the creation process.

Constant offset between dimension line and geometry

The distance between the created dimension and the geometry remains the same when 
you move the geometry.

Default dimension line/geometry distance

If you position the dimension according to the cursor, you can define the value at which 
the dimension is created. If you create associativity between the dimension and the 
geometry, you can define the value at which the dimension will remain positioned.
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Associativity on 3D

If you click the switch button, the Dimensions associativity on 3D dialog box appears.

A link can be applied between a dimension and the 3D part. As a result, when you 
update the drawing, the dimension is automatically re-computed. If you do not check 
this option, when you perform the update, you need to re-create the dimension 
afterwards.

 

Create driving dimensions

The dimensions you will create will drive the geometry.

A new field will appear in the Tools Palette during the creation process, allowing you to 
enter the driving dimension value.

 Detect chamfer

Automatically detects chamfers so that you can create chamfer dimensions in a single 
click. 
As chamfer detection may slow performance down, you may want to deactivate this 
option for large products or assemblies.
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 By default, create dimensions on circle's

Specify whether the dimension you will create between a circle and another element 
should be on the circle center or on the circle edge.

Move 

 

Activate Snapping (shift toggles)

Select to activate the snapping option. Click the Configure button. In the dialog box, 
specify whether the dimension should be snapped on the grid, or whether the 
dimension value should be located at its default position between symbols (it will work 
only if the cursor is between the symbols), or both.

 

Pressing the Shift key allows you to temporarily deactivate or activate this mode.

Move only selected sub-part

Activate this option if you want to move only a dimension sub-part (text, line, etc.).

Line-Up 
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You can organize dimensions into a system with a linear offset. The offset will align the 
dimensions to each other as well as the smallest dimension to the reference element.

Default offset to reference

This allows you to set the offset between the smallest dimension and the reference 
element.

Default offset between dimensions

This allows you to set the offset between dimensions.

Align stacked dimension values

Lets you align all the values of a group of stacked dimensions on the value of the 
smallest dimension of the group. 

Align cumulated dimension values

Lets you align all the values of a group of cumulated dimensions on the value of the 
smallest dimension of the group. 

Automatically add a funnel

Whenever the value of a cumulated dimension requires a funnel to be displayed 
correctly, lets you have one added automatically.

Analysis Display Mode 
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Activate analysis display mode 

Colors can be customized with this option. To activate this mode, select this option and 
then click the Types and colors button. The Types and colors of dimensions dialog box 
lets you assign the desired color(s) to the selected dimension types. You will then be 
able to visualize the different types of dimensions using their assigned colors.  

4. Choose the options you want and then click OK to validate your settings.
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Manipulators 
These options apply to the Interactive Drafting workbench only.

You can decide that you will visualize given manipulators whenever creating or modifying 
dimensions.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Manipulators tab. It contains several categories of options:

●     Manipulators

●     Dimension Manipulators

Manipulators 

 

 

These settings can be used for any type of manipulator (texts, leaders, center lines, dimensions and 
so forth). 

Reference size

Specify the reference size that should be used for manipulators. In the case of texts, for 
example, this reference size corresponds to the diameter of the rotation manipulators. 

 

Zoomable

Check this box if you want to make manipulators zoomable.

Dimension Manipulators  
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 These settings let you define which manipulators you will visualize and therefore use when creating 
and/or modifying dimensions:
 

  

Modify overrun

If you drag select one overrun manipulator, both overrun extension lines are modified. To 
modify only the selected overrun extension line, use the Ctrl key. You can also double-
click on the manipulator and enter the new value in the dialog box that appears.

Modify blanking

If you drag select one blanking manipulator, both blanking are modified. To modify only 
the selected blanking, use the Ctrl key.  You can also double-click on the manipulator and 
enter the new value in the dialog box that appears.
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Insert text before 

Allow inserting a text before, without using the Properties dialog box. For this, you will 
click on the manipulator and enter the new text in the dialog box that appears.

Insert text after

Allows inserting a text after, without using the Properties dialog box. For this, you will 
click on the manipulator and enter the new text in the dialog box that appears.

Move value 

Allows moving the dimension value and only it.

Move dimension line

Allows moving the dimension line and only it by dragging to the new location.

Move dimension line secondary part

Allows moving the dimension line secondary part and only it by dragging to the new 
location.

4. Choose the options you want and then click OK to validate your settings.
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Annotation and Dress-up 

You can customize given options that will be used when creating annotations.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the Annotation and Dress-Up tab. It contains the following sets of options:

●     Annotation Creation

●     Move

●     2D Component Creation

●     Balloon Creation

Annotation Creation 
 

In order for these options to be taken into account, the Activate Snapping (SHIFT toggles) 
box must be checked. Note that the option selected in the Activate snapping dialog box will be 
taken into account. See the Move section.

Create text along reference

Select this option if you want to create annotation texts along a reference direction. For 
example, if you select a line when creating a text, the text will be oriented parallel to 
the line. 

Text

Select this option if you want to create the extremity of text leaders normal to a 
reference direction. For example, if you select a line when creating a text with leader, 
the leader will be normal to the line.  

Geometrical tolerance
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Select this option if you want to create the extremity of geometrical tolerance leaders 
normal to a reference direction. For example, if you select a line when creating a 
geometrical tolerance, the leader will be normal to the line.  

Move 
 

 Activate Snapping (SHIFT toggles)

Select this option to activate snapping. Click the Configure button.

In the dialog box that appears, specify whether you want the annotation to be snapped 
on the grid, according to the orientation, or both. This will apply to the annotations 
selected in the Annotation Creation area. To deactivate snapping when creating or 
moving annotations, press the Shift key.

 

 

2D Component Creation 
 

Create with a constant size

Select this option if you want all 2D component instances to have the same size when 
you create them, no matter what the view scale is. 

This lets you create 2D component instances whose size is independent from the view 
scale so that they always look the same. You can use them as symbols, for example. 
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If you want to use as symbols 2D components with text, activate both the Create with 
a constant size setting and the Apply Scale property for the text (in Edit -> 
Properties): the size of both the 2D component and its text will then be independent 
from the view scale.

 

Balloon Creation 
 

 3D associativity

You can specify what kind of balloons you want to create (using the Balloon command 
from the Annotation toolbar) or to generate (using the Generate Balloons command 
from the Generation toolbar).
First, select the 3D associativity box to indicate that you want to associate balloons 
with information from the 3D. Then, select from the list the kind of balloons you want to 
create or generate: the numbering of parts within an assembly (default option), the 
instance name or the part number. 

4. Choose the options you want and then click OK to validate your settings.
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Administration Settings 

You can customize settings for the management of drawings.

1. Select Tools -> Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog 
box.

3. Select the Administration tab. It contains the following sets of options:

●     Drawing management

●     Style

●     Generative view style

●     Dress-up

Drawing management 
 

Prevent File>New

Check this box to make it impossible to create drawings using the File -> New 
command. All drawings will be created using the File -> New From... command 
instead.

Prevent switch of standard

Check this box to make it impossible to change standards, i.e. to use a standard other 
than the one currently defined in the Page Setup dialog box.

Prevent update of standard

Check this box to make it impossible to update standards for the current document in 
the Page Setup dialog box.

Prevent background view access
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Check this box to make it impossible to access the background view.

Style 
 

 Use style values to create new objects

Check this box if you want dialog boxes, Properties toolbars and the Tools Palette to be 
pre-filled with custom style values (as defined in the Standards Editor) when creating 
new annotations. In this case, Properties toolbars and the Tools Palette will be disabled 
during the creation of the annotation. 
If you leave this box unchecked, annotation dialog boxes, Properties toolbars and the 
Tools Palette will be pre-filled with the last entered values (except for Texts, Texts with 
leader, Balloons and Datum features). In this case, Properties toolbars and the Tools 
Palette will be active during the creation of the annotation.

If you check this box, you will be able to reset the current style values in dialog boxes 
at any time using the Reset button. 

 Create new sheet from

This setting lets you specify if the properties used for creating new sheets should be 
those defined in the standards or those defined in the first sheet in a drawing. These 
properties are the scale and the projection method (first or third angle).  

Select Style if you want the sheet to use the style defined in the standards (in Tools -
> Standards -> Drafting -> [StandardName] -> Styles -> Sheet).

Select First sheet if you want the sheet to use the properties defined in the first sheet 
in a drawing. For example, you can use this option if you use an existing drawing to 
create a new one (i.e. when you want the new drawing to have the same properties as 
the existing drawing).
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 Lock "User Default" Style

Check this box to make it compulsory to use User Defaults (i.e., user-defined values set 
as default). The Styles drop-down list will be set to Only User Defaults and will be 
inactive so that Original Defaults or User Defaults cannot be selected. 

This option applies only to drawings created with versions up to V5 R10 whose standard 
has NOT been updated or changed in V5 R11 and later. 

Prevent "Set As Default" and "Reset All Defaults"

Check this box to use the current defaults and to make it impossible to create, change 
and reset user defaults (i.e. user-defined values). This disables the Set as Default and 
the Reset All Defaults commands. 

This option applies only to drawings created with versions up to V5 R10 whose standard 
has NOT been updated or changed in V5 R11 and later.

 

 

Generative view style 
 

 Prevent generative view style creation

Check this box if you do not want to use generative view styles when creating views. In 
this case, you will not be able to select a generative view style after having selected a 
view creation command, which means that the Generative View Style toolbar will not be 
displayed. (In the case of advanced front views, it is the Generative view style list in the 
View Parameters dialog box which will not be displayed).

 

Dress-up 
 

 Prevent dimensions from driving 3D constraints

Check this box to make it impossible to modify a 3D constraint via a 2D dimension that 
was generated from it.
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4. Choose the options you want and then click OK to validate your settings.
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Customizing Toolbars

 

You can customize the appearance of some fields in the following properties toolbars: Styles, 
Graphic Properties, Text Properties, Dimension Properties.

 

1. Right-click the toolbar field you want to customize. A contextual menu is displayed. 

2. If necessary, scroll down this contextual menu to display the toolbar customization options.

 

 The customization options that you can apply to the selected field are displayed.  

 

The options available depend on the selected field. For more information on what options will be 
available for each field, see the table below.

3. Click the option you want. Depending on the option you selected, the corresponding dialog box 
appears. 

4. Enter the appropriate value in the dialog box.

 ●     Set text width: sets the width used to display the field in the toolbar, in number of 
characters to be displayed (based on 'W').

●     Set list width: sets the width used to display the drop-down list, in number of characters to 
be displayed (based on 'W').

●     Set list height: sets the height used to display the list, in number of lines to be displayed (up 
and down arrows will make it possible to scroll within the list).

●     Icons display: defines whether icons should be displayed in this field, or only in the list, 
when the list is collapsed.

●     Precision: sets the precision used to display a numerical value in this field, in number of 
digits after the separator. 

5. Click OK to validate.

 

The table below indicates which fields you can customize in each toolbar, along with what you can 
customize for each field.
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 Set text 
width

Set list 
width

Set list 
height

Icons 
display Set precision

Style toolbar

Style Yes Yes Yes Yes No

Text Properties toolbar

Font Name Yes Yes Yes Yes No

Font Size Yes Yes Yes No Yes

Dimension Properties toolbar

Tolerance 
Description Yes Yes Yes Yes No

Tolerance Yes Yes Yes No No

Numerical Display 
Description Yes Yes Yes No No

Precision Yes Yes Yes No Yes

Graphic Properties toolbar

Color Yes No No No No

Thickness Yes No Yes No No

Linetype Yes No Yes No No

Point type Yes No Yes No No
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Customizing For Aerospace Sheet Metal 
Design

This section describes how to customize different settings specific to the Aerospace Sheet Metal Design 
workbench. The settings described here deal with permanent setting customization. 

Customizing Standards Files To Define Design Tables
Customizing General Settings

Customizing Standards Files To Define Methods for Compensations 
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Customizing Standards Files
To Define Design Tables

This section describes how to customize settings.
The task described here deals with permanent setting customizing.

Using Sheet Metal Standards Files

This task explains how to access company standards files in order to access and define design tables.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

 

2.  Select the 

Sheet 

Standards 

Files... 

button. The 

File Selection 

window is 

displayed.

3.  Indicate the 

path to the 

Sheet Metal 

table.

These files are available under .txt format or .xls format (only for NT and Windows)

4.  Click Open.

In the 
Sheet Metal 
Parameters 
dialog box, 
the Design 
Table icon 

 

appears 
opposite 
the 
Thickness 
and Bend 
radius 
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fields.

The parameters are now in gray, indicating that you can no longer modify the values.

5.  Click the 

Thickness 

Design Table 

icon  and 

select the line 

containing the 

appropriate 

parameters 

(for example 

Line 1).

 
Using the Tools -> Options -> General -> Document tab, Other Folders option, you can specify where the files are located. 
Refer to Document.

This scenario can work when the .CATPart document and all reference table files (Design & Radius) are located in the same 
directory. This directory is the current one when  the Design table is created, and also when the .CATPart is open.
However, generally speaking,  you must reference the complete path indicating where the radius table files are to be found in 
the RadiusTable column. In this case, regardless of the current directory, the correct tables are located when re-opening the 
.CATPart document.

6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.

7.  Click the Bend 

Radius Design 

Table icon 

.

8.  Select line 2 

and click OK. 

The parameter 

values are 

updated in the 
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Sheet Metal 

Parameters 

dialog box.

9.  Create a 

flange.

The Flange 

definition 

dialog box 

reflects the 

modification 

for the 

Radius.

The default 

mode, that 

is to say 

the 

formula:

Bend 

Radius = 

Part 

Radius is 

deactivated.

Using the Sheet Metal Design Tables:
Steps 1 to 4 are 
identical. 

5.  Click the 

Design Table 

icon  and 

select a line.

6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.
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At that time, the parameters Thickness and Bend radius are driven by the design table.

They are now in gray, indicating that you can no longer modify the values.

Note that if you create a bend, there is no design table: it's the formula which is used.

 
To disable the access to design tables:

●     Select the Tools -> Options -> Part -> Display tab and check Relations: the Design Table icon  is displayed in the 

specification tree.

●     Right-click this icon: the contextual menu appears.

●     Select SheetMetal Thickness Table object -> Deactivate 

The relation is no longer used but still exists. It can be activated at any time.
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Customizing General Settings

This task explains how to customize the Aerospace Sheetmetal Design General Settings.

1.  Select the Tools -> Options menu item.

The Options dialog box appears.

2.  Click Mechanical Design category then the Aerospace Sheetmetal Design 

subcategory. 

The default path is displayed in the Standard Profiles Catalog Files. You can modify it by clicking 

the Browse icon .

If no catalog path has been defined prior to entering the Catalog Browser command, the default 

catalog is selected and is path automatically added to the Standard Profiles Catalog Files field.
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Customizing Standards Files
To Define Methods for Compensations

This task explains how to access company standards files (available in .xls format) in order to define methods for joggle and sides 

compensations. The methods described in this task apply to joggles relying on a flange with a base feature (either a web or a flange) without 

joggles.

Open a new document.

  

1.  Click the Sheet Metal Parameters icon . The Sheet Metal Parameters dialog box is displayed.

2.  Select the Sheet Standards Files... button. The File Selection window is displayed.

3.  Indicate the path to the Sheet Metal methods (Std_Method1.xls or Std_Method1_2.xls). 

 Two methods are available to enable the joggle compensations. Both use Design Tables.
 

Method 1
This method is the method which was used in V4.

 The type of modifications performed depends on the position of the joggle with regards to:
●     the end of the part:

❍     near the end of part (case 1)

❍     not near the end of part (case 2)

●     the position of other joggles:
❍     twin joggles (case 3)

❍     double joggle near the end of part (case 4)

❍     double joggle not near the end of part (case 5)

How the different cases and the deformation are managed

Six values are used in the following description: C1, C2, C3, C4, C5, Ra. These values are defined in a design table. The path to this design table 
is defined in the Std_Method1.xls file.

Here is an example of a design table:
 C1 C2 C3 C4 C5 Ra

75 5 150 10 75 3

 
  
 Case 1
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●     The parameters necessary for performing the modifications are as follows:

❍     The parameter of the feature is: S (joggle depth) 

❍     Some values are computed to define the type of deformation: alpha, X.

●     The parameter definition and links are as follows:
❍     This case is applied if X < C1.

❍     C1 is defined with a constant value.

●     This deformation is performed as follows:
❍     The alpha angle is computed from S and X ( tangent(alpha) = S / X ). 

❍     The side and the EOP are then rotated with the alpha angle. The center of rotation is the intersection between the BTL on the flange and 
the side. 

 Case 2

 

 
●     The parameters necessary for performing the modifications are as follows:

❍     The values of the modification are: C1, Ra.

●     The parameter definition and links are as follows:
❍     This case is applied if X > C1.

❍     C1 is defined with a constant value.

❍     Ra is defined with a constant value.

 Case 3

 

 
●     The parameters necessary for performing the modifications are as follows:

❍     The values of the modification are: C2, C3, C4, Ra.

❍     A value is computed to define the type of deformation (table) to apply: X.

●     The parameter definition and links are as follows:
❍     This case is applied if C3 > X > C2.

❍     Then: a = (X - C4) / 2.

❍     C2, C3 and C4 are defined with a constant value.

❍     Ra is defined with a constant value.

 Case 4

This case applies only to the joggle positioned on the right; the joggle positioned on the left follows case 1.
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●     The parameters necessary for performing the modifications are as follows:

❍     A value is computed to define the type of deformation (table) to apply: X.

●     The parameter definition and links are as follows:
❍     This case is applied if C4 > X.

❍     C4 is defined with a constant value.

 Case 5

This case applies only to the joggle positioned on the right; the joggle positioned on the left follows case 2.

 

 
●     The parameters necessary for performing the modifications are as follows:

❍     A value is computed to define the type of deformation (table) to apply: X.

●     The parameter definition and links are as follows:
❍     This case is applied if C5 > X.

❍     C5 is defined with a constant value.

  
 

Method 2
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●     The parameters necessary for performing the modifications are as follows:

❍     Input parameters for joggle compensation:
■     Material Thickness: t

■     Joggle parameters: S (joggle depth)

■     Distance between the joggle and the side of the flange: X

❍     Output parameters:
■     Offset from start of joggle: a

■     Offset from end of joggle: b

■     Flange side compensation: A

■     Radius on start and end of joggle compensation: Ra, Rb

●     The parameter definition and links are as follows:
❍     A, a, b, Ra, Rb are defined from two design tables. The paths to these design tables are defined in the Std_Method1_2.xls file. 

Std_Method1_2.xls also contains the path to each defined thickness.

For each value of a material (therefore for each thickness) in Std_Method1_2.xls, two tables defining compensation values may be 
defined:

A first table defining A, depending on S and X:
SMax XMax A

0.8 X1  

0.8 X2  

0.8 X3  

1.1 X1  

1.1 X2  

1.1 X3  

A second table defining A, depending on S:
 

SMax a b Ra Rb

0.8     

1.1     

1.5     

 

Definition of Side Compensation
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●     The parameters necessary for performing the modifications are as follows:

❍     The values of the modification are: A1, A2

❍     Compensation can be automatic, or manual (defined in flange parameters)
■     Automatic (for symmetric flanges): A1 = A2 = 0;5 * (length btl - length eop)

■     Manual: manual input for A1 and A2

 
4.  Choose the appropriate file for the desired method.

 
5.  Click Open.

In the Sheet Metal Parameters dialog box, if you chose Method 2, the Design Table icon  appears opposite the Thickness field. 

You can click this icon to edit the design table.
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Customizing For Generative Sheetmetal 
Design

This section describes how to customize different settings specific to the Generative Sheetmetal Design 
workbench. The settings described here deal with permanent setting customization. 

Customizing General Settings
Customizing Standard Files 
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Customizing General Settings

This task explains how to customize the Generative Sheetmetal Design General Settings.

1.  Select the Tools -> Options menu item.

The Options dialog box appears.

2.  Click Mechanical Design category then the Generative Sheetmetal Design subcategory. 

The default path is displayed in the Standard Profiles Catalog Files. You can modify it by clicking the 

Browse icon .

If no catalog path has been defined prior to entering the Catalog Browser command, the default 

catalog is selected and is path automatically added to the Standard Profiles Catalog Files field.
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Customizing Standard Files
This section describes how to customize settings.
The task described here deals with permanent setting customizing.

Using Sheet Metal Standards Files

This task explains how to access company standards files.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

2.  Select the 

Sheet 

Standards 

Files... 

button. The 

Sheet Metal 

Part Samples 

window is 

displayed.

3.  Indicate the 

path to the 

Sheet Metal 

table.

These files are available under .xls or .txt format.
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4.  Click Open.

In the 
Sheet Metal 
Parameters 
dialog box, 
the Design 
Table icon 

 

appears 
opposite 
the 
Thickness 
and Bend 
radius 
fields.

The parameters are now in gray, indicating that you can no longer modify the values.

5.  Click the Thickness Design Table icon  and select the line containing the appropriate 

parameters (for example Line 1).

Using the Tools -> Options -> General -> Document tab, Other Folders option, you can specify 
where the files are located. Refer to Document.

This scenario can work when the .CATPart document and all reference table files (Design & Radius) are 
located in the same directory. This directory is the current one when  the Design table is created, and 
also when the .CATPart is open.
However, generally speaking,  you must reference the complete path indicating where the radius table 
files are to be found in the RadiusTable column. In this case, regardless of the current directory, the 
correct tables are located when re-opening the .CATPart document.
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6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.

7.  Click the Bend 

Radius Design 

Table icon 

.

8.  Select line 2 

and click OK. 

The parameter 

values are 

updated in the 

Sheet Metal 

Parameters 

dialog box.

9.  Create a bend.

The Bend 

Definition 

dialog box 

displays a 

design table 

for the 

Bend 

Radius.

The default 

mode, that 

is to say 

the 

formula:

Bend 
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Radius = 

Part 

Radius is 

deactivated.

Let's see the Bend Radius Table, using this icon . 

It shows the Bend Radius and the corresponding Bend Table. 

10.  Click OK.

If the Angle value is contained in the Bend Table, the Bend Allowance uses the 
corresponding value.
If not, the Bend Allowance is computed according to the KFactor. 

Using the Sheet Metal Design Tables:
Steps 1 to 4 are identical. 

5.  Click the Design Table icon  and select a line.
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6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.

 
At that time, the parameters Thickness and Bend radius are driven by the design table.

They are now in gray, indicating that you can no longer modify the values.

Note that if you create a bend, there is no design table: it's the formula which is used.

 
To disable the access to design tables:

●     Select the Tools -> Options -> Part -> Display tab and check Relations:

the Design Table icon  is displayed in the specification tree.

●     Right-click this icon: the contextual menu appears.

●     Select SheetMetal Thickness Table object -> Deactivate

The relation is no longer used but still exists.

It can be activated at any time.
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Customizing for 3D Functional Tolerancing & 
Annotation  

This section describes the various settings you can customize for 3D Functional Tolerancing & Annotations 
via the Tools -> Options command. 

Tolerancing
Display
Constructed Geometry
Manipulators
Dimension
Annotation
Tolerance Values
View/Annotation Plane 
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Tolerancing  

This task will show you how to customize 3D Functional Tolerancing & Annotation tolerancing 
settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Tolerancing tab.

The Tolerancing tab appears, displaying five categories of options:

Tolerancing Standard  

 Default standard at creation

Defines the default standard at creation. 

Provides five conventional standards:

●     ASME: American Society for Mechanical Engineers

●     ASME 3D: American Society for Mechanical Engineers

●     ANSI: American National Standards Institute

●     ISO: International Organization for Standardization

●     JIS: Japanese Industrial Standard

Semantic Control  
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 Always try to upgrade non-semantic tolerances and dimensions

 Defines automatic upgrade of a non-semantic annotation during its creation to a 
semantic annotation. If it can be upgradeable to a semantic annotation only.

 Non-semantic tolerance creation allowed

 Defines whether non-semantic tolerances creation is allowed or not.

 Non-semantic dimension creation allowed

 Defines whether non-semantic dimensions creation is allowed or not.

Leader associativity to the geometry  

 Free

 Specifies that leader annotations are freely positioned relative to their 
geometrical elements.

 Perpendicular

 Specifies that leader annotations are positioned perpendicular to their geometrical 
elements.

Rotation  

 Rotation snap angle

 Defines an angle value for rotating elements. This option is used to rotate text 
elements (text, frame, or leader).

 Automatic snapping

 Defines whether the rotation will be snapped to the angle value or not.
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Note Object Attribute  

 Allow Note Object Attribute creation

 Defines whether note object attribute may be created by user or not. Enable or 
disable the icon and menu item.
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Display  

This task will show you how to customize 3D Functional Tolerancing & Annotation display 
settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Display tab.

The Display tab appears, displaying the following categories of options:

Non-Semantic  

 Mark non-semantic annotations

 Defines whether non-semantic annotations (datum elements, datum targets, 
geometrical tolerances, linear and angular dimensions) are marked with a wavy 
red line in the specification tree and in the geometry. 

Grid  

Display

Defines whether the grid is displayed.
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Snap to point

Defines whether annotations are snapped to the grid's point. 

Allow Distortions

Defines whether grid spacing and graduations are the same horizontally and 
vertically. 

H Primary spacing

Defines the grid's horizontal spacing. 

H Graduations

Defines the grid's horizontal graduations.

V Primary spacing

Defines the grid's vertical spacing (available only if Allow Distortions is checked).

V Graduations

Defines the grid's vertical graduations (available only if Allow Distortions is 
checked).

 

Annotations in Specification Tree  

Under Geometric Feature nodes

Defines that 3D annotations should be displayed under the geometric feature 
nodes in the specification tree. This lets you view 3D annotations under the Part 
Design or GSD feature nodes to which they are applied.

Under View/Annotation Plane nodes

Defines that 3D annotations should be displayed under the view/annotation plane 
nodes in the specification tree. This lets you view 3D annotations under the view 
node to which they are linked.

Under Annotations Set node

Defines that 3D annotations should be displayed under the annotation set node in 
the specification tree.

 

Partial Surface  
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 Apply Settings

 Defines whether the following settings are applied while creating a partial surface 
feature.

 Surface Color

 Defines the surface color of the partial surface. 

 Edge Type

 Defines the edge type of the partial surface's border. 

 Edge Thickness

 Defines the edge thickness of the partial surface's border.

 Edge Color

 Defines the edge color of the partial surface's border.

 

Annotation Parameters  
 

 Display parameters under annotation feature node

 Defines that knowledge parameters (such as tolerance values, datum label, etc.) 
of annotations should be displayed under the annotation feature node in the 
specification tree; also defines that feature parameters of dimensions (accessible 
through the Edit Generative Parameter command) should be displayed under 
the dimension feature node in the specification tree.
Note that in order to have the value of the parameters displayed in the 
specification tree, you need to select the With value knowledge setting in Tools -
> Options -> General -> Parameters and Measure -> Knowledge tab.

 

Surface Normal  
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 Display for shifted profile tolerance

 Defines whether the normal of all the selected surfaces are displayed, or not, 
when a shifted profile tolerance is specified or queried.

3D Annotation Query  
 

 Allow query for default annotation (automatic selection mode)

 Defines whether the query for default annotation is allowed, or not. This option 
allows you to highlight the related annotations or geometrical elements with the 
selected annotation or the related annotations with the selected geometrical 
element.
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Constructed Geometry   

This task will show you how to customize 3D Functional Tolerancing & Annotation tolerances 
settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Constructed Geometry tab.

The Constructed Geometry tab appears, displaying three categories of options:

Graphic Properties  

 Surface color

 Defines the constructed geometry surface color for plane and cylinder.

 Curve type

 Defines the constructed geometry curve type.

 Curve thickness
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 Defines the constructed geometry curve thickness.

 Curve color

 Defines the constructed geometry curve color.

 Point type

 Defines the constructed geometry point type.

 Point color

 Defines the constructed geometry point color.

 Apply settings

 Defines whether all the graphic properties settings are applied or not.

Limits  

 All around overrun

 Defines the minimal limit between the constructed geometry and its related 
geometry.

Automatic Creation  

 Center point

 Defines whether all the center point's constructed geometry is automatically 
created or not, for circle center, sphere center.

 Center axis

 Defines whether all the center axis's constructed geometry is automatically 
created or not, for cylinder, cone.

 Center plane

 Defines whether all the center plane's constructed geometry is automatically 
created or not, for slot.
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Manipulators  

This task will show you how to customize 3D Functional Tolerancing & Annotation manipulators 
settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Manipulators tab.

The Manipulators tab appears, displaying two categories of options:

Manipulators  

 Reference size

 Defines the annotation manipulator's size.

 Zoomable

 Defines whether the annotation manipulator is zoomable or not.

Dimension Manipulators  
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 Modify overrun

 Defines whether overrun extension lines can be modified during creation or 
modification, or not.

 Modify blanking

 Defines whether blanking can be modified during creation or modification, or not.

 Insert text before

 Defines whether a text before can be inserted during creation or modification, or 
not.

 Insert text after

 Defines whether a text after can be inserted during creation or modification, or 
not.

 Move value

 Defines whether only the value can be moved during creation or modification, or 
not.

 Move dimension line

 Defines whether only the dimension line can be moved during creation or 
modification, or not.

 Move dimension line secondary part

 Defines whether only the dimension line  secondary part can be moved during 
creation or modification, or not.
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Dimension   

This task will show you how to customize 3D Functional Tolerancing & Annotation dimension settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Dimension tab.

The Dimension tab appears, displaying two categories of options:

Dimension Creation  

Dimension following the mouse

 Defines whether the dimension line is positioned according to the cursor, following it 
dynamically during the creation process or not.

Constant offset between dimension line and geometry

 Defines whether the distance between the created dimension and the geometry remains the 
same when you move the geometry or not.

Default dimension line/geometry distance

 Defines the value at which the dimension is created from the geometry.
If you create associativity between the dimension and the geometry, you can define the 
value at which the dimension will remain positioned.

By default, dimension circles on their

 Defines the dimension you will create between a circle and another element will be either on 
the circle center or on the circle edge.
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Move  

Activate Snapping

 Defines whether the dimension will be snapped on the grid and/or the dimension value will 
be located at its default position between symbols (it will work only if the cursor is between 
the symbols) or not.

Move only selected sub-part

 Defines whether only a dimension sub-part (text, line, etc...) will be moved or not.

Line-Up  

Default offset to reference

 Defines the distance and angular offset between the smallest dimension and the reference 
element.

Default offset between dimension 

 Defines the distance and angular offset between the dimension.

Align stacked dimension values

 Defines whether the values of a group of stacked dimensions are aligned on the value of the 
smallest dimension of the group or not.

Align cumulated dimension values

 Defines whether the values of a group of cumulated dimensions are aligned on the value of 
the smallest dimension of the group or not.

Automatically add a funnel

 Defines whether the value of a cumulated dimension requires a funnel added automatically 
to be displayed correctly or not.

Dimension related to an origin  
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Use Dimension Origin Symbol

 Defines whether the dimension origin symbol is used or not.
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Annotation   

This task will show you how to customize 3D Functional Tolerancing & Annotation annotation 
settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Annotation tab.

The Annotation tab appears, displaying two categories of options:

Annotation Creation  

 Annotation following the mouse (Ctrl toggles)

 Defines whether the annotation is positioned according to the cursor, following it 
dynamically during the creation process or not.

Geometrical Tolerance  

 Extension line length

 Defines the extension line length between the geometrical frame and the its 
leader.
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Tolerances  

This task will show you how to customize 3D Functional Tolerancing & Annotation tolerances 
settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Tolerances tab.

The Tolerances tab appears, displaying three categories of options:

Angular Size  

 Default upper tolerance value

 Defines the default upper tolerance value for angular size.

 Symmetric lower limit

 Defines whether the default lower tolerance value is symmetric in relation to the 
default upper tolerance value.

 Default lower tolerance value

 Defines the default lower tolerance value for angular size, disable when 
Symmetric lower limit is checked.

 Numerical value increment
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 Defines the increment for angular size numerical value.

Linear Size  

 Default upper tolerance value

 Defines the default upper tolerance value for linear size.

 Symmetric lower limit

 Defines whether the default lower tolerance value is symmetric in relation to the 
default upper tolerance value.

 Default lower tolerance value

 Defines the default lower tolerance value for linear size, disable when Symmetric 
lower limit is checked.

 Numerical value increment

 Defines the increment for linear size numerical value.

 Default tabulated value

 Defines the default tabulated for linear size.

Geometrical Tolerance  

 Default numerical value

 Defines the default numerical for geometrical tolerance.
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 Numerical value increment

 Defines the increment for the to geometrical tolerance numerical value.

 Precision

 Defines the geometrical tolerance precision after the numerical separator.

 Separator

 Defines the geometrical tolerance symbol used as numerical separator.

 Display trailing zeros

 Defines whether "0"s complete the number of digit displayed after the separator, 
according to the precision, or not.

 Display leading zeros

 Defines whether the "0" before the numerical separator, when value is less than 
1, is displayed or not.
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View/Annotation Plane  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
view/annotation plane settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the View/Annotation Plane tab.

The View/Annotation Plane tab appears, displaying the following categories of 
options:

View/Annotation Plane Associativity   

 Create views associative to geometry

 Creates views associative to the geometry, so that views and their annotations 
are automatically updated when the geometry is modified. 

View/Annotation Plane Display   

 Current view axis display

 Defines whether the active annotation plane axis system is displayed. 
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 Zoomable

 Defines whether the annotation plane axis is zoomable.

 Visualization of the profile in the current view

 Defines whether the view/annotation plane profile on the part/product is 
displayed or not. 
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Shape

Free Style
Automotive Body in White Fastening

Generative Shape Design
Shape Sculptor
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Customizing For FreeStyle Shaper,
Optimizer, and Profiler

This task explains how to customize settings for FreeStyle workbenches.

1.  Select the Tools -> Options menu item. 

The Options dialog box is displayed.

2.  Select the Shape category then select the FreeStyle subcategory. 

The options for FreeStyle settings appear, organized in separate areas depending on the 

type of setting. 

●     Geometry

●     Auto-detection

●     Display

●     Tuning

3.  In the Geometry area, check:

 
 

●     Tolerances: to impose user-defined tolerances to every elements to be created and modified 
within a FreeStyle workbench.
You can define: 

❍     the constraint tolerance value used to define the continuity variation. In this case if the 
continuity is over the set value the element is not created/modified.
In P1 mode, the constraint tolerance value is set and cannot be modified.

❍     the deviation tolerance value, used when converting elements using the Converter Wizard 
for example (see tasks "Approximating/Segmenting Procedural Curves" and 
"Approximating/Segmenting Procedural Surfaces" within the FreeStyle Shaper, Optimizer, 
and  Profiler User's Guide). In this case you accept the conversion up to the set tolerance 
value.

●     Order: to set the maximum allowed order along the U (and V) directions for each curve segment 
and surface patch.
This maximum order value ranges from 5 to 16 included, in a given direction.

1571Page Infrastructure Version 5 Release 13



In P1 mode, the Max order is set to 16 and cannot be modified.

4.  In the Auto-Detection area, you 

can choose to display: 

●     the point coordinates as the pointer 

moves along the geometry by selecting 

the Coordinates checkbox

●     the dressing mode by selecting the 

Search dressing checkbox. This 

option allows the display of control 

points on geometry detected with the 

pointer when using the Snap on Cpt 

(snap on control points) option from 

the Dashboard.

5.  In the Display area, you set the 

information to be displayed on the 

geometry as you manipulate it, 

that is:

●     the Control Points on the geometry. 

See "Displaying Control Points 

Temporarily" in the FreeStyle Shaper, 

Optimizer, and  Profiler User's Guide).
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●     the Continuity at every connection 
between elements (such as blend and 
match curves and surfaces, fill 
surfaces, and so forth)

●     the Curvature texts on an element 
(such as blend and match curves and 
surfaces, and so forth)

●     the Order number along the U (for 
curves) or U and V directions (for 
surfaces).

●     the Contact Point at every connection 
between connected elements (such as 
blend and match curves and surfaces, 
and so forth)

 
●     the Tension manipulators at every 

connection between connecting 
elements (such as blend and match 
curves and surfaces, and so forth)
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6.  In the Tuning area, you set the 

values used when manipulating 

views or geometry (P2 only).

See "Editing Surfaces Using 

Control Points", and 

"Manipulating Views" in the 

FreeStyle Shaper, Optimizer, 

and  Profiler User's Guide for 

example. 

7.  Click OK to confirm setting these permanent options.

For further information on the Performance tab, refer to the chapter called Performance in the 
Infrastructure User's Guide.
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Customizing For Automotive Body In White 
Fastening

This section describes how to customize different settings specific to the Automotive Body In White 
Fastening workbench. The settings described here deal with permanent setting customization. 

General Settings
BiW Fastening Application Display User Settings 
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General Settings 
This task explains how to customize Automotive BiW settings.

1.  Select the Tools -> Options menu item.

The Options dialog box appears. 

2.  Click the Shape category then select the Automotive Body In White subcategory to 

display the General tab:

Default paths are displayed. You can change them by clicking the Browse icon .
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 Setting Up Parameters

 
●     The Default Fasteners Parameters Set-Up Standard File corresponds to the path where the 

default standards are stored.
❍     You can automatically configure the BiW Application and import the standard by clicking on 

the Automatic Set-Up and Standard Import check box (checked by default).
If this option is activated, all the icons (except Export, Rename and Check) are accessible 
in the workbench. Selecting any of these icons automatically configure the BiW Application 
and import the standard.

❍     You can also Check the Standard File Consistency at Import Time (unchecked by 
default) to check the consistency of the standard values when importing the standard file 
(whose path is mentioned above)
If the standard file is not valid, it cannot be imported and an error message is issued.

 
Defining the Export Directory

 The Export default directory is the directory where the export file is stored.
 

Defining the Report Directory
 The Report default directory is the directory where the report file is stored.

Setting Up Extract Parameters
 

●     You can define a fixed size for the 2D drawing spots: check the Fixed Drawing Spot Size 
button and define a diameter value.
As a consequence, all spots in the 2D document will have this diameter, whatever their size in 
the 3D document.

●     You can define a user Angular Tolerance.

●     You can check the Include View Reverse Direction checkbox to visualize 2D reverse spots.

Refer to the chapter Integration With Drafting to have further information.

3.  Click OK to confirm setting these options.

[ Up ] [ Next ]
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BiW Fastening Application Display User Settings  

This task shows you how to control the display of the fasteners in the geometry area.

1.  Select the Tools -> Options command.

The Options dialog box is displayed.

2.  Click the Shape category, then the Automotive BiW Fastening subcategory.

3.  Select the Display tab.

4.  Click the Unset All button to uncheck all the options, except for the Shape Representation 

option. Similarly click the Set All button to check all options.
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5.  Click the Show buttons to visualize the different options.

●     Shape 
Representation 

●     Text ID

 

●     Fastener Parameters

 You can associate a symbol with a 
specification:

●     a process type (by default): 
the symbol is displayed 
according to the symbol code 
assigned to the Fastener 
Process Type in the standard 
file. By default, if no symbol is 
assigned to the process type 
in standard, or if there is no 
imported standard, the 

symbol is  (101)

●     an unspecified type (Unspec): 

the default symbol  is 

displayed. It can be modified 

through the Properties 
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contextual command.

●     the thickness count: the 

symbol is displayed according 

to symbol code assigned to 

the Thickness Count  in the 

standard file.

By default, if no symbol is 

assigned to the thickness 

count in standard, or if there 

is no imported standard, the 

symbol is: 

for 1 

thicknesses 

(1)

 for 2 

thicknesses 

(2T)

 for 3 

thicknesses 

(3T)

 for 4 

thicknesses 

(4T)

 for more 

than 4 

thicknesses

 

●     None: no symbol is visualized.

Once the symbol is associated 
with a specification, it can not 
longer be modified when editing 
the fastener's properties, except 
for the Unspecified type.

The example above shows that the graphic symbol is assigned to the 
Laser process type. The symbol color is assigned to the Welding 
process category.
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 // Symbol 
Dependency from
Thickness Count  

NTH_2_SYM 151

NTH_3_SYM 113

NTH_4_SYM 114

For 1T: 

For 2T: 

For 3T: 

For 4T: 

 The example above shows how to define a graphic symbol associated to a thickness count

 You can associate a color with a specification:

●     a process category (by default): the color is displayed according to the color code assigned to the 

Fastener Process Category in the standard file.

By default, if no color is assigned to the Process Category or no standard is imported, the default 

color is:

Yellow for Welding
Cyan for Adhesive
Magenta for Sealant
Green for BiW Mechanical
White for Unspecified

●     an unspecified type (Unspec): a default color is displayed:

Yellow for Welding

Cyan for Adhesive

Magenta for Sealant

Green for BiW Mechanical

White for Unspecified

 
●     None: no symbol color is visualized.  

In this case, the color associated with the process category will be transparent.

Once the color is associated with a specification, it can not longer be modified when editing the 
fastener's properties, except for the Unspecified type.
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 You can associate marks with 
the specification:

●     Robustness

●     Regulation

●     Finish

●     None

Note that:

●     1 is for assigning a mark

●     0 is for assigning no mark.

For instance assign the 1 mark code for the Robustness parameter 
and which value set by default is C: 

You will get this Mark: 

 In this case all the Fasteners with the Robustness specification will get the mark symbol.

In the Standard file, Marks are assigned by default:
●     For Robustness parameter ("Safety") enter the C value.

●     For Regulation parameter ("Norm A") enter the A value.

●     For Finish parameter ("Class A") enter the A value.

 

●     Fastener Normal 
Vector 
Orientation
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●     Support Contact 
Zone
Material 
Orientation

●     Show Projected 
Points

●     Show Material 
Orientation

●     Show Thickness 

Stack-Up

Order

6.  Click OK to confirm setting these options.
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●     You can define the thickness and the material orientation for a GSD feature using the Thin Parts 
Attribute command in the Generative Shape Design workbench.
Refer to the Applying a Thickness chapter in the Generative Shape Design documentation.

●     The options listed above can also be accessed using the fasteners' properties via the contextual 
menu.
Refer to the Editing the Fasteners' Properties chapter.
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Customizing For Generative Shape Design
General Settings

Working with a Support
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General Settings

This task explains how to customize general settings for Generative Shape Design workbenches.

1.  Select the Tools -> Options menu item.

The Options dialog box is displayed.

2.  Select the Shape category then the Generative Shape Design subcategory to display the General 

tab:

These settings are available with the Projections and Parallel Curves functionalities: next time you open one of 
them, the Smoothing type and the Maximum deviation will already be set.

Tolerant Modeling
Input parameters

●     Merging distance: default value defining the distance below which elements are to be joined or healed.

This option is available with the following commands: Join and Healing.

 
●     Tolerant laydown: in case the lay down of an input guide on a surface fails, you can check the Tolerant 

laydown button. When activated, a fixed lay down tolerance of 0.1mm is applied.

This option is available with the following commands: Parallel Curve, Sweep, Multi-Sections Surface, Blend, 
Split, and Curve Smooth.
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Here is a scenario with 
the Sweep command.
You can open the 
TolerantLaydown.CATPart 
document.

1.  Create a tolerant 

swept surface 

and define a 

Deviation from 

guide of 0.1 mm.

In our scenario 

we created a 

swept surface 

using an implicit 

linear profile and 

the ''two limits'' 

sub-type. We 

selected Curve.1 

and Curve.2 as 

the guide curves.

2.  Create a parallel 

curve of one of 

the guide curves 

using the swept 

surface as the 

support.

The creation of 

the parallel curve 

fails.

An error message 

opens informing 

you that the 

guide curve does 

not lie on the 

swept surface.
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3.  Check the 

Tolerant 

laydown option.

4.  Perform step 2 

again.

The creation of 

the parallel curve 

is successful.

It is advised not to use a wire that lies on the edge of the sweep when working with the tolerant laydown 

option.

  
Output parameters

●     Choose the Continuity Type:

❍     None: deactivates the smoothing result

❍     Tangency: enhances the current continuity to tangent continuity

❍     Curvature: enhances the current continuity to curvature continuity

This option is available with the following commands: Project and Parallel Curve.

 
●     You can specify a Maximum deviation to set the allowed deviation between the initial element and the 

smoothed element by entering a value or using the spinners. 

This option is available with the following commands: Project, Parallel Curve, Sweep, Multi-Sections Surface, 

and Curve Smooth.

For the Sweep and Multi-Sections Surface commands, only the Deviation parameter can be defined from 

Tools -> Options (the Angular correction parameter cannot be defined here). The Deviation and Angular 

correction will be activated only if the smoothing type is set to Tangency or Curvature.

 
Axes Visualization

 

 Uncheck the Axes visualization limited to the geometry block of the input button to visualize an infinite 

axis in the 3D geometry.
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 Option checked Option unchecked
  

Groups
 

●     Check the Integration of created features as group inputs option if you want each new feature to be 
included as an input in an existing group and remain visible in the specification tree.
If you uncheck this option, created features will not included in the group and will be hidden in the group 
tree (expand the group to be able to see it).

●     This option is only available when creating a new feature.

●     It is only available for features accessible in the Generative Shape Design workbench. All other features will 
not be included in the group even if the option is checked.

For further information, please refer to the Managing Groups chapter.

3.  Click OK to confirm setting these permanent options.
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Working with a Support

This task explains how to customize certain options that are used when creating a support.

1.  Select the Tools -> Options menu item.

The Options dialog box is displayed.

2.  Select the Shape category then the Generative Shape Design subcategory to display the 

Work On Support tab:

 
Work on Support

●     Define the First direction scale (H for horizontal), by setting Primary spacing and Graduations 

values.

●     If you wish, you can define another scale for the Second direction scale (V for vertical), thus 

allowing distortions of the grid. Check the Allow distortions option to activate the Primary 

spacing and Graduations fields of the second direction.

Work on Support 3D
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●     Define the default values for the grids, by defining Labels names and Primary Spacing values 

for each direction.

●     Define the Grid labels unit, that is the coefficient of division for all straight lines units.

For example, the grid label unit is set to 1 and the X label for one line is set to 500. If you 

modify the grid label unit to 10, the X label will be 50.

●     Define the Automatic Scale Factor, that is the scale to be used when the grid becomes too 
small. The factor is comprised between 2 to 10.

●     Define the Maximum lines number to be displayed on the screen, from 70 up to 500 lines.

  
 

These values will be used as the default values when creating a support.
  

Please refer to the Working With a Support and Working With a 3D Support chapters in the 
Generative Shape Design documentation for further information.
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Customizing For Shape Sculptor

This task explains how to customize general settings for the Shape Sculptor workbench.

1.  Select the Tools -> Options menu item.

The Options dialog box is displayed.

2.  Select the Shape category then the Shape Sculptor subcategory to display the General 

tab:

 

 
3.  Check Custom Settings to enable the modification of parameters that control the precision 

of the curves.

4.  Define the Chordal Deviation by entering a value or using the spinners.

5.  Define the Segment Length by entering a value or using the spinners.

6.  Click OK to confirm setting these options.
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Analysis & Simulation
Tolerance Analysis

Analysis
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Customizing for Tolerance Analysis of Deformable 
Assembly

This section describes the different types of setting customization you can perform in Tolerance Analysis of 
Deformable Assembly using the Tools -> Options command. 

All tasks described here deal with permanent setting customization.

General
Fastening
Tolerancing
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General   

This task will show you how to customize Tolerance Analysis of Deformable Assembly general 
settings.

1.  Select  Tools -> Options... 

The Options dialog box appears.

2.  Click the Analysis & Simulation category.

3.  Click the Tolerance Analysis subcategory.

4.  Click the General tab

The General tab appears, displaying five categories of options:

File Out Folder  

 
●     External Result Path

❍     Define the folder path where to save file out of tolerance analysis files.

●     Computation Result Path

❍     Define the folder path where to save file out of computation files.

●     Temporary Result Path

❍     Define the folder path where to save file out of temporary files.

Feature Colors  
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●     Rigid Support

❍     Define the default colors of rigid support.

●     Flexible Support

❍     Define the default colors of flexible support.

●     Mechanical joint

❍     Define the default colors of mechanical joint.

●     Fastening

❍     Define the default colors of Fastening.

●     Contact

❍     Define the default colors of Contact.

Links Creation Mode  

 
●     Automatic

❍     Define whether the links creation can be automatic or not.
With the automatic mode, the application take into account the appropriate 
contacts around a fastening element, else user must define the contacts take into 
account the fastening element.

Meshes  
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●     Distance maximal between geometry and point

❍     Define the maximal distance allowed between a point defined as node by user and 
the part geometry.
Out of this distance the point is not take into account when the mesh is 
automatically generated.

 

Node and Point Filter  
 

 
●     Activate Filter during selection

❍     Validate node or point according to the tolerance analysis feature context when 
selecting them.

●     Activate Filter during creation

❍     Validate node or point according to the tolerance analysis feature context when 
creating the tolerance analysis feature (Clicking OK in its dialog box).

●     Deactivate Filter

❍     Validate node or point according to the tolerance analysis feature context when 
computing the tolerance analysis.
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Fastening   

This task will show you how to customize Tolerance Analysis of Deformable Assembly fastening 
settings.

1.  Select  Tools -> Options... 

The Options dialog box appears.

2.  Click the Analysis & Simulation category.

3.  Click the Tolerance Analysis subcategory.

4.  Click the Fastening tab

The Fastening tab appears, displaying four categories of options:

Spot Welding  

 
●     Joint type before welding

❍     Define the mechanical joint take into account to represent spot welding before a 
spot welding activity.

●     Joint type after welding

❍     Define the mechanical joint take into account to represent spot welding after a 
spot welding activity.

 Available settings are:

Before After

Point
Revolute

or
Spherical

Planar Revolute
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Riveting  

 
●     Joint type before riveting

❍     Define the mechanical joint take into account to represent spot welding before a 
riveting activity.

●     Joint type after riveting

❍     Define the mechanical joint take into account to represent spot welding after a 
riveting activity.

 Available settings are:

Before After

Point
Revolute

or
Spherical

Planar Revolute

Spherical
Revolute

or
Spherical

Revolute Revolute

Bolting  
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●     Joint type before bolting

❍     Define the mechanical joint take into account to represent spot welding before a 
bolting activity.

●     Joint type after bolting

❍     Define the mechanical joint take into account to represent spot welding after a 
bolting activity.

 Available settings are:

Before After

Point
Revolute

or
Spherical

Planar Revolute

Spherical
Revolute

or
Spherical

Revolute Revolute

Spot Glueing  

 
●     Joint type before glueing

❍     Define the mechanical joint take into account to represent spot welding before a 
spot glueing activity.

●     Joint type after glueing

❍     Define the mechanical joint take into account to represent spot welding after a 
spot glueing activity.

 Available settings are:
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Before After

Point
Revolute

or
Spherical

Planar Revolute
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Tolerancing   

This task will show you how to customize Tolerance Analysis of Deformable Assembly tolerancing 
settings.

1.  Select  Tools -> Options... 

The Options dialog box appears.

2.  Click the Analysis & Simulation category.

3.  Click the Tolerance Analysis subcategory.

4.  Click the Tolerancing tab

The Tolerancing tab appears, displaying two categories of options:

Conversion Range  

 
●     Range

❍     Define the range value to switch between tolerance interval and statistic law.
Example, with a range value of 3 and applied to a normal law, 99.73% of 
measures contained in the tolerance interval represent the statistic law field.

Tolerance Translation Reduction Coefficient  

 
●     Coefficient Value

❍     Define the coefficient value to translate Functional tolerances due to form 
uncertainty in deviation point grid.
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Minimum Variance  

 
●     Minimum Variance

❍     Define the percentage value of minimum variance to translate Functional 
tolerances.
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Customizing

This section describes the different type of setting customization you can perform in the Analysis workbenches using 

the Tools -> Options... submenu.

This type of customization is stored in permanent setting files: these settings will not be lost if you end your session.

1.  Select the Tools -> Options... submenu.

The Options dialog box appears.

2.  Select the Analysis & Simulation category.

The following tab appears:

These tabs lets you define the 

❍     general settings

❍     graphic settings

❍     post processing settings

❍     quality settings

❍     storage settings

3.  Change the desired parameters.

4.  Click OK in the Options dialog box when done.
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General

This task explains how to customize Analysis & Simulation general settings. 

The General tab deals with the following settings:

●     the default analysis case choice

●     the specification tree display

Click here to see the parent page.

Default Analysis Case

Define a default starting analysis case

This option lets you define a default analysis case that will be inserted each time you enter the Generative 

Structural Analysis workbench or the Advanced Meshing Tools workbench.

Before defining a default analysis case using Tools->Options command, make sure you started the 

Analysis & Simulation (Generative Structural Analysis or Advanced Meshing Tools) workbench at least 

once.

The default starting analysis case is Static Analysis. You can decide that the new default case will be: 

●     Static Analysis

●     Frequency Analysis

●     Free Frequency Analysis

 

The cases will only be displayed if an analysis workbench has been loaded at least once because 

the listed cases are linked to the Analysis workbenches last loaded. 
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 By default, this option is deactivated.

Specification Tree

Show parameters

This option lets you display parameters in the specification tree.

 By default, this option is deactivated.

Show relations

This option lets you display relations in the specification tree.

 By default, this option is deactivated.
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Graphics

This page deals with the following options: 

●     Nodes

●     Elements

Click here to see the parent page.

 

Nodes

This option lets you select the symbol and color you wish to assign to the nodes.

Elements

This option lets you define the shrink of 1D elements.
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Post Processing

This task explains how to customize Analysis & Simulation post processing image settings.

You can define the location of the SPMUserTemplateImageDefinition.xml file or manage this file.

This file contains all the generated images that have been saved with the Save As New Template 

contextual menu.

Click here to see the parent page.

Save As New Template Folder

Output directory 

This option lets you choose the directory in which you want to store the .xml file.

 By default, this field is empty.

Output file name

This option indicates the name of the associated .xml file. You can rename or remove the stored images.

Images must have been saved with the Save As New Template contextual menu and a 

.CATAnalysis document must be launched (in the opposite case, the Manage button is not 

available).

If you click the Manage button, the Available Images dialog box appears.
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●     Remove...: lets you remove the selected images (multi-selection is available).

●     Rename...: lets you rename a selected image.

●     Remove All: lets remove all the images that are stored in the xml file.

 

All modifications are updated only if you click OK in the Options dialog box.

For example: if you change the path directory after managing images and without clicking OK 

in the Options dialog box, your modifications are not preserved. 
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Quality

This page deals with the following options: 

●     Quality Criteria

●     Default Standard File

●     Export Default Format

Click here to see the parent page.

 

Quality Criteria

This frame lets you visualize the quality criteria that are taken into account and their limit values 

between:

●      good and poor elements

●      poor and bad elements

 By default, all the Quality Criteria are taken into account.

The limit values change as you define the Default Standard File option.
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Default Standard File

This option lets you define the list of quality criteria that will be used by default.

 By default, the Default Standard File field is empty and so all the Quality Criteria are taken 

into account.

Export Default Directory

This option lets you define the default directory in which the criteria configuration have been saved.

 By default, the Export Default Directory field is empty.

While a default directory is not defined, you cannot use the Export Criteria option in the Quality 

Analysis functionality in the Advanced Meshing Tools workbench (for more details, please refer to the 

Advanced Meshing Tools User's Guide - Analyzing Element Quality)
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External Storage

This page deals with the following options:

●     CATAnalysisResults Folder Default Location

●     CATAnalysisComputations Folder Default Location

●     Temporary Data Folder Default Location

●     Clear Computations Mode

●     Renaming Mode

Click here to see the parent page.

 

CATAnalysisResults Folder Default Location

This option lets you change the default directory location of the CATAnalysisResults file.

●     From settings: lets you choose the last selected default directory location (CATSettings).

●     Current CATAnalysis folder: lets you choose the same default directory as the current 
CATAnalysis directory. 

●     Local host tmp folder: lets you choose the temporary directory.

●     Always in...: lets you define a default directory that will be always the same. You have to define 
the path directory.

 By default, the From settings option is activated.
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CATAnalysisComputations Folder Default Location

This option lets you change the default directory location of the CATAnalysisComputations file.

●     From settings: lets you choose the last selected default directory location (CATSettings).

●     Current CATAnalysis folder: lets you choose the same default directory as the current 
CATAnalysis directory. 

●     Local host tmp folder: lets you choose the temporary directory.

●     Always in...: lets you define a default directory that will be always the same. You have to define 
the path directory.

 By default, the From settings option is activated.

Temporary Data Folder Default Location

This option lets you specify the default directory location of temporary data.

●     From settings: lets you choose the last selected default directory location (CATSettings).

●     Local host tmp folder: lets you choose the temporary directory.

●     Always in...: lets you define a default directory that will be always the same. You have to define 
the path directory.

 By default, the From settings option is activated.
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Clear Computations Mode

Automatic clearing of computations data before save

This option lets you set the automatic clearing of computations data before saving documents.

 By default, this option is deactivated.

 Renaming Mode

Automatic renaming of CATAnalysisResults and CATAnalysisComputations files

This option lets you rename automatically the CATAnalysisResults and CATANalysisComputations 

files when you save a CATAnalysis document (using the Save as... menu or the Save Management 

menu) with the new name of the associated CATAnalysis document.

 By default, this option is deactivated.
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AEC Plant
Refer to the Version 5 Plant Layout User's Guide
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Customizing Settings for 
NC Manufacturing

This section describes how to customize settings for NC Manufacturing.

Before you start your first working session, you can customize the settings to suit your working habits. Your 
customized settings are stored in permanent setting files: they will not be lost at the end of your session.

1. Select Tools > Options from the menu bar: the Options dialog box appears. 

2. Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing settings appear, 
organized in tab pages. 

3. Select the tab corresponding to the parameters to be customized.

Parameters in this tab... Allow you to customize...

General general settings for all NC Manufacturing products

Resources tooling, feeds&speeds and resource files 

Operation machining operations

Output PP files and NC data output

Program manufacturing programs (sequencing, and so on)

Photo / Video material removal simulation 

4. Change theses options according to your needs. 

5. Click OK to save the settings and quit the Options dialog box. 
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Customize General Settings

This document explains how to customize General settings for NC Manufacturing products.

These settings are accessed as follows:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing 
settings appear, organized in tab pages.

●     Select the General tab, which is divided up into areas. 

Parameters in this area... Allow you to customize...

Performance settings for optimized performance

Trees Display display of the specification tree

Color and Highlight colors of displayed geometry and parameters

Tool Path Replay tool display during tool path replay

Complementary Geometry handling of geometry necessary for manufacturing

Design Changes use of the Smart NC mode and enhanced detection of design 
changes.

Performance

●     Click the Optimize button in order to automatically set a number of the NC Manufacturing options for 
optimized performance. These options are listed in the Information dialog box that appears: 
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If you click Yes, these options will be set as described in the dialog box. Note that, if needed, you may 
locally reset any of these options.
If you click No, the options will remain with their current settings.

The Information box also lists some recommendations for manually setting other options that have an 
influence on performance. 
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Tree Display

●     Select the checkbox if you want the status of activities in the tree to be updated automatically. 

●     If this checkbox is not selected:

❍     you can update activity status manually in your workbench using the Update Status icon  in 
the Auxiliary Commands toolbar. 

❍     the status of the activity after a manual update is masked at the first action on the node (for 
example, edit, replay, collapse/expand of a parent node). To retrieve the status of the activity you 

must select the Update Status icon  again. 

If this checkbox is not selected, performance is improved.

Color and Highlight

●     Select the colors to be used to identify the various manufacturing entities by means of the combos. 
Note that for Geometry that is not found or not up to date, you can select the colors used to display 
the valuated parameters in the corresponding Operation or Feature dialog boxes.

●     For certain entities, you can select the corresponding checkbox to use highlighting. 
Performance is improved when all the Highlight checkboxes are selected.
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Tool Path Replay

●     Select the first checkbox if you want to display the tool near your cursor position on the trajectory 
during a tool path replay

●     Select the second checkbox if you want to display the tool center point instead of the tool tip during a 
tool path replay

●     Select the third checkbox if you want to display each circular trajectory as a circular arc instead of a 
set of discretization points. The extremities of the circular arc are indicated by means of 'O' symbols.
This allows better control of the Point by Point replay mode, where it is necessary to make several 
interactions to replay a circle (because of its representation by a set of points). With the graphic 
representation as a circle, only one interaction is necessary to perform the replay.

Complementary Geometry

●     Select the checkbox to create a CATPart dedicated to manufacturing-specific geometry in the Product 
List of the PPR tree.

Design Changes

●     Select the first checkbox to activate the Smart NC mode. In this mode, an image of the geometry 
selected in machining operations is kept to allow analysis of design changes.
Performance is improved when this checkbox is not selected.

●     Select the second check box to enable a geometrical comparison mode in order to more precisely 
determine the design change status of machining operations.
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Customize Resource Settings

This document explains how to customize Resource settings for NC Manufacturing products.

These settings are accessed as follows:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing settings appear, organized in tab 
pages. 

●     Select the Resources tab, which is divided up into areas. 

Parameters in this area... Allow you to customize...

Catalogs and Files the path name for resource files

Tool Selection the selection of tools

Automatic Compute from Tool Feeds and 
Speeds

the update of feeds and speeds according to tooling data

Tool Query Mode in Machining Processes 
Instantiation

tool queries in machining processes

Catalogs and Files 

●     Enter the path of the folder containing tool catalogs, PP tables, macros, and machining processes. You can choose a folder by 
clicking the [...] button.

You can concatenate paths using:
❍     a semi colon (;) character for Windows NT platforms.

❍     a colon (:) character for UNIX platform.

For example, if the concatenated folders E:\DownloadOfCXR12rel\intel_a\startup and e:\users\jmn\NC in the figure above contain PP 
tables, then those PP tables will be available for selection in the Part Operation's Machine Editor dialog box.

Please note, however, that:

●     PP tables must be contained in folders named Manufacturing\PPTables

●     tools must be contained in folders named Manufacturing\Tools.

Tool Selection 

●     Select the first checkbox if you want to to activate an automatic query after each modification of a tool parameter. Performance is 
improved when this checkbox is not selected.

●     Select the second checkbox if you want to preview the tool after selection.
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Automatic Compute from Tool Feeds and Speeds 

●     Select the first checkbox if you want the Automatic Update of Feedrates option to be set by default in the Feeds and Speeds tab 
page of machining operations.
This option allows feedrates of operations to be automatically updated whenever feedrate information on the tool is modified.

●     Select the second checkbox if you want the Automatic Update of Speeds option to be set by default in the Feeds and Speeds tab 
page of machining operations.
This option allows spindle speeds of operations to be automatically updated whenever speed information on the tool is modified.

Tool Query mode in Machining Processes Instantiation

select the type of Tool Query to be executed when a Machining Process is instantiated:

●     automatically computed Tool Query

●     interactively defined Tool Selection in case of multiple results

●     interactively defined Tool Selection if no tool is found.

Depending on the selected option, the Advanced tab page of the Search Tool dialog box shows the solved Tool Query for each operation 
in the Machining Process.

In the example below, you can choose one of the tools found in the ToolsSampleMP, or use the Look in combo to select a tool from 
the current document or another tool catalog. 
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Customize Operation Settings

This document explains how to customize Operation settings for NC Manufacturing products.

These settings are accessed as follows:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing 
settings appear, organized in tab pages. 

●     Select the Operation tab, which is divided up into areas. 

Parameters in this area... Allow you to customize...

Default Values the use of default values

After Creation or Machining process (MP) 
Instantiation

what happens after creating machining operations or 
machining processes

When Copying the duplication of geometry links

Display tool path displays of operations

User Interface dialog boxes of 3-axis surface machining operations.

Default Values

●     Select the checkbox if you want operations to be created with the values used in the current program. 
The values and units of attributes at the creation step of an operation are set to the values and units 
of the last edited and validated operation whatever its type (that is, exit the operation definition 
dialog box using OK) .

Otherwise the default settings delivered with the application are used.

After Creation or Machining Process (MP) Instantiation

Select the desired checkboxes to specify conditions to be applied when you create machining operations 
or machining processes.
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●     Sequence machining operations
Machining operations are automatically sequenced in the current program after creation. 
Otherwise, sequencing can be managed in the feature view.

●     Search compatible tool in previous operations
When creating an operation, if a compatible tool exists in a previous operation of the current 
program, it will be set in the new operation. 
Otherwise, the operation will be incomplete.

●     Use a default tool
When creating an operation, a search is done in the document to find a compatible tool. If no 
compatible tool exists, a default one is created in the document and set in the created operation.
If checkbox is not selected, no tool will be defined on the operation.

●     Start edit mode (for machining operations only, not for machining processes)
When creating an operation, Edit mode is automatically started to allow modifying parameters of the 
created operation.
Otherwise, the operation is added to the program but the machining operation editor is not started.

When Copying

●     Select the checkbox if you want geometry links to be duplicated in a copied operation.

Otherwise the geometry must be defined for the copied operation. Performance is improved when this 
checkbox is not selected.

Display

●     Select the checkbox if you want to display tool paths of operations in the current Part Operation.

User Interface

●     Select the checkbox if you want to have the possibility of simplifying the dialog boxes of machining 
operations (that is, you can display the minimum number of parameters necessary for a correct tool 
path). This setting is available for 3-axis surface machining operations only. 

1625Page Infrastructure Version 5 Release 13



Customize Output Settings

This document explains how to customize Output settings for NC Manufacturing products.

These settings are accessed as follows:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing 
settings appear, organized in tab pages. 

●     Select the Output tab, which is divided up into areas. 

Parameters in this area... Allow you to customize...

Post Processor the type of PP files to be used for generating NC code output 
and the path where these files are located

Tool Path Storage the tool path storage capability

Tool Path Edition the tool path edition capability

During Tool Path Computation contact point storage

Tool Output Point type of tool output point

Tool Output Files ... Location default paths for NC output files storage.

Post Processor 

Select the desired Processor option:

●     None: no Post Processor is defined. NC code output is not possible in this case

●     Cenit: you can choose from among the Post Processor parameter files proposed by Cenit to generate 
your NC code

●     IMS: you can choose from among the Post Processor parameter files proposed by Intelligent 
Manufacturing Software (IMS) to generate your NC code

●     ICAM: you can choose from among the Post Processor parameter files proposed by ICAM 
Technologies Corporation (ICAM) to generate your NC code.

Enter the path of the folder containing Post processors. You can choose a folder by clicking the [...] 
button. File concatenation is possible.
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Tool Path Storage

Select the desired option to store tool path data either in the current document or in an external file (as a 
tpl file).

For operations with large tool paths (more than 100 000 points), tool path storage in an external file is 
recommended. 

Tool Path Edition

Select the checkbox if you want to be able to edit tool paths even when the operation is locked. 

This capability is available only for activities with a tool path node in the specification tree.

During Tool Path Computation

Select the checkbox if you want to store contact points in the tool path.

Performance is improved when this checkbox is not selected.

Tool Output Point

Select the desired option to select either the tool tip or tool center point as output point.

Performance is better when the Tool Tip option is selected.
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Default File Locations

Specify default locations for storing Tool Path files, NC Documentation, and NC Code output. 

You can store tool paths files (tpl files) in the same folder as the CATProcess by selecting the checkbox. 
This allows you to store these files according to your CATProcess context. Otherwise, you can choose 
another location by clicking the [...] button.

For NC Documentation, and NC Code output you can choose a folder easily by clicking the [...] button. 

You can customize the extension to be used for NC Code output (by default, the suffix used is 
CATNCCode).
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 Customize Program Settings

This document explains how to customize Program settings for NC Manufacturing products.

These settings are accessed as follows:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing 
settings appear, organized in tab pages. 

●     Select the Program tab to customize program auto-sequencing rules and priorities. These settings 
are mainly intended for the administrator.

Make sure that the document in the sequencing rules path (AllSequencingRules.CATProduct in the 
example below) is accessible in Read/Write.

Auto Sequencing

 
Select the Access to sequencing rules settings checkbox to authorize user access to sequencing 
rules.

You can then specify the path for the rules base 
You can choose a rules base easily by clicking the [...] button.

Select the Display sequencing rules and priorities checkbox to authorize the display of sequencing 
rules and priorities in the user's view. In this case two more checkboxes can be selected in order to: 

●     allow the user to filter rules 

●     allow the user to modify rule priorities.
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Customize Photo and Video Settings

This document explains how to customize Photo / Video material removal simulation settings for NC 
Manufacturing products.

To access these settings:
●     Select Tools > Options from the menu bar.

●     Select the NC Manufacturing category in the tree to the left. The options for NC Manufacturing 
settings appear, organized in tab pages. 

●     Select the Photo /Video tab, which is divided up into areas. 

Parameters in this area... Allow you to customize...

Simulation at material removal simulation at program of Part 
Operation level

Video Video material removal simulation options

Photo Photo material removal simulation options

Performance settings that influence performance

Color color during material removal simulation

Positioning Move allowed tool axis variation between two operations

Simulation at 

●     Select the desired option to perform material removal simulation at either Program or Part Operation 
level. 
Depending on the selected level, simulation begins either from the start of the manufaturing progam 
or from the start of the Part Operation. 
Best performance is obtained with Program level.
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Video 

●     Select the Stop at tool change checkbox if you want the Video simulation to stop each time a tool 
change is encountered in the program.

●     Select the desired Collisions detection option to: 
❍     ignore collisions during the Video simulation

❍     stop the Video simulation at the first collision

❍     continue the Video simulation even when collisions are detected. In this case, you can consult the 
list of collisions at any time duing the simulation.

Best performance is obtained when collisions are ignored.

●     Select the Touch is collision checkbox if you want touch (or contact) type of collision to be 
detected. 

Photo

●     Select the desired Fault box type for examining remaining material or gouges:
❍     Transparent: to display a transparent bounding box

❍     Wireframe: to display a wireframe bounding box

❍     None: if no bounding box is required.

Best performance is obtained when no bounding box is required and the checkbox is not selected.

●     Select the checkbox to compute all information at picked point.
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Performance 

●     There are three methods of tool faceting used in Video simulation: Standard, Smaller and Larger. 
The number of facets for a tool representation is determined by the chord deviation that is set for the 
tool diameter (0.005% of the tool diameter). 

❍     Smaller: The picture shows a rough approximation of a tool with six facets. Note that the chord 
deviation is always inside the actual circle, and that the points are always on the circle 
(accurate).  

This is the most accurate method for the Arc through Three Points command.

❍     Standard: The picture shows a rough approximation of a tool with six facets. Note that the chord 
deviation is partly inside and partly outside the actual circle, and that the points are not always on 
the circle.
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This is the best method for material removal simulation. 
However, this is not suitable for the Arc through Three Points command.

❍     Larger: The picture shows a rough approximation of a tool with six facets. Note that the chord 
deviation is outside the actual circle, and that the points are not on the circle.

This is not suitable for the Arc through Three Points command.
However, it can be useful for gouge detection.

●     Set the resolution for Photo simulation. 
Best performance is obtained when the resolution is set to 0. In this case, a detailed simulation of a 
portion of the part can be obtained using the Closeup command.
Increasing the resolution improves machining accuracy and gives a very detailed 
simulation. However, this requires increased memory and computation time.

●     Specify the maximum angle that the tool axis is allowed to vary between two consecutive points. 
Best performance is obtained for an angle of 10 degrees. Decreasing the angle improves the precision 
of the simulation. However, this requires increased memory and computation time.

●     Set the Optimized rendering for Video checkbox to obtain an optimized rendering to improve 
Video simulation performance.
Otherwise, more realistic colors are obtained with a slightly degraded performance.
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Color 

●     Set the tool (and associated machined area) color to be the same as or different from the last tool, or 
have different colors for all tools. Best performance is obtained with same colored tools.

●     Assign colors to the different tools using the associated color combo.

●     Assign colors to tool holders, parts, and fixtures using the associated color combos.

Positioning Move

●     Set the Maximum tool axis variation that is to be allowed between the end point of an operation 
and the start point of the next operation. If the tool axis varies by an amount greater than the 
specified value, then the tool is positioned at the start of the following operation.
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Digital Mockup

DMU Navigator

DMU Space Analysis

DMU Fitting

DMU Immersive Review

DMU Optimizer

DMU Space Engineering
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Customizing for DMU Navigator
 

Customizing General DMU Settings
Customizing DMU Navigator Settings

Customizing Product Visualization Settings
Customizing Multi-Process Settings 

Customizing Cache Settings
Customizing Visualization Settings

Customizing 2D Workshop Visualization Settings
Customizing Product Structure Settings

Customizing Navigation Settings
Customizing External Format Import 
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Customizing General DMU Settings

This task explains how to customize general DMU settings.

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears

2. Click the Digital Mockup category.

The General tab is active.

The General tab lets you customize: 
●     Automatic display of preview windows

 
3. Click preview checkboxes as appropriate to change the automatic display setting of preview 
windows when creating cameras, manipulating objects, etc.

By default, preview windows are automatically displayed.

 
4. Click OK in the dialog box when done. 
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Customizing DMU Navigator Settings
This task explains how to customize DMU Navigator settings.

1.  In the menu bar, select Tools -> Options.

The Options dialog box appears.

2. Click the Digital Mockup category, then click the DMU Navigator tab.
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The DMU Navigator tab enables you to customize: 
●     Hyperlink representation (name)

●     Marker Default Properties

●     Scene Default Properties

●     3D annotation update (when moving the product)

●     Spatial Query parameters

●     Import of applicative data

 

You can add hyperlinks to your document and then use them to jump to a variety of locations, for 
example, to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the 
intranet.

3. In the  Hyperlink Representation area, check the Name selection box.

By default, hyperlink names are displayed : all hyperlink  will be textual. The name you give the 
link in the Manage Hyperlink dialog box when you create it will appear when using go to hyperlink. 

 

4. Click preview checkboxes as appropriate to change the automatic display setting of preview 
windows when creating cameras, manipulating objects, etc.

By default, preview windows are automatically displayed.
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5. Change the color, font type and font size of 2D markers. 

Note: Defining the Marker default properties in the Tools->Options->DMU Navigator sets the 
selected properties as default properties and changes how new annotations will look when you 
create them.

 6. Click the 2D Marker Product Name Recognition checkbox in order to activate the option to 
automatically use a Part's Name as the default for the creation of text annotations.

 7. Click the 3D Marker with Graphic Message Mode checkbox in order to activate the 
mechanism that enables you to transform temporary markers into persistent 3D annotations.

8. Change the Scene background color as desired.

9. Uncheck the Update on Product Structure Modifications and Scenes Activation option if 
necessary. This option manages a publish/subscribe mechanism which will manage the automatic 
updates of certain events:

●     move

●     shape activation

●     insert 

●     replace product

●     delete product

●     UI-activation modification

●     graphic attributes modification

●     Enhanced Scene activation 

If the option is unchecked, some applicative data will not be automatically updated upon the above 
events. However, if the option is unchecked, performance will be faster.  

 
10. To activate the automatic launching of Publish results in a browser upon the stopping of the 
Publish process, in the Publish area, check the Browser automatically opened checkbox .
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 11. Spatial Query Released Accuracy

The default value for released accuracy is 20mm.
This value can also be defined by the administrator.

How do you, as administrator, define the released accuracy value?

●     you set a precise and required value in the Released Accuracy field.

●     you then run the CATDMUUtility batch process without defining the -vox  option, the 
released accuracy value is taken into account. The data is pre-tessellated. 

●     you check the Force Released Accuracy in interactive command checkbox if you 
wish to force users of the Spatial Query command to use the defined Released 
Accuracy. 

 12. Spatial Query Clearance

The default value for clearance is 0mm.
This value can also be defined by the administrator.

How do you, as administrator, define the clearance value?

●     you set a precise and required value in the Clearance field.

●     you check the Force Clearance in interactive command checkbox if you wish to 
force users of the Spatial Query command to use the defined Clearance value. 

 

13. Import Applicative Data

●     Do the Import:
❍     activated: the applicative data will be inserted

❍     not activated: the applicative data will not be inserted

●     with user prompt: a dialog box will appear enabling you to select any subset of 
applicative data to be inserted

●     automatically: all applicative data will be inserted, no dialog box will appear
❍     activated: the applicative data will be inserted

14. Fast Clash Detection 

●     If you select a voxel size and check the View Collision Feedback button, then you obtain a clash 
detection with a voxel precision of the size selected, with the clashing parts highlighted, and the 
center of the voxel points appearing in red. 
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●     If the View Collision Feedback button is unchecked, then you will obtain a clash detection with 
only the clashing parts highlighted. 

●     If you select sag precision and check the View Collision Feedback button, then you obtain a 
clash detection with the precision of the sag. The clashing parts are highlighted and the 
intersection curve of the clashing parts appears in red. 

●     If the View Collision Feedback button is unchecked, then you obtain clash detection with with 
the clashing parts highlighted. 
 

15. DMU Review Default Properties

In the Name text-entry field, enter the desired default name for DMU Reviews.
 

 16. Note that you need to exit and restart to see the effects of customization, so click OK to 
confirm. 
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 Customizing Product Visualization Settings

This task explains how to customize Product Visualization settings.

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears

2. Click the Infrastructure -> Product Structure category.

3. Click the Product Visualization  tab.

The Product Visualization  tab enables you to customize: 

●     Default shape activation on open 

●     Visualization mode type

 

4. In the Representation area, check the Do not activate default shapes on open selection 
box. 

 
5. In the Visualization mode type area, check one of the following visualization mode types: 

●     Visualization mode with local cache

●     Multi-process visualization mode with local cache

Note that the last two visualization mode types are currently grayed out and are not available.

By default, preview windows are automatically displayed.
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Customizing Multi-Process Settings

This task explains how to customize Multi-Process settings. These multi-processes concern the 
CATDMUUtility processes that are created as child processes for the tessellation of documents when 
performing a File -> Open of a CATProduct or when running the CATDMUUtility batch process 
using the -mp option. This new feature enables the management of possible coredumps and / or 
looping problems during tessellation such that the impact is localized to the specific document that 
cannot be tessellated; the state of a V5 session will no longer be impacted by these problems and a 
CATDMUUtility batch process will run to conclusion. A log file indicates which documents could not 
be tessellated.
1. Select Tools -> Options from the menu bar. 

The Options dialog box appears.

2. Click the Digital Mockup category.

3. Click the Multi-Process Settings tab.

The Multi-Process Settings  tab enables you to customize: 

The maximum number of child processes that will be launched.

The maximum amount of time a process will be allowed to loop before it is killed.

The path of the log file that will report the success or non-success of each tesselation concerned 
with the opening of a CATProduct.

The number of child processes is limited to 1. 

4. In the Maximum son processes text-entry field, enter the maximum number of child 
CATDMUUtility processes to be used during tessellation.
5. In the Timeout (minutes) text-entry field, enter the maximum time that a single  tessellation 
process will be allowed to loop before being aborted.
6. In the Log File Path text-entry field, enter the path of the log file of the tessellation process or 

click the Browse icon  to choose a path via the File Browser. 

 

1644Page Infrastructure Version 5 Release 13



 Customizing 2D Workshop Visualization Settings
This task explains how to customize the background color of your 2D Workshop session.

1. Select Tools -> Options from the menu bar. 

The Options dialog box appears.

2. Select the Digital Mockup category.

3. Click the 2D Workshop  tab.
4. Modify the Background color to the color of your choice: 

Click on the Background color bar .

Enter the different values for Red, Blue, Green or click on the combo-box selection button and choose the desired standard color 
from the proposed list.

●     Click on the Background color bar .

●     Enter the different values for Red, Blue, Green or click on the combo-box selection button and choose the desired standard color 
from the proposed list.

5. If you wish the background color to be graduated, click the Graduated color background selection box.
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Customizing for DMU Space Analysis
 

DMU Clash
DMU Clash - Detailed Computation

DMU Clash - Penetration
DMU Clash - Rule

DMU Clash - Process
DMU Sectioning
DMU Distance
Measure Tools
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DMU Clash

 

 

This task explains how to customize the clash settings of the Clash command.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup category, then the DMU Space Analysis subcategory. 

3. Click the DMU Clash tab.

 
The DMU Clash tab lets you customize the following clash command settings: 

Retrieve Information: retrieves clash results for comparison purposes: 

●     From previous computation
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●     From PDM: from both Enovia V5 and Enovia VPM. 

Note: This setting cannot be combined with the authorized penetration interference type.

 
●     No comparison (default setting)

 Results Window / Automatically open: automatically displays the results window when you run 
a clash command computation. 

Display in Results box:  three options to set the default display in the results box of the Check 
Clash dialog box: 

●     List by conflict tab (default setting).

●     List by product tab.

●     First line automatically selected: automatically selects the first line in the List by Conflict or List 
by Product tab (default setting).

Type of Computation: sets the default computation type and, if necessary, the default clearance 
value.

During Initial Computation: specifies what the system computes in addition to detecting and 
identifying the different types of interference. 

●     Compute penetration depth or minimum distance: if selected, automatically computes and 
displays the penetration depth and minimum distance for all interferences detected.

●     Compute all numeric and graphic results: if selected, automatically computes and displays 
numeric results as well as graphic results as defined in the Detailed Computation tab.

Note: Computation time can be long. 
In this case, the progress bar shows the status of the calculation in two different steps:

Stage 1/2: determines the number of interferences
Stage 2/2: computes appropriate numeric and graphic results.
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●     None: if selected, the initial computation detects and identifies the different types of interference 

only. 

4. Click OK in the dialog box when done
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DMU Clash - Detailed Computation

 

 

This task explains how to customize the detailed computation settings of the Clash command. 

The detailed computation mode defines what is computed when you select a conflict or product in 
the Check Clash Results box. It can be run at element or product level.

By default, the detailed computation is run at element level. The graphics representation of 
interferences (triangles for contacts and clearances, curves for clashes) and the  penetration depth 
or minimum distance are computed.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box. 

3. Click the DMU Clash - Detailed Computation tab.
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The DMU Clash - Detailed Computation tab lets you customize the following settings:  

Level of Detail: sets the level of detail.  

●     Element: lets you work globally at product level while allowing you to pinpoint the elements 
involved. 

●     Product: gives information at product level only.

Note: Element analysis in Detailed Results and Visualization boxes is only available if the level of 
detail is set to Element.
Clash Result: specifies the graphics representation for clashes. 

●     Curve: Red intersection curves identifying clashing products are computed and displayed. 

●     None: No intersection curves are computed.
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 Contact & Clearance Result: specifies the graphics representation for contacts and clearances. 

●     Triangles: Yellow and green triangles identifying products in contact and products separated by 
less than the specified clearance distance respectively are computed and displayed. 

Note: The graphics display and storage of the triangular representation is costly and may 
adversely affect performance.

●     Surface: Yellow and green surfaces identifying products in contact and products separated by 
less than the specified clearance distance respectively are computed and displayed. 

If you select this option, you must set an accuracy. The value entered defines the maximum 
value for the length of the longest side of a triangular representation of the results. This 
representation is used to obtain the yellow and green surfaces.

●     None: No triangles or surfaces are computed.

Numeric Result: specifies the numeric result computed and displayed. 

●     Penetration depth or minimum distance: The penetration depth of clashes and the minimum 
distance for clearances is computed and displayed.

●     None: No penetration depth or minimum distance is computed.

 Intersection Volume: specifies a graphics representation for clashes. This representation can be 
requested in addition to that selected under Clash Result.

Important: The intersection volume is only visible in the Results window.

●     Voxel: Voxels (cubes) identifying clashing products are computed and displayed.

If you check this option, you must set the voxel size. The value entered is the edge-length of 
the voxel or cube. A lower value will give a more accurate result but will also require a longer 
computation time and more memory. The minimum value is 1mm (0.03937 inch).

 
●     Boolean: Boolean solids identifying clashing products are computed and displayed.

●     None: No intersection volume is computed.

Notes: 

●     The intersection volume is also given in the Detailed Results box of the Check Clash dialog box.

●     The intersection volume is not stored in the model and cannot be saved in ENOVIA LCA or 
ENOVIA VPM.

 4. Click OK in the dialog box when done.
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DMU Clash - Penetration

 

This task explains how to customize the penetration mode setting of the Clash command.

The penetration mode defines how penetration depth is computed. Two modes are available:

●     Element (default mode)

●     Product.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box. 

3. Click the DMU Clash - Penetration tab.

The DMU Clash - Penetration tab lets you set the penetration mode: 
Mode of Penetration: Element 

This is the default mode and lets you assess the seriousness of a clash.

In the Element mode, penetration depth corresponds to the depth of the intersection area 
visualized by the penetration vector. The maximum value is output, in our example, N2.

Note: You cannot use this calculation to translate products and avoid clashes.

In our example, the green product comprises 
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three elements and the blue product two 
elements.

Mode of Penetration: Product 

In the Product mode, penetration depth (visualized 
by a vector) is the minimum distance by which it is 
necessary to translate a product to avoid a clash.

This mode corresponds to the penetration depth 
computation prior to Version 5 Release 8.

4. Click OK in the dialog box when done
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DMU Clash - Rule

 

This task explains how to customize clash rule settings. 

Clash rules written using knowledgeware capabilities can be used in the Clash command.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box. 

3. Click the DMU Clash - Rule tab.

 
The DMU Clash -Rule tab lets you identify the full path to the CATProduct containing knowledgeware 
clash rules. 
4. Click OK in the dialog box when done
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DMU Clash - Process

 

This task explains how to customize process settings of the Clash command.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box. 

3. Click the DMU Clash - Process tab.

 
 The DMU Clash - Process tab lets you customize XML settings:  
 

●     XML export for class process purpose: exports clash results and geometry to XML files as 
part of a standalone clash process.

●     Federated XML output: generates one file per conflict plus one header file summarizing 
results. If you de-activate this option, a single large XML file containing all conflicts is 
generated.

●     Picture generated in XML: generates pictures in png format in a picture folder. This option 
has an obvious impact on performance.

●     Browser automatically opened: automatically opens a browser displaying results when clash 
results are exported.

●     Database repository: sets the default location in which to save the XML files.

●     Style sheet location: lets you select and apply your customized style sheet.

4. Click OK in the dialog box when done
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DMU Sectioning

 

This task explains how to customize sectioning settings.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box 

3. Click the DMU Sectioning tab 
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The DMU Sectioning tab lets you customize: 

Section Planes: sets default section plane settings.

●     Default color: sets the default color of the section plane.

●     Normal X,Y,Z: specifies the absolute axis along which you want to orient the normal vector of the 
section plane (master plane in the case of slices and boxes).

●     Origin: locates the center of the plane at absolute coordinates 0,0,0 or at the center of the bounding 
sphere around the products in the selection you defined.

●     Hide the plane: hides the plane on exiting the command. De-activate this option to keep the plane in 
the Show space.

●     Hide the section results in the No Show space: transfers the section results to the No Show place on 
exiting the command.

●     Automatic computation of the result: automatically updates sectioning results while manipulating the 
plane. De-activating this option means that results are computed when you release the mouse 
button.

●     Wireframe elements cut: the section plane sections any wireframe elements present. Points 
represent the intersection of the plane with wireframe elements.
De-activating this option means that wireframe elements are not taken into account. 

Section Grid: sets default grid options. 
●     Absolute  mode: sets grid coordinates with respect to the absolute axis system of the document.

●     Relative mode: places the center of the grid on the center of the section plane (master plane in the 
case of slices and boxes).

●     Style: sets the grid representation to lines or crosses.

●     Automatic filtering: if clicked, automatically adjusts the level of detail of the grid display when you 
zoom in and out.

●     Steps: specifies the spacing between grid lines. The default value is 100. Units are current units set 
using  Tools -> Options.

●     Automatic grid resizing: automatically re-sizes the grid to section results when moving the section 
plane. De-activating this option means that the grid has the same dimensions as the section plane.

 Automatic grid resizing ON: Automatic grid resizing OFF:
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 Results Window: sets default Section viewer settings. 
 

●     Automatically open: always displays the Section viewer when in the Sectioning command. 
Note: If cleared, the preview window is displayed. 
If, in addition, you clear the Sectioning preview option in the Digital Mockup General tab (Tools -> 
Options -> Digital Mockup -> General), then no viewers are displayed.

●     Always 2D view: always displays the 2D view in the Section viewer.

●     Automatically reframe: automatically fits the results into the available space in both the Section 
viewer and preview window when manipulating the section plane in the document window.

●     Section fill: fills in the section to make a surface for measurement and display.

4. Click OK in the dialog box when done
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DMU Distance

 

This task explains how to customize results window and publish settings of the Distance and Band 
Analysis command.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup -> DMU Space Analysis in the left-hand box. 

3. Click the DMU Distance tab.

 
The DMU Distance tab lets you customize Distance and Band Analysis command settings. 

Results Window / Automatically open: automatically displays the results window when you run 
a distance command computation.

XML Publish Default Directory (Band analysis only):

●     Default path: sets the default location in which to save the XML file.

●     Style sheet: lets you select and apply your customized style sheet.

●     Browser automatically opened: automatically opens a browser displaying results when 
distance results are exported.

4. Click OK in the dialog box when done
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Customizing for DMU Fitting Simulator
DMU Fitting Settings

DMU Manipulation Settings 
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Customizing DMU Fitting Settings

This task explains how to customize DMU Fitting settings.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup in the left-hand frame, then DMU Fitting.

 

The DMU Fitting tab is active by default.  If it is not on top, select it.  The default values are 
shown below.

Shuttle Angular Validation
Checking the box enables you set the angular shuttle validation option in the Edit Shuttle 
dialog box. 

You can specify a maximum rotation angle for the shuttle and the vector around which the 
shuttle will rotate.
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Path Finder
Automatic Smooth: If checked, smooth is performed within 
the pathfinder command once you click the OK button.

Track
Automatic track update: if checked, the track is automatically updated after modification.
The manual update is set by default (see the track contextual menu).

Default speed is 0.001m_s.  You can modify this value at any time.  When you modify the 
default speed, the modification applies to tracks created after the modification.  To modify 
the speed on existing tracks, use the Properties dialog box.

Default Clash Detection
When activating the default clash detection, the clash computation can take several minutes 
before the simulation dialog boxes are displayed. 

Sometimes it is more convenient not to compute this clash detection for the first step. 

This step can already be validated by a static clash analysis. 

●     Activated only while moving: if checked,  no calculation will be performed when the 
default clash detection is activated (ON, STOP). When running tracks, sequencesm, and 
simulations, clashes are still calculated with respect to the default clash detection state 
(OFF, ON, STOP)

●     By default this option is not checked

3. Click OK in the dialog box when done.
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Customizing DMU Manipulation Settings

This task explains how to customize DMU Fitting settings.

 

1. Select Tools -> Options from the menu bar: 

The Options dialog box appears.

2. Click Digital Mockup in the left-hand frame, then DMU Fitting.

3. Select the DMU Manipulation tab.  The default values are shown below.

Clash Feedback
Click the Clash Beep checkbox to activate the Beep during interference analyses, simulation recordings, etc.

By default, the Clash Beep option is unchecked. 

Automatic Insert Configurations
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●     On mouse release (default): Lets you record positions on mouse release.

●     While mouse moving:

❍     Distance: Specifies the minimum distance step during simulation recording .

❍     Angle: Specifies the maximum rotation angle step during simulation recording. 

The Distance and Angle fields are only grayed out when On mouse release is checked.  Once While mouse 
moving is checked, you can enter the appropriate values to record the the motion.

Regardless of which configuration you have selected, you will not get Automatic Insert unless the Automatic Insert option is 
checked in Manipulation Mode, described in the section below.

Manipulation Mode for Simulations and Tracks
Lets you validate the shuttle simulation detecting clashes.

This setting is linked to the Automatic Clash Detection toolbar. The icon changes automatically with respect to the option 
checked.

●     No clash detection (default) : Clash detection will not occur.

●     Clash detection on : Activates the clash detection mode 
(The objects in clash are highlighted in the geometry area while recording the simulation )

●     Stop on collision : Activates the stop mode.  Consequently, the simulation stops once any objects clash.  The 
objects in clash are highlighted in the geometry area.

●     Automatic insert: When checked, it enables automatic insert mode.  Automatic insert mode enable users to insert shots 
in a track without using the Record (Insert) command on the Recorder toolbar.  The two configurations available for 
Automatic Insert appear above.

Snap Sensitivity
Lets you customize the snap 
functionality parameters within a 
sphere and a cylinder:

●     Position value: Specifies the 
sphere radius (first area) 
where the shuttle is snapped 
onto the object.

●     Orientation value: Specifies the 
cylinder height (second area) 
where the shuttle is snapped 
onto the object.

3. Click OK in the dialog box when done.
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Customizing for DMU Immersive Review 
Customizing DMU Immersive Review

Customizing 3D Joystick Buttons
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Customizing DMU Immersive Review Settings
This task will show you how to customize DMU Immersive Review Settings

1.  Select Tools->Options from the menu bar. 

The Options dialog box appears

2.  Expand the Digital Mockup category from the upper-left tree

3.  Click the DMU Immersive item:

The DMU Immersive Review tab page appears containing three categories of options:

●     Starting Options

●     Scale of the review

●     Default toolbar position

Starting Options
 

 

Viewpoint tracking

If you select this check box, the viewpoint changes as your head turns if you use a head tracker device.
This option is linked to Stereoscopic option which enables or disables 3D visualization of your session. You need to 
launch the device driver. Please refer to Customizing Devices Settings 

Stereoscopic

Enables or disables stereoscopic visualization of graphical data with a perception of realistic, three-dimensional 
images.

P3 grid

Enables to display the P3 grid when you enter the DMU Immersive Workbench

Action triggers activated by default

If you select this check box a "demo mode" is launched which means each time you select an object which has 
been assigned an action trigger, the operation is automatically launched (the CATScript macro is triggered). In this 
case, only the standard toolbar is available, the action triggers command is activated.

If you clear this check box, you need to click the Action Triggers icon first and then select the object. All 
immersive review toolbars are available.

 

Scale of the Review
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To get the most of this capability, make sure either the Stereoscopic check box is selected (MPK compliant) or both 
Viewpoint Tracking and Stereoscopic check boxes are selected.  

Note: when selecting the Start at the scale defined below check box, the following warning message is displayed:  

  

Start at the scale defined below

activates the scale command when entering Immersive Review workbench, it is selected by default.

Display the current scale

activates the display of the current scale factor (at the bottom left in the review window)

Scale of the review:

allows the user to define a specific scale factor (i.e the required scale, applied by the Scale command)

Default toolbar position

 

Default toolbar position

You can choose the toolbars location. The default location is at the bottom left (lower left option), but is can be 
useful to turn on the upper left option depending on the display configuration you need (one or more screens)

 

4.  Click OK in the dialog box when done.
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Customizing 3D Joystick Buttons 
This task explains how to customize 3D Joystick buttons which allows you to assign (i.e. map) any given command or macro a device 
button. 
This functionality is available for any application-supported hardware providing the necessary buttons, e.g. Space Mouse and the 
Space ball range of 3D input devices.

Please also read Customizing Buttons in the Infrastructure User's Guide

1.  Select Tools->Customize commands, choose the Commands tab then click the VR Customize button

You can also access the Button Customize dialog box using one of the methods below:
1.  select the View->Commands List commands then select the VR Button Customize command
2.  type  c:VR Button Customize or  c:3Dx Button Customize in the power input field then press 

ENTER
3.  press button "1" of your Space Mouse or Spaceball (if you are using original settings).

 
The Button Customize dialog box is displayed:
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2.  Use the input device name area on top of the dialog box to select the desired device from the drop-down list in order to 

modify button mappings.

In our example, the device is a Joystick3D. 

3.  Map the desired device button to a particular command or macro using one of the methods detailed in Customizing Buttons 

For example, using the Drag and Drop capability from the Customize toolbar (still open)
1.  In the Categories list, select a category to map a command, or select the "Macros" category to map a macro.
2.  Select the command or macro to be mapped from the list of commands. 

3.  Press and hold down the left-mouse button on top of the command or macro entry. 

4.  Drag the icon to the top of the button drag-and-drop area.
5.  Release the left-mouse button. 

The command is assigned to the device button.

4.  Repeat step 3. as many times as needed to map your 4 device buttons. 

In our example, we assigned the following commands:

Commands Buttons

Wireframe: Button1

Shading Button2

Zoom In Button3

Zoom Out Button4
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Note that when entering the DMU Immersive Review workbench, the commands assigned to the first two buttons 
(button1 button2) are automatically deactivated

If you wish to remove a button mapping, simply right-click the desired button drag-and-drop area then select the 
Delete contextual command. This will empty the button drag-and-drop area to indicate that no macro or command is 
currently assigned to this device button.

5.  Press the desired device button to activate the command you assigned to it. 

This is what you obtain if you press button1 and button2 successively:
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The help area in bottom part of the panel displays a help text for the corresponding mapped command
when a device button is pressed (a red arrow identifies in the panel the button you press)
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 DMU Optimizer Settings

This task will show you how to manage representations as alternate shapes automatically.

1.   Select Tools->Options from the menu bar 

 

The Options dialog box appears

2.  Expand the Digital Mockup category from the upper-left tree 

 

 New 3D Cut and Merger representations can be managed as alternate shapes
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3.  Click DMU Optimizer item to display the corresponding tab

4.  Select the required representation, for example Offset.

5.  Customize the representation settings as required using the following options:

❍     Manage as alternate shape: if this check box is selected, the resulting offset shape is managed as the offset component alternate shape 

(i.e. input component)

❍     Activate Shape: if this check box is selected, the offset representation becomes the one visualized in the session.

❍     Default Shape: if this check box is selected, the offset representation is the default shape, i.e. the one loaded when opening the product.

 

Saving Operation...

 

6.  Specify the required path for save: 

❍     enter the precise path

❍     use the browse button  to display the following dialog box:
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Note: the path/directory you selected for one shape is now the default path specified in the Save as dialog box. You can still 
change it, if you need to when saving. You can customize a specific path/directory for each alternate shape.

 

7.   You can also customize vibration volume and wrapping color
 

❍     selecting the Use part color when possible, otherwise... check box: this is useful to swap from the part color to another color when it is 
appropriate (default color or a color of your choice)

❍     selecting a color of your choice from the color palette (using  the drop-down list) or keeping the default color
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A list of sixteen default colors from the color palette as well as the More Colors option appear

 

8.  Click Ok to confirm your operation 

After a new offset calculation, if you right-click the product and select Manage representations, the Manage representation dialog box is 

automatically updated with the offset representation.
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In DMU Optimizer, it is impossible to generate various alternate shapes with the same 
name. Only the last generated alternate shape is taken into account.
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Customizing DMU Space Engineering Settings

 

This task explains how to customize DMU Space Engineering settings.

1.  Select Tools -> Options from the menu bar: 

The Options dialog box appears

2.  Click Digital Mockup category.

3.  Click the DMU Space Engineering tab.

The tab page appears, containing three categories of options:

❍     Connection Mode

❍     Server Connection Parameters

❍     Clash Result Path
 

Connection Mode

Automatic

If you select the Automatic check box, DMU space Engineering Assistant is automatically connected to the http server, you do not 

need to click the Connect/Disconnect icon . 
(The connection is established during the Send to CATIA... operation)

If disabled (default mode), you need to connect manually the server clicking the Connect/Disconnect icon in the Spy toolbar.

 

Server Connections Parameters
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Host Server

Specify the host server name (name of the machine hosting the Apache server) using the drop-down list.

Port Server

Specify the port server name (it is grayed out by default).

Clash Result Path
 

Path

Click Browse and specify the path directory where the clash results are to be written.

4.  Click OK in the dialog box when done.
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Equipment and Systems
  Understanding Project Resource Management

Using the PRM Command
General
Display

Specification Tree
Diagrams

Electrical Mapping
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Electrical Process Interfacing
Electrical Assembly Design

Electrical Harness Flattening
Electrical Wire Routing

Electrical Harness Installation
Electrical Connectivity Diagrams

Electrical Cableway Routing
Equipment Support Structures

Electrical 3D Design and Documentation
Structure Drawing

Structure Preliminary Layout
Structure Functional Design

Circuit Board Design
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Understanding Project Resource Management
This task shows you how to manage project resources like catalogs and dictionaries. These changes can only be made at 
system administrator level.

The Project Resource Management (PRM) file identifies resources (such as line list catalogs, user dictionaries, etc.) to the 
application. Specifically, the PRM file identifies each resource and its location (directory path). The PRM file also organizes 
the resources by discipline and application, associating resources to specific applications. Therefore, you get the correct 
resource, equipment catalog for instance, for the resource you are working in.

It's hierarchical structure allows you to share resources, so that you do not have to place duplicate copies of the same 
resource in several directories.

The PRM file is also used for certain other purposes, such as setting flags. These are explained below.

A sample file is provided with this application, and it is best to make a copy of it and edit it. The default location is 
...intel_a\startup\EquipmentAndSystems\ProjectData and the file is named Project.xml.

The application will function even if the user does not enter information particular to his site,  but nothing can be saved. 
Therefore, the first task an administrator needs to do is enter information relevant to his site or project.

1.  If there is more than one project at your site then make a project resource management file for each project. You 

can name the file anything you want to and change its location too (see below). However, you must set the 

variable in the Environment Editor. You do this by opening the Environment Editor dialog box and entering against 

the line CATDisciplinePath the directory in which your project resource management files are: 

If you have more than one project resource management file then by default the application will start with the file 
named Project.xml, if there is such a file, or the last file used. If you wish to select another resource 
management file then you must open it by clicking Tools - Project Management. Go to the Select tab, and 
select the file and discipline you need. This dialog box shows each resource available to you, unless the value of 
"Visible" (see below) against a resource or application is set to No.

2.  The resource management file is organized into several sections to make it easier to manage and utilize 

resources. The image below shows its hierarchical structure, with an exception, which is explained below. "Other 

disciplines" refers to other disciplines like Tubing, or AEC V4 to V5 Migration Discipline, that are placed at the same 

level. They are not shown in this image for reasons of space.
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The Project box refers to the project for which the PRM file has been created, and will frequently be identified by 
the file name. In this case it is Project.xml.

When you look at the Project.xml file you will see that the resource listings begin with project resources. Any 
resources you place under the heading Project Resources can be used by all applications that are included in the 
file. In the sample file you will see items like zones, feature dictionary and application-generated object names in 
this section. All disciplines and applications shown under project resources will be able to access the resources 
identified under the heading project resources.

The next level is the discipline level. All resources placed under a discipline, such as Piping, can be used by all 
the applications which are listed under it. In the example above, Piping Diagrams, Piping Design and Equipment 
applications are shown under the Piping Discipline. Resources such as various catalogs and report definitions are 
listed at the discipline level and can be accessed by all applications that belong to that discipline.

The next level of resource management is the application itself. Any resource referred to at this level can only be 
used by that application. Resources like catalogs, files that contain connector attributes and resolved parts 
directories are listed at this level.

Equipment Arrangement and Hanger Design have been placed under several disciplines. These applications are 
considered multi-discipline because their resources are used by all disciplines. When you are working in these 
disciplines you may need Equipment or Hanger resources. However, in different disciplines you may not use the 
same resources from Equipment Arrangement or Hanger Design and this structuring allows you to place different 
resources under each discipline. For instance, under the Piping Discipline, Equipment Arrangement may have a 
different catalog (with Piping related equipment only) than under the HVAC Discipline.

Equipment and Hanger applications have also been placed at the project resource level, primarily to allow sharing 
of resources, under the headings "Equipment Application Resources" and "Hanger Design Application Resources".

To explain: If you are working in Piping Design you are in the Piping Discipline. You select the discipline by 
clicking Tools - Project Management, or simply by opening an application, which will activate the correct 
discipline. For this to happen your PRM file must be set up correctly.

Now, while in the piping workbench, you want to place equipment in your document, and you launch Equipment 
Arrangement. When you do so you will only have access to equipment resources that are identified in the PRM file 
under the piping discipline, for instance the "piping equipment catalog" containing piping related equipment. But 
let us assume that in your project you have certain types of equipment that are used by all disciplines. You can 
create a catalog that contains all this common equipment and identify it under "Equipment Application Resources" 
at the project level (it should not be identified under discipline also). When you do this you will have acecss to 
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this catalog when you open Equipment Arrangement under any discipline.

Some applications have the entry "Visible = yes". If you set the value to No then this application cannot be used 
and will not be visible in the Tools - Project Management dialog box.

3.  A resource entry looks like this:

<Resource Name="PipingIDSchema" Description="Piping ID Schema Directory">
<ID Type="Path" Driver="File" Location="..\..\EquipmentAndSystems\Piping\DataDictionary"/> 
</Resource>

❍     You should not change the Resource Name, even if you replace a resource with a different one. 

❍     You can change the Description if you want to - this is a brief explanation of the resource.

❍     The Type field refers to file type. If the Type field says CATIA, then it refers to a file type unique to CATIA, 
such as .catalog. The type Misc is used for resources which are of a type not unique to CATIA and must be 
opened in another way. The type Path is similar, except that in the Location field only the directory in which 
the resource is located is named.

❍     If your resources do not reside in ENOVIA then enter File in the Driver field. Define the Location field as 
follows: As shown in the resource example above, the location entry is relative - it is relative to the entry you 
made in the Environment Editor as shown in Step 1. The entry in the location field will be added to the entry 
you had in the Environment Editor and it is in that location that the application will look for the resource. 
Which is why it is preferable to enter absolute paths - including the drive letter - in the location field.

❍     If your resources are ENOVIA-based then enter ENOVIAV5 in the Driver field. For ENOVIA-based resources, 
all you need to enter in the Location field is the file name of the resource without the file extension. For 
instance, the catalog PipingParts.catalog would be entered as PipingParts.

❍     The Location field is sometimes used to enter a value for a flag or behavior, such as 0 or 1, or True and False.

❍     Some resources have the entry "Visible = yes". If you set the value to No then this resource cannot be used 
and will not be visible in the Tools - Project Management dialog box.

4.  The Project Resources listed in the sample Project.xml file are described in the following sections, beginning with 

the resources referred to under Project Resources:

❍     ID schema resources: The "location" lists the directory where the rules for naming objects are stored. Use 
the default location provided in the sample file. You need to have this for every application you use. In 
addition, there is an entry for "MultiDisciplineIDSchema." This location is used for objects -such as zones - that 
are used by all disciplines. 

❍     User dictionary resources: In the location field enter the name of the CATfct file for each application. You do 
not need to enter the location. The CATfct file is used to store all the classes and attributes created by you. 
The default names for CATfct files in each application are included in the sample project.xml file and you 
should use these names unless you have created a different CATfct file, or changed the default name. There is 
also a MultiDisciplineUserDictionary - this CATfct file can be referred to by all applications.

❍     Zones catalog: The zones that you create need to be stored in a catalog accessible to all users, because they 
are shared. The default location is CATMldZone.catalog. Even though zones are only created in schematic 
applications, other applications may use them when documents are moved from schematic to 3D. Enter a 
different name or location if you change them.

❍     Discrete values: Many attributes have discrete values and this directory is used to store them. 

❍     Schematic driven flag: This is a flag that needs to be set for schematic driven routing and parts placement. 
If the value of "Location" is set to 0 then individual users can check or uncheck an option that allows schematic 
driven 3D design.  If the value is set to 1 then the option "schematic driven" is always selected and users 
cannot uncheck it. 

❍     Create Part Flag: This is a flag that needs to be set if you intend to use Enovia as a database. If you use 
Enovia as a database then every run you create must be saved as a CATPart. If you set the value of "Location" 
to 1 then every run you make will be saved as a CATPart. If you set the value to 0 then the parts will not be 
deleted when you deleted the run.

❍     Graphic representations: When you create graphic representations for a part you need a file in which to 
store the categories (single, double, etc.). That file is created within an application, as you will see later. There 
is also a file under Project Resources because the categories must be available to all applications. If you add a 
new category you must include it in this file too. Enter a new location and file name if you want to change 
them.

❍     Penetration openings catalog: The profiles of the holes you may want to make through walls and partitions 
to pass pipes and ducts are noted in this catalog. If you make a new profile you must enter it here too. Enter a 
new location and file name if you want to change them.
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❍     Penetration cutout catalog: This contains the rules for how much clearance to allow for the pipes and ducts 
you want to put through walls. Enter a new location and file name if you want to change them.

❍     ID Sequence Number directory: The IDSequenceNumbers directory contains the last sequence number that 
was generated for an object. You should specify a location for it.

❍     Importer CATfcts: This lists the location of your CATfct files, and is used when migrating V4 models to V5. If 
you change the location for the CATfct files you must enter the new  location in the "Locatoin" field. You do not 
need to do anything if you continue to use the default location.

❍     Reference Grid System: Location of the CATPart that contains the reference grid definition used by 
applications. You need to modify this entry if you change the location of the CATPart or rename it.

❍     Discipline super class: This is a text file that lists the object classes that will be visible in a class browser. 
You can have files at project, discipline and application level.

5.  The next level, as explained above, is the Discipline level. Resources placed under the Discipline category can 

be used by all the applications in that discipline.

The sample Project.xml file places the following resources at the Discipline level. Each entry names the file and 
gives its default location. If you intend to use different resources, which is likely, then you must enter the new file 
name and location, as appropriate. The following resources are referenced, but not all disciplines will have all of 
these resources. 

❍     Specifications catalog

❍     Insulation specifications catalog

❍     Material specifications catalog

❍     Standards catalog

❍     Design rules: You need to use the default location and file name

❍     Parts catalog name and location: contains parametric parts

❍     Piping lines shared catalog: The file where shared piping lines are stored and its location.

❍     Sample data directory: This is the location where the reports you run will be stored.

❍     Report definitions directory: The formats (definitions) you create for running reports are stored in this 
directory.

6.  In addition to resources placed at the Project and Discipline levels, resources are also placed at the application 

level and are only available to the application under which they are placed. 

For information about resources placed under 2-D applications and 3-D applications, click here.
For information about the AEC Migration Discipline, click here. The AEC Migration Discipline refers to a product 
that enables you to migrate V4 models to V5. It has Piping Design, Piping and Instrumentation Diagrams, 
Equipment Arrangement, Tubing Design and HVAC Design resources under it.
For information about resources in the Structure Discipline, see appropriate application user's guides.

7.  Make sure to save your changes.
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Using the PRM Command

This task explains how to select a project and a discipline.

1.  From the appropriate CATIA workbench, launch the PRM command by selecting Tools -> Project Management 

Resource from the menu bar.

The Project Resource Management dialog box is displayed:

The Select tab lists all the XML projects setup found in the directory defined by the environment variable 
CATDisciplinePath. This list begins with a CNEXT project which contains only the applications with their resources 
as defined and delivered with CNEXT.

2.  Select the project of your choice, here Project.

The XML is read and the disciplines it contains are listed. Similarly, all projects start with a CNEXT discipline, that is 

to say applications as delivered with CNEXT.
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3.  Select the corresponding discipline, here Pipe21.

Its description is displayed, and the Browse page is populated. This discipline becomes the active discipline for the 
PRM system.

4.  Select the Browse tab.

Once a project and a discipline have been selected, the Browse window lists all the applications defined for the 
chosen discipline, the description of the selected application, and  the list of resource of that application.

5.  Select the application of your choice (here EQT) to display its description and list its resources:

6.  Select a resource (here Valve) to display its description.

Note that the description does not declare as active the application to the PRM.
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General Settings

This task is to inform you about the settings in the General tab.

The General tab provides settings for General Environment, Resolved Part Storage path, Resource Attributes and Catalog Placement Options. 

1.  Click Tools - Options - Equipment & Systems and select the General tab.

2.  General Environment:

❍     Grid Step. This is the default grid step setting that displays in the General Environment toolbar at the bottom of the 3-D viewer. 
Even if you change the value in the toolbar during your session, the value entered in the Grid Step field will re-appear when you 
open a new session. Enter your preference for the Grid Step. Note: The Units (unit of measure) is set in the Units tab under Tools - 
Options - General - Parameters and Measure. See also Set Correct Working Units and Grid.

❍     The Snap Angle sets the degree of rotation of the plane manipulator. See Using the Plane Manipulator for more information.

3.  Resolved Part Storage for Spatial Objects:

❍     Directory. This is the location where resolved Spatial objects unique to the Plant Layout, Systems Routing and Systems Space 
Reservations products are stored. Click the Open file button and navigate in the Resolved Part Storage Directory Browser window to 
set or change the location for the directory. 

4.  Resource Attributes:

❍     Automatic creation of resource attributes. Certain attributes accompany Spatial objects  (those created in Plant Layout, Systems 
Routing and Systems Space Reservations); objects such as item reservations, areas, runs, etc. These attributes, or properties, are 
generated specifically for the Delmia product line and cannot be assigned or changed in other product lines.

Although you will not be making use of these resource properties, their creation will have no affect on the product you are working in. If 
you do not want these properties to be created, uncheck the box Automatic creation of resource attributes and click OK.

5.  Catalog Placement Options:
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❍     Display image while placing catalog object in 3-D viewer. You can choose to hide or display a "preview" of the part you are placing. 
Check or uncheck the box Display image while placing catalog object in 3D viewer to obtain the effect you want.

❍     Place at component's origin when placing in free space. By default, when you click (in free space) to place a part, the center of the 
part will be placed at that location. The application determines the center of the part by creating a box around it and selecting the 
center of the base of the box. You can also choose to place the origin of the part at the point where you click. To do this check the 
box Place at component's origin when placing in free space.

6.  Click OK when you are done.
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Display Settings
This task is to inform you about the options available in the Display tab. 

The Display tab provides display options for Analysis Mode, Specifications Tree, 3-D Viewer Display and Routable Display options.

1.  Go to Tools - Options - Equipment & Systems and click the Display tab.

❍     Analysis Mode: Check the box in Analysis Mode to display information about routables.  It works only when you are performing an 
action with a routable, such as placing a part, branching a run or creating an offset route.

❍     Specification Tree: In Application objects check the box Show application grouping to organize the objects in the tree by 
application, e.g. Piping objects, Equipment, etc. Under Spatial objects check the boxes of the items you want to appear in the 
specifications tree. Spatial objects may only be placed using the Systems Routing, Systems Space Reservation and Plant Layout 
workbenches.
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❍     3-D Viewer Display Options: Check or uncheck the boxes to set the connection and connector display options as desired. Set the 
color of the connection and connector symbols using the drop down color palette.

❍     Routable Display Options: Increase the Twist Smoothness Factor to increase the smoothness of a run at a twisting turn.
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Specifications Tree Settings

This task shows you how to change the specifications tree settings so that the objects in the tree 
display in an organized manner of your choice.

The default display setting for objects in the specifications tree is single-tier, and the objects 
appear in the order in which they were placed in the document.   

By changing the Tools -> Options settings they can be organized in two ways, by product and, as 
an additional step, by application group also. If you do not check the option as described below you 
will be unable to collapse the specification tree display and it looks as shown below. After you 
check the Products option the objects will be organized under the Products node and the tree 
can be collapsed. The Products node is simply an organizational element. After you check the 
Application Grouping option the objects will be further grouped by type.

1.  With your document open, go to Tools -> Options -> Infrastructure -> Product 

Structure and click the Product Structure tab. Check to activate the Products option. 

The objects in the specifications tree will be organized under the Products node.

2.  To organize the specifications tree in application groups go to Tools -> Options -> 

Equipment & Systems and click the Display tab.
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Under Specifications Tree, activate the Show application grouping option: Objects in 

the specifications tree will be organized under type of object. (You can expand the 

Products node to see the ungrouped elements.)

When working with Design Rules such as Attribute Filters and 
FunctionPhysicalMapping, or during parts creation, turn on the Relations and 
Parameters options.

3.  Go to Tools -> Options -> Infrastructure -> Product Structure and click the Tree 

Customization tab.

The Specification Tree Order table displays: You can toggle any of the entries from Yes to 

No and back by clicking in the Activated column.

1692Page Infrastructure Version 5 Release 13



Diagrams Settings

This task explains the diagrams settings.

The Diagrams tab is one of three tabs under the Options -> Equipment & Systems menu that is specific to P&ID, 
HVAC, Electrical and Waveguide Diagrams.

1.  Click Tools -> Options, Equipment & Systems and select the Diagrams tab. 

The Options window displays:

2.  Make your selections from the options.

Most of them are self explanatory.

In the Connector Display frame, two options allow you to show or not the connectors in the drawing sheet:
By default,

❍     Show connected connectors is unchecked to lighten the display

❍     Show unconnected connectors is checked to emphasize the display.

In the Reference Components Display frame, the option allows you to show or not the reference components in 
the specification tree: by default, the option is checked.
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If you uncheck the option, the specification tree looks 
like this: 

3.  Click OK to validate.
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Electrical Mapping 

In order to valuate the keywords automatically when the devices are stored in the catalog with their properties, you need to define 
a mapping between keywords of each family and the attributes of the component type.

1.  Select the Tools -> Options command.
The Options dialog box is displayed.

2.  Click Equipments & Systems in the left-hand box.

3.  Click the Electrical Mapping tab.

The tab lets you:

❍     define the current catalog using the drop-down list or the Browse button 

❍     customize the mapping between the catalog and the electrical objects

❍     define the keyword attributes.

4.  Customize the mapping: associate an electrical type to the currently selected Family.
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Use the combo list to select the corresponding type.

5.  Define for each keyword the corresponding reference attribute.

The result looks like this:

Use the combo list to select the corresponding attribute.

6.  Click OK to validate the options.

The mapping definition can be set by the administrator.
In this case it can also be locked. 

To get more information about the Administration Mode in CATIA, refer to CATIA - Infrastructure User's Guide.
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Design Criteria Settings
This task is to inform you about the settings in the Design Criteria tab.

The Design Criteria tab allows you to toggle settings for ID Management, 3D Design, and 3D Placement.

1.  Click Tools - Options - Equipment & Systems and select the Design Criteria tab.

❍     ID Management: Update ID on property change. When the object naming convention (ID schema) includes an attribute, e.g. 
nominal size, and you change its value using the Properties dialog box, the name of the object will change to reflect the new value 
of the attribute.

❍     3D Design: Check Schematic Driven if you are placing parts from a schematic into a 3D design document. Used with Piping Design, 
Tubing Design, HVAC Design and Waveguide Design applications.

❍     3D Placement Options: When the Place automatic parts box is checked you can place an object such as a valve and the flanges and 
gaskets will be placed automatically.
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Electrical Process Interfacing 
This document shows how to set up the options to take advantage of external data from partners through XML files or from CAA V5 
APIs to get information from legacy databases.

Note that the default value for External Data Interfacing is enabled:
Enable External System Interfacing is checked.

 
1.  Select the Tools -> Options... command.

The Options dialog box is displayed.

2.  Click Equipments & Systems category.

3.  Click the Electrical Process Interfacing tab.

The tab lets you define:
❍     the access to external data

❍     the electrical iXF repository path

❍     the electrical working catalog path

❍     the identifier for mapping management.

4.  Make sure Enable external systems interfacing is checked.

However, you are required to identify the path:
❍     of the folder in which the XML files available are stored

❍     of the working catalog containing the V5 parts which Part Number are referred to in the XML files.

5.  Use  to locate the iXF systems repository.
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6.  Use  to indicate the catalog path.

7.  Check the Instance Name option so that the Instance Name will be taken into account instead of the Reference 

Designator to insure the mapping between 3D objects and external system's objects.

8.  Click OK to validate the options.

It is also necessary to define the electrical objects mapping regarding the working catalog.
To do so:

●     use the Tools -> Options... menu.

●     then in the Equipment & Systems category, select the Electrical mapping tab.

Refer to the Customizing - Equipment & Systems - Electrical mapping documentation.
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Customizing for Electrical Library

Before you start your first working session, you can customize the way you work to suit your 
habits.
This is done using Tools -> Options from the menu bar.
This type of customization is stored in permanent setting files. Settings will not be lost if you exit 
your session.

General
Electrical Library Access
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General 

1.  Select the Tools -> Options menu.

The Options dialog box is displayed.

2.  Click Equipment & Systems in the left-hand box.

3.  Click the Electrical Assembly Design workbench.

It lets you define the Automatic compass option:
❍     Check the Snap to placed element to take advantage of the compass:

when you place an element, the compass snaps to this element allowing you to modify the orientation and 
location.

❍     By default this option is checked.

4.  Click OK when done.
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Electrical Library Access 

Electrical System Functional Definition takes advantage of Electrical Library for the mapping between functional 
equipments and connectors to V4 library parts. It consists of the definition of the corresponding physical components 
for functional equipments or connectors. This is done in EFD.
The V4 libraries access is defined in the Tools -> Options menu.
Moreover, a compatibility can be established between functional and physical components in order to reduce the list of 
physical components available for a functional component. The compatibility sets a relation between the External 
Reference attribute of the functional component and the Part Number attribute of the physical component. These 
relations are stored in a compatibility table, in csv format.

1.  Select the Tools -> Options menu.
The Options dialog box is displayed.

2.  Click Equipment & Systems in the left-hand box.

3.  Click the Electrical Assembly Design workbench.

It lets you define:
❍     the library names and their locations in the upper frame

❍     the location of the compatibility table if it exists
(for example: c:\Temp)

4.  Click OK when done.

VA Library Access Configuration
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●     To add a library in the list, click the corresponding button.

The dialog box opens:

●     Enter the library name and path then click OK to validate.

●     You can delete or modify the library access, using respectively the Remove or Edit button.

Functional-Physical Compatibility Location

 
●     To gain access to the compatibility table, enter its path in the Compatibility Storage Path field. Let's see its 

structure:

In this sample, the functional equipment which External Reference is ExtRefEqt is compatible with three 
physical equipments which PartNumber are PN1, PN2, PN3.

For more information about the interoperability with CATIA - Electrical System Functional Definition, refer to Mapping 
Functional Components to Physical Parts in this User's Guide.
The Electrical Library Access can be set by the administrator.
In this case it can also be locked. 

To get more information about the Administration Mode in CATIA, refer to CATIA - Infrastructure User's Guide
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Customizing Electrical Harness Flattening 

Before you start your first working session, you can customize the way you work to suit your 
habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you 
end your session.

For the time being, Electrical Harness Flattening does not function with the Visualization Mode.

The entire geometrical bundle must be in Design mode for the workbench to work properly.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Choose the Equipment & Systems category in the left-hand box.

3.  Click the Electrical Harness Flattening workbench.

The General tab displays:

This tab lets you define:

❍     the synchronization report repository

❍     the graphic replacement catalog

4.  If you want to work with the cache system, select the Infrastructure -> Product 

Structure item.

The Cache Management tab displays:

This tab lets you define:

❍     the cache activation

5.  Fill up theses options according to your needs.

6.  Click OK when done.
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Electrical Harness Flattening  

This tab lets you define:

●     the synchronization report repository

●     the graphic replacement catalog

Click here to see the parent page.

Synchronization Report Repository 

Path

Indicate the folder path where you want to save the synchronization report html files.

 By default, this field contains: ...\DassaultSystemes\CATTemp.

Graphic Replacement Catalog 

Catalog path and Catalog name

Indicate the catalog path and name where the drawing 2D details are stored.

 By default, this field is empty.
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Cache Management
Click here to see the parent page.

Cache Activation  

Work with the cache system

If this option is checked, it means that a representation of the geometry only is available and stored in 

the cache.

For more information, refer to the customizing section about cache management.

 By default, this option is not checked.
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Customizing Electrical Wire Routing 

Before you start your first working session, you can customize the way you work to suit your habits.
This is done using Tools -> Options from the menu bar.
This type of customization is stored in permanent setting files. Settings will not be lost if you exit your session.

1.  Select the Tools -> Options command.

The Options dialog box is displayed.

2.  Expand the Equipments & Systems in the left-hand box.

3.  Click the Electrical Wire Routing workbench.

The General tab is displayed:

This tab lets you customize:
❍     the wire extremities management

❍     the property naming to be displayed as a column title

❍     the separation code file access

❍     the extremity color

❍     the bundle segment update mode.

4.  Click OK in the dialog box when done.
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Wire Extremities Management

 
●     The Favorites list contains the properties displayed in the Interconnection frame of the Wire Extremities Management dialog 

box. To add properties to the list, select the property in the Available list and click the --->  arrow.

●     To remove properties, do the reverse: select the property from the Favorites list and click the <---  arrow.

Property Naming

 
●     Select a property in the Favorites list and enter a name in the Favorite column Title field.

It is displayed in the Wire Connection Management dialog box:

Separation Code File

The Separation Code File area is used to define Separation Code rules to optimize the routing.
●     the separation code is not used. The routing is done according to the shortest route found.

It is the default value.

●     the separation codes may be File Based. In that case, define the path to access the compatibility table by clicking the Browse 
button to choose the separation code file.
This file is used during the Automatic Routing and the Routing Simulation.
Two options are available:

❍     Signal-Signal manages compatibility between signals,

❍     Signal-Arc manages compatibility between signal and pathways.

●     the separation codes may also be Rule Based, using CATIA Knowledgeware.
Only one rule can be implemented at a time, but this rule may combine several conditions.
Click the Edit button to enter a new rule: the Routing Rule Editor is displayed.

The line above the input field is a reminder of the knowledgeware syntax.
The Eraser icon is used to clear the input field.

Extremity Color
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●     The Extremity Color field is used to change the color of the extremity boxes.

Select a color from the combo box.

or 

Bundle Segment Minimum Bend Radius Update

Three modes are available:
●     Never: no update of the bundle segment minimum bend radius is performed.

●     Always: the greatest bend radius of the wires routed in the bundle segment determines the segment bend radius to be applied.

●     Conditional: the wire bend radius is taken into account for update when it is greater than the bundle segment bend radius.

The default mode is Always.
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Customizing Electrical Harness Installation 

Before you start your first working session, you can customize the way you work to suit your habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you end 
your session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Choose the Equipment & Systems category in the left-hand box.

3.  Click the Electrical Harness Installation workbench.

The Harness Management tab displays.

This tab lets you define:

❍     the bundle segment creation options

❍     the bundle segment naming rule

❍     the bundle segment connection options

❍     the bundle segment disconnection options

❍     the management of contextual links.

4.  Two other tabs, located in the Infrastructure category, in the Part Infrastructure workbench, 

also interfere with Electrical Harness Installation:

❍     General

❍     Display

5.  For migration purpose, you may need to customize the Electrical and Migration Batch tabs 

located in the General -> Compatibility category.

❍     Migration Batch

❍     Electrical

6.  Change theses options according to your needs.

7.  Click OK when done.
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Electrical Harness Installation  
This page deals with the options concerning:

●     the bundle segment creation

●     the bundle segment naming rule

●     the bundle segment connection

●     the bundle segment disconnection

●     the management of contextual links.

Click here to see the parent page.

Bundle Segment Creation 

Geometrical bundle is mandatory

If this option is checked, it means that you need to create a geometrical bundle prior to defining a bundle segment.

 By default, this option is checked.

Work with one multi-branchable per geometrical bundle

If this option is checked, only one multi-branchable bundle segment can be created within a geometrical bundle: a 

single part contains the full harness, reducing the size of the document, the number of contextual links and 

consequently the update time.

However to take advantage of the ENOVIA configuration management, this option needs to be unchecked if you 

want to manage the effectivity at a more detailed granularity level: the branchable bundle segment.

Check this option if the configuration management does not need to be done at the level of each branchable bundle 

segment, but at the level of a set of branchable bundle segments created in a single document.

 By default, this option is unchecked.

Bundle segment color
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Use the color chooser to define the bundle segment color at creation.

Bundle Segment Naming Rule 

Bundle segment (#PN#)

If this option is selected, the bundle segment name shows like this in the specification tree:

 It is the default value.

Parent-bundle segment (#PN#)

If this option is selected, the bundle segment name shows like this in the specification tree:

Bundle Segment Connection 

Geometrical link

If this option is checked, when the selection is completed, the bundle segment is extended to the second point 

selected (which is either a bundle segment extremity or a bundle connection point).

 By default, this option is checked.

Automatic link to new bundle segment
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If this option is checked, the electrical connection is created at the same time as the bundle segment.

 By default, this option is checked.

Bundle Segment Disconnection 

Remove geometrical link at unlink

If this option is checked, when a bundle segment is disconnected from a connector, the geometrical link is also 

removed and the bundle segment geometry is modified to its last but one definition point.

 By default, this option is checked.

Contextual Links 

For this option to be taken into account, you must first uncheck the Use root context in assembly option, 

which is located in the Part Infrastructure -> General -> External References frame. If not, the links 

will be created to the root of the assembly.

 By default, this option is checked.

Keep link with selected object
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The object created from the selection will or not keep the link according to this option. This option can take three 

values: 

●     Always:  always creates the external reference links.

 It is the default value.

●     In geometrical bundle: creates external reference links only if the selected object is part of the geometrical 

bundle of the bundle segment.

●     Never: always creates a local copy of the selected object with no associativity.

Forbid selection outside current geometrical bundle

If this option checked, the selection of points, supports or devices which do not belong to the current geometrical 

bundle for bundle segment routing is forbidden.

 By default, this option is unchecked.
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Part Infrastructure for
Electrical Harness Installation

This page deals with the options concerning:

●     the external references: keep link with selected object

●     the specification tree display.

Click here to display the parent page.

Part Infrastructure General option 

Click here to know more about the Part Infrastructure General options.

Keep link with selected object

You need to check this option to take advantage of the associativity between the construction points or 

part body and the bundle segment.

 By default, this option is unchecked.

Part Infrastructure Display option 
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Click here to know more about the Part Infrastructure Display options.

External References

If this option is checked, the External References will display in the specification tree.

 By default, this option is checked.
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Compatibility for
Electrical Harness Installation

This page deals with the options concerning:

●     the migration batch

●     the migration options.

Click here to display the parent page.

Migration Batch 

Click here to know more about the Compatibility -> Migration Batch options.

Interface Name

You need to enter CATIE3DMigration in this field if you want to migrate V4 electrical data to V5.

 By default, this option is empty.

Electrical 

Click here to know all the details about the Compatibility -> Electrical options.
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Bundle segments

If this option is checked, each V4 BNS is migrated to a V5 bundle segment (CATPart document).

 By default, this option is checked.

Multi-branchable bundle segments

If this option is checked, all the BNSs of a V4 GBN are migrated to one multi-branchable bundle segment 

in a V5 geometrical bundle. All the V5 bundle segments are stored in a single CATPart document, the 

multi-branchable bundle segment CATPart.
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Customizing Electrical Connectivity Diagrams

This file explains the settings specific to Electrical Connectivity Diagrams workbench.
Before you start your first working session, you can customize the way you work to suit your habits.
This is done using Tools -> Options from the menu bar.
This type of customization is stored in permanent setting files. Settings will not be lost if you exit 
your session.

Feature Dictionary Settings
From-To List 
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Feature Dictionary Settings 

This file explains how to set the options for the user dictionary and schema Id.

1.  Click Tools -> Options -> Equipment & Systems -> Electrical Connectivity Diagrams.

The Feature Dictionary tab offers two frames:
❍     User Dictionary

❍     User Schema ID

2.  Fill up the fields according to the information given below.

3.  Click OK when you are done.

User Dictionary 
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The dictionary contains object basic classes such as: equipments, sockets, plugs, switches, cables, etc.
These objects have standard properties: type, part number, etc.
According to you needs, you may want to define more properties such as subtype classes, and other specific 
attributes: 

In this example, four subtype classes have been defined for the Schematic Equipment class.

This is done using the Feature Dictionary Editor , available in the Start -> Equipment & Systems menu.

The classes, subclasses and their properties are saved in a document with a CATfct extension.
This file must be stored in the following directory according to your operating system:

on NT: .../intel_a/resources/graphic/
on Solaris: .../solaris_a/resources/graphic/
on Irix: .../irix_a/resources/graphic/
on Aix: .../aix_a/resources/graphic/
on Hpux: .../hpux_a/resources/graphic/

In the User Dictionary File Name field, only enter the file name and extension.

You can have more than one .CATfct file, but you will reference only one at a time.
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In order to access the user subclasses and properties defined in the .CATfct file, always reference an existing 
.CATfct file. If a .CATfct file has been used to create data, it must not be deleted to preserve the data 
consistency.

Client ID 

The Client ID is defined in the Feature Dictionary Editor as a protection on the CATfct file, before creating the 
user dictionary and the subclasses. 

In the ID field, enter the same three characters:

User Schema ID 

Within a project, it is possible to define naming rules for the schematic objects. They are used to set 
automatically the Reference Designator attribute on electrical components. These rules (Schema ID) are saved 
in xml files and stored together in specific directory. It is the path to this directory that you indicate in the first 
field (Schema) of the frame below.
The Sequence Number is assign automatically provided that the file server is stored in a directory shared 
between all the users working on the project. Enter the path to this directory in the second field (Sequence 
Number) of the frame below 

You can decide then to use the naming rules you have defined or not.

In the first case, check the Automatic instances ID generation.

To enter manually the Reference Designator, uncheck this box.
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From-To List Settings 

This file explains how to set the options for the from-to list, to display the wires and the components connected to their 
extremities.

1.  Click Tools -> Options -> Equipment & Systems -> Electrical Connectivity Diagrams.

The From-To List tab lets you define which attributes will be displayed in the list.
Favorites attributes are selected by default.
If other attributes have been defined using the Feature Dictionary Editor, they will be available in the left column.

2.  Select the attributes of interest in the left column and click the right arrow.

The attributes shown in the right column will be displayed in the list.

3.  Use the Up and Down buttons to reorder the list.

4.  Enter a name in the Favorite column title to change the title of this column in the list.

5.  Click OK when you are done.

Detailing the From-to list
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Each row displays a wire and the components connected to its extremities.

Unit Id 
It is the reference designator of the component (i.e. equipment, junction box or switch).

Plug\Board Id 
It is the reference designator of the connector on the board or plug.

Pin Id Number 
It is the Id Number of the pin.

Wire Reference Designator 
It is the reference designator of the wire.

Wire Color 
it is the color code of the wire.
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Customizing Equipment Support Structures

Before you start you first session, you can customize the way you work to suit your habits. This type of customization 
is stored in permanent setting files: these settings will not be lost if you end your session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Select the Equipment & Systems category in the left-hand box.

3.  Select the Equipment Support Structures sub-category.

The General tab displays.

This tab lets you define:

❍     Color options: default color for members and plates 

❍     Material options: default materials for members and plates

❍     User types: create and manage member and plate user types

❍     Catalogs storage path: path of the folder containing sample standard catalog sections

❍     Sections storage path: path of the folder that will contain the list of available sections

❍     Thickness table path

One other tab, Structure Drawing, located in the Equipment & Systems category, is also needed for 
Equipment Support Structures.

❍     The Structural Drawing tab lets you customize how data extracted from the 3D document is presented on 
structural drawings.

4.  Set options in these tabs according to your needs.

5.  Click OK in the Options dialog box when done.
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Equipment Support Structures
The Equipment Support Structures tab contains the following categories of 
options:

●     Color

●     Material

●     User types

●     Catalogs storage

●     Sections storage

●     Thickness table

Color

Member or Plate 

 Select the default color for members and plates in the appropriate box list.

 By default, colors are as shown above.

Material

Member or Plate 

 Select the default material for members and plates in the appropriate box 
list.

 By default, materials are as shown above.
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User types

Member or Plate

 Lets you create and manage user types:
●     Add: enter the name of the member or plate type then click Add to add 

user types.

●     Remove: select the member or plate type in the list then click Remove 
to remove user types.

 By default, these options are blank.

Catalogs storage

Path

 Enter the path of the folder containing sample standard catalog sections 
supplied with the product:

downloaddirectory/OS/startup/components/structuralcatalogs

where OS is the operating system, for example intel_a (Windows). 

 By default, this option is left blank.

Sections storage

Path
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 Enter the full path of the folder that will contain the list of available 
sections, for example e:\Section, or use [...] to locate the folder of 
interest.

This folder will contain resolved user-defined sections stored here directly 
and any sample standard or user-defined catalog sections accessed via the 
Section command or the Other section... option. It is recommended that an 
empty directory be identified. 

 By default, this option is left blank.

Thickness table

Path

 Enter the path of the thickness table. A sample table, 
ThicknessListSample.txt, is supplied with the product.

downloaddirectory/OS/startup/components/StructuralCatalogs/Thickness 
Tables/ThicknessListSample.txt

where OS is the operating system, for example intel_a (Windows). 

 By default, this option is left blank.
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Customizing Electrical 3D Design & Documentation 

Before you start your first working session, you can customize the way you work to suit your habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you end your 
session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Choose the Equipment & Systems category in the left-hand box.

3.  Click the Electrical 3D Design workbench.

The options for 3D Design settings appear, organized in tab pages.

4.  Select the tab corresponding to the parameters to be customized.

Parameters in this tab... Allow you to customize...

General the automatic compass

Harness Flattening the synchronization report repository

Harness Management the bundle segment creation options

Wire Routing the options to optimize the routing

Electrical Process Interfacing the external data file repository

5.  A tab located in the Infrastructure category, in the Part Infrastructure workbench, also interfere with 

Electrical 3D Design:

❍     General

6.  Another tab located in the Mechanical Design category, in the Drafting workbench, also interfere with 

Electrical 3D Design:

❍     View

7.  Change theses options according to your needs.

8.  Click OK when done.
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General  
This page deals with the options concerning:

●     the automatic compass

Click here to see the parent page.

Automatic Compass 

Snap to placed element

if this option is checked, you take advantage of the compass:

when you place an element, the compass snaps to this element allowing you to modify the orientation 

and location. 

 By default this option is checked.
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Harness Flattening  

This page deals with the options concerning:

●     the synchronization report repository

●     the graphic replacement catalog

Click here to display the parent page.

Synchronization Report Repository 

Path

Indicate the folder path where you want to save the synchronization report html files.

 By default, this field contains: ...\DassaultSystemes\CATTemp.

Graphic Replacement Catalog 

Catalog path and Catalog name

Indicate the catalog path and name where the drawing 2D details are stored.

 By default, this field is empty.
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Harness Management  
This page deals with the options concerning:

●     the bundle segment creation

Click here to see the parent page.

Bundle Segment Creation 

Bundle segment color

Use the color chooser to define the bundle segment color at creation.
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Wire Routing  
This page deals with the options concerning:

●     the separation code file

●     the bundle segment bend radius update

Click here to see the parent page.

Separation Code File 

This option is used to define separation code rules to optimize the routing.

No rule

The separation code is not used. The routing is done according to the shortest route found.

 It is the default value.

File based

The separation codes may be File Based.
In this case, define the path to access the compatibility table by clicking the Browse button to choose the 
separation code file.
This file is used during the automatic routing.

Bundle Segment Bend Radius Update 

According to the wire bend radius
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Three modes are available:
●     Never: no update of the bundle segment minimum bend radius is performed. 

●     Always: the greatest bend radius of the wires routed in the bundle segment determines the segment 
bend radius to be applied. 

●     Conditional: the wire bend radius is taken into account for update when it is greater than the bundle 
segment bend radius. 

 The default mode is Always.
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Electrical Process Interfacing  
This page deals with the options concerning:

●     the electrical iXF repository path

Click here to see the parent page.

Electrical iXF Data Repository 

System repository

You are required to identify the path of the folder in which the XML files available are stored.

Use  to locate the iXF systems repository.

 By default the field is empty.
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Part Infrastructure for
Electrical 3D Design

This page deals with the options concerning:

●     the external references: keep link with selected object

Click here to display the parent page.

Part Infrastructure General option 

Click here to know more about the Part Infrastructure General options.

Keep link with selected object

You need to check this option to take advantage of the associativity between the construction points or 

part body and the bundle segment.

 By default, this option is unchecked.
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Drafting for
Electrical 3D Design

This page deals with the options concerning:

●     Geometry generation / Dress-up

Click here to display the parent page.

Drafting View options 

Click here to know more about the Drafting View options.

Project 3D wireframe

You need to check this option to take advantage of the line type personalization used to display the 

bundle segments as single line in the drawings you will generate.

 By default, this option is unchecked.

Project 3D points

You need to check this option to display construction points in the drawings you will generate..

 By default, this option is unchecked.
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Structure Drawing
The Structure Drawing tab contains the following categories of options:

●     Molded forms: to define how molded forms will be represented on drawings.

●     Members/Stiffeners: to define how members or stiffeners will be represented on drawings.

●     Plates: to define how plates will be represented on drawings.

●     Openings: to define how openings will be represented on drawings

●     Midship designation

●     Datum line

Molded forms

Linetype

 

Defines the linetype used to represent molded forms on drawings. Select the desired linetype from the 
drop-down list.

 By default, this option is set to 0.
Apply linetype on profile view only

 

If this option is selected, the selected linetype is applied to profile views only.

 By default, this option is cleared.

Members / Stiffeners

Graphic replacement
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If this option is selected, a line representing the trace of visible members / stiffeners is generated on 
drawings. The user can specify the linetype (near side linetype) for this line.

 By default, this option is cleared and the 3D representation of members / stiffeners is generated on 
drawings.

Angular tolerance

 
Defines the value above which the member/ stiffener section is not represented. It is the angle between 
the member/ stiffener section and the projection vector. In the example below, the angular tolerance is 
15.

 

Near side linetype

 Defines the linetype to be used for the trace of visible members / stiffeners if the Graphic replacement 
option is selected. Select the desired linetype from the drop-down list. A solid line font is recommended.

Show far side stiffeners

 

If this option is selected, a line representing the trace of hidden members / stiffeners, below a deck for 
example, is generated on drawings. The user can specify the linetype (far side linetype) for this line.

 By default, this option is cleared and hidden members / stiffeners are not shown on drawings.
Far side linetype

 Defines the linetype to be used for the trace of hidden members / stiffeners if the Show far side stiffeners 
option is selected. Select the desired linetype from the drop-down list. A phantom font is recommended.

Generate arrowheads

 

If this option is selected, arrows are generated at ends of members / stiffeners.

 By default, this option is cleared and no arrowheads are shown on drawings.
Generate material throw orientation - stiffeners only
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If this option is selected, marks indicating the material throw orientation of stiffeners are generated. 

Note: This option is valid for stiffeners only.

 By default, this option is cleared and no marks are generated on drawings.

Plates

Graphic replacement

 

If this option is selected, you can define how plates will be represented on drawings.

 By default, this option is cleared and the 3D representation of plates is generated.
Generate Material Throw Orientation

 

If this option is selected, marks indicating the material throw orientation of plates are shown on drawings.

 By default, this option is cleared.
Angular tolerance

 

Specifies an angular tolerance. If the angle between plates is less than the specified value, weld seams 
are generated; if the angle is greater than or equal to the specified value, knuckle lines are generated.

 By default, this option is set to 0 degrees.
Weld seam callout offset

 

Specifies the offset for weld seam callouts.

 By default, this option is set to 0 mm.
Weld seam callout thickness

 

Specifies the thickness for weld seam callouts.

 By default, this option is set to 0 mm.
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Openings

Graphic replacement

 

If this option is selected, the user can define the symbols to use to represent openings on drawings.

 By default, this option is cleared and the 3D representation of openings is generated.
Center line representation

 Defines the symbol used for the centerline on front views if the Graphic replacement option is selected. 
Two options are available:

 

●     Axis line

●     Cross symbol: the centerline is represented by a cross.

  By default, the axis line is used.
Butterfly symbol thickness

 

Defines the thickness of the butterfly symbol in mm. Applies to profile views.

 By default, this option is set to 0 mm.

Midship Designation
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Generate hull centerline

 

If this option is selected, the hull centerline is generated on drawings.

 By default, this option is cleared.
Hull centerline text

 

Defines the text to be placed at both ends of the centerline.

 By default, this field is blank.
Symbol representation

 

If this option is selected, the midship symbol is generated on drawings.

Note that dimensions of this symbol do not change.

 By default, this option is cleared.

Datum Line

Generate datum line

 

If this option is selected, a datum line is generated on drawings.

 By default, this option is cleared.
Annotation style

 

Defines the annotation style to use for the datum line. Options available are:
●     No annotation

●     Names from 3D: specifies frame names

●     Position values: specifies the offset from the origin (units are indicated)

●     Position values without units: specifies the offset from the origin.

 By default, this option is set to No annotation.
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Customizing Structure Preliminary Layout
Before you start your first session, you can customize the way you work to suit your habits. This 
type of customization is stored in permanent setting files: these settings will not be lost if you end 
your session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Select the Equipment & Systems category in the left-hand box.

3.  Click the Structure Preliminary Layout sub-category.

The Design, Drafting and Offset Data tabs display.

❍     The Design tab lets you set default colors for main items.

❍     The Drafting tab lets you customize lines drawings.

❍     The Offset Data tab lets you manage the output formats for your offset data.

One other setting, Keep link with seleted object, is also needed to ensure associativity 
between the items you create and entities selected to create them.

4.  Select Infrastructure -> Part Infrastructure -> General, then select Keep link with 

selected object.

5.  Set options in these tabs according to your needs.

6.  Click OK in the Options dialog box when done.
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Design Settings
The Design tab contains one category of options: Default colors.

Default Colors

Use the color chooser to define the default color for molded forms, bounded zones (compartments) and 
boundaries.

 By default, colors are as shown above.
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Drafting 
The Drafting tab contains five categories of options letting you customize your lines drawings:

●     Geometry to display

●     Waterlines view

●     Waterline position

●     Body plan

●     Midship position

Geometry to Display

Select the option defining how the shape of the ship is shown on lines drawings: Wireframe only or 
Surface only, or Both. 

 By default, the option is Wireframe only.

 For a body plan, ensure Wireframe only is checked. 

Waterlines View

Select the option defining the view looking at the ship from above: Symmetrical  or Asymmetrical 
depending on whether or not the ship is symmetrical about the centerline. This generates a half-breadth 
or full-breadth view respectively.

Typical half-breadth view: 
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 By default, the option is Asymmetrical.

Waterline Position

Select WaterLine reference plane

If this option is selected, the waterline is located at the selected reference plane in the 3D document.

Specify value (absolute z coordinates)

If this option is selected, the waterline is located along the Z direction at the absolute coordinate entered 
in the Absolute Z coordinate box.

 By default, the option is Specify value.

Body Plan

Select the option defining the view showing the shapes of the frame lines: Symmetrical or 
Asymmetrical depending on whether or not the ship is symmetrical about the centerline.

The generated view is made of two parts. If the ship is symmetrical, only one side of the ship is shown 
(usually the portside) and the right-hand part looks aft at the forward portside of the ship, while the left-
hand part looks forward at the after half of the portside. If the ship is asymmetrical, both sides of the ship 
are shown.

Typical body plan: 
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To generate this drawing, you need to define the midship position (see below).

 By default, the option is Asymmetrical.

Midship Position

Select middle station

If this option is selected, the midship is located at the selected reference plane in the 3D document.

Specify value (absolute xcoordinates)

If this option is selected, the midship is located along the X direction at the absolute coordinate entered in 
the Absolute X coordinate box.

 By default, the option is Specify value.
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For the options in this tab page to be taken into account, you need to select Project 3D 
wireframe, Project 3D points and Apply 3D specifications located in Mechanical Design -> 
Drafting -> View -> Geometry generation/Dress-up frame.

  By default, Project 3D wireframe and Project 3D points are cleared, and Apply 3D 
specifications is selected.
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Offset Data 
The Offset Data tab contains one category of options to manage output formats, for example HTML pages 
or CSV files, for your offset data: Global.

Global

New / Edit / Delete
Use New, Edit or Delete to add new stylesheets, and edit or delete existing ones. 

Sample stylesheets (OffsetDataAsHTML.xls and OffsetDataAsCSV.xls) for two formats, HTML and CSV 
respectively, are provided. By default, they are located in the installation folder under 
OS/startup/EquipmentAndSystems/StructurePreliminaryLayout/StyleSheet.
Apply XSL Transformation
Select this option to take all stylesheets into account and choose the format of your output data when 
interactively generating your offset data. 

 By default, this option is cleared and only XML files will be generated.
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Customizing Structure Functional Design
Before you start your first session, you can customize the way you work to suit your habits. This type 
of customization is stored in permanent setting files: these settings will not be lost if you end your 
session.

1.  Select the Tools -> Options command.

The Options dialog box displays.

2.  Select the Equipment & Systems category in the left-hand box.

3.  Click the Structure Functional Design sub-category.

The Catalogs and Design tabs display.

❍     The Catalogs tab lets you identify the path to the resolved sections folder.

❍     The Design tab lets you define default colors and a default material-grade combination.

4.  Set options in these tabs according to your needs.

5.  Click OK in the Options dialog box when done.
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Catalog Settings
The Catalogs tab contains only one category of options: Resolved Sections Folder. 

Resolved Sections Folder

 
Path
Enter the path of the folder in which the list of available sections will be stored, for example e:\Section, 
or use [...] to locate the folder of interest.

This directory will contain resolved user-defined sections which are stored here directly as well as any 
standard or user-defined catalog sections selected via the Section icon or the Other section... option. It is 
recommended that you identify an empty directory.

 By default, this option is left blank.

Note: Other catalogs, such as the standard section catalog, thickness table and opening catalog are 
project resources and can be browsed via the Project Management command (Tools menu).
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Design Settings
The Design tab contains the following categories of options:

●     Color

●     Material

Color

Use the color chooser to define the default color for functional stiffeners, functional plates, 
functional pillars and the selected support surface.

 By default, colors are as shown above.

Material

Select the default material-grade combination for functional stiffeners, functional plates and 
functional pillars from the corresponding list. 

This is the combination proposed when creating functional plates, insert plates, stiffeners, twisted profiles 
and pillars if no default value has been specified in the Feature dictionary.

 By default, the material-grade combination is Steel A100.

1752Page Infrastructure Version 5 Release 13



Customizing Circuit Board Design 

This task shows you how to change the user settings. These are permanent settings.

1.  Select the Tools -> Options menu.

The Options dialog box opens.

2.  Click Equipment & Systems in the left-hand box.

3.  Click the Circuit Board Design workbench:

The Circuit Board Design workbench displays with two tabs:

The Graphic tab lets you set the color of your choice to the different areas.
If you check the Update documents in session box, your change will be applied to the current document.
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The Components tab allows you to:
❍     browse to specify the default catalog,

❍     set a default height for the component used when importing data:
the .lib file contains the component footprint.
If its height is null, the Default height will be used as the component pad height.

❍     check the With constraints box to generate the mechanical constraints according to the component status:
■     the component is fixed: FixTogether constraint

■     the component is placed: Offset constraint.

4.  Click OK to validate.
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Customizing for Knowledgeware
This section describes the ways in which you can customize the Knowledgeware workbenches. See also 
the Parameters and Measure customizing section.

Knowledge Tab
Language Tab 

Report Generation Tab
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Knowledge Tab

This task explains how to specify the options when working with Knowledgeware relations, 
parameters and design tables. Refer to Using Knowledgeware Capabilities for more 
information.  

 1.  Select the Tools->Options... command. The Options dialog box displays. 

2.  Select General->Parameters and Measure and click the Knowledge tab. This is what 

you can see onscreen:  

 
Parameter Tree View Field
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●     Check Tools->Options...->General->Parameters and Measure->Knowledge-
>Parameter Tree View->With value to display the parameter values in the 
specification tree.

●     Check the Tools->Options...->General->Parameters and Measure-
>Knowledge->Parameter Tree View->With formula to display the formulas 
constraining  the parameter  in the specification tree. 

 
Parameter names Field

 

●     Check the Tools->Options...->General->Parameters and Measure-
>Knowledge->Parameter Names->Surrounded by the symbol' option if you 
work with non-Latin characters. If this option is unchecked,  parameter names 
should have to be renamed in Latin characters when used in formulas.

 Relations update in part context

Before V5R12, Knowledge relations (formulas, rules, checks, design tables, and sets of 
equations) used to execute as soon as one of their inputs was modified.
The user can now choose, when creating the relation, if it will be synchronous (i.e. the 
evaluation will be launched as soon as one of its parameters is modified) or 
asynchronous (i.e. the evaluation will be launched when the Part is updated). Each 
relation can therefore be synchronous or asynchronous. 

The 2 following options enable the user to create synchronous or asynchronous 
relations.

Creation of 
synchronous 
relations

Enables the user to create synchronous relations, that is to say 
relations that will be immediately updated if one of their 
parameters/inputs is modified. Relations based on parameters are 
the only one that can be synchronous.

Creation of 
relations evaluated 
during the global 
update

Enables the user to associate the evaluation of asynchronous 
relations with the global update. The relations can be 
asynchronous for 2 reasons:

●     The user wants the relations to be asynchronous

●     The relation contains measures. 

●     Relations based on parameters: These relations can be synchronous or 
asynchronous.

●     Relations based on geometry: These relations can only be asynchronous.

●     Relations based on parameters and on geometry: For the part of the relations 
containing parameters, the user decides if he wants the update to be synchronous 
or not. For the other part of the relations, the update occurs when the global update 
is launched. 
 

Note that the user can also decide if already existing relations are synchronous 
or asynchronous. To know more, see Controlling Relations Update in the 
Infrastructure User's Guide.
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Design Tables Field

 

Automatic 
Synchronization at 
Load

When loading a model containing user design tables, if the design 
table files have been modified and the external file data is 
contained in the model, the design table will be synchronized 
automatically if this radio button is checked. 

Interactive 
Synchronization at 
Load

When loading a model containing user design tables whose 
external source file was deleted, this option enables the user to 
select a new source file or to save the data contained in the design 
tables in a new file.

Manual 
Synchronization

When loading a model containing user design tables, if the design 
table files have been modified and the external file data is 
contained in the model, the design table will be synchronized if 
this radio button is checked. To synchronize both files, right-click 
the design table in the specification tree and select the 
DesignTable object->Synchronize command or the Edit-
>Links command.

Default Mode: Copy 
Data Into Model

If checked, the data contained in the external source file will be 
copied into the model.

Default Mode: Do 
Not Copy Data Into 
Model

If checked, the data contained in the external source file will not 
be copied into the model.

3.  Click OK when done.  
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Language Tab

This task explains how to specify the options you may need to check when working with Knowledge browsers.

 
1.  Select the Tools->Options... command. The Options dialog box is displayed. 

2.  Select General->Parameters and Measure and click the Language tab. This is what you can see 

onscreen:  

 

Language Field

This field is to be used when using measures in relations or user functions. Measures are specific 

functions to be used in formulas and rules.

The Knowledge Advisor User's Guide provides you with tasks explaining how to use measures. For 

how to create and use user functions, see the CATIA Application Architecture documentation.

●     Check Tools->Options...->General->Parameters and Measure->Knowledge->Load 

extended language libraries and select the packages you want to

load under Packages to load if you want to load a limited number of packages. 

This option is particularly useful for the administrator to limit the number of packages 
used by the user. 
It is also very useful to improve performances since only the required libraries are loaded.
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●     When you open a document and some relations are broken, you might need to load 

all libraries to solve the error, which may take quite a long time. 

●     It is strongly recommended to identify the packages you will need and to select them. 

●     Check Tools->Options...->General->Parameters and Measure->Knowledge

->Load extended language librariesand select All packages to load all the packages 

displayed under Packages to load. 

Reference Directory For Types field 

If you want to reuse the generated type in another CATIA session in the PKT workbench, proceed as 

follows: 

●     save the CATGScript file in the Directory indicated in the Reference Directory for Types field (see 

Tools->Options->Parameters and Measure-> Language tab) 

●     check the Load extended language libraries check box and select the package containing the 

type you created.

3.  Click OK when done.  
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Report Generation Tab

 

This task explains how to customize the reports generated by the Global Check Analysis tool in the 
Knowledge Advisor and Knowledge Expert workbenches.

You can choose to display a xml or a html report.

Displaying a HTML report

To generate a html report when performing the check analysis, go to Tools->Options->General-
>Parameters and Measure and select the Report customization tab. Select Html in the Select 
Report Visualization area. 

In this case, only the Check Advisor, the Check expert and the Passed objects options are 
available in the Report content area. You can specify the output directory containing the generated 
HTML report in the Select output directory field.

 
Select Html if you use a Netscape browser. 

Displaying a XML report

To display a XML report when performing the check analysis, go to Tools->Options->General-
>Parameters and Measure and select the Report customization tab. Select Xml in the Select 
Report Visualization area. The following window opens:
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The Report Customization tab is made up of 4 different fields: The Select Input XSL, the Report 
Content, the Select output directory, and the HTML options fields.

Select Input XSL field

This field enables the user to select the XSL style sheet that will be applied to the generated XML 
report. The StyleSheet.xsl file is the default XSL file, but you can use your own template.

Report content field

Failed Checks If checked, the generated report will contain information about 
the failed checks only.

All Checks If checked, the generated report will contain information about 
all the  checks contained in the document.

Check advisor
If checked, the generated report will contain information about 
all the  Knowledge Advisor checks contained in the document.
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Parameter 
information If checked, the generated report will contain information about 

the parameters of the Advisor checks.

Check expert If checked, the generated report will contain information about 
all the  Knowledge Expert checks contained in the document.

Passed 
objects

If checked, the generated report will contain information about 
the objects that passed the Expert checks as well as information 
about the parameters of these objects (diameter, depth, 
pitch,...).

 

Objects 
information

If checked, the generated report will contain information about 
all the objects contained in the Expert checks as well as 
information about the parameters of these objects (diameter, 
depth, pitch,...).

Select output directory field

This field enables the user to select the output directory containing the generated XML report.

HTML options field

This option is available for Windows only. It enables the user to define if the report will be opened 
in a CATIA session (in this case, the check box should be checked) or if it will be opened in an 
Internet Explorer session (in this case, the check box should remain unchecked.)

 

Note that it is highly recommended not to use this report as a basis for macros or for 
other applications. It is only provided for information purposes.
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Digital Process for Manufacturing
DPM Process for Manufacturing

(refer to the DPM Process Planner User's Guide)

DPM Body In White
(refer to the DPM Body-in-White Process Planner User's Guide)

DPM Machining Process Planner
(refer to the DPM Machining Process Planner User's Guide)
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Ergonomics Design & Analysis
Human Measurements Editor

(refer to the Human Measurements Editor User's Guide)

Human Task Simulation
(refer to the Human Task Simulation User's Guide)

Human Activity Analysis
(refer to the Human Activity Analysis User's Guide)

Human Builder
(refer to the Human Builder User's Guide)
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Glossary 

                    

 

A
 

access key The key that corresponds to an underlines letter on a menu or control (also referred to 
as a mnemonic access key).

active end The ending point for a selected range of objects. It is usually established at the object 
logically nearest the hot spot of the pointer when a user releases a mouse button. 
Compare anchor point.

active object Object currently being edited.

active window The window in which a user is currently working or directing input. An active window 
is typically at the top of the Z order and is distinguished by the color of its title bar. 
Compare inactive window.

album Collection of images you generate with the Tools -> Capture command.

anchor point The starting point for a selected range of objects. An anchor point is usually 
established at the object logically nearest the hot spot of the pointer when a user 
presses a mouse button. Compare active end.

application 
window

Window containing the Version 5 application.

apply To commit a set of changes or pending transactions made in a secondary window, 
typically without closing that window.

auto-repeat An event or interaction that is automatically repeated. Auto-repeat events usually 
occur when a user holds down a keyboard key or presses and holds a special control 
(for example, scroll bar buttons).

   

B  
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background Area in document windows to which you can apply a background color. 

box edit A standard Microsoft Windows interface control that provides a discrete area for 
entering each character. A user can also edit text within the control.

   

C  

cancel To halt an operation or process and return to the state before it was invoked. 
Compare stop.

cascading menu A menu that is a submenu of a menu item (also referred to as a hierarchical menu, 
child menu, or submenu).

check box A standard Windows control that displays a setting, either checked (set) or unchecked 
(not set). Compare option button.

child menu See cascading menu.

click (v.) To position the pointer over an object and then press and release a mouse button. 
See also press.
(n.) The act of clicking.

clipboard The area of storage for objects, data or their references after a user carries out a Cut 
or Copy command.

clipping Depth effect for viewing parts or all of a 3D object between two planes.

character set A character is any symbol used for the organization, control, or representation of data. 
A group of such symbols used to describe a particular language. Each language (or 
group of languages) has its character set

combo box A standard Windows control that combines a text box and interdependent list box.

command button A standard Windows control that initiates a command or sets an option (also referred 
to as a push button).

context-sensitive 
Help

Information about an object and its current condition. It answers the questions "What 
is this" and "Why would I want to use it?" Compare reference Help and task-oriented 
Help.
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contextual menu A menu that is displayed at the location of a selected object (also referred to as a 
shortcut menu). The menu contains the commands that are contextually relevant to 
the selection, and the most frequently used. You display the contextual menu by right-
clicking.

contiguous 
selection

A selection that consists of a set of objects that are logically sequential or adjacent to 
each other (also referred to as range selection). 

current State of an object when selected.

cursor A generic term for the visible indication of where a user's interaction will occur. See 
also input focus, insertion point, and pointer.

   

D  

default An operation or value that the system or application assumes, unless a user makes an 
explicit choice.

desktop The visual work area that fills the display. The desktop is also a container and can be 
used as a convenient location to place objects stored in the file system.

dialog box A secondary window that gathers additional information from a user. A dialog box 
usually contains one or more controls, such as buttons, list boxes, combo boxes, and 
edit boxes, with which the user enters text, chooses options, or directs the action of 
the command.

document A common unit of data (typically a file) used in user tasks and exchanged between 
users. When saved on disk, a document is given a unique filename by which it can be 
retrieved. 

document 
window

A window that provides a primary view of a document (typically its content).

double-click (v.) To press an release a mouse button twice in rapid succession.
(n.) The act of double-clicking.

duplicate Performs mirroring or pattern operations on an active object.
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E  

edit field See text box.

Edit menu A common drop-down menu that includes general purpose commands for editing the 
current object, such as Cut, Copy, and Paste.

ellipsis The "..." suffix added to a menu item or button label to indicate that the command 
requires additional information to be completed. When a user chooses the command, 
a dialog box is usually displayed for the user input of this additional information.

embedded object See OLE embedded object.

enter (v.) To type a character from the keyboard.
(n.) A classification of an object based on its characteristics, behavior, and attributes.

extended 
selection

A section technique that is optimized for the selection of a single object or single 
range using contiguous selection techniques (that is, canceling any existing selection 
when a new selection is made). However, it also supports modifying an existing 
selection using disjoint selection techniques.

   

F  

filter Tool for organizing elements of V4 model document into layers.

File menu A common drop-down menu that includes commands for file operations, such as 
Open, Save, and Print.

font A set of attributes for text characters.

font size The size of a font, typically represented in points.

   

G  

1769Page Infrastructure Version 5 Release 13



geometry area Area of a document window in which application data are displayed and edited.

glyph A generic term used to refer to any graphic or pictorial image that can be used on a 
button or in a message box. Compare icon.

   

H  

handle An interface element added to an object that provides a control point for moving, 
sizing, reshaping, or other operations pertaining to that object.

Help menu A common drop-down menu that includes commands that provide access to Help 
information or other forms of user assistance. See also context-sensitive Help, and 
task-oriented Help.

hierarchical menuSee cascading menu.

hold down To continue pressing a keyboard key, or mouse button.

hot spot The specific portion of the pointer (or pointing device) that defines the exact location, 
or object, to which a user is pointing.

   

I  

icon A pictorial representation of an object. Compare glyph.

inactive window A window in which a user's input is not currently being directed. An inactive window is 
typically distinguished by the color of its title bar. Compare active window.

in-place 
activation

The ability to edit an OLE embedded object in place, without opening it into its own 
window.

insertion point The location where text or graphics will be inserted (also referred to as the caret). 
Also used for text box controls to indicate input focus.
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interoperability ●     Ability to exchange data between CATIA Version 4 and Version 5. 

●     Ability to exchange Version 5 data between Version 5 workshops 

●     Ability to exchange data between Version 5 and OLE-compliant applications. 

   

J  

jump A special form of a link that navigates to another location (also referred to as a 
hyperlink).

   

L  

label The text (or graphic) that identifies a control (also referred to as a caption).

landscape An orientation where the long dimension of a rectangular area (for example, screen or 
paper) is horizontal.

link (v.) To form a connection between two objects.
(n)) A reference to an object that is linked to another object. See also OLE linked 
object.

link path The descriptive form of referring to the location of a link source (also referred to as a 
moniker).

list box A standard Windows control that displays a list of choices.

   

M  

marquee See region selection.

maximize To make a window its largest size. See also minimize.

menu A list of textual or graphical choices from which a user can choose. See also 
contextual menu.
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menu bar A horizontal bar at the top of a window, below the title bar, that contains menus.

menu button A command button that displays a menu.

menu item A choice on a menu.

menu title A text or graphic label that designates a particular menu. For drop-down menus, the 
titles is the entry in the menu bar; for cascading menus the menu title is the name of 
its parent menu item.

message box A secondary window that is displayed to inform a user about a particular condition.

minimize To minimize the size of a window: in some cases, this means to hide the window. See 
also maximize.

mirror An operation creating a 3D object by duplicating an initial object. The duplication is 
defined by symmetry.

model CATIA Version 4 model.

model document Document containing a CATIA Version 4 model.

most recently 
used

List of most recently used files (MRU) located in the File menu for easy access.

mouse A commonly used input device that has one or more buttons used to interact with a 
computer. It is also used as a generic term to include other pointing devices that 
operate similarly (for example, trackballs and head pointers).

   

O  

object An entity or component identifiable by a user that can be distinguished by its 
properties, operations, and relationships.

OLE Object Linking and Embedding. The name that describes the technology and interface 
for implementing support for object interaction.

OLE embedded 
object

A data object that retains the original editing and operating functionality of the 
application that created it, while physically residing in another document.
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OLE linked object An object that represents or provides an access point to another object that resides at 
another location in the same container or a different, separate container. See also 
link.

operation A generic term that refers to the actions that can be done to or with an object.

option button A standard Windows control that allows a user to select from a fixed set of mutually 
exclusive choices (also referred to as a radio button). Compare check box.

   

P  

package An OLE encapsulation of a file so that it can be embedded in an OLE container.

point (v.) To position the pointer over a particular object an location.
(n.) A unit of measurement for type (1 point equals approximately 1/72 inch).

pointer A graphic image displayed on the screen that indicates the location of a pointing 
devices (also referred to as a cursor).

portrait An orientation where the long dimension of a rectangular area (for example, screen or 
paper) is vertical.

press To press and release a keyboard key. See also click.

preview Tool allowing you to view a document or album image prior to printing.

progress 
indicator

Any form of feedback that provides the user with information about the state of a 
process.

property Attribute or characteristic of an object that define its state, appearance, or value.

push button See command button.

   

R  
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radio button See option button.

range selection See contiguous selection.

redo Repeat the last operation.

reference Help A form of online Help information that can contain conceptual and explanatory 
information. Compare task-oriented Help and context-sensitive Help.

region selection A selection technique that involves dragging out a bounding outline (also referred to 
as a marquee) to define the selected objects.

right-click Click using the right mouse button (to display contextual menu).

   

S  

scale Operation that resizes the contents of document prior to printing or previewing.

scroll To move the view of an object or information to make a different portion visible.

scroll arrow 
button

A component of a scroll bar that allows the information to be scrolled by defined 
increments when the user clicks it. The direction of the arrow indicates the direction in 
which the information scrolls.

scroll bar A standard Windows control that supports scrolling.

scroll box A component of a scroll bar that indicates the relative position (and optionally the 
proportion) of the visible information relative to the entire amount of information. The 
user can drag the scroll box to view areas of information not currently visible. 

section view 3D view of a cross-section generated using a plane.

select To identify one or more objects upon which an operation can be performed.

selection An object or set of objects hat have been selected.

selection handle A graphical control point of an object that provides direct manipulation support for 
operations of that object, such as moving, sizing, or scaling.

selection set A group of selected objects that you can store and retrieve.
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Send To Tool used for sharing document files with other users.

settings Set of setup parameters and user preferences stored in non-editable files. 

shell A generic term that refers to the interface that allows the user control over the 
system.

shortcut A generic term that refers to an action or technique that invokes a particular 
command or performs an operation with less interaction than its usual method.

shortcut icon A link presented as an icon that provides a user with access to another object.

shortcut key A keyboard key or key combination that invokes a particular command (also referred 
to as an accelerator key).

shortcut menu See contextual menu.

slider A standard Windows control that displays and sets a value from a continuous range of 
possible values, such as brightness or volume.

specification tree Area of the document window reserved for viewing the design specifications of a part, 
presented in the form of a tree structure.

spin box A control composed of a text box and increment and decrement buttons that allow a 
user to adjust a values from a limited range of possible values.

split An operation allowing splitting 3D objects using a plane.

standard view Typical view available in 3D workshops: top, bottom, front, back, left, right, isometric.

status bar An area that allows the display of state information of the information being viewed in 
the window, typically places at the bottom of a window.

stop To halt a process or actions, typically without restoring the state before the process 
began. Compare cancel.

STRIM/STYLER 
models

Model files generated by STRIM or STYLER. These files have the same ".tdg" 
extensions. They are read  and converted to Version 5 documents for further 
processing.

submenu See cascading menu.

1775Page Infrastructure Version 5 Release 13



   

T  

taskbar A special toolbar that docks on an edge of the desktop supplied by the system. The 
taskbar includes the Start button, buttons for each open primary window, and a status 
bar.

task-oriented 
Help

Information about the steps involved in carrying out a particular task. Compare 
context-sensitive Help and reference Help.

template An object that automates the creation of new objects of a particular type.

text box A standard Windows control in which a user can enter an edit text (also referred to as 
the edit field).

toolbar A frame or special area that contains a set of other controls.

tooltip A standard Windows control that provides a small pop-up window that provides 
descriptive text such as a label, for a control or graphic object.

   

U  

unavailable The state of a control or data whose normal functionality is not presently available to 
a user (also referred to as dimmed).

undo To reverse one operation performed on an object.

user-defined view3D view an end user can generate by customizing view parameters. The view can be 
named. Also referred to as named view.

   

V  

View toolbar Toolbar containing viewing tools.

viewing tools Tools for viewing contents of current document in different ways.
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VRML Virtual Reality Markup Language. A vector-based language for modeling three-
dimensional environments. It sends ASCII text files over the Internet, which are 
translated by the VRML viewing engine at the other end. VRML complements HTML. 
This format is useful for viewing Version 5 data using a Web browser.

   

W  

window A standard Windows object that displays information. A window is a separately 
controllable area of the screen that typically has a rectangular border. 

workbench Set of tools for completing specific tasks. Each type of document can be edited with a 
document-specific set of tools.

workspace A window or task management technique that consists of a container holding a set of 
objects, where the windows of the contained objects are constrained to a parent 
window. Similar to the multiple document interface, except that the window displayed 
within the parent window are of objects that are also contained in the workspace.
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Index

Symbols & Numerics

A B C D E F

G H I J K L

M N O P Q R

S T U V W Z
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Index Numerics 

                      

  

Numerics
2D component creation (annotation and dress-up settings)  
3D compass 

free rotation angle  

locking current orientation  

locking to local axis system  

manipulation  

manipulation bounding box   

privileged plane  

snapping to selected objects  

viewpoint manipulation  

3Dx Device toolbar   

3Dx Dominant On/Off command  

3Dx Fast Zoom command  

3Dx Rotation On/Off command  

3Dx Sensitivity Decrease command  

3Dx Sensitivity Increase command  

3Dx Sensitivity Reset command  

3Dx Translation On/Off command  
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Index A 

                      

  

A
Accelerate command   
acquisition agent 

searching  
actions 

redoing  

repeating  

undoing  
activating 

viewing tools  

activating a component  

activity  

Add Attributes command  

Add to favorites option  
adding 

PostScript fonts  

printer  

adding a row to a design table external file  

administration settings  
Advanced mode 

searching  
album 

deleting images  

editing images  

previewing images  

printing images  

saving images to other formats  

Album icon  

Album... command            
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ambient 

light source  
Analysis and Simulation 

settings  
applying 

color  

applying ranges to parameters by using a rule  

Approximate views  

associative link  
attribute 

searching  
automatic 

saving  
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Index B 

                      

  

B
banner options 

printing  
basic software requirements 

virtual reality  
batch 

CATDUA V5  

Batch Monitor  

bitstream fonts  

bounding outline  
brightness 

light source  

Browse window  

button mapping  
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Index C 

                      

  

C
Capture toolbar    

Capture... command      
capturing 

images  

selected areas of images  

simple images  

Cascade command  

CATDownwardCompatibility utility  

CATDUAV5 utility  

CATGraphSize  

CATOptionsMgt command  

catsite.DEFAULT_DS_CODE_PAGE  

CATStdLayerAndFilter file  

CATStdTypeLayerAndFilter file  

CATUIDownwardCompatibility utility  

catutil utility  

CellAsBoolean method  

CellAsReal method  

CellAsString method  

CGM formats  
changing 

view  

Close command  

CloserInfConfig method  

CloserSupConfig method  

CloserValueInfInColumn method  

CloserValueSupInColumn method  
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closing 

documents  
code page 

standard  

Collapse All command  
collapsing 

specification tree  
collision detection 

Walk Mode  
color 

applying  

customizing  

light source  

searching  
color options 

printing  
command 

3Dx Dominant On/Off  

3Dx Fast Zoom  

3Dx Rotation On/Off  

3Dx Sensitivity Decrease  

3Dx Sensitivity Increase  

3Dx Sensitivity Reset  

3Dx Translation On/Off  

Accelerate   

Add Attributes  

Album...            

Capture...      

Cascade  

CATOptionsMgt  

CATPrinterManager  

Close  

Collapse All  

Command List...   
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Contents, Index and Search  

Control Points   

Copy  

Create New Tracking Station  

Create Subclass  

Customize...        

Customize View Parameters   

Cut  

Decelerate   

Define Dynamic Level of Detail  

Define Dynamic Pixel Culling  

Define ID Schema  

Define/modify ID Schema  

Delete...  

Depth Effect...  

Design Table  

Desk   

Equivalent Dimensions  

Examine Mode   

Expand All  

Expand First Level  

Expand Second Level  

Expand Selection  

Find Owning Selection Sets...  

Fit All In  

Fly   

Full Screen  

Generate Configuration Files  

Generate Report  

Geometry  

Geometry Overview  

Ground  
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Hide/Show  

Intersecting Outside Trap Selection  

Intersecting Trap  

Lighting...  

Links...   

Look At  

Magnifier  

mpconfig  

Named Views...   

New Font...  

New from...  

New IG  

New View  

New Window   

New...  

Next View  

Normal View  

Open Application Dictionary    

Open Reference Dictionary  

Open User Dictionary  

Open...  

Opens the Button Mapping dialog box  

Options...  

Other Layers...  

Other Selection...  

Outside Trap Selection  

Paint Stroke  

Pan  

Parallel  

Paste   

Paste Special...  

Perspective  
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Polygonal Trap  

Preview View  

Print...      

Printer Setup...       

Properties  

Quick Print  

Redo  

Repeat  

Reset Compass  

Rotate  

Save  

Save All  

Save As...    

Save Management...  

Scale Planes  

Search  

Search...   

Select      

Selection Sets Edition...  

Selection Sets...  

Selection Trap  

Send To Directory  

Send To Mail  

Settings Management  

Shading (SHD)  

Shading With Edges  

Shading with Edges and Hidden Edges  

Shading With Edges Without Smooth Edges  

Shading With Material  

Snap  

Snapping Viewpoint  

Specifications  
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Specifications Overview  

Standards...   

Swap view/tree  

Swap visible space  

Test viewpoint and VR cursor tracking  

TestVisuPerfoDraw  

Text  

Tile Horizontally  

Tile Vertically  

Toggle the plan view on  

Toolbars  

Turn Head    

Undo  

Utility   

Video...  

View Angle  

Visualization Filters...  

Walk   

What is This  

Zoom Area  

Zoom In  

Zoom Out  
command list 

viewing  

Command List... command   
command properties 

customizing  
commands 

options  
compressing 

images  
compression-decompression 

parameters  
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configuring 

printer  

constant parameter  

Contents, Index and Search command  

Control Points command   

controlling design tables synchronization  

Copy command  

Copy icon  

copy/paste a parameter  
copying 

data to directory or diskette  

images to the clipboard  

objects  

Create New Tracking Station command  

Create Subclass command  
creating 

new document from existing one  

new documents  

creating a design table from a pre-existing file  

creating a design table from the current parameter values  

creating a formula  

creating a formula based on publications  

creating a parameter  

creating points and lines as parameters  

Ctrl-clicking  

Customize... command        
Customize View Parameters 

rendering style  

Customize View Parameters command   

customizing  

2d workshop visualization settings  

administration settings  

annotation and dress-up settings  

1789Page Infrastructure Version 5 Release 13



buttons  

cache settings  

catalog settings  

client ID  

color  

command properties  

design settings   

Devices  

dimension creation settings  

Display settings  

DMU navigator settings  

Document settings  

drawing production  

Font settings  

fonts for displaying geometry area texts  

fonts for displaying texts  

fonts on UNIX  

fonts on Windows  

generation settings  

geometry creation settings  

Help settings  

icon size  

Layer Filters  

Licensing settings  

lines drawings  

Linetype settings  

Macro settings  

manipulators settings  

Material Library settings  

multi-process settings  

Navigation settings  

offset data  
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Performance (display) settings  

Performances  

Photo Studio settings  

pin Id Number  

plug\board Id  

print driver setup  

print settings  

Printers  

product visualization settings  

Statistics  

Tablet Support  

Thickness settings  

toolbar  

tooltips  

Tree options   

unit Id  

user dictionary  

user schema ID  

view and sheet layout settings  

view generation settings  

view mode  

Visualization settings  

wire color  

wire reference designator  

Cut command  
cutting 

objects  
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Index D 

                      

  

D
data 

copying to directory or diskette  

sending in the mail  

sharing between Windows and UNIX  

Data Life Cycle utility  

Data Upward Assistant  

deactivating a component  

Decelerate command   

declaring parameters in V4  

Define Dynamic Level of Detail command  

Define Dynamic Pixel Culling command  

Define ID Schema command  

Define/modify ID schema command  

Delete... command  
deleting 

images from the album  

objects  

Depth Effect... command  

depth effects  
design table 

adding a row to a design table external file  

automatic synchronization at load  

controlling synchronization  

creating a design table from a pre-existing file  

creating a design table from the current parameter values  

functions  

generating a file from a design table  
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getting familiar with the design table dialog box  

interactive synchronization at load  

introducing  

manual synchronization  

methods  

storing a design table in a powercopy  

useful tips  

Desk command   

Desk File Management toolbar  

Desk toolbar   
Devices 

customizing  
diagrams 

settings  
dictionary 

analysis operators  

circle constructors  

design table methods  

evaluate method  

line constructors  

list  

mathematical functions  

measures  

operators  

part measures  

plane constructors  

point constructors  

surface constructors  

wireframe constructors  
diffuse 

light source  
Digital Mockup 

settings  
Digital Process for Manufacturing 
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settings  

Display the preselection navigator after...seconds option  
displaying 

document links  

graphic properties   

hidden objects  

preselection navigator  

DLNames  

document environment  
document links 

displaying  

editing  

pointed documents   
Document settings 

customizing  
documents 

closing  

creating new from existing one  

managing save  

opening recently used  

opening using the Browse Window  

saving all  

saving existing documents  

saving for the first time or under another name   

saving in other formats  

window layout  

windows  

downward compatibility  
dragging and dropping 

icons  

objects  

dynamic level of detail  

dynamic pixel culling  
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Index E 

                      

  

E
edges 

graphic properties  

highlighting   

Edit... contextual command  
editing 

document links  

graphic properties   

Enable independent saves option  

ENOVIA LCA interoperability  
entering data 

power input mode  
Equipment and Systems 

settings  

equivalent dimensions  

interface  

Erase icon  
Ergonomics Design and Analysis 

settings  

Evaluate method  
evaluate method 

dictionary  
Examine Mode 

navigating  

Examine Mode command   

Expand All command  

Expand First Level command  

Expand Second Level command  

Expand Selection command  
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expanding 

specification tree  
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Index F 

                      

  

F
favorites 

search language  
Favorites mode 

searching  

Feature Dictionary Editor  
file 

printing to  
FileDesk 

deleting documents  

finding documents  

loading documents  

moving documents  

opening documents  

renaming documents  

filenames  
fill 

graphic properties  
filter 

searching  

visualization  

Find Owning Selection Sets... command  

Fit All In command  

Fit in Page option  

Fit to option  
fitting all in 

geometry area  

Fly command   

Fly Mode  
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Font settings 

customizing  
fonts 

display and printed output  

for displaying texts  

formats  

introduction  

on UNIX  

on Windows  

PostScript  

Version 4   

Version 5  
formula 

creating a formula  

creating a formula based on publications  

getting familiar with the formula dialog box  

introducing  

referring to external parameters in a formula  

specifying a measure in a formula  

full screen  

Full Screen command  
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Index G 

                      

  

G
General mode 

searching  
General settings 

cutomizing  

Generate Configuration Files command  

Generate Report command  

generating a file from a design table  
geometry 

overview  

geometry area  

fitting all in  

Geometry command  

Geometry Overview command  

getting familiar with the design table dialog box  

getting familiar with the formula dialog box  
getting help 

accessing sample documents  

contextual help  

copyright information  

displaying tooltips and Help messages  

online help library   

user galaxy  

What is This command  

global name  
graphic properties 

displaying   

edges  
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editing   

fill  

layers  

lines and curves  

pick  

points  

show  

transparency  

Graphic Properties toolbar     

Graphic Properties Wizard  

Ground command  
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Index H 

                      

  

H
hand tracking 

virtual reality  
hardware requirements 

virtual reality  
head tracking 

virtual reality  
Help settings 

cutomizing  
hidden objects 

displaying  

hidden parameter  

Hide/Show command  
hiding 

objects  

toolbar  
highlighting 

edges   
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Index I 

                      

  

I
Icon Browser  
icon size 

customizing  
icons 

dragging and dropping  
images 

capturing  

compressing  

printing  
Immersive System Assistant workbench 

virtual reality  

importing a parameter  
Infrastructure 

settings  

Initial Drawing Path  

inserting a design table saved in LCA into a new part  

Intersecting Outside Trap Selection command  

Intersecting Trap command  

introducing design tables  

introducing formulas  
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Index J 

                      

  

J
joystick control panel 

virtual reality  
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Index K 

                      

  

K
keyboard 

viewing tools  

keyboard shortcuts  
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Index L 

                      

  

L
layer box  
Layer Filters 

customizing  
layers 

adding and naming  

assigning objects  

graphic properties  
layers and filters 

standards  
licensing 

virtual reality  
Licensing settings 

customizing  
light source 

ambient  

brightness  

color  

diffuse  

specular  

lighting effects  

Lighting... command  
lines and curves 

graphic properties  
Linetype 

customizing  

link between measures and parameters  

linked document localization  

Links... command   
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local name  

LocateInColumn method  

LocateInRow method  

Lock Current Orientation contextual command  

Lock Privileged Plane Orientation Parallel to Screen contextual command  
locking 

compass to local axis system  

current compass orientation  

privileged plane  

Look At command  

looking at objects  
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Index M 

                      

  

M
Macro settings 

customizing  

Magnifier command  

magnifying  

Make Privileged Plane Most Visible contextual command  

Make YZ the Privileged Plane contextual command  
managing 

document save  
manipulating 

objects using Edit... command  

objects using mouse and compass  

viewpoints using mouse and compass  
manipulation 

3D compass  

bounding box   

handle  
Material Library settings 

customizing  

mathematical functions  

MaxInColumn method  
measuring 

objects  
Mechanical Design 

settings  

Menu bar  

MinInColumn method  
mouse 

viewing tools  
movie replay 
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parameters  

mpconfig command  
multi-documents 

printing  
multipiped session 

virtual reality  
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Index N 

                      

  

N
Named Views... command   
navigating 

Advanced Fly Mode  

Advanced Walk Mode  

Beginner`s Fly Mode  

Beginner`s Walk Mode  

Examine Mode   

Fly Mode  

Walk Mode  
Navigation settings 

customizing  

Neon Light mode  

New Font... command  

New from... command  

New IG command  

New View command  

New Window command   

New... command  

Next View command  

No Fitting option  

No Light mode  

Normal View command  
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Index O 

                      

  

O
object class 

adding properties to  

creating a new  

managing  
objects 

copying  

cutting  

deleting  

dragging and dropping  

hiding  

measuring  

pasting   

occlusion culling  

OLE-compliant applications  

OLE-compliant documents  

online help library   

Open Application Dictionary command    

Open in New Window contextual command  

Open Pointed Document contextual command  

Open Reference Dictionary command  

Open User Dictionary command  

Open... command  
opening 

existing documents  

recently used documents  

Opens the Button Mapping dialog command  
operating signs 
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search language  

searching  
operators 

search language  
option 

Add to favorites  
options 

commands  

Options... command  

Other Layers... command  

Other Selection... command  

Outside Trap Selection command  
overview 

geometry  

specification tree  
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Index P 

                      

  

P
packaging 

virtual reality  

Paint Stroke command  

Pan command  

panning  
paper format 

printing  
paper margins 

printing  

Parallel command  
parameter 

activating and deactivating a component  

applying ranges to a parameter by using a rule  

copying/pasting a parameter  

creating a link between measures and parameters  

creating a parameter  

creating points and lines as parameters  

global name  

importing a parameter  

local name  

publishing a parameter  

specifying a parameter value as a measure  

specifying the material parameter  

useful tips  

using relations based on publications  
parameters 

compression-decompression  

1812Page Infrastructure Version 5 Release 13



movie replay  

part measures  

Paste command   

Paste Special... command  
pasting 

objects   
pausing 

recording  
Performance (display) settings 

customizing  
Performances 

customizing  

perspective and parallel view  

Perspective command  
Photo Studio settings 

customizing  
pick 

graphic properties  

pixel image formats  

Pixel Mode  

plane constructors  
pointed documents 

document links   
points 

graphic properties  

Polygonal Trap command  
PostScript fonts 

adding  
power input mode 

entering data  

introduction  

running commands  
powercopy 

storing a design table  

Preselect in geometry view option  

1813Page Infrastructure Version 5 Release 13



preselecting 

using pointer  
preselection navigator 

displaying  

using  

Preview icon  
previewing 

printing  

Previous View command  
print driver setup 

customizing  
print settings 

customizing  

Print... command      

PrintBatch utility  
printer 

adding  

configuring  

setting as default  

setting up  

testing  

Printer Setup... command       
Printers 

customizing  
printing 

area  

banner options  

color options  

image orientation  

image position and size  

images  

images from the album  

in batch mode  

multi-documents  
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page orientation  

paper format  

paper margins  

previewing  

quickly  

sheets  

to file  

various options  
privileged plane 

locking  

swapping  

visible  
Product Structure 

activating a different workbench  

creating a new document  

creating a workbench document  

introduction  

navigation tools  

Properties command  

publication  

publishing a parameter  

1815Page Infrastructure Version 5 Release 13



Index Q 

                      

  

Q
Quick Print command  

quick search  
quickly 

printing  
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Index R 

                      

  

R
recording 

interactions in video format  

pausing  

stopping  

video   

Redo command  
redoing 

actions  

referring to external parameters in a formula  
relation 

using relations based on publications (Product)  

relation based on a publication  
removing 

printer  
rendering style 

Customize View Parameters  

Repeat command  
repeating 

actions  

Reset Compass command  

Rotate command  

rotating  
running commands 

power input mode  
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Index S 

                      

  

S
Save All command  

Save as new option  

Save As... command    

Save command  

Save Management... command  
saving 

all documents  

automatic  

documents for the first time or under another name   

documents in other formats  

existing documents  

images to other formats  

saving a Design Table in ENOVIA LCA  

saving a design table in ENOVIA LCA using the VPM Navigator  

Scale Planes command  

Screen Mode capture  
search language 

favorites  

operating signs  

operators  

search filters  

special characters  

syntax  

Search Order command  

Search... command    
searching 

acquisition agent  
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Advanced mode  

by attribute  

by color   

by name  

by product properties   

by specific attributes  

by type   

combination of search criteria  

Favorites mode  

filter  

General mode  

lines by thickness or type  

material  

More... option  

objects belonging to a selection set  

operating signs  

visible or hidden elements  

Select command      
selected areas of images 

capturing  
selecting 

selection sets  

using a filter  

using Other Selection... command  

using pointer  

using preselection navigator  

using selection sets  

using selection traps  

using the Search command (General Mode)  

Selection filter  
selection sets 

selecting  

Selection Sets Edition... command  
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Selection Sets... command  

Selection Trap command  

selection traps  

Send To Directory command  

Send To Mail command  
sending 

data in the mail  

SetCell method  

settings  

Analysis and Simulation  

DELMIA Infrastructure  

Digital Mockup  

Digital Process for Manufacturing  

Drafting 

Equipment and Systems  

Ergonomics Design and Analysis  

how to specify without running a session  

Infrastructure  

Mechanical Design  

Shape  

Settings Management command  

Shading (SHD) command  

Shading with Edges and Hidden Edges command  

Shading With Edges command  

Shading with Edges Without Smooth Edges command  

Shading With Material command  
Shape 

settings  
sheets 

printing  

Shift-clicking  
show 

graphic properties  
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simple images 

capturing  

Single Light mode  

sketch plane (settings)  

Snap automatically to selected object contextual command  

Snap command  
snapping 

3D compass to selected objects  

snapping viewpoint  
solid objects 

pasting as special  
special characters 

search language  

specification tree  

collapsing  

expanding  

introduction  

overview  

Specifications command  

Specifications Overview command  

specifying a measure in a formula  

specifying the material parameter  
specular 

light source  
standard 

code page  

Standard toolbar  

standard views  
standards 

general overview  

layers and filters  

Standards... command   
starting a session 

choosing the language on UNIX  
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choosing the language on Windows  

on UNIX  

on Windows  

using document icons  
stereoscopic viewing 

virtual reality  
stopping 

recording  

storing a design table in a powercopy  

surface constructors  
surfacic objects 

pasting as special  

Swap view/tree command  

Swap visible space command  
swapping 

privileged plane  

symbols  
syntax 

search language  
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Index T 

                      

  

T
Tablet Support 

customizing  
TabletPC 

viewing tools  

Test viewpoint and VR Cursor Tracking command  
testing 

printer  

TestVisuPerfoDraw command  

Text command  
Thickness settings 

customizing  

Tile Horizontally command  

Tile Vertically command  

Toggle the plan view on command  
toolbar 

3Dx Device   

Capture    

customizing  

Desk   

Desk File Management  

Graphic Properties  

Graphic Properties toolbar   

hiding  

Menu  

Standard  

User Selection Filter  

View    
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viewing  

Toolbars command  
tooltips 

customizing  
transparency 

graphic properties  
Tree options 

customizing   

Turn Head command    

Two Lights mode  
type 

searching  
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Index U 

                      

  

U
Undo command  
undoing 

actions  

Use Local Axis System contextual command  

User Selection Filter toolbar  
user-defined 

toolbars  

views  

workbenches  
using 

preselection navigator  

using equivalent dimensions  
using selection sets 

selecting  
utility 

CATDownwardCompatibility  

CATDUAV5  

CATUIDownwardCompatibility  

catutil  

Data Life Cycle  

PrintBatch  

Utility command   

UUID    
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Index V 

                      

  

V
various options 

printing  

vector image formats  

Vector Mode  

versioning a design table  
video 

format  

properties  

recording   

Video... command  
view 

changing  
view angle 

editing  

View Angle command  
view mode 

customizing  

View toolbar    

Viewer Mode capture  
viewing 

along normal to plane  

command list  

objects against the ground  

toolbar  
viewing tools 

activating  

keyboard  

mouse  
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TabletPC  

Viewpoint Snapping command  
virtual reality 

basic software requirements  

hand tracking  

hardware requirements  

head tracking  

Immersive System Assistant workbench  

joystick control panel  

licensing  

multipiped session  

navigating in Examine Mode  

navigating in Fly Mode  

packaging  

stereoscopic viewing  

support  
visible 

privileged plane  

Visual Basic Script (VBScript)  

visualization filter  

Visualization Filter Editor  

Visualization Filters... command  

visualization performance  
Visualization settings 

customizing  

Visula Basic for applications (VBA)  

VR Button Customize  
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Index W 

                      

  

W
Walk command    
Walk Mode 

collision detection  

Warm Start  

What is This command  

wireframe constructors  
workbench 

description  
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Index Z 

                      

  

Z
Zoom Area command  

Zoom In command  

Zoom Out command  
zooming 

in  

in on area  

out  
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